/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.109 Revision 1.188
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.109 2010/02/16 06:47:45 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.188 2012/06/27 10:36:57 pesa Exp $
4
5*PyQt4-4.9.3 (27 Jun 2012)
6
7 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
8 -PyQt4-4.9.2.ebuild:
9 Version bump.
10
11 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
12 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
13
14*PyQt4-4.9.2 (21 Jun 2012)
15
16 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
17 Version bump
18
19 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
20 Destabling to ~ia64 because last available stable qt will be masked pending
21 removal
22
23 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
24 marked x86 per bug 412929
25
26 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
27 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
28 Inherit eutils.
29
30 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
31 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
32 Revert previous change.
33
34 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
35 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
36 Restrict python 3.1 to match dev-python/dbus-python.
37
38 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
39 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
40
41 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
42 Migrating dev-util/pkgconfig -> virtual/pkgconfig
43
44 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
45 Stable for amd64, wrt bug #412929
46
47 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
48 Stable on alpha, bug #354033
49
50 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
51 PyQt4-4.8.4.ebuild:
52 PyQt4-4.8 does not build with sip-4.13, bug 407291
53
54 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
55 Slightly improve the ewarn message in pkg_postinst().
56
57 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
58 Put qt as the primary herd in metadata.
59
60 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
61 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
62 <slong@rathaus.eclipse.co.uk> in bug #407281.
63
64 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
65 Switch to EAPI 4, add REQUIRED_USE.
66
67 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
68 PyQt4-4.8.4.ebuild:
69 Drop ~x86-fbsd because of unkeyworded dependencies.
70
71 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
72 Don't enable QtAssistant module because it was removed in qt-4.7 and we
73 already depend on 4.7.2 or later.
74
75 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
76 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
77 Restrict pypy for older versions too.
78
79 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
80 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
81 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
82 version.
83
84 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
85 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
86 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
87 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
88 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
89 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
90
91 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
92 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
93 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
94 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
95 Fixing pypy restricts to actually work
96
97*PyQt4-4.9.1 (12 Feb 2012)
98
99 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
100 version bump
101
102 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
103 builds with qt-opengl-4.8.0[egl], updated dep
104
105 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
106 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
107 Fixes backported from Progress Overlay. Patch by Arfrever.
108
109*PyQt4-4.9 (24 Dec 2011)
110
111 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
112 Version bump
113
114*PyQt4-4.8.6 (11 Nov 2011)
115
116 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
117 Version bump
118
119 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
120 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
121 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
122 python overlay.
123
124*PyQt4-4.8.5 (19 Aug 2011)
125
126 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
127 Version bump
128
129 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
130 ppc/ppc64 stable wrt #374591
131
132 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
133 x86 stable, bug #374591
134
135 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
136 ppc64 stable wrt #354033
137
138 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
139 Stable on amd64 wrt bug #374591
140
141 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
142 Marking PyQt4-4.8.3 ppc stable for bug 354033
143
144 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
145 Stable on amd64 wrt bug #354033
146
147 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
148 x86 stable per bug 354033
149
150*PyQt4-4.8.4 (02 May 2011)
151
152 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
153 +PyQt4-4.8.4.ebuild:
154 Version bump.
155
156 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
157 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
158 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
159 Adapt phonon dependency for package move
160
161 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
162 ppc64 stable wrt #349607
163
164 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
165 ia64/sparc stable wrt #349607
166
167 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
168 Stable on alpha, bug #349607
169
170 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
171 PyQt4-4.8.3.ebuild:
172 Update dependencies (bug #353053).
173
174*PyQt4-4.8.3 (25 Jan 2011)
175
176 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
177 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
178 Version bump.
179
180 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
181 x86 stable wrt bug #349607
182
183 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
184 Marking PyQt4-4.8.1 ppc stable for bug 349607
185
186 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
187 Stable on amd64 wrt bug #349607
188
189 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
190 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
191 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
192
193*PyQt4-4.8.1-r1 (30 Dec 2010)
194
195 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
196 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
197 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
198
199 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
200 PyQt4-4.8.2.ebuild:
201 Fix dependencies (bug #349672).
202
203*PyQt4-4.8.2 (24 Dec 2010)
204
205 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
206 +PyQt4-4.8.2.ebuild:
207 Version bump.
208
209 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
210 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
211 Restrict Jython ABIs.
212
213 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
214 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
215 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
216 -files/configure.py.patch:
217 Delete.
218
219 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
220 old, depends on qt 4.5
221
222 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
223 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
224 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
225 Remove HPPA keywording (bug #239441).
226
227*PyQt4-4.8.1 (30 Oct 2010)
228
229 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
230 +PyQt4-4.8.1.ebuild:
231 Version bump.
232
233 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
234 ia64/sparc stable wrt #315775
235
236*PyQt4-4.8 (23 Oct 2010)
237
238 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
239 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
240 +PyQt4-4.8.ebuild, metadata.xml:
241 Version bump.
242
243*PyQt4-4.7.7-r1 (06 Oct 2010)
244
245 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
246 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
247 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
248
249*PyQt4-4.7.7 (21 Sep 2010)
250
251 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
252 +PyQt4-4.7.7.ebuild:
253 Version bump. Remove old bogus version
254
255 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
256 Stable on alpha, bug #315775
257
258 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
259 Marked ppc stable for bug #315775.
260
261 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
262 PyQt4-4.7.6.ebuild:
263 Update EAPI. Fix dependencies.
264
265*PyQt4-4.7.6 (08 Sep 2010)
266
267 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
268 +PyQt4-4.7.6.ebuild:
269 Version bump. Remove old ebuild
270
271 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
272 PyQt4-4.7.5.ebuild:
273 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
274
275*PyQt4-4.7.5 (01 Sep 2010)
276
277 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
278 +PyQt4-4.7.5.ebuild:
279 Version bump
280
281 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
282 Stable for HPPA (bug #315775).
283
284 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
285 Bump sip dependency to 4.10.3. Fix arm epatch command
286
287*PyQt4-4.7.4 (13 Jul 2010)
288
289 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
290 Version bump
291
292 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
293 ppc64 stable wrt #315775
294
295 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
296 +files/PyQt4-4.7.3-qreal_float_support.patch:
297 Add patch for qreal/float support in ARM wrt bug 322349
298
299 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
300 x86 stable wrt bug 315775
301
302 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
303 Stable on amd64 wrt bug 315775
304
305 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
306 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
307 Fix sip dep in PyQt4 ebuilds
308
309*PyQt4-4.7.3 (17 Apr 2010)
310
311 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
312 Version bump
313
314 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
315 ppc stable #301105
316
317*PyQt4-4.7.2 (18 Mar 2010)
318
319 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
320 +files/PyQt4-4.7.2-configure.py.patch:
321 Version bump. ChangeLog is no longer shipped. Update patch.
322
323 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
324 stable x86, bug 301105
325
326 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
327 amd64 stable wrt #301105
4 328
5 16 Feb 2010; Jonathan Callen <abcd@gentoo.org> 329 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
6 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch, 330 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
7 -files/fix_license_check.patch: 331 -files/fix_license_check.patch:
8 Drop old patches 332 Drop old patches
444*PyQt4-4.0_beta1 (05 May 2006) 768*PyQt4-4.0_beta1 (05 May 2006)
445 769
446 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 770 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
447 +PyQt4-4.0_beta1.ebuild: 771 +PyQt4-4.0_beta1.ebuild:
448 initial import, from bug #121554 772 initial import, from bug #121554
449

Legend:
Removed from v.1.109  
changed lines
  Added in v.1.188

  ViewVC Help
Powered by ViewVC 1.1.20