/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.109 Revision 1.207
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.109 2010/02/16 06:47:45 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.207 2013/01/29 18:44:19 kensington Exp $
4
5*PyQt4-4.9.6-r2 (29 Jan 2013)
6
7 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
8 Migrate to the new python eclass.
9
10 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
11 Improve pyqt4_use_enable() as suggested by Arfrever.
12
13 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
14 old
15
16*PyQt4-4.9.6-r1 (26 Dec 2012)
17
18 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
19 metadata.xml:
20 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
21 pyside: rename assistant to help, add script and scripttools (bug 431460 by
22 Arfrever).
23
24*PyQt4-4.9.6 (10 Dec 2012)
25
26 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
27 Version bump, with some minor updates from qt overlay.
28
29 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
30 arm stable, bug #435074
31
32 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
33 PyQt4-4.9.4-r1.ebuild:
34 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
35
36 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
37 -PyQt4-4.9.1.ebuild:
38 Remove old
39
40*PyQt4-4.9.5 (05 Oct 2012)
41
42 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
43 Version bump
44
45 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
46 alpha/ia64/sparc stable wrt #429042
47
48*PyQt4-4.9.4-r1 (03 Sep 2012)
49
50 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
51 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
52 Apply upstream patch to fix regression in pyuic's handling of custom widgets
53 (bug 431070 by Laurent Bachelier).
54
55 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
56 Stable for x86, wrt bug #429042
57
58 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
59 Stable for amd64, wrt bug #429042
60
61 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
62 Stable ppc64, bug #429042
63
64 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
65 Stable ppc, bug #429042
66
67 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
68 ia64 stable
69
70 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
71 -files/PyQt4-4.6.1-configure-multilib.patch:
72 Remove old.
73
74 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
75 PyQt4-4.9.4.ebuild:
76 alpha/ia64/sparc stable wrt #412929
77
78*PyQt4-4.9.4 (02 Jul 2012)
79
80 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
81 -PyQt4-4.9.3.ebuild:
82 Version bump.
83
84*PyQt4-4.9.3 (27 Jun 2012)
85
86 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
87 -PyQt4-4.9.2.ebuild:
88 Version bump.
89
90 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
91 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
92
93*PyQt4-4.9.2 (21 Jun 2012)
94
95 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
96 Version bump
97
98 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
99 Destabling to ~ia64 because last available stable qt will be masked pending
100 removal
101
102 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
103 marked x86 per bug 412929
104
105 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
106 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
107 Inherit eutils.
108
109 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
110 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
111 Revert previous change.
112
113 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
114 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
115 Restrict python 3.1 to match dev-python/dbus-python.
116
117 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
118 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
119
120 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
121 Migrating dev-util/pkgconfig -> virtual/pkgconfig
122
123 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
124 Stable for amd64, wrt bug #412929
125
126 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
127 Stable on alpha, bug #354033
128
129 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
130 PyQt4-4.8.4.ebuild:
131 PyQt4-4.8 does not build with sip-4.13, bug 407291
132
133 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
134 Slightly improve the ewarn message in pkg_postinst().
135
136 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
137 Put qt as the primary herd in metadata.
138
139 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
140 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
141 <slong@rathaus.eclipse.co.uk> in bug #407281.
142
143 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
144 Switch to EAPI 4, add REQUIRED_USE.
145
146 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
147 PyQt4-4.8.4.ebuild:
148 Drop ~x86-fbsd because of unkeyworded dependencies.
149
150 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
151 Don't enable QtAssistant module because it was removed in qt-4.7 and we
152 already depend on 4.7.2 or later.
153
154 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
155 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
156 Restrict pypy for older versions too.
157
158 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
159 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
160 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
161 version.
162
163 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
164 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
165 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
166 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
167 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
168 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
169
170 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
171 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
172 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
173 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
174 Fixing pypy restricts to actually work
175
176*PyQt4-4.9.1 (12 Feb 2012)
177
178 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
179 version bump
180
181 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
182 builds with qt-opengl-4.8.0[egl], updated dep
183
184 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
185 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
186 Fixes backported from Progress Overlay. Patch by Arfrever.
187
188*PyQt4-4.9 (24 Dec 2011)
189
190 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
191 Version bump
192
193*PyQt4-4.8.6 (11 Nov 2011)
194
195 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
196 Version bump
197
198 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
199 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
200 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
201 python overlay.
202
203*PyQt4-4.8.5 (19 Aug 2011)
204
205 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
206 Version bump
207
208 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
209 ppc/ppc64 stable wrt #374591
210
211 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
212 x86 stable, bug #374591
213
214 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
215 ppc64 stable wrt #354033
216
217 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
218 Stable on amd64 wrt bug #374591
219
220 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
221 Marking PyQt4-4.8.3 ppc stable for bug 354033
222
223 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
224 Stable on amd64 wrt bug #354033
225
226 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
227 x86 stable per bug 354033
228
229*PyQt4-4.8.4 (02 May 2011)
230
231 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
232 +PyQt4-4.8.4.ebuild:
233 Version bump.
234
235 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
236 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
237 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
238 Adapt phonon dependency for package move
239
240 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
241 ppc64 stable wrt #349607
242
243 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
244 ia64/sparc stable wrt #349607
245
246 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
247 Stable on alpha, bug #349607
248
249 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
250 PyQt4-4.8.3.ebuild:
251 Update dependencies (bug #353053).
252
253*PyQt4-4.8.3 (25 Jan 2011)
254
255 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
256 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
257 Version bump.
258
259 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
260 x86 stable wrt bug #349607
261
262 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
263 Marking PyQt4-4.8.1 ppc stable for bug 349607
264
265 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
266 Stable on amd64 wrt bug #349607
267
268 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
269 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
270 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
271
272*PyQt4-4.8.1-r1 (30 Dec 2010)
273
274 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
275 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
276 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
277
278 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
279 PyQt4-4.8.2.ebuild:
280 Fix dependencies (bug #349672).
281
282*PyQt4-4.8.2 (24 Dec 2010)
283
284 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
285 +PyQt4-4.8.2.ebuild:
286 Version bump.
287
288 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
289 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
290 Restrict Jython ABIs.
291
292 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
293 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
294 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
295 -files/configure.py.patch:
296 Delete.
297
298 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
299 old, depends on qt 4.5
300
301 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
302 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
303 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
304 Remove HPPA keywording (bug #239441).
305
306*PyQt4-4.8.1 (30 Oct 2010)
307
308 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
309 +PyQt4-4.8.1.ebuild:
310 Version bump.
311
312 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
313 ia64/sparc stable wrt #315775
314
315*PyQt4-4.8 (23 Oct 2010)
316
317 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
318 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
319 +PyQt4-4.8.ebuild, metadata.xml:
320 Version bump.
321
322*PyQt4-4.7.7-r1 (06 Oct 2010)
323
324 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
325 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
326 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
327
328*PyQt4-4.7.7 (21 Sep 2010)
329
330 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
331 +PyQt4-4.7.7.ebuild:
332 Version bump. Remove old bogus version
333
334 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
335 Stable on alpha, bug #315775
336
337 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
338 Marked ppc stable for bug #315775.
339
340 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
341 PyQt4-4.7.6.ebuild:
342 Update EAPI. Fix dependencies.
343
344*PyQt4-4.7.6 (08 Sep 2010)
345
346 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
347 +PyQt4-4.7.6.ebuild:
348 Version bump. Remove old ebuild
349
350 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
351 PyQt4-4.7.5.ebuild:
352 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
353
354*PyQt4-4.7.5 (01 Sep 2010)
355
356 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
357 +PyQt4-4.7.5.ebuild:
358 Version bump
359
360 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
361 Stable for HPPA (bug #315775).
362
363 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
364 Bump sip dependency to 4.10.3. Fix arm epatch command
365
366*PyQt4-4.7.4 (13 Jul 2010)
367
368 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
369 Version bump
370
371 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
372 ppc64 stable wrt #315775
373
374 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
375 +files/PyQt4-4.7.3-qreal_float_support.patch:
376 Add patch for qreal/float support in ARM wrt bug 322349
377
378 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
379 x86 stable wrt bug 315775
380
381 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
382 Stable on amd64 wrt bug 315775
383
384 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
385 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
386 Fix sip dep in PyQt4 ebuilds
387
388*PyQt4-4.7.3 (17 Apr 2010)
389
390 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
391 Version bump
392
393 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
394 ppc stable #301105
395
396*PyQt4-4.7.2 (18 Mar 2010)
397
398 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
399 +files/PyQt4-4.7.2-configure.py.patch:
400 Version bump. ChangeLog is no longer shipped. Update patch.
401
402 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
403 stable x86, bug 301105
404
405 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
406 amd64 stable wrt #301105
4 407
5 16 Feb 2010; Jonathan Callen <abcd@gentoo.org> 408 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
6 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch, 409 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
7 -files/fix_license_check.patch: 410 -files/fix_license_check.patch:
8 Drop old patches 411 Drop old patches
444*PyQt4-4.0_beta1 (05 May 2006) 847*PyQt4-4.0_beta1 (05 May 2006)
445 848
446 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 849 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
447 +PyQt4-4.0_beta1.ebuild: 850 +PyQt4-4.0_beta1.ebuild:
448 initial import, from bug #121554 851 initial import, from bug #121554
449

Legend:
Removed from v.1.109  
changed lines
  Added in v.1.207

  ViewVC Help
Powered by ViewVC 1.1.20