/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.109 Revision 1.261
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.109 2010/02/16 06:47:45 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.261 2014/05/30 18:30:07 pesa Exp $
4
5*PyQt4-4.11 (30 May 2014)
6
7 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
8 Version bump.
9
10 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
11 PyQt4-4.10.3-r3.ebuild, metadata.xml:
12 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
13 Martin Walch in bug 510812.
14
15 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
16 -PyQt4-4.10.3.ebuild:
17 Drop the old versions that required python-exec:0.
18
19 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
20 Remove python herd as discussed with them.
21
22*PyQt4-4.10.3-r3 (27 Mar 2014)
23
24 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
25 Replace manual Python wrapping with proper eclass functions, bug #484404.
26
27 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
28 Stable for sparc, wrt bug #495638
29
30 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
31 Stable for x86, wrt bug #495638
32
33 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
34 Stable for alpha, wrt bug #495638
35
36 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
37 Stable for ia64, wrt bug #495638
38
39 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
40 Stable for ppc64, wrt bug #495638
41
42 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
43 amd64 stable, bug 495638
44
45 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
46 Stable for ppc, wrt bug #495638
47
48 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
49 arm stable, bug #495638
50
51 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
52 files/PyQt4-4.7.3-qreal_float_support.patch:
53 Updated qreal_float patch to remove first hunk (already applied
54 upstream). Tested on arm chromebook; no existing bug.
55
56*PyQt4-4.10.3-r2 (25 Dec 2013)
57
58 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
59 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
60 Introduce USE="designer".
61
62 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
63 old
64
65 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
66 Stable for sparc, wrt bug #483112
67
68 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
69 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
70 Update the ebuilds to dep on dev-lang/python-exec.
71
72 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
73 old
74
75*PyQt4-4.10.3-r1 (23 Oct 2013)
76
77 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
78 Support python-exec:2.
79
80 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
81 Depend on sip >=4.15.0 to fix build failure (bug #485274)
82
83 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
84 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
85 Add explicit dep on python-exec:0 since the package wraps the script manually.
86
87*PyQt4-4.10.3 (17 Sep 2013)
88
89 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
90 Version bump
91
92 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
93 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
94 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
95
96 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
97 arm stable, bug #483112
98
99 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
100 Stable for x86, wrt bug #483112
101
102 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
103 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
104 Clean up PYTHON_COMPAT from old implementations.
105
106 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
107 Stable for ppc64, wrt bug #483112
108
109 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
110 Stable for ppc, wrt bug #483112
111
112 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
113 Stable for ia64, wrt bug #483112
114
115 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
116 Stable for alpha, wrt bug #483112
117
118 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
119 Stable for amd64, wrt bug #483112
120
121 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
122 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
123 Reorder Qt dependencies.
124
125 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
126 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
127 Fixing qtgui/designer deps for qt-4.8.5
128
129 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
130 PyQt4-4.9.6-r2.ebuild:
131 Fixing qtgui deps for qt-4.8.5
132
133 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
134 Remove wrong usedep for qtgui.
135
136*PyQt4-4.10.2 (24 Jun 2013)
137
138 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
139 Version bump.
140
141 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
142 PyQt4-4.10.1.ebuild:
143 Add PYTHON_REQUIRED_USE. Remove old.
144
145*PyQt4-4.10.1 (22 May 2013)
146
147 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
148 Version bump.
149
150 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
151 Remove unused flag description from metadata
152
153 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
154 -files/PyQt4-4.7.2-configure.py.patch,
155 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
156 old
157
158*PyQt4-4.10 (12 Mar 2013)
159
160 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
161 Version bump. Fix also bug #433944 by Franz Fellner.
162
163 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
164 Stable for sparc, wrt bug #457046
165
166 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
167 PyQt4-4.9.6-r2.ebuild:
168 Move Qt dependencies to the new category
169
170 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
171 Stable for ia64, wrt bug #457046
172
173 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
174 Stable for ppc64, wrt bug #457046
175
176 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
177 Stable for ppc, wrt bug #457046
178
179 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
180 Stable for alpha, wrt bug #457046
181
182 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
183 Stable for arm, wrt bug #457046
184
185 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
186 Stable for x86, wrt bug #457046
187
188 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
189 Stable for amd64, wrt bug #457046
190
191 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
192 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
193
194 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
195 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
196 Fix double prefix; remove old.
197
198 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
199 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
200
201*PyQt4-4.9.6-r2 (29 Jan 2013)
202
203 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
204 Migrate to the new python eclass.
205
206 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
207 Improve pyqt4_use_enable() as suggested by Arfrever.
208
209 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
210 old
211
212*PyQt4-4.9.6-r1 (26 Dec 2012)
213
214 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
215 metadata.xml:
216 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
217 pyside: rename assistant to help, add script and scripttools (bug 431460 by
218 Arfrever).
219
220*PyQt4-4.9.6 (10 Dec 2012)
221
222 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
223 Version bump, with some minor updates from qt overlay.
224
225 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
226 arm stable, bug #435074
227
228 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
229 PyQt4-4.9.4-r1.ebuild:
230 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
231
232 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
233 -PyQt4-4.9.1.ebuild:
234 Remove old
235
236*PyQt4-4.9.5 (05 Oct 2012)
237
238 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
239 Version bump
240
241 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
242 alpha/ia64/sparc stable wrt #429042
243
244*PyQt4-4.9.4-r1 (03 Sep 2012)
245
246 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
247 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
248 Apply upstream patch to fix regression in pyuic's handling of custom widgets
249 (bug 431070 by Laurent Bachelier).
250
251 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
252 Stable for x86, wrt bug #429042
253
254 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
255 Stable for amd64, wrt bug #429042
256
257 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
258 Stable ppc64, bug #429042
259
260 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
261 Stable ppc, bug #429042
262
263 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
264 ia64 stable
265
266 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
267 -files/PyQt4-4.6.1-configure-multilib.patch:
268 Remove old.
269
270 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
271 PyQt4-4.9.4.ebuild:
272 alpha/ia64/sparc stable wrt #412929
273
274*PyQt4-4.9.4 (02 Jul 2012)
275
276 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
277 -PyQt4-4.9.3.ebuild:
278 Version bump.
279
280*PyQt4-4.9.3 (27 Jun 2012)
281
282 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
283 -PyQt4-4.9.2.ebuild:
284 Version bump.
285
286 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
287 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
288
289*PyQt4-4.9.2 (21 Jun 2012)
290
291 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
292 Version bump
293
294 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
295 Destabling to ~ia64 because last available stable qt will be masked pending
296 removal
297
298 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
299 marked x86 per bug 412929
300
301 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
302 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
303 Inherit eutils.
304
305 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
306 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
307 Revert previous change.
308
309 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
310 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
311 Restrict python 3.1 to match dev-python/dbus-python.
312
313 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
314 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
315
316 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
317 Migrating dev-util/pkgconfig -> virtual/pkgconfig
318
319 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
320 Stable for amd64, wrt bug #412929
321
322 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
323 Stable on alpha, bug #354033
324
325 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
326 PyQt4-4.8.4.ebuild:
327 PyQt4-4.8 does not build with sip-4.13, bug 407291
328
329 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
330 Slightly improve the ewarn message in pkg_postinst().
331
332 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
333 Put qt as the primary herd in metadata.
334
335 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
336 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
337 <slong@rathaus.eclipse.co.uk> in bug #407281.
338
339 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
340 Switch to EAPI 4, add REQUIRED_USE.
341
342 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
343 PyQt4-4.8.4.ebuild:
344 Drop ~x86-fbsd because of unkeyworded dependencies.
345
346 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
347 Don't enable QtAssistant module because it was removed in qt-4.7 and we
348 already depend on 4.7.2 or later.
349
350 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
351 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
352 Restrict pypy for older versions too.
353
354 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
355 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
356 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
357 version.
358
359 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
360 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
361 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
362 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
363 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
364 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
365
366 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
367 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
368 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
369 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
370 Fixing pypy restricts to actually work
371
372*PyQt4-4.9.1 (12 Feb 2012)
373
374 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
375 version bump
376
377 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
378 builds with qt-opengl-4.8.0[egl], updated dep
379
380 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
381 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
382 Fixes backported from Progress Overlay. Patch by Arfrever.
383
384*PyQt4-4.9 (24 Dec 2011)
385
386 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
387 Version bump
388
389*PyQt4-4.8.6 (11 Nov 2011)
390
391 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
392 Version bump
393
394 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
395 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
396 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
397 python overlay.
398
399*PyQt4-4.8.5 (19 Aug 2011)
400
401 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
402 Version bump
403
404 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
405 ppc/ppc64 stable wrt #374591
406
407 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
408 x86 stable, bug #374591
409
410 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
411 ppc64 stable wrt #354033
412
413 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
414 Stable on amd64 wrt bug #374591
415
416 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
417 Marking PyQt4-4.8.3 ppc stable for bug 354033
418
419 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
420 Stable on amd64 wrt bug #354033
421
422 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
423 x86 stable per bug 354033
424
425*PyQt4-4.8.4 (02 May 2011)
426
427 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
428 +PyQt4-4.8.4.ebuild:
429 Version bump.
430
431 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
432 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
433 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
434 Adapt phonon dependency for package move
435
436 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
437 ppc64 stable wrt #349607
438
439 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
440 ia64/sparc stable wrt #349607
441
442 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
443 Stable on alpha, bug #349607
444
445 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
446 PyQt4-4.8.3.ebuild:
447 Update dependencies (bug #353053).
448
449*PyQt4-4.8.3 (25 Jan 2011)
450
451 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
452 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
453 Version bump.
454
455 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
456 x86 stable wrt bug #349607
457
458 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
459 Marking PyQt4-4.8.1 ppc stable for bug 349607
460
461 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
462 Stable on amd64 wrt bug #349607
463
464 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
465 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
466 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
467
468*PyQt4-4.8.1-r1 (30 Dec 2010)
469
470 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
471 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
472 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
473
474 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
475 PyQt4-4.8.2.ebuild:
476 Fix dependencies (bug #349672).
477
478*PyQt4-4.8.2 (24 Dec 2010)
479
480 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
481 +PyQt4-4.8.2.ebuild:
482 Version bump.
483
484 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
485 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
486 Restrict Jython ABIs.
487
488 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
489 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
490 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
491 -files/configure.py.patch:
492 Delete.
493
494 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
495 old, depends on qt 4.5
496
497 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
498 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
499 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
500 Remove HPPA keywording (bug #239441).
501
502*PyQt4-4.8.1 (30 Oct 2010)
503
504 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
505 +PyQt4-4.8.1.ebuild:
506 Version bump.
507
508 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
509 ia64/sparc stable wrt #315775
510
511*PyQt4-4.8 (23 Oct 2010)
512
513 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
514 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
515 +PyQt4-4.8.ebuild, metadata.xml:
516 Version bump.
517
518*PyQt4-4.7.7-r1 (06 Oct 2010)
519
520 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
521 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
522 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
523
524*PyQt4-4.7.7 (21 Sep 2010)
525
526 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
527 +PyQt4-4.7.7.ebuild:
528 Version bump. Remove old bogus version
529
530 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
531 Stable on alpha, bug #315775
532
533 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
534 Marked ppc stable for bug #315775.
535
536 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
537 PyQt4-4.7.6.ebuild:
538 Update EAPI. Fix dependencies.
539
540*PyQt4-4.7.6 (08 Sep 2010)
541
542 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
543 +PyQt4-4.7.6.ebuild:
544 Version bump. Remove old ebuild
545
546 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
547 PyQt4-4.7.5.ebuild:
548 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
549
550*PyQt4-4.7.5 (01 Sep 2010)
551
552 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
553 +PyQt4-4.7.5.ebuild:
554 Version bump
555
556 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
557 Stable for HPPA (bug #315775).
558
559 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
560 Bump sip dependency to 4.10.3. Fix arm epatch command
561
562*PyQt4-4.7.4 (13 Jul 2010)
563
564 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
565 Version bump
566
567 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
568 ppc64 stable wrt #315775
569
570 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
571 +files/PyQt4-4.7.3-qreal_float_support.patch:
572 Add patch for qreal/float support in ARM wrt bug 322349
573
574 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
575 x86 stable wrt bug 315775
576
577 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
578 Stable on amd64 wrt bug 315775
579
580 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
581 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
582 Fix sip dep in PyQt4 ebuilds
583
584*PyQt4-4.7.3 (17 Apr 2010)
585
586 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
587 Version bump
588
589 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
590 ppc stable #301105
591
592*PyQt4-4.7.2 (18 Mar 2010)
593
594 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
595 +files/PyQt4-4.7.2-configure.py.patch:
596 Version bump. ChangeLog is no longer shipped. Update patch.
597
598 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
599 stable x86, bug 301105
600
601 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
602 amd64 stable wrt #301105
4 603
5 16 Feb 2010; Jonathan Callen <abcd@gentoo.org> 604 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
6 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch, 605 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
7 -files/fix_license_check.patch: 606 -files/fix_license_check.patch:
8 Drop old patches 607 Drop old patches
444*PyQt4-4.0_beta1 (05 May 2006) 1043*PyQt4-4.0_beta1 (05 May 2006)
445 1044
446 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1045 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
447 +PyQt4-4.0_beta1.ebuild: 1046 +PyQt4-4.0_beta1.ebuild:
448 initial import, from bug #121554 1047 initial import, from bug #121554
449

Legend:
Removed from v.1.109  
changed lines
  Added in v.1.261

  ViewVC Help
Powered by ViewVC 1.1.20