/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.109 Revision 1.283
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.109 2010/02/16 06:47:45 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.283 2015/02/17 11:09:13 ago Exp $
4
5 17 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
6 Stable for ppc64, wrt bug #517344
7
8 16 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
9 Stable for ppc, wrt bug #517344
10
11 14 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
12 Stable for x86, wrt bug #517344
13
14 09 Jan 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.3.ebuild:
15 Stop using deprecated python_parallel_foreach_impl.
16
17 31 Dec 2014; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.3-r2.ebuild,
18 PyQt4-4.11.1.ebuild, PyQt4-4.11.2.ebuild:
19 Enforce USE dependency for media-libs/phonon.
20
21 10 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> PyQt4-4.11.1.ebuild:
22 amd64 stable wrt bug #517344
23
24 22 Nov 2014; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.11.1.ebuild:
25 Stable on alpha, bug 523322
26
27*PyQt4-4.11.3 (15 Nov 2014)
28
29 15 Nov 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.3.ebuild,
30 -PyQt4-4.11.3_pre20141024.ebuild:
31 Version bump.
32
33*PyQt4-4.11.3_pre20141024 (01 Nov 2014)
34
35 01 Nov 2014; Davide Pesavento <pesa@gentoo.org>
36 +PyQt4-4.11.3_pre20141024.ebuild, -PyQt4-4.11.2-r1.ebuild:
37 Bump to 4.11.3 prerelease, which contains upstream fixes for bugs #525392 and
38 #525470. Also switch to out-of-source builds.
39
40 15 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.2-r1.ebuild:
41 Fix bug #525392.
42
43 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
44 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
45 Fix building against media-libs/phonon (bug 525354).
46
47*PyQt4-4.11.2-r1 (13 Oct 2014)
48
49 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
50 metadata.xml:
51 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
52 from QtGui.
53
54 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
55 Revert to ~amd64, see bug #523322 comment #4.
56
57 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
58 Stable for amd64, wrt bug #523322
59
60 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
61 arm stable, bug #523322
62
63*PyQt4-4.11.2 (20 Sep 2014)
64
65 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
66 PyQt4-4.11.1.ebuild:
67 Version bump. Silence harmless repoman warning.
68
69 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
70 Drop deprecated python versions.
71
72 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
73 PyQt4-4.11.1.ebuild:
74 Stop using dohtml, remove old.
75
76 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
77 Remove old.
78
79*PyQt4-4.11.1 (15 Jul 2014)
80
81 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
82 PyQt4-4.11.ebuild:
83 Version bump.
84
85 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
86 PyQt4-4.11.ebuild:
87 add py3.4 support req'd to support py packages such as pandas
88
89 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
90 PyQt4-4.10.3-r3.ebuild:
91 Restrict sip dep to =4.15* for older PyQt4 versions.
92
93*PyQt4-4.11 (30 May 2014)
94
95 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
96 Version bump.
97
98 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
99 PyQt4-4.10.3-r3.ebuild, metadata.xml:
100 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
101 Martin Walch in bug 510812.
102
103 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
104 -PyQt4-4.10.3.ebuild:
105 Drop the old versions that required python-exec:0.
106
107 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
108 Remove python herd as discussed with them.
109
110*PyQt4-4.10.3-r3 (27 Mar 2014)
111
112 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
113 Replace manual Python wrapping with proper eclass functions, bug #484404.
114
115 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
116 Stable for sparc, wrt bug #495638
117
118 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
119 Stable for x86, wrt bug #495638
120
121 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
122 Stable for alpha, wrt bug #495638
123
124 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
125 Stable for ia64, wrt bug #495638
126
127 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
128 Stable for ppc64, wrt bug #495638
129
130 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
131 amd64 stable, bug 495638
132
133 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
134 Stable for ppc, wrt bug #495638
135
136 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
137 arm stable, bug #495638
138
139 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
140 files/PyQt4-4.7.3-qreal_float_support.patch:
141 Updated qreal_float patch to remove first hunk (already applied
142 upstream). Tested on arm chromebook; no existing bug.
143
144*PyQt4-4.10.3-r2 (25 Dec 2013)
145
146 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
147 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
148 Introduce USE="designer".
149
150 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
151 old
152
153 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
154 Stable for sparc, wrt bug #483112
155
156 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
157 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
158 Update the ebuilds to dep on dev-lang/python-exec.
159
160 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
161 old
162
163*PyQt4-4.10.3-r1 (23 Oct 2013)
164
165 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
166 Support python-exec:2.
167
168 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
169 Depend on sip >=4.15.0 to fix build failure (bug #485274)
170
171 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
172 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
173 Add explicit dep on python-exec:0 since the package wraps the script manually.
174
175*PyQt4-4.10.3 (17 Sep 2013)
176
177 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
178 Version bump
179
180 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
181 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
182 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
183
184 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
185 arm stable, bug #483112
186
187 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
188 Stable for x86, wrt bug #483112
189
190 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
191 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
192 Clean up PYTHON_COMPAT from old implementations.
193
194 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
195 Stable for ppc64, wrt bug #483112
196
197 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
198 Stable for ppc, wrt bug #483112
199
200 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
201 Stable for ia64, wrt bug #483112
202
203 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
204 Stable for alpha, wrt bug #483112
205
206 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
207 Stable for amd64, wrt bug #483112
208
209 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
210 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
211 Reorder Qt dependencies.
212
213 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
214 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
215 Fixing qtgui/designer deps for qt-4.8.5
216
217 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
218 PyQt4-4.9.6-r2.ebuild:
219 Fixing qtgui deps for qt-4.8.5
220
221 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
222 Remove wrong usedep for qtgui.
223
224*PyQt4-4.10.2 (24 Jun 2013)
225
226 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
227 Version bump.
228
229 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
230 PyQt4-4.10.1.ebuild:
231 Add PYTHON_REQUIRED_USE. Remove old.
232
233*PyQt4-4.10.1 (22 May 2013)
234
235 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
236 Version bump.
237
238 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
239 Remove unused flag description from metadata
240
241 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
242 -files/PyQt4-4.7.2-configure.py.patch,
243 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
244 old
245
246*PyQt4-4.10 (12 Mar 2013)
247
248 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
249 Version bump. Fix also bug #433944 by Franz Fellner.
250
251 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
252 Stable for sparc, wrt bug #457046
253
254 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
255 PyQt4-4.9.6-r2.ebuild:
256 Move Qt dependencies to the new category
257
258 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
259 Stable for ia64, wrt bug #457046
260
261 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
262 Stable for ppc64, wrt bug #457046
263
264 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
265 Stable for ppc, wrt bug #457046
266
267 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
268 Stable for alpha, wrt bug #457046
269
270 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
271 Stable for arm, wrt bug #457046
272
273 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
274 Stable for x86, wrt bug #457046
275
276 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
277 Stable for amd64, wrt bug #457046
278
279 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
280 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
281
282 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
283 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
284 Fix double prefix; remove old.
285
286 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
287 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
288
289*PyQt4-4.9.6-r2 (29 Jan 2013)
290
291 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
292 Migrate to the new python eclass.
293
294 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
295 Improve pyqt4_use_enable() as suggested by Arfrever.
296
297 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
298 old
299
300*PyQt4-4.9.6-r1 (26 Dec 2012)
301
302 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
303 metadata.xml:
304 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
305 pyside: rename assistant to help, add script and scripttools (bug 431460 by
306 Arfrever).
307
308*PyQt4-4.9.6 (10 Dec 2012)
309
310 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
311 Version bump, with some minor updates from qt overlay.
312
313 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
314 arm stable, bug #435074
315
316 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
317 PyQt4-4.9.4-r1.ebuild:
318 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
319
320 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
321 -PyQt4-4.9.1.ebuild:
322 Remove old
323
324*PyQt4-4.9.5 (05 Oct 2012)
325
326 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
327 Version bump
328
329 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
330 alpha/ia64/sparc stable wrt #429042
331
332*PyQt4-4.9.4-r1 (03 Sep 2012)
333
334 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
335 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
336 Apply upstream patch to fix regression in pyuic's handling of custom widgets
337 (bug 431070 by Laurent Bachelier).
338
339 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
340 Stable for x86, wrt bug #429042
341
342 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
343 Stable for amd64, wrt bug #429042
344
345 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
346 Stable ppc64, bug #429042
347
348 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
349 Stable ppc, bug #429042
350
351 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
352 ia64 stable
353
354 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
355 -files/PyQt4-4.6.1-configure-multilib.patch:
356 Remove old.
357
358 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
359 PyQt4-4.9.4.ebuild:
360 alpha/ia64/sparc stable wrt #412929
361
362*PyQt4-4.9.4 (02 Jul 2012)
363
364 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
365 -PyQt4-4.9.3.ebuild:
366 Version bump.
367
368*PyQt4-4.9.3 (27 Jun 2012)
369
370 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
371 -PyQt4-4.9.2.ebuild:
372 Version bump.
373
374 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
375 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
376
377*PyQt4-4.9.2 (21 Jun 2012)
378
379 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
380 Version bump
381
382 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
383 Destabling to ~ia64 because last available stable qt will be masked pending
384 removal
385
386 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
387 marked x86 per bug 412929
388
389 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
390 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
391 Inherit eutils.
392
393 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
394 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
395 Revert previous change.
396
397 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
398 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
399 Restrict python 3.1 to match dev-python/dbus-python.
400
401 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
402 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
403
404 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
405 Migrating dev-util/pkgconfig -> virtual/pkgconfig
406
407 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
408 Stable for amd64, wrt bug #412929
409
410 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
411 Stable on alpha, bug #354033
412
413 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
414 PyQt4-4.8.4.ebuild:
415 PyQt4-4.8 does not build with sip-4.13, bug 407291
416
417 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
418 Slightly improve the ewarn message in pkg_postinst().
419
420 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
421 Put qt as the primary herd in metadata.
422
423 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
424 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
425 <slong@rathaus.eclipse.co.uk> in bug #407281.
426
427 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
428 Switch to EAPI 4, add REQUIRED_USE.
429
430 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
431 PyQt4-4.8.4.ebuild:
432 Drop ~x86-fbsd because of unkeyworded dependencies.
433
434 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
435 Don't enable QtAssistant module because it was removed in qt-4.7 and we
436 already depend on 4.7.2 or later.
437
438 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
439 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
440 Restrict pypy for older versions too.
441
442 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
443 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
444 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
445 version.
446
447 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
448 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
449 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
450 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
451 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
452 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
453
454 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
455 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
456 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
457 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
458 Fixing pypy restricts to actually work
459
460*PyQt4-4.9.1 (12 Feb 2012)
461
462 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
463 version bump
464
465 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
466 builds with qt-opengl-4.8.0[egl], updated dep
467
468 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
469 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
470 Fixes backported from Progress Overlay. Patch by Arfrever.
471
472*PyQt4-4.9 (24 Dec 2011)
473
474 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
475 Version bump
476
477*PyQt4-4.8.6 (11 Nov 2011)
478
479 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
480 Version bump
481
482 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
483 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
484 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
485 python overlay.
486
487*PyQt4-4.8.5 (19 Aug 2011)
488
489 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
490 Version bump
491
492 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
493 ppc/ppc64 stable wrt #374591
494
495 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
496 x86 stable, bug #374591
497
498 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
499 ppc64 stable wrt #354033
500
501 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
502 Stable on amd64 wrt bug #374591
503
504 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
505 Marking PyQt4-4.8.3 ppc stable for bug 354033
506
507 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
508 Stable on amd64 wrt bug #354033
509
510 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
511 x86 stable per bug 354033
512
513*PyQt4-4.8.4 (02 May 2011)
514
515 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
516 +PyQt4-4.8.4.ebuild:
517 Version bump.
518
519 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
520 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
521 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
522 Adapt phonon dependency for package move
523
524 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
525 ppc64 stable wrt #349607
526
527 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
528 ia64/sparc stable wrt #349607
529
530 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
531 Stable on alpha, bug #349607
532
533 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
534 PyQt4-4.8.3.ebuild:
535 Update dependencies (bug #353053).
536
537*PyQt4-4.8.3 (25 Jan 2011)
538
539 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
540 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
541 Version bump.
542
543 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
544 x86 stable wrt bug #349607
545
546 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
547 Marking PyQt4-4.8.1 ppc stable for bug 349607
548
549 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
550 Stable on amd64 wrt bug #349607
551
552 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
553 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
554 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
555
556*PyQt4-4.8.1-r1 (30 Dec 2010)
557
558 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
559 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
560 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
561
562 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
563 PyQt4-4.8.2.ebuild:
564 Fix dependencies (bug #349672).
565
566*PyQt4-4.8.2 (24 Dec 2010)
567
568 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
569 +PyQt4-4.8.2.ebuild:
570 Version bump.
571
572 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
573 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
574 Restrict Jython ABIs.
575
576 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
577 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
578 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
579 -files/configure.py.patch:
580 Delete.
581
582 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
583 old, depends on qt 4.5
584
585 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
586 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
587 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
588 Remove HPPA keywording (bug #239441).
589
590*PyQt4-4.8.1 (30 Oct 2010)
591
592 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
593 +PyQt4-4.8.1.ebuild:
594 Version bump.
595
596 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
597 ia64/sparc stable wrt #315775
598
599*PyQt4-4.8 (23 Oct 2010)
600
601 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
602 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
603 +PyQt4-4.8.ebuild, metadata.xml:
604 Version bump.
605
606*PyQt4-4.7.7-r1 (06 Oct 2010)
607
608 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
609 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
610 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
611
612*PyQt4-4.7.7 (21 Sep 2010)
613
614 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
615 +PyQt4-4.7.7.ebuild:
616 Version bump. Remove old bogus version
617
618 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
619 Stable on alpha, bug #315775
620
621 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
622 Marked ppc stable for bug #315775.
623
624 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
625 PyQt4-4.7.6.ebuild:
626 Update EAPI. Fix dependencies.
627
628*PyQt4-4.7.6 (08 Sep 2010)
629
630 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
631 +PyQt4-4.7.6.ebuild:
632 Version bump. Remove old ebuild
633
634 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
635 PyQt4-4.7.5.ebuild:
636 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
637
638*PyQt4-4.7.5 (01 Sep 2010)
639
640 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
641 +PyQt4-4.7.5.ebuild:
642 Version bump
643
644 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
645 Stable for HPPA (bug #315775).
646
647 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
648 Bump sip dependency to 4.10.3. Fix arm epatch command
649
650*PyQt4-4.7.4 (13 Jul 2010)
651
652 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
653 Version bump
654
655 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
656 ppc64 stable wrt #315775
657
658 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
659 +files/PyQt4-4.7.3-qreal_float_support.patch:
660 Add patch for qreal/float support in ARM wrt bug 322349
661
662 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
663 x86 stable wrt bug 315775
664
665 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
666 Stable on amd64 wrt bug 315775
667
668 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
669 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
670 Fix sip dep in PyQt4 ebuilds
671
672*PyQt4-4.7.3 (17 Apr 2010)
673
674 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
675 Version bump
676
677 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
678 ppc stable #301105
679
680*PyQt4-4.7.2 (18 Mar 2010)
681
682 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
683 +files/PyQt4-4.7.2-configure.py.patch:
684 Version bump. ChangeLog is no longer shipped. Update patch.
685
686 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
687 stable x86, bug 301105
688
689 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
690 amd64 stable wrt #301105
4 691
5 16 Feb 2010; Jonathan Callen <abcd@gentoo.org> 692 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
6 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch, 693 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
7 -files/fix_license_check.patch: 694 -files/fix_license_check.patch:
8 Drop old patches 695 Drop old patches
444*PyQt4-4.0_beta1 (05 May 2006) 1131*PyQt4-4.0_beta1 (05 May 2006)
445 1132
446 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1133 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
447 +PyQt4-4.0_beta1.ebuild: 1134 +PyQt4-4.0_beta1.ebuild:
448 initial import, from bug #121554 1135 initial import, from bug #121554
449

Legend:
Removed from v.1.109  
changed lines
  Added in v.1.283

  ViewVC Help
Powered by ViewVC 1.1.20