/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.171
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.171 2012/03/02 18:34:25 pesa Exp $
4
5 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
6 PyQt4-4.8.4.ebuild:
7 Drop ~x86-fbsd because of unkeyworded dependencies.
8
9 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
10 Don't enable QtAssistant module because it was removed in qt-4.7 and we
11 already depend on 4.7.2 or later.
12
13 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
14 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
15 Restrict pypy for older versions too.
16
17 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
18 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
19 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
20 version.
21
22 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
23 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
24 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
25 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
26 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
27 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
28
29 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
30 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
31 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
32 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
33 Fixing pypy restricts to actually work
34
35*PyQt4-4.9.1 (12 Feb 2012)
36
37 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
38 version bump
39
40 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
41 builds with qt-opengl-4.8.0[egl], updated dep
42
43 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
44 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
45 Fixes backported from Progress Overlay. Patch by Arfrever.
46
47*PyQt4-4.9 (24 Dec 2011)
48
49 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
50 Version bump
51
52*PyQt4-4.8.6 (11 Nov 2011)
53
54 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
55 Version bump
56
57 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
58 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
59 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
60 python overlay.
61
62*PyQt4-4.8.5 (19 Aug 2011)
63
64 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
65 Version bump
66
67 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
68 ppc/ppc64 stable wrt #374591
69
70 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
71 x86 stable, bug #374591
72
73 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
74 ppc64 stable wrt #354033
75
76 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
77 Stable on amd64 wrt bug #374591
78
79 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
80 Marking PyQt4-4.8.3 ppc stable for bug 354033
81
82 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
83 Stable on amd64 wrt bug #354033
84
85 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
86 x86 stable per bug 354033
87
88*PyQt4-4.8.4 (02 May 2011)
89
90 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
91 +PyQt4-4.8.4.ebuild:
92 Version bump.
93
94 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
95 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
96 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
97 Adapt phonon dependency for package move
98
99 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
100 ppc64 stable wrt #349607
101
102 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
103 ia64/sparc stable wrt #349607
104
105 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
106 Stable on alpha, bug #349607
107
108 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
109 PyQt4-4.8.3.ebuild:
110 Update dependencies (bug #353053).
111
112*PyQt4-4.8.3 (25 Jan 2011)
113
114 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
115 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
116 Version bump.
117
118 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
119 x86 stable wrt bug #349607
120
121 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
122 Marking PyQt4-4.8.1 ppc stable for bug 349607
123
124 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
125 Stable on amd64 wrt bug #349607
126
127 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
128 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
129 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
130
131*PyQt4-4.8.1-r1 (30 Dec 2010)
132
133 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
134 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
135 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
136
137 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
138 PyQt4-4.8.2.ebuild:
139 Fix dependencies (bug #349672).
140
141*PyQt4-4.8.2 (24 Dec 2010)
142
143 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
144 +PyQt4-4.8.2.ebuild:
145 Version bump.
146
147 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
148 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
149 Restrict Jython ABIs.
150
151 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
152 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
153 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
154 -files/configure.py.patch:
155 Delete.
156
157 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
158 old, depends on qt 4.5
159
160 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
161 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
162 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
163 Remove HPPA keywording (bug #239441).
164
165*PyQt4-4.8.1 (30 Oct 2010)
166
167 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
168 +PyQt4-4.8.1.ebuild:
169 Version bump.
170
171 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
172 ia64/sparc stable wrt #315775
173
174*PyQt4-4.8 (23 Oct 2010)
175
176 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
177 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
178 +PyQt4-4.8.ebuild, metadata.xml:
179 Version bump.
180
181*PyQt4-4.7.7-r1 (06 Oct 2010)
182
183 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
184 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
185 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
186
187*PyQt4-4.7.7 (21 Sep 2010)
188
189 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
190 +PyQt4-4.7.7.ebuild:
191 Version bump. Remove old bogus version
192
193 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
194 Stable on alpha, bug #315775
195
196 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
197 Marked ppc stable for bug #315775.
198
199 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
200 PyQt4-4.7.6.ebuild:
201 Update EAPI. Fix dependencies.
202
203*PyQt4-4.7.6 (08 Sep 2010)
204
205 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
206 +PyQt4-4.7.6.ebuild:
207 Version bump. Remove old ebuild
208
209 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
210 PyQt4-4.7.5.ebuild:
211 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
212
213*PyQt4-4.7.5 (01 Sep 2010)
214
215 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
216 +PyQt4-4.7.5.ebuild:
217 Version bump
218
219 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
220 Stable for HPPA (bug #315775).
4 221
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 222 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 223 Bump sip dependency to 4.10.3. Fix arm epatch command
7 224
8*PyQt4-4.7.4 (13 Jul 2010) 225*PyQt4-4.7.4 (13 Jul 2010)

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.171

  ViewVC Help
Powered by ViewVC 1.1.20