/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.172
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.172 2012/03/03 11:48:59 pesa Exp $
4
5 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
6 Switch to EAPI 4, add REQUIRED_USE.
7
8 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
9 PyQt4-4.8.4.ebuild:
10 Drop ~x86-fbsd because of unkeyworded dependencies.
11
12 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
13 Don't enable QtAssistant module because it was removed in qt-4.7 and we
14 already depend on 4.7.2 or later.
15
16 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
17 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
18 Restrict pypy for older versions too.
19
20 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
21 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
22 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
23 version.
24
25 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
26 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
27 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
28 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
29 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
30 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
31
32 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
33 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
34 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
35 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
36 Fixing pypy restricts to actually work
37
38*PyQt4-4.9.1 (12 Feb 2012)
39
40 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
41 version bump
42
43 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
44 builds with qt-opengl-4.8.0[egl], updated dep
45
46 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
47 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
48 Fixes backported from Progress Overlay. Patch by Arfrever.
49
50*PyQt4-4.9 (24 Dec 2011)
51
52 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
53 Version bump
54
55*PyQt4-4.8.6 (11 Nov 2011)
56
57 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
58 Version bump
59
60 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
61 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
62 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
63 python overlay.
64
65*PyQt4-4.8.5 (19 Aug 2011)
66
67 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
68 Version bump
69
70 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
71 ppc/ppc64 stable wrt #374591
72
73 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
74 x86 stable, bug #374591
75
76 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
77 ppc64 stable wrt #354033
78
79 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
80 Stable on amd64 wrt bug #374591
81
82 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
83 Marking PyQt4-4.8.3 ppc stable for bug 354033
84
85 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
86 Stable on amd64 wrt bug #354033
87
88 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
89 x86 stable per bug 354033
90
91*PyQt4-4.8.4 (02 May 2011)
92
93 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
94 +PyQt4-4.8.4.ebuild:
95 Version bump.
96
97 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
98 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
99 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
100 Adapt phonon dependency for package move
101
102 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
103 ppc64 stable wrt #349607
104
105 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
106 ia64/sparc stable wrt #349607
107
108 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
109 Stable on alpha, bug #349607
110
111 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
112 PyQt4-4.8.3.ebuild:
113 Update dependencies (bug #353053).
114
115*PyQt4-4.8.3 (25 Jan 2011)
116
117 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
118 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
119 Version bump.
120
121 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
122 x86 stable wrt bug #349607
123
124 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
125 Marking PyQt4-4.8.1 ppc stable for bug 349607
126
127 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
128 Stable on amd64 wrt bug #349607
129
130 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
131 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
132 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
133
134*PyQt4-4.8.1-r1 (30 Dec 2010)
135
136 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
137 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
138 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
139
140 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
141 PyQt4-4.8.2.ebuild:
142 Fix dependencies (bug #349672).
143
144*PyQt4-4.8.2 (24 Dec 2010)
145
146 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
147 +PyQt4-4.8.2.ebuild:
148 Version bump.
149
150 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
151 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
152 Restrict Jython ABIs.
153
154 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
155 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
156 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
157 -files/configure.py.patch:
158 Delete.
159
160 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
161 old, depends on qt 4.5
162
163 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
164 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
165 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
166 Remove HPPA keywording (bug #239441).
167
168*PyQt4-4.8.1 (30 Oct 2010)
169
170 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
171 +PyQt4-4.8.1.ebuild:
172 Version bump.
173
174 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
175 ia64/sparc stable wrt #315775
176
177*PyQt4-4.8 (23 Oct 2010)
178
179 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
180 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
181 +PyQt4-4.8.ebuild, metadata.xml:
182 Version bump.
183
184*PyQt4-4.7.7-r1 (06 Oct 2010)
185
186 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
187 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
188 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
189
190*PyQt4-4.7.7 (21 Sep 2010)
191
192 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
193 +PyQt4-4.7.7.ebuild:
194 Version bump. Remove old bogus version
195
196 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
197 Stable on alpha, bug #315775
198
199 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
200 Marked ppc stable for bug #315775.
201
202 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
203 PyQt4-4.7.6.ebuild:
204 Update EAPI. Fix dependencies.
205
206*PyQt4-4.7.6 (08 Sep 2010)
207
208 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
209 +PyQt4-4.7.6.ebuild:
210 Version bump. Remove old ebuild
211
212 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
213 PyQt4-4.7.5.ebuild:
214 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
215
216*PyQt4-4.7.5 (01 Sep 2010)
217
218 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
219 +PyQt4-4.7.5.ebuild:
220 Version bump
221
222 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
223 Stable for HPPA (bug #315775).
4 224
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 225 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 226 Bump sip dependency to 4.10.3. Fix arm epatch command
7 227
8*PyQt4-4.7.4 (13 Jul 2010) 228*PyQt4-4.7.4 (13 Jul 2010)

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.172

  ViewVC Help
Powered by ViewVC 1.1.20