/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.177
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.177 2012/03/31 14:14:31 klausman Exp $
4
5 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
6 Stable on alpha, bug #354033
7
8 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
9 PyQt4-4.8.4.ebuild:
10 PyQt4-4.8 does not build with sip-4.13, bug 407291
11
12 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
13 Slightly improve the ewarn message in pkg_postinst().
14
15 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
16 Put qt as the primary herd in metadata.
17
18 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
19 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
20 <slong@rathaus.eclipse.co.uk> in bug #407281.
21
22 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
23 Switch to EAPI 4, add REQUIRED_USE.
24
25 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
26 PyQt4-4.8.4.ebuild:
27 Drop ~x86-fbsd because of unkeyworded dependencies.
28
29 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
30 Don't enable QtAssistant module because it was removed in qt-4.7 and we
31 already depend on 4.7.2 or later.
32
33 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
34 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
35 Restrict pypy for older versions too.
36
37 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
38 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
39 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
40 version.
41
42 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
43 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
44 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
45 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
46 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
47 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
48
49 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
50 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
51 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
52 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
53 Fixing pypy restricts to actually work
54
55*PyQt4-4.9.1 (12 Feb 2012)
56
57 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
58 version bump
59
60 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
61 builds with qt-opengl-4.8.0[egl], updated dep
62
63 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
64 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
65 Fixes backported from Progress Overlay. Patch by Arfrever.
66
67*PyQt4-4.9 (24 Dec 2011)
68
69 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
70 Version bump
71
72*PyQt4-4.8.6 (11 Nov 2011)
73
74 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
75 Version bump
76
77 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
78 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
79 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
80 python overlay.
81
82*PyQt4-4.8.5 (19 Aug 2011)
83
84 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
85 Version bump
86
87 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
88 ppc/ppc64 stable wrt #374591
89
90 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
91 x86 stable, bug #374591
92
93 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
94 ppc64 stable wrt #354033
95
96 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
97 Stable on amd64 wrt bug #374591
98
99 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
100 Marking PyQt4-4.8.3 ppc stable for bug 354033
101
102 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
103 Stable on amd64 wrt bug #354033
104
105 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
106 x86 stable per bug 354033
107
108*PyQt4-4.8.4 (02 May 2011)
109
110 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
111 +PyQt4-4.8.4.ebuild:
112 Version bump.
113
114 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
115 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
116 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
117 Adapt phonon dependency for package move
118
119 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
120 ppc64 stable wrt #349607
121
122 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
123 ia64/sparc stable wrt #349607
124
125 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
126 Stable on alpha, bug #349607
127
128 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
129 PyQt4-4.8.3.ebuild:
130 Update dependencies (bug #353053).
131
132*PyQt4-4.8.3 (25 Jan 2011)
133
134 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
135 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
136 Version bump.
137
138 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
139 x86 stable wrt bug #349607
140
141 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
142 Marking PyQt4-4.8.1 ppc stable for bug 349607
143
144 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
145 Stable on amd64 wrt bug #349607
146
147 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
148 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
149 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
150
151*PyQt4-4.8.1-r1 (30 Dec 2010)
152
153 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
154 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
155 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
156
157 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
158 PyQt4-4.8.2.ebuild:
159 Fix dependencies (bug #349672).
160
161*PyQt4-4.8.2 (24 Dec 2010)
162
163 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
164 +PyQt4-4.8.2.ebuild:
165 Version bump.
166
167 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
168 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
169 Restrict Jython ABIs.
170
171 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
172 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
173 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
174 -files/configure.py.patch:
175 Delete.
176
177 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
178 old, depends on qt 4.5
179
180 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
181 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
182 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
183 Remove HPPA keywording (bug #239441).
184
185*PyQt4-4.8.1 (30 Oct 2010)
186
187 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
188 +PyQt4-4.8.1.ebuild:
189 Version bump.
190
191 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
192 ia64/sparc stable wrt #315775
193
194*PyQt4-4.8 (23 Oct 2010)
195
196 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
197 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
198 +PyQt4-4.8.ebuild, metadata.xml:
199 Version bump.
200
201*PyQt4-4.7.7-r1 (06 Oct 2010)
202
203 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
204 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
205 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
206
207*PyQt4-4.7.7 (21 Sep 2010)
208
209 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
210 +PyQt4-4.7.7.ebuild:
211 Version bump. Remove old bogus version
212
213 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
214 Stable on alpha, bug #315775
215
216 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
217 Marked ppc stable for bug #315775.
218
219 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
220 PyQt4-4.7.6.ebuild:
221 Update EAPI. Fix dependencies.
222
223*PyQt4-4.7.6 (08 Sep 2010)
224
225 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
226 +PyQt4-4.7.6.ebuild:
227 Version bump. Remove old ebuild
228
229 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
230 PyQt4-4.7.5.ebuild:
231 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
232
233*PyQt4-4.7.5 (01 Sep 2010)
234
235 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
236 +PyQt4-4.7.5.ebuild:
237 Version bump
238
239 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
240 Stable for HPPA (bug #315775).
4 241
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 242 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 243 Bump sip dependency to 4.10.3. Fix arm epatch command
7 244
8*PyQt4-4.7.4 (13 Jul 2010) 245*PyQt4-4.7.4 (13 Jul 2010)

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.177

  ViewVC Help
Powered by ViewVC 1.1.20