/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.198
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.198 2012/09/09 15:52:48 armin76 Exp $
4
5 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
6 alpha/ia64/sparc stable wrt #429042
7
8*PyQt4-4.9.4-r1 (03 Sep 2012)
9
10 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
11 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
12 Apply upstream patch to fix regression in pyuic's handling of custom widgets
13 (bug 431070 by Laurent Bachelier).
14
15 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
16 Stable for x86, wrt bug #429042
17
18 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
19 Stable for amd64, wrt bug #429042
20
21 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
22 Stable ppc64, bug #429042
23
24 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
25 Stable ppc, bug #429042
26
27 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
28 ia64 stable
29
30 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
31 -files/PyQt4-4.6.1-configure-multilib.patch:
32 Remove old.
33
34 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
35 PyQt4-4.9.4.ebuild:
36 alpha/ia64/sparc stable wrt #412929
37
38*PyQt4-4.9.4 (02 Jul 2012)
39
40 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
41 -PyQt4-4.9.3.ebuild:
42 Version bump.
43
44*PyQt4-4.9.3 (27 Jun 2012)
45
46 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
47 -PyQt4-4.9.2.ebuild:
48 Version bump.
49
50 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
51 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
52
53*PyQt4-4.9.2 (21 Jun 2012)
54
55 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
56 Version bump
57
58 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
59 Destabling to ~ia64 because last available stable qt will be masked pending
60 removal
61
62 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
63 marked x86 per bug 412929
64
65 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
66 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
67 Inherit eutils.
68
69 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
70 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
71 Revert previous change.
72
73 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
74 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
75 Restrict python 3.1 to match dev-python/dbus-python.
76
77 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
78 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
79
80 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
81 Migrating dev-util/pkgconfig -> virtual/pkgconfig
82
83 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
84 Stable for amd64, wrt bug #412929
85
86 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
87 Stable on alpha, bug #354033
88
89 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
90 PyQt4-4.8.4.ebuild:
91 PyQt4-4.8 does not build with sip-4.13, bug 407291
92
93 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
94 Slightly improve the ewarn message in pkg_postinst().
95
96 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
97 Put qt as the primary herd in metadata.
98
99 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
100 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
101 <slong@rathaus.eclipse.co.uk> in bug #407281.
102
103 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
104 Switch to EAPI 4, add REQUIRED_USE.
105
106 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
107 PyQt4-4.8.4.ebuild:
108 Drop ~x86-fbsd because of unkeyworded dependencies.
109
110 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
111 Don't enable QtAssistant module because it was removed in qt-4.7 and we
112 already depend on 4.7.2 or later.
113
114 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
115 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
116 Restrict pypy for older versions too.
117
118 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
119 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
120 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
121 version.
122
123 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
124 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
125 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
126 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
127 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
128 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
129
130 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
131 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
132 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
133 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
134 Fixing pypy restricts to actually work
135
136*PyQt4-4.9.1 (12 Feb 2012)
137
138 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
139 version bump
140
141 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
142 builds with qt-opengl-4.8.0[egl], updated dep
143
144 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
145 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
146 Fixes backported from Progress Overlay. Patch by Arfrever.
147
148*PyQt4-4.9 (24 Dec 2011)
149
150 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
151 Version bump
152
153*PyQt4-4.8.6 (11 Nov 2011)
154
155 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
156 Version bump
157
158 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
159 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
160 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
161 python overlay.
162
163*PyQt4-4.8.5 (19 Aug 2011)
164
165 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
166 Version bump
167
168 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
169 ppc/ppc64 stable wrt #374591
170
171 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
172 x86 stable, bug #374591
173
174 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
175 ppc64 stable wrt #354033
176
177 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
178 Stable on amd64 wrt bug #374591
179
180 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
181 Marking PyQt4-4.8.3 ppc stable for bug 354033
182
183 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
184 Stable on amd64 wrt bug #354033
185
186 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
187 x86 stable per bug 354033
188
189*PyQt4-4.8.4 (02 May 2011)
190
191 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
192 +PyQt4-4.8.4.ebuild:
193 Version bump.
194
195 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
196 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
197 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
198 Adapt phonon dependency for package move
199
200 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
201 ppc64 stable wrt #349607
202
203 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
204 ia64/sparc stable wrt #349607
205
206 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
207 Stable on alpha, bug #349607
208
209 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
210 PyQt4-4.8.3.ebuild:
211 Update dependencies (bug #353053).
212
213*PyQt4-4.8.3 (25 Jan 2011)
214
215 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
216 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
217 Version bump.
218
219 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
220 x86 stable wrt bug #349607
221
222 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
223 Marking PyQt4-4.8.1 ppc stable for bug 349607
224
225 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
226 Stable on amd64 wrt bug #349607
227
228 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
229 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
230 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
231
232*PyQt4-4.8.1-r1 (30 Dec 2010)
233
234 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
235 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
236 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
237
238 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
239 PyQt4-4.8.2.ebuild:
240 Fix dependencies (bug #349672).
241
242*PyQt4-4.8.2 (24 Dec 2010)
243
244 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
245 +PyQt4-4.8.2.ebuild:
246 Version bump.
247
248 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
249 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
250 Restrict Jython ABIs.
251
252 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
253 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
254 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
255 -files/configure.py.patch:
256 Delete.
257
258 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
259 old, depends on qt 4.5
260
261 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
262 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
263 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
264 Remove HPPA keywording (bug #239441).
265
266*PyQt4-4.8.1 (30 Oct 2010)
267
268 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
269 +PyQt4-4.8.1.ebuild:
270 Version bump.
271
272 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
273 ia64/sparc stable wrt #315775
274
275*PyQt4-4.8 (23 Oct 2010)
276
277 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
278 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
279 +PyQt4-4.8.ebuild, metadata.xml:
280 Version bump.
281
282*PyQt4-4.7.7-r1 (06 Oct 2010)
283
284 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
285 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
286 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
287
288*PyQt4-4.7.7 (21 Sep 2010)
289
290 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
291 +PyQt4-4.7.7.ebuild:
292 Version bump. Remove old bogus version
293
294 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
295 Stable on alpha, bug #315775
296
297 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
298 Marked ppc stable for bug #315775.
299
300 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
301 PyQt4-4.7.6.ebuild:
302 Update EAPI. Fix dependencies.
303
304*PyQt4-4.7.6 (08 Sep 2010)
305
306 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
307 +PyQt4-4.7.6.ebuild:
308 Version bump. Remove old ebuild
309
310 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
311 PyQt4-4.7.5.ebuild:
312 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
313
314*PyQt4-4.7.5 (01 Sep 2010)
315
316 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
317 +PyQt4-4.7.5.ebuild:
318 Version bump
319
320 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
321 Stable for HPPA (bug #315775).
4 322
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 323 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 324 Bump sip dependency to 4.10.3. Fix arm epatch command
7 325
8*PyQt4-4.7.4 (13 Jul 2010) 326*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 807*PyQt4-4.0_beta1 (05 May 2006)
490 808
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 809 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 810 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 811 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.198

  ViewVC Help
Powered by ViewVC 1.1.20