/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.199
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.199 2012/10/05 20:25:54 hwoarang Exp $
4
5*PyQt4-4.9.5 (05 Oct 2012)
6
7 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
8 Version bump
9
10 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
11 alpha/ia64/sparc stable wrt #429042
12
13*PyQt4-4.9.4-r1 (03 Sep 2012)
14
15 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
16 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
17 Apply upstream patch to fix regression in pyuic's handling of custom widgets
18 (bug 431070 by Laurent Bachelier).
19
20 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
21 Stable for x86, wrt bug #429042
22
23 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
24 Stable for amd64, wrt bug #429042
25
26 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
27 Stable ppc64, bug #429042
28
29 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
30 Stable ppc, bug #429042
31
32 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
33 ia64 stable
34
35 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
36 -files/PyQt4-4.6.1-configure-multilib.patch:
37 Remove old.
38
39 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
40 PyQt4-4.9.4.ebuild:
41 alpha/ia64/sparc stable wrt #412929
42
43*PyQt4-4.9.4 (02 Jul 2012)
44
45 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
46 -PyQt4-4.9.3.ebuild:
47 Version bump.
48
49*PyQt4-4.9.3 (27 Jun 2012)
50
51 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
52 -PyQt4-4.9.2.ebuild:
53 Version bump.
54
55 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
56 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
57
58*PyQt4-4.9.2 (21 Jun 2012)
59
60 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
61 Version bump
62
63 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
64 Destabling to ~ia64 because last available stable qt will be masked pending
65 removal
66
67 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
68 marked x86 per bug 412929
69
70 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
71 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
72 Inherit eutils.
73
74 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
75 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
76 Revert previous change.
77
78 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
79 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
80 Restrict python 3.1 to match dev-python/dbus-python.
81
82 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
83 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
84
85 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
86 Migrating dev-util/pkgconfig -> virtual/pkgconfig
87
88 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
89 Stable for amd64, wrt bug #412929
90
91 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
92 Stable on alpha, bug #354033
93
94 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
95 PyQt4-4.8.4.ebuild:
96 PyQt4-4.8 does not build with sip-4.13, bug 407291
97
98 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
99 Slightly improve the ewarn message in pkg_postinst().
100
101 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
102 Put qt as the primary herd in metadata.
103
104 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
105 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
106 <slong@rathaus.eclipse.co.uk> in bug #407281.
107
108 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
109 Switch to EAPI 4, add REQUIRED_USE.
110
111 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
112 PyQt4-4.8.4.ebuild:
113 Drop ~x86-fbsd because of unkeyworded dependencies.
114
115 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
116 Don't enable QtAssistant module because it was removed in qt-4.7 and we
117 already depend on 4.7.2 or later.
118
119 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
120 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
121 Restrict pypy for older versions too.
122
123 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
124 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
125 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
126 version.
127
128 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
129 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
130 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
131 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
132 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
133 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
134
135 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
136 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
137 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
138 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
139 Fixing pypy restricts to actually work
140
141*PyQt4-4.9.1 (12 Feb 2012)
142
143 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
144 version bump
145
146 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
147 builds with qt-opengl-4.8.0[egl], updated dep
148
149 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
150 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
151 Fixes backported from Progress Overlay. Patch by Arfrever.
152
153*PyQt4-4.9 (24 Dec 2011)
154
155 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
156 Version bump
157
158*PyQt4-4.8.6 (11 Nov 2011)
159
160 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
161 Version bump
162
163 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
164 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
165 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
166 python overlay.
167
168*PyQt4-4.8.5 (19 Aug 2011)
169
170 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
171 Version bump
172
173 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
174 ppc/ppc64 stable wrt #374591
175
176 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
177 x86 stable, bug #374591
178
179 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
180 ppc64 stable wrt #354033
181
182 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
183 Stable on amd64 wrt bug #374591
184
185 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
186 Marking PyQt4-4.8.3 ppc stable for bug 354033
187
188 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
189 Stable on amd64 wrt bug #354033
190
191 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
192 x86 stable per bug 354033
193
194*PyQt4-4.8.4 (02 May 2011)
195
196 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
197 +PyQt4-4.8.4.ebuild:
198 Version bump.
199
200 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
201 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
202 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
203 Adapt phonon dependency for package move
204
205 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
206 ppc64 stable wrt #349607
207
208 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
209 ia64/sparc stable wrt #349607
210
211 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
212 Stable on alpha, bug #349607
213
214 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
215 PyQt4-4.8.3.ebuild:
216 Update dependencies (bug #353053).
217
218*PyQt4-4.8.3 (25 Jan 2011)
219
220 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
221 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
222 Version bump.
223
224 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
225 x86 stable wrt bug #349607
226
227 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
228 Marking PyQt4-4.8.1 ppc stable for bug 349607
229
230 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
231 Stable on amd64 wrt bug #349607
232
233 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
234 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
235 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
236
237*PyQt4-4.8.1-r1 (30 Dec 2010)
238
239 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
240 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
241 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
242
243 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
244 PyQt4-4.8.2.ebuild:
245 Fix dependencies (bug #349672).
246
247*PyQt4-4.8.2 (24 Dec 2010)
248
249 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
250 +PyQt4-4.8.2.ebuild:
251 Version bump.
252
253 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
254 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
255 Restrict Jython ABIs.
256
257 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
258 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
259 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
260 -files/configure.py.patch:
261 Delete.
262
263 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
264 old, depends on qt 4.5
265
266 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
267 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
268 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
269 Remove HPPA keywording (bug #239441).
270
271*PyQt4-4.8.1 (30 Oct 2010)
272
273 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
274 +PyQt4-4.8.1.ebuild:
275 Version bump.
276
277 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
278 ia64/sparc stable wrt #315775
279
280*PyQt4-4.8 (23 Oct 2010)
281
282 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
283 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
284 +PyQt4-4.8.ebuild, metadata.xml:
285 Version bump.
286
287*PyQt4-4.7.7-r1 (06 Oct 2010)
288
289 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
290 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
291 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
292
293*PyQt4-4.7.7 (21 Sep 2010)
294
295 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
296 +PyQt4-4.7.7.ebuild:
297 Version bump. Remove old bogus version
298
299 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
300 Stable on alpha, bug #315775
301
302 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
303 Marked ppc stable for bug #315775.
304
305 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
306 PyQt4-4.7.6.ebuild:
307 Update EAPI. Fix dependencies.
308
309*PyQt4-4.7.6 (08 Sep 2010)
310
311 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
312 +PyQt4-4.7.6.ebuild:
313 Version bump. Remove old ebuild
314
315 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
316 PyQt4-4.7.5.ebuild:
317 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
318
319*PyQt4-4.7.5 (01 Sep 2010)
320
321 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
322 +PyQt4-4.7.5.ebuild:
323 Version bump
324
325 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
326 Stable for HPPA (bug #315775).
4 327
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 328 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 329 Bump sip dependency to 4.10.3. Fix arm epatch command
7 330
8*PyQt4-4.7.4 (13 Jul 2010) 331*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 812*PyQt4-4.0_beta1 (05 May 2006)
490 813
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 814 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 815 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 816 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.199

  ViewVC Help
Powered by ViewVC 1.1.20