/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.213
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.213 2013/02/15 22:01:24 ago Exp $
4
5 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
6 Stable for arm, wrt bug #457046
7
8 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
9 Stable for x86, wrt bug #457046
10
11 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
12 Stable for amd64, wrt bug #457046
13
14 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
15 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
16
17 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
18 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
19 Fix double prefix; remove old.
20
21 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
22 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
23
24*PyQt4-4.9.6-r2 (29 Jan 2013)
25
26 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
27 Migrate to the new python eclass.
28
29 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
30 Improve pyqt4_use_enable() as suggested by Arfrever.
31
32 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
33 old
34
35*PyQt4-4.9.6-r1 (26 Dec 2012)
36
37 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
38 metadata.xml:
39 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
40 pyside: rename assistant to help, add script and scripttools (bug 431460 by
41 Arfrever).
42
43*PyQt4-4.9.6 (10 Dec 2012)
44
45 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
46 Version bump, with some minor updates from qt overlay.
47
48 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
49 arm stable, bug #435074
50
51 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
52 PyQt4-4.9.4-r1.ebuild:
53 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
54
55 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
56 -PyQt4-4.9.1.ebuild:
57 Remove old
58
59*PyQt4-4.9.5 (05 Oct 2012)
60
61 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
62 Version bump
63
64 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
65 alpha/ia64/sparc stable wrt #429042
66
67*PyQt4-4.9.4-r1 (03 Sep 2012)
68
69 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
70 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
71 Apply upstream patch to fix regression in pyuic's handling of custom widgets
72 (bug 431070 by Laurent Bachelier).
73
74 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
75 Stable for x86, wrt bug #429042
76
77 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
78 Stable for amd64, wrt bug #429042
79
80 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
81 Stable ppc64, bug #429042
82
83 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
84 Stable ppc, bug #429042
85
86 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
87 ia64 stable
88
89 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
90 -files/PyQt4-4.6.1-configure-multilib.patch:
91 Remove old.
92
93 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
94 PyQt4-4.9.4.ebuild:
95 alpha/ia64/sparc stable wrt #412929
96
97*PyQt4-4.9.4 (02 Jul 2012)
98
99 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
100 -PyQt4-4.9.3.ebuild:
101 Version bump.
102
103*PyQt4-4.9.3 (27 Jun 2012)
104
105 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
106 -PyQt4-4.9.2.ebuild:
107 Version bump.
108
109 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
110 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
111
112*PyQt4-4.9.2 (21 Jun 2012)
113
114 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
115 Version bump
116
117 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
118 Destabling to ~ia64 because last available stable qt will be masked pending
119 removal
120
121 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
122 marked x86 per bug 412929
123
124 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
125 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
126 Inherit eutils.
127
128 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
129 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
130 Revert previous change.
131
132 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
133 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
134 Restrict python 3.1 to match dev-python/dbus-python.
135
136 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
137 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
138
139 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
140 Migrating dev-util/pkgconfig -> virtual/pkgconfig
141
142 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
143 Stable for amd64, wrt bug #412929
144
145 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
146 Stable on alpha, bug #354033
147
148 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
149 PyQt4-4.8.4.ebuild:
150 PyQt4-4.8 does not build with sip-4.13, bug 407291
151
152 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
153 Slightly improve the ewarn message in pkg_postinst().
154
155 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
156 Put qt as the primary herd in metadata.
157
158 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
159 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
160 <slong@rathaus.eclipse.co.uk> in bug #407281.
161
162 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
163 Switch to EAPI 4, add REQUIRED_USE.
164
165 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
166 PyQt4-4.8.4.ebuild:
167 Drop ~x86-fbsd because of unkeyworded dependencies.
168
169 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
170 Don't enable QtAssistant module because it was removed in qt-4.7 and we
171 already depend on 4.7.2 or later.
172
173 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
174 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
175 Restrict pypy for older versions too.
176
177 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
178 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
179 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
180 version.
181
182 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
183 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
184 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
185 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
186 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
187 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
188
189 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
190 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
191 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
192 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
193 Fixing pypy restricts to actually work
194
195*PyQt4-4.9.1 (12 Feb 2012)
196
197 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
198 version bump
199
200 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
201 builds with qt-opengl-4.8.0[egl], updated dep
202
203 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
204 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
205 Fixes backported from Progress Overlay. Patch by Arfrever.
206
207*PyQt4-4.9 (24 Dec 2011)
208
209 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
210 Version bump
211
212*PyQt4-4.8.6 (11 Nov 2011)
213
214 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
215 Version bump
216
217 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
218 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
219 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
220 python overlay.
221
222*PyQt4-4.8.5 (19 Aug 2011)
223
224 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
225 Version bump
226
227 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
228 ppc/ppc64 stable wrt #374591
229
230 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
231 x86 stable, bug #374591
232
233 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
234 ppc64 stable wrt #354033
235
236 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
237 Stable on amd64 wrt bug #374591
238
239 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
240 Marking PyQt4-4.8.3 ppc stable for bug 354033
241
242 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
243 Stable on amd64 wrt bug #354033
244
245 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
246 x86 stable per bug 354033
247
248*PyQt4-4.8.4 (02 May 2011)
249
250 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
251 +PyQt4-4.8.4.ebuild:
252 Version bump.
253
254 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
255 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
256 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
257 Adapt phonon dependency for package move
258
259 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
260 ppc64 stable wrt #349607
261
262 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
263 ia64/sparc stable wrt #349607
264
265 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
266 Stable on alpha, bug #349607
267
268 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
269 PyQt4-4.8.3.ebuild:
270 Update dependencies (bug #353053).
271
272*PyQt4-4.8.3 (25 Jan 2011)
273
274 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
275 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
276 Version bump.
277
278 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
279 x86 stable wrt bug #349607
280
281 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
282 Marking PyQt4-4.8.1 ppc stable for bug 349607
283
284 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
285 Stable on amd64 wrt bug #349607
286
287 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
288 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
289 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
290
291*PyQt4-4.8.1-r1 (30 Dec 2010)
292
293 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
294 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
295 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
296
297 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
298 PyQt4-4.8.2.ebuild:
299 Fix dependencies (bug #349672).
300
301*PyQt4-4.8.2 (24 Dec 2010)
302
303 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
304 +PyQt4-4.8.2.ebuild:
305 Version bump.
306
307 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
308 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
309 Restrict Jython ABIs.
310
311 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
312 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
313 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
314 -files/configure.py.patch:
315 Delete.
316
317 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
318 old, depends on qt 4.5
319
320 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
321 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
322 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
323 Remove HPPA keywording (bug #239441).
324
325*PyQt4-4.8.1 (30 Oct 2010)
326
327 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
328 +PyQt4-4.8.1.ebuild:
329 Version bump.
330
331 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
332 ia64/sparc stable wrt #315775
333
334*PyQt4-4.8 (23 Oct 2010)
335
336 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
337 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
338 +PyQt4-4.8.ebuild, metadata.xml:
339 Version bump.
340
341*PyQt4-4.7.7-r1 (06 Oct 2010)
342
343 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
344 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
345 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
346
347*PyQt4-4.7.7 (21 Sep 2010)
348
349 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
350 +PyQt4-4.7.7.ebuild:
351 Version bump. Remove old bogus version
352
353 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
354 Stable on alpha, bug #315775
355
356 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
357 Marked ppc stable for bug #315775.
358
359 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
360 PyQt4-4.7.6.ebuild:
361 Update EAPI. Fix dependencies.
362
363*PyQt4-4.7.6 (08 Sep 2010)
364
365 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
366 +PyQt4-4.7.6.ebuild:
367 Version bump. Remove old ebuild
368
369 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
370 PyQt4-4.7.5.ebuild:
371 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
372
373*PyQt4-4.7.5 (01 Sep 2010)
374
375 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
376 +PyQt4-4.7.5.ebuild:
377 Version bump
378
379 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
380 Stable for HPPA (bug #315775).
4 381
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 382 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 383 Bump sip dependency to 4.10.3. Fix arm epatch command
7 384
8*PyQt4-4.7.4 (13 Jul 2010) 385*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 866*PyQt4-4.0_beta1 (05 May 2006)
490 867
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 868 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 869 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 870 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.213

  ViewVC Help
Powered by ViewVC 1.1.20