/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.219
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.219 2013/03/11 17:51:00 ago Exp $
4
5 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
6 Stable for sparc, wrt bug #457046
7
8 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
9 PyQt4-4.9.6-r2.ebuild:
10 Move Qt dependencies to the new category
11
12 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
13 Stable for ia64, wrt bug #457046
14
15 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
16 Stable for ppc64, wrt bug #457046
17
18 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
19 Stable for ppc, wrt bug #457046
20
21 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
22 Stable for alpha, wrt bug #457046
23
24 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
25 Stable for arm, wrt bug #457046
26
27 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
28 Stable for x86, wrt bug #457046
29
30 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
31 Stable for amd64, wrt bug #457046
32
33 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
34 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
35
36 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
37 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
38 Fix double prefix; remove old.
39
40 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
41 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
42
43*PyQt4-4.9.6-r2 (29 Jan 2013)
44
45 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
46 Migrate to the new python eclass.
47
48 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
49 Improve pyqt4_use_enable() as suggested by Arfrever.
50
51 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
52 old
53
54*PyQt4-4.9.6-r1 (26 Dec 2012)
55
56 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
57 metadata.xml:
58 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
59 pyside: rename assistant to help, add script and scripttools (bug 431460 by
60 Arfrever).
61
62*PyQt4-4.9.6 (10 Dec 2012)
63
64 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
65 Version bump, with some minor updates from qt overlay.
66
67 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
68 arm stable, bug #435074
69
70 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
71 PyQt4-4.9.4-r1.ebuild:
72 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
73
74 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
75 -PyQt4-4.9.1.ebuild:
76 Remove old
77
78*PyQt4-4.9.5 (05 Oct 2012)
79
80 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
81 Version bump
82
83 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
84 alpha/ia64/sparc stable wrt #429042
85
86*PyQt4-4.9.4-r1 (03 Sep 2012)
87
88 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
89 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
90 Apply upstream patch to fix regression in pyuic's handling of custom widgets
91 (bug 431070 by Laurent Bachelier).
92
93 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
94 Stable for x86, wrt bug #429042
95
96 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
97 Stable for amd64, wrt bug #429042
98
99 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
100 Stable ppc64, bug #429042
101
102 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
103 Stable ppc, bug #429042
104
105 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
106 ia64 stable
107
108 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
109 -files/PyQt4-4.6.1-configure-multilib.patch:
110 Remove old.
111
112 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
113 PyQt4-4.9.4.ebuild:
114 alpha/ia64/sparc stable wrt #412929
115
116*PyQt4-4.9.4 (02 Jul 2012)
117
118 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
119 -PyQt4-4.9.3.ebuild:
120 Version bump.
121
122*PyQt4-4.9.3 (27 Jun 2012)
123
124 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
125 -PyQt4-4.9.2.ebuild:
126 Version bump.
127
128 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
129 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
130
131*PyQt4-4.9.2 (21 Jun 2012)
132
133 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
134 Version bump
135
136 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
137 Destabling to ~ia64 because last available stable qt will be masked pending
138 removal
139
140 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
141 marked x86 per bug 412929
142
143 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
144 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
145 Inherit eutils.
146
147 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
148 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
149 Revert previous change.
150
151 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
152 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
153 Restrict python 3.1 to match dev-python/dbus-python.
154
155 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
156 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
157
158 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
159 Migrating dev-util/pkgconfig -> virtual/pkgconfig
160
161 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
162 Stable for amd64, wrt bug #412929
163
164 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
165 Stable on alpha, bug #354033
166
167 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
168 PyQt4-4.8.4.ebuild:
169 PyQt4-4.8 does not build with sip-4.13, bug 407291
170
171 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
172 Slightly improve the ewarn message in pkg_postinst().
173
174 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
175 Put qt as the primary herd in metadata.
176
177 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
178 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
179 <slong@rathaus.eclipse.co.uk> in bug #407281.
180
181 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
182 Switch to EAPI 4, add REQUIRED_USE.
183
184 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
185 PyQt4-4.8.4.ebuild:
186 Drop ~x86-fbsd because of unkeyworded dependencies.
187
188 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
189 Don't enable QtAssistant module because it was removed in qt-4.7 and we
190 already depend on 4.7.2 or later.
191
192 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
193 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
194 Restrict pypy for older versions too.
195
196 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
197 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
198 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
199 version.
200
201 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
202 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
203 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
204 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
205 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
206 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
207
208 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
209 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
210 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
211 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
212 Fixing pypy restricts to actually work
213
214*PyQt4-4.9.1 (12 Feb 2012)
215
216 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
217 version bump
218
219 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
220 builds with qt-opengl-4.8.0[egl], updated dep
221
222 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
223 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
224 Fixes backported from Progress Overlay. Patch by Arfrever.
225
226*PyQt4-4.9 (24 Dec 2011)
227
228 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
229 Version bump
230
231*PyQt4-4.8.6 (11 Nov 2011)
232
233 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
234 Version bump
235
236 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
237 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
238 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
239 python overlay.
240
241*PyQt4-4.8.5 (19 Aug 2011)
242
243 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
244 Version bump
245
246 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
247 ppc/ppc64 stable wrt #374591
248
249 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
250 x86 stable, bug #374591
251
252 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
253 ppc64 stable wrt #354033
254
255 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
256 Stable on amd64 wrt bug #374591
257
258 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
259 Marking PyQt4-4.8.3 ppc stable for bug 354033
260
261 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
262 Stable on amd64 wrt bug #354033
263
264 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
265 x86 stable per bug 354033
266
267*PyQt4-4.8.4 (02 May 2011)
268
269 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
270 +PyQt4-4.8.4.ebuild:
271 Version bump.
272
273 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
274 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
275 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
276 Adapt phonon dependency for package move
277
278 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
279 ppc64 stable wrt #349607
280
281 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
282 ia64/sparc stable wrt #349607
283
284 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
285 Stable on alpha, bug #349607
286
287 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
288 PyQt4-4.8.3.ebuild:
289 Update dependencies (bug #353053).
290
291*PyQt4-4.8.3 (25 Jan 2011)
292
293 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
294 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
295 Version bump.
296
297 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
298 x86 stable wrt bug #349607
299
300 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
301 Marking PyQt4-4.8.1 ppc stable for bug 349607
302
303 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
304 Stable on amd64 wrt bug #349607
305
306 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
307 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
308 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
309
310*PyQt4-4.8.1-r1 (30 Dec 2010)
311
312 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
313 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
314 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
315
316 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
317 PyQt4-4.8.2.ebuild:
318 Fix dependencies (bug #349672).
319
320*PyQt4-4.8.2 (24 Dec 2010)
321
322 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
323 +PyQt4-4.8.2.ebuild:
324 Version bump.
325
326 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
327 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
328 Restrict Jython ABIs.
329
330 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
331 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
332 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
333 -files/configure.py.patch:
334 Delete.
335
336 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
337 old, depends on qt 4.5
338
339 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
340 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
341 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
342 Remove HPPA keywording (bug #239441).
343
344*PyQt4-4.8.1 (30 Oct 2010)
345
346 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
347 +PyQt4-4.8.1.ebuild:
348 Version bump.
349
350 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
351 ia64/sparc stable wrt #315775
352
353*PyQt4-4.8 (23 Oct 2010)
354
355 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
356 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
357 +PyQt4-4.8.ebuild, metadata.xml:
358 Version bump.
359
360*PyQt4-4.7.7-r1 (06 Oct 2010)
361
362 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
363 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
364 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
365
366*PyQt4-4.7.7 (21 Sep 2010)
367
368 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
369 +PyQt4-4.7.7.ebuild:
370 Version bump. Remove old bogus version
371
372 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
373 Stable on alpha, bug #315775
374
375 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
376 Marked ppc stable for bug #315775.
377
378 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
379 PyQt4-4.7.6.ebuild:
380 Update EAPI. Fix dependencies.
381
382*PyQt4-4.7.6 (08 Sep 2010)
383
384 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
385 +PyQt4-4.7.6.ebuild:
386 Version bump. Remove old ebuild
387
388 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
389 PyQt4-4.7.5.ebuild:
390 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
391
392*PyQt4-4.7.5 (01 Sep 2010)
393
394 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
395 +PyQt4-4.7.5.ebuild:
396 Version bump
397
398 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
399 Stable for HPPA (bug #315775).
4 400
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 401 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 402 Bump sip dependency to 4.10.3. Fix arm epatch command
7 403
8*PyQt4-4.7.4 (13 Jul 2010) 404*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 885*PyQt4-4.0_beta1 (05 May 2006)
490 886
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 887 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 888 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 889 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.219

  ViewVC Help
Powered by ViewVC 1.1.20