/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.256
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.256 2014/03/23 17:16:24 ago Exp $
4
5 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
6 Stable for sparc, wrt bug #495638
7
8 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
9 Stable for x86, wrt bug #495638
10
11 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
12 Stable for alpha, wrt bug #495638
13
14 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
15 Stable for ia64, wrt bug #495638
16
17 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
18 Stable for ppc64, wrt bug #495638
19
20 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
21 amd64 stable, bug 495638
22
23 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
24 Stable for ppc, wrt bug #495638
25
26 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
27 arm stable, bug #495638
28
29 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
30 files/PyQt4-4.7.3-qreal_float_support.patch:
31 Updated qreal_float patch to remove first hunk (already applied
32 upstream). Tested on arm chromebook; no existing bug.
33
34*PyQt4-4.10.3-r2 (25 Dec 2013)
35
36 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
37 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
38 Introduce USE="designer".
39
40 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
41 old
42
43 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
44 Stable for sparc, wrt bug #483112
45
46 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
47 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
48 Update the ebuilds to dep on dev-lang/python-exec.
49
50 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
51 old
52
53*PyQt4-4.10.3-r1 (23 Oct 2013)
54
55 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
56 Support python-exec:2.
57
58 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
59 Depend on sip >=4.15.0 to fix build failure (bug #485274)
60
61 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
62 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
63 Add explicit dep on python-exec:0 since the package wraps the script manually.
64
65*PyQt4-4.10.3 (17 Sep 2013)
66
67 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
68 Version bump
69
70 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
71 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
72 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
73
74 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
75 arm stable, bug #483112
76
77 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
78 Stable for x86, wrt bug #483112
79
80 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
81 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
82 Clean up PYTHON_COMPAT from old implementations.
83
84 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
85 Stable for ppc64, wrt bug #483112
86
87 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
88 Stable for ppc, wrt bug #483112
89
90 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
91 Stable for ia64, wrt bug #483112
92
93 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
94 Stable for alpha, wrt bug #483112
95
96 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
97 Stable for amd64, wrt bug #483112
98
99 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
100 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
101 Reorder Qt dependencies.
102
103 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
104 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
105 Fixing qtgui/designer deps for qt-4.8.5
106
107 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
108 PyQt4-4.9.6-r2.ebuild:
109 Fixing qtgui deps for qt-4.8.5
110
111 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
112 Remove wrong usedep for qtgui.
113
114*PyQt4-4.10.2 (24 Jun 2013)
115
116 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
117 Version bump.
118
119 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
120 PyQt4-4.10.1.ebuild:
121 Add PYTHON_REQUIRED_USE. Remove old.
122
123*PyQt4-4.10.1 (22 May 2013)
124
125 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
126 Version bump.
127
128 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
129 Remove unused flag description from metadata
130
131 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
132 -files/PyQt4-4.7.2-configure.py.patch,
133 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
134 old
135
136*PyQt4-4.10 (12 Mar 2013)
137
138 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
139 Version bump. Fix also bug #433944 by Franz Fellner.
140
141 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
142 Stable for sparc, wrt bug #457046
143
144 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
145 PyQt4-4.9.6-r2.ebuild:
146 Move Qt dependencies to the new category
147
148 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
149 Stable for ia64, wrt bug #457046
150
151 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
152 Stable for ppc64, wrt bug #457046
153
154 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
155 Stable for ppc, wrt bug #457046
156
157 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
158 Stable for alpha, wrt bug #457046
159
160 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
161 Stable for arm, wrt bug #457046
162
163 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
164 Stable for x86, wrt bug #457046
165
166 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
167 Stable for amd64, wrt bug #457046
168
169 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
170 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
171
172 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
173 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
174 Fix double prefix; remove old.
175
176 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
177 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
178
179*PyQt4-4.9.6-r2 (29 Jan 2013)
180
181 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
182 Migrate to the new python eclass.
183
184 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
185 Improve pyqt4_use_enable() as suggested by Arfrever.
186
187 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
188 old
189
190*PyQt4-4.9.6-r1 (26 Dec 2012)
191
192 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
193 metadata.xml:
194 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
195 pyside: rename assistant to help, add script and scripttools (bug 431460 by
196 Arfrever).
197
198*PyQt4-4.9.6 (10 Dec 2012)
199
200 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
201 Version bump, with some minor updates from qt overlay.
202
203 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
204 arm stable, bug #435074
205
206 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
207 PyQt4-4.9.4-r1.ebuild:
208 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
209
210 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
211 -PyQt4-4.9.1.ebuild:
212 Remove old
213
214*PyQt4-4.9.5 (05 Oct 2012)
215
216 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
217 Version bump
218
219 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
220 alpha/ia64/sparc stable wrt #429042
221
222*PyQt4-4.9.4-r1 (03 Sep 2012)
223
224 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
225 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
226 Apply upstream patch to fix regression in pyuic's handling of custom widgets
227 (bug 431070 by Laurent Bachelier).
228
229 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
230 Stable for x86, wrt bug #429042
231
232 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
233 Stable for amd64, wrt bug #429042
234
235 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
236 Stable ppc64, bug #429042
237
238 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
239 Stable ppc, bug #429042
240
241 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
242 ia64 stable
243
244 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
245 -files/PyQt4-4.6.1-configure-multilib.patch:
246 Remove old.
247
248 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
249 PyQt4-4.9.4.ebuild:
250 alpha/ia64/sparc stable wrt #412929
251
252*PyQt4-4.9.4 (02 Jul 2012)
253
254 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
255 -PyQt4-4.9.3.ebuild:
256 Version bump.
257
258*PyQt4-4.9.3 (27 Jun 2012)
259
260 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
261 -PyQt4-4.9.2.ebuild:
262 Version bump.
263
264 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
265 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
266
267*PyQt4-4.9.2 (21 Jun 2012)
268
269 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
270 Version bump
271
272 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
273 Destabling to ~ia64 because last available stable qt will be masked pending
274 removal
275
276 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
277 marked x86 per bug 412929
278
279 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
280 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
281 Inherit eutils.
282
283 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
284 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
285 Revert previous change.
286
287 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
288 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
289 Restrict python 3.1 to match dev-python/dbus-python.
290
291 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
292 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
293
294 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
295 Migrating dev-util/pkgconfig -> virtual/pkgconfig
296
297 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
298 Stable for amd64, wrt bug #412929
299
300 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
301 Stable on alpha, bug #354033
302
303 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
304 PyQt4-4.8.4.ebuild:
305 PyQt4-4.8 does not build with sip-4.13, bug 407291
306
307 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
308 Slightly improve the ewarn message in pkg_postinst().
309
310 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
311 Put qt as the primary herd in metadata.
312
313 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
314 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
315 <slong@rathaus.eclipse.co.uk> in bug #407281.
316
317 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
318 Switch to EAPI 4, add REQUIRED_USE.
319
320 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
321 PyQt4-4.8.4.ebuild:
322 Drop ~x86-fbsd because of unkeyworded dependencies.
323
324 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
325 Don't enable QtAssistant module because it was removed in qt-4.7 and we
326 already depend on 4.7.2 or later.
327
328 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
329 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
330 Restrict pypy for older versions too.
331
332 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
333 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
334 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
335 version.
336
337 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
338 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
339 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
340 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
341 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
342 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
343
344 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
345 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
346 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
347 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
348 Fixing pypy restricts to actually work
349
350*PyQt4-4.9.1 (12 Feb 2012)
351
352 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
353 version bump
354
355 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
356 builds with qt-opengl-4.8.0[egl], updated dep
357
358 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
359 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
360 Fixes backported from Progress Overlay. Patch by Arfrever.
361
362*PyQt4-4.9 (24 Dec 2011)
363
364 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
365 Version bump
366
367*PyQt4-4.8.6 (11 Nov 2011)
368
369 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
370 Version bump
371
372 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
373 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
374 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
375 python overlay.
376
377*PyQt4-4.8.5 (19 Aug 2011)
378
379 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
380 Version bump
381
382 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
383 ppc/ppc64 stable wrt #374591
384
385 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
386 x86 stable, bug #374591
387
388 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
389 ppc64 stable wrt #354033
390
391 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
392 Stable on amd64 wrt bug #374591
393
394 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
395 Marking PyQt4-4.8.3 ppc stable for bug 354033
396
397 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
398 Stable on amd64 wrt bug #354033
399
400 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
401 x86 stable per bug 354033
402
403*PyQt4-4.8.4 (02 May 2011)
404
405 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
406 +PyQt4-4.8.4.ebuild:
407 Version bump.
408
409 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
410 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
411 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
412 Adapt phonon dependency for package move
413
414 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
415 ppc64 stable wrt #349607
416
417 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
418 ia64/sparc stable wrt #349607
419
420 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
421 Stable on alpha, bug #349607
422
423 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
424 PyQt4-4.8.3.ebuild:
425 Update dependencies (bug #353053).
426
427*PyQt4-4.8.3 (25 Jan 2011)
428
429 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
430 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
431 Version bump.
432
433 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
434 x86 stable wrt bug #349607
435
436 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
437 Marking PyQt4-4.8.1 ppc stable for bug 349607
438
439 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
440 Stable on amd64 wrt bug #349607
441
442 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
443 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
444 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
445
446*PyQt4-4.8.1-r1 (30 Dec 2010)
447
448 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
449 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
450 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
451
452 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
453 PyQt4-4.8.2.ebuild:
454 Fix dependencies (bug #349672).
455
456*PyQt4-4.8.2 (24 Dec 2010)
457
458 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
459 +PyQt4-4.8.2.ebuild:
460 Version bump.
461
462 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
463 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
464 Restrict Jython ABIs.
465
466 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
467 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
468 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
469 -files/configure.py.patch:
470 Delete.
471
472 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
473 old, depends on qt 4.5
474
475 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
476 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
477 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
478 Remove HPPA keywording (bug #239441).
479
480*PyQt4-4.8.1 (30 Oct 2010)
481
482 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
483 +PyQt4-4.8.1.ebuild:
484 Version bump.
485
486 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
487 ia64/sparc stable wrt #315775
488
489*PyQt4-4.8 (23 Oct 2010)
490
491 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
492 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
493 +PyQt4-4.8.ebuild, metadata.xml:
494 Version bump.
495
496*PyQt4-4.7.7-r1 (06 Oct 2010)
497
498 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
499 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
500 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
501
502*PyQt4-4.7.7 (21 Sep 2010)
503
504 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
505 +PyQt4-4.7.7.ebuild:
506 Version bump. Remove old bogus version
507
508 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
509 Stable on alpha, bug #315775
510
511 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
512 Marked ppc stable for bug #315775.
513
514 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
515 PyQt4-4.7.6.ebuild:
516 Update EAPI. Fix dependencies.
517
518*PyQt4-4.7.6 (08 Sep 2010)
519
520 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
521 +PyQt4-4.7.6.ebuild:
522 Version bump. Remove old ebuild
523
524 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
525 PyQt4-4.7.5.ebuild:
526 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
527
528*PyQt4-4.7.5 (01 Sep 2010)
529
530 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
531 +PyQt4-4.7.5.ebuild:
532 Version bump
533
534 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
535 Stable for HPPA (bug #315775).
4 536
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 537 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 538 Bump sip dependency to 4.10.3. Fix arm epatch command
7 539
8*PyQt4-4.7.4 (13 Jul 2010) 540*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 1021*PyQt4-4.0_beta1 (05 May 2006)
490 1022
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1023 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 1024 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 1025 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.256

  ViewVC Help
Powered by ViewVC 1.1.20