/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.259
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.259 2014/05/19 18:07:12 mgorny Exp $
4
5 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
6 -PyQt4-4.10.3.ebuild:
7 Drop the old versions that required python-exec:0.
8
9 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
10 Remove python herd as discussed with them.
11
12*PyQt4-4.10.3-r3 (27 Mar 2014)
13
14 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
15 Replace manual Python wrapping with proper eclass functions, bug #484404.
16
17 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
18 Stable for sparc, wrt bug #495638
19
20 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
21 Stable for x86, wrt bug #495638
22
23 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
24 Stable for alpha, wrt bug #495638
25
26 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
27 Stable for ia64, wrt bug #495638
28
29 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
30 Stable for ppc64, wrt bug #495638
31
32 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
33 amd64 stable, bug 495638
34
35 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
36 Stable for ppc, wrt bug #495638
37
38 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
39 arm stable, bug #495638
40
41 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
42 files/PyQt4-4.7.3-qreal_float_support.patch:
43 Updated qreal_float patch to remove first hunk (already applied
44 upstream). Tested on arm chromebook; no existing bug.
45
46*PyQt4-4.10.3-r2 (25 Dec 2013)
47
48 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
49 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
50 Introduce USE="designer".
51
52 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
53 old
54
55 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
56 Stable for sparc, wrt bug #483112
57
58 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
59 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
60 Update the ebuilds to dep on dev-lang/python-exec.
61
62 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
63 old
64
65*PyQt4-4.10.3-r1 (23 Oct 2013)
66
67 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
68 Support python-exec:2.
69
70 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
71 Depend on sip >=4.15.0 to fix build failure (bug #485274)
72
73 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
74 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
75 Add explicit dep on python-exec:0 since the package wraps the script manually.
76
77*PyQt4-4.10.3 (17 Sep 2013)
78
79 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
80 Version bump
81
82 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
83 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
84 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
85
86 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
87 arm stable, bug #483112
88
89 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
90 Stable for x86, wrt bug #483112
91
92 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
93 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
94 Clean up PYTHON_COMPAT from old implementations.
95
96 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
97 Stable for ppc64, wrt bug #483112
98
99 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
100 Stable for ppc, wrt bug #483112
101
102 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
103 Stable for ia64, wrt bug #483112
104
105 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
106 Stable for alpha, wrt bug #483112
107
108 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
109 Stable for amd64, wrt bug #483112
110
111 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
112 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
113 Reorder Qt dependencies.
114
115 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
116 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
117 Fixing qtgui/designer deps for qt-4.8.5
118
119 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
120 PyQt4-4.9.6-r2.ebuild:
121 Fixing qtgui deps for qt-4.8.5
122
123 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
124 Remove wrong usedep for qtgui.
125
126*PyQt4-4.10.2 (24 Jun 2013)
127
128 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
129 Version bump.
130
131 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
132 PyQt4-4.10.1.ebuild:
133 Add PYTHON_REQUIRED_USE. Remove old.
134
135*PyQt4-4.10.1 (22 May 2013)
136
137 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
138 Version bump.
139
140 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
141 Remove unused flag description from metadata
142
143 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
144 -files/PyQt4-4.7.2-configure.py.patch,
145 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
146 old
147
148*PyQt4-4.10 (12 Mar 2013)
149
150 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
151 Version bump. Fix also bug #433944 by Franz Fellner.
152
153 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
154 Stable for sparc, wrt bug #457046
155
156 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
157 PyQt4-4.9.6-r2.ebuild:
158 Move Qt dependencies to the new category
159
160 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
161 Stable for ia64, wrt bug #457046
162
163 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
164 Stable for ppc64, wrt bug #457046
165
166 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
167 Stable for ppc, wrt bug #457046
168
169 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
170 Stable for alpha, wrt bug #457046
171
172 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
173 Stable for arm, wrt bug #457046
174
175 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
176 Stable for x86, wrt bug #457046
177
178 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
179 Stable for amd64, wrt bug #457046
180
181 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
182 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
183
184 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
185 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
186 Fix double prefix; remove old.
187
188 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
189 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
190
191*PyQt4-4.9.6-r2 (29 Jan 2013)
192
193 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
194 Migrate to the new python eclass.
195
196 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
197 Improve pyqt4_use_enable() as suggested by Arfrever.
198
199 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
200 old
201
202*PyQt4-4.9.6-r1 (26 Dec 2012)
203
204 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
205 metadata.xml:
206 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
207 pyside: rename assistant to help, add script and scripttools (bug 431460 by
208 Arfrever).
209
210*PyQt4-4.9.6 (10 Dec 2012)
211
212 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
213 Version bump, with some minor updates from qt overlay.
214
215 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
216 arm stable, bug #435074
217
218 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
219 PyQt4-4.9.4-r1.ebuild:
220 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
221
222 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
223 -PyQt4-4.9.1.ebuild:
224 Remove old
225
226*PyQt4-4.9.5 (05 Oct 2012)
227
228 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
229 Version bump
230
231 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
232 alpha/ia64/sparc stable wrt #429042
233
234*PyQt4-4.9.4-r1 (03 Sep 2012)
235
236 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
237 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
238 Apply upstream patch to fix regression in pyuic's handling of custom widgets
239 (bug 431070 by Laurent Bachelier).
240
241 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
242 Stable for x86, wrt bug #429042
243
244 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
245 Stable for amd64, wrt bug #429042
246
247 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
248 Stable ppc64, bug #429042
249
250 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
251 Stable ppc, bug #429042
252
253 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
254 ia64 stable
255
256 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
257 -files/PyQt4-4.6.1-configure-multilib.patch:
258 Remove old.
259
260 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
261 PyQt4-4.9.4.ebuild:
262 alpha/ia64/sparc stable wrt #412929
263
264*PyQt4-4.9.4 (02 Jul 2012)
265
266 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
267 -PyQt4-4.9.3.ebuild:
268 Version bump.
269
270*PyQt4-4.9.3 (27 Jun 2012)
271
272 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
273 -PyQt4-4.9.2.ebuild:
274 Version bump.
275
276 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
277 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
278
279*PyQt4-4.9.2 (21 Jun 2012)
280
281 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
282 Version bump
283
284 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
285 Destabling to ~ia64 because last available stable qt will be masked pending
286 removal
287
288 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
289 marked x86 per bug 412929
290
291 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
292 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
293 Inherit eutils.
294
295 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
296 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
297 Revert previous change.
298
299 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
300 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
301 Restrict python 3.1 to match dev-python/dbus-python.
302
303 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
304 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
305
306 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
307 Migrating dev-util/pkgconfig -> virtual/pkgconfig
308
309 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
310 Stable for amd64, wrt bug #412929
311
312 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
313 Stable on alpha, bug #354033
314
315 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
316 PyQt4-4.8.4.ebuild:
317 PyQt4-4.8 does not build with sip-4.13, bug 407291
318
319 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
320 Slightly improve the ewarn message in pkg_postinst().
321
322 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
323 Put qt as the primary herd in metadata.
324
325 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
326 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
327 <slong@rathaus.eclipse.co.uk> in bug #407281.
328
329 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
330 Switch to EAPI 4, add REQUIRED_USE.
331
332 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
333 PyQt4-4.8.4.ebuild:
334 Drop ~x86-fbsd because of unkeyworded dependencies.
335
336 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
337 Don't enable QtAssistant module because it was removed in qt-4.7 and we
338 already depend on 4.7.2 or later.
339
340 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
341 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
342 Restrict pypy for older versions too.
343
344 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
345 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
346 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
347 version.
348
349 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
350 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
351 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
352 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
353 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
354 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
355
356 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
357 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
358 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
359 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
360 Fixing pypy restricts to actually work
361
362*PyQt4-4.9.1 (12 Feb 2012)
363
364 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
365 version bump
366
367 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
368 builds with qt-opengl-4.8.0[egl], updated dep
369
370 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
371 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
372 Fixes backported from Progress Overlay. Patch by Arfrever.
373
374*PyQt4-4.9 (24 Dec 2011)
375
376 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
377 Version bump
378
379*PyQt4-4.8.6 (11 Nov 2011)
380
381 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
382 Version bump
383
384 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
385 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
386 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
387 python overlay.
388
389*PyQt4-4.8.5 (19 Aug 2011)
390
391 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
392 Version bump
393
394 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
395 ppc/ppc64 stable wrt #374591
396
397 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
398 x86 stable, bug #374591
399
400 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
401 ppc64 stable wrt #354033
402
403 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
404 Stable on amd64 wrt bug #374591
405
406 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
407 Marking PyQt4-4.8.3 ppc stable for bug 354033
408
409 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
410 Stable on amd64 wrt bug #354033
411
412 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
413 x86 stable per bug 354033
414
415*PyQt4-4.8.4 (02 May 2011)
416
417 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
418 +PyQt4-4.8.4.ebuild:
419 Version bump.
420
421 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
422 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
423 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
424 Adapt phonon dependency for package move
425
426 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
427 ppc64 stable wrt #349607
428
429 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
430 ia64/sparc stable wrt #349607
431
432 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
433 Stable on alpha, bug #349607
434
435 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
436 PyQt4-4.8.3.ebuild:
437 Update dependencies (bug #353053).
438
439*PyQt4-4.8.3 (25 Jan 2011)
440
441 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
442 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
443 Version bump.
444
445 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
446 x86 stable wrt bug #349607
447
448 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
449 Marking PyQt4-4.8.1 ppc stable for bug 349607
450
451 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
452 Stable on amd64 wrt bug #349607
453
454 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
455 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
456 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
457
458*PyQt4-4.8.1-r1 (30 Dec 2010)
459
460 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
461 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
462 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
463
464 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
465 PyQt4-4.8.2.ebuild:
466 Fix dependencies (bug #349672).
467
468*PyQt4-4.8.2 (24 Dec 2010)
469
470 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
471 +PyQt4-4.8.2.ebuild:
472 Version bump.
473
474 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
475 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
476 Restrict Jython ABIs.
477
478 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
479 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
480 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
481 -files/configure.py.patch:
482 Delete.
483
484 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
485 old, depends on qt 4.5
486
487 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
488 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
489 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
490 Remove HPPA keywording (bug #239441).
491
492*PyQt4-4.8.1 (30 Oct 2010)
493
494 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
495 +PyQt4-4.8.1.ebuild:
496 Version bump.
497
498 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
499 ia64/sparc stable wrt #315775
500
501*PyQt4-4.8 (23 Oct 2010)
502
503 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
504 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
505 +PyQt4-4.8.ebuild, metadata.xml:
506 Version bump.
507
508*PyQt4-4.7.7-r1 (06 Oct 2010)
509
510 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
511 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
512 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
513
514*PyQt4-4.7.7 (21 Sep 2010)
515
516 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
517 +PyQt4-4.7.7.ebuild:
518 Version bump. Remove old bogus version
519
520 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
521 Stable on alpha, bug #315775
522
523 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
524 Marked ppc stable for bug #315775.
525
526 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
527 PyQt4-4.7.6.ebuild:
528 Update EAPI. Fix dependencies.
529
530*PyQt4-4.7.6 (08 Sep 2010)
531
532 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
533 +PyQt4-4.7.6.ebuild:
534 Version bump. Remove old ebuild
535
536 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
537 PyQt4-4.7.5.ebuild:
538 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
539
540*PyQt4-4.7.5 (01 Sep 2010)
541
542 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
543 +PyQt4-4.7.5.ebuild:
544 Version bump
545
546 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
547 Stable for HPPA (bug #315775).
4 548
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 549 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 550 Bump sip dependency to 4.10.3. Fix arm epatch command
7 551
8*PyQt4-4.7.4 (13 Jul 2010) 552*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 1033*PyQt4-4.0_beta1 (05 May 2006)
490 1034
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1035 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 1036 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 1037 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.259

  ViewVC Help
Powered by ViewVC 1.1.20