/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.273
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.273 2014/10/14 02:49:02 pesa Exp $
4
5 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
6 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
7 Fix building against media-libs/phonon (bug 525354).
8
9*PyQt4-4.11.2-r1 (13 Oct 2014)
10
11 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
12 metadata.xml:
13 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
14 from QtGui.
15
16 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
17 Revert to ~amd64, see bug #523322 comment #4.
18
19 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
20 Stable for amd64, wrt bug #523322
21
22 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
23 arm stable, bug #523322
24
25*PyQt4-4.11.2 (20 Sep 2014)
26
27 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
28 PyQt4-4.11.1.ebuild:
29 Version bump. Silence harmless repoman warning.
30
31 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
32 Drop deprecated python versions.
33
34 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
35 PyQt4-4.11.1.ebuild:
36 Stop using dohtml, remove old.
37
38 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
39 Remove old.
40
41*PyQt4-4.11.1 (15 Jul 2014)
42
43 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
44 PyQt4-4.11.ebuild:
45 Version bump.
46
47 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
48 PyQt4-4.11.ebuild:
49 add py3.4 support req'd to support py packages such as pandas
50
51 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
52 PyQt4-4.10.3-r3.ebuild:
53 Restrict sip dep to =4.15* for older PyQt4 versions.
54
55*PyQt4-4.11 (30 May 2014)
56
57 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
58 Version bump.
59
60 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
61 PyQt4-4.10.3-r3.ebuild, metadata.xml:
62 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
63 Martin Walch in bug 510812.
64
65 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
66 -PyQt4-4.10.3.ebuild:
67 Drop the old versions that required python-exec:0.
68
69 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
70 Remove python herd as discussed with them.
71
72*PyQt4-4.10.3-r3 (27 Mar 2014)
73
74 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
75 Replace manual Python wrapping with proper eclass functions, bug #484404.
76
77 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
78 Stable for sparc, wrt bug #495638
79
80 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
81 Stable for x86, wrt bug #495638
82
83 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
84 Stable for alpha, wrt bug #495638
85
86 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
87 Stable for ia64, wrt bug #495638
88
89 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
90 Stable for ppc64, wrt bug #495638
91
92 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
93 amd64 stable, bug 495638
94
95 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
96 Stable for ppc, wrt bug #495638
97
98 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
99 arm stable, bug #495638
100
101 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
102 files/PyQt4-4.7.3-qreal_float_support.patch:
103 Updated qreal_float patch to remove first hunk (already applied
104 upstream). Tested on arm chromebook; no existing bug.
105
106*PyQt4-4.10.3-r2 (25 Dec 2013)
107
108 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
109 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
110 Introduce USE="designer".
111
112 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
113 old
114
115 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
116 Stable for sparc, wrt bug #483112
117
118 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
119 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
120 Update the ebuilds to dep on dev-lang/python-exec.
121
122 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
123 old
124
125*PyQt4-4.10.3-r1 (23 Oct 2013)
126
127 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
128 Support python-exec:2.
129
130 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
131 Depend on sip >=4.15.0 to fix build failure (bug #485274)
132
133 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
134 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
135 Add explicit dep on python-exec:0 since the package wraps the script manually.
136
137*PyQt4-4.10.3 (17 Sep 2013)
138
139 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
140 Version bump
141
142 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
143 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
144 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
145
146 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
147 arm stable, bug #483112
148
149 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
150 Stable for x86, wrt bug #483112
151
152 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
153 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
154 Clean up PYTHON_COMPAT from old implementations.
155
156 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
157 Stable for ppc64, wrt bug #483112
158
159 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
160 Stable for ppc, wrt bug #483112
161
162 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
163 Stable for ia64, wrt bug #483112
164
165 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
166 Stable for alpha, wrt bug #483112
167
168 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
169 Stable for amd64, wrt bug #483112
170
171 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
172 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
173 Reorder Qt dependencies.
174
175 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
176 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
177 Fixing qtgui/designer deps for qt-4.8.5
178
179 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
180 PyQt4-4.9.6-r2.ebuild:
181 Fixing qtgui deps for qt-4.8.5
182
183 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
184 Remove wrong usedep for qtgui.
185
186*PyQt4-4.10.2 (24 Jun 2013)
187
188 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
189 Version bump.
190
191 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
192 PyQt4-4.10.1.ebuild:
193 Add PYTHON_REQUIRED_USE. Remove old.
194
195*PyQt4-4.10.1 (22 May 2013)
196
197 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
198 Version bump.
199
200 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
201 Remove unused flag description from metadata
202
203 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
204 -files/PyQt4-4.7.2-configure.py.patch,
205 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
206 old
207
208*PyQt4-4.10 (12 Mar 2013)
209
210 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
211 Version bump. Fix also bug #433944 by Franz Fellner.
212
213 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
214 Stable for sparc, wrt bug #457046
215
216 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
217 PyQt4-4.9.6-r2.ebuild:
218 Move Qt dependencies to the new category
219
220 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
221 Stable for ia64, wrt bug #457046
222
223 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
224 Stable for ppc64, wrt bug #457046
225
226 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
227 Stable for ppc, wrt bug #457046
228
229 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
230 Stable for alpha, wrt bug #457046
231
232 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
233 Stable for arm, wrt bug #457046
234
235 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
236 Stable for x86, wrt bug #457046
237
238 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
239 Stable for amd64, wrt bug #457046
240
241 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
242 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
243
244 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
245 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
246 Fix double prefix; remove old.
247
248 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
249 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
250
251*PyQt4-4.9.6-r2 (29 Jan 2013)
252
253 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
254 Migrate to the new python eclass.
255
256 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
257 Improve pyqt4_use_enable() as suggested by Arfrever.
258
259 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
260 old
261
262*PyQt4-4.9.6-r1 (26 Dec 2012)
263
264 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
265 metadata.xml:
266 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
267 pyside: rename assistant to help, add script and scripttools (bug 431460 by
268 Arfrever).
269
270*PyQt4-4.9.6 (10 Dec 2012)
271
272 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
273 Version bump, with some minor updates from qt overlay.
274
275 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
276 arm stable, bug #435074
277
278 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
279 PyQt4-4.9.4-r1.ebuild:
280 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
281
282 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
283 -PyQt4-4.9.1.ebuild:
284 Remove old
285
286*PyQt4-4.9.5 (05 Oct 2012)
287
288 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
289 Version bump
290
291 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
292 alpha/ia64/sparc stable wrt #429042
293
294*PyQt4-4.9.4-r1 (03 Sep 2012)
295
296 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
297 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
298 Apply upstream patch to fix regression in pyuic's handling of custom widgets
299 (bug 431070 by Laurent Bachelier).
300
301 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
302 Stable for x86, wrt bug #429042
303
304 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
305 Stable for amd64, wrt bug #429042
306
307 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
308 Stable ppc64, bug #429042
309
310 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
311 Stable ppc, bug #429042
312
313 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
314 ia64 stable
315
316 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
317 -files/PyQt4-4.6.1-configure-multilib.patch:
318 Remove old.
319
320 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
321 PyQt4-4.9.4.ebuild:
322 alpha/ia64/sparc stable wrt #412929
323
324*PyQt4-4.9.4 (02 Jul 2012)
325
326 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
327 -PyQt4-4.9.3.ebuild:
328 Version bump.
329
330*PyQt4-4.9.3 (27 Jun 2012)
331
332 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
333 -PyQt4-4.9.2.ebuild:
334 Version bump.
335
336 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
337 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
338
339*PyQt4-4.9.2 (21 Jun 2012)
340
341 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
342 Version bump
343
344 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
345 Destabling to ~ia64 because last available stable qt will be masked pending
346 removal
347
348 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
349 marked x86 per bug 412929
350
351 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
352 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
353 Inherit eutils.
354
355 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
356 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
357 Revert previous change.
358
359 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
360 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
361 Restrict python 3.1 to match dev-python/dbus-python.
362
363 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
364 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
365
366 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
367 Migrating dev-util/pkgconfig -> virtual/pkgconfig
368
369 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
370 Stable for amd64, wrt bug #412929
371
372 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
373 Stable on alpha, bug #354033
374
375 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
376 PyQt4-4.8.4.ebuild:
377 PyQt4-4.8 does not build with sip-4.13, bug 407291
378
379 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
380 Slightly improve the ewarn message in pkg_postinst().
381
382 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
383 Put qt as the primary herd in metadata.
384
385 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
386 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
387 <slong@rathaus.eclipse.co.uk> in bug #407281.
388
389 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
390 Switch to EAPI 4, add REQUIRED_USE.
391
392 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
393 PyQt4-4.8.4.ebuild:
394 Drop ~x86-fbsd because of unkeyworded dependencies.
395
396 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
397 Don't enable QtAssistant module because it was removed in qt-4.7 and we
398 already depend on 4.7.2 or later.
399
400 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
401 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
402 Restrict pypy for older versions too.
403
404 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
405 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
406 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
407 version.
408
409 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
410 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
411 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
412 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
413 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
414 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
415
416 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
417 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
418 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
419 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
420 Fixing pypy restricts to actually work
421
422*PyQt4-4.9.1 (12 Feb 2012)
423
424 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
425 version bump
426
427 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
428 builds with qt-opengl-4.8.0[egl], updated dep
429
430 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
431 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
432 Fixes backported from Progress Overlay. Patch by Arfrever.
433
434*PyQt4-4.9 (24 Dec 2011)
435
436 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
437 Version bump
438
439*PyQt4-4.8.6 (11 Nov 2011)
440
441 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
442 Version bump
443
444 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
445 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
446 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
447 python overlay.
448
449*PyQt4-4.8.5 (19 Aug 2011)
450
451 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
452 Version bump
453
454 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
455 ppc/ppc64 stable wrt #374591
456
457 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
458 x86 stable, bug #374591
459
460 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
461 ppc64 stable wrt #354033
462
463 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
464 Stable on amd64 wrt bug #374591
465
466 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
467 Marking PyQt4-4.8.3 ppc stable for bug 354033
468
469 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
470 Stable on amd64 wrt bug #354033
471
472 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
473 x86 stable per bug 354033
474
475*PyQt4-4.8.4 (02 May 2011)
476
477 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
478 +PyQt4-4.8.4.ebuild:
479 Version bump.
480
481 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
482 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
483 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
484 Adapt phonon dependency for package move
485
486 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
487 ppc64 stable wrt #349607
488
489 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
490 ia64/sparc stable wrt #349607
491
492 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
493 Stable on alpha, bug #349607
494
495 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
496 PyQt4-4.8.3.ebuild:
497 Update dependencies (bug #353053).
498
499*PyQt4-4.8.3 (25 Jan 2011)
500
501 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
502 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
503 Version bump.
504
505 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
506 x86 stable wrt bug #349607
507
508 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
509 Marking PyQt4-4.8.1 ppc stable for bug 349607
510
511 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
512 Stable on amd64 wrt bug #349607
513
514 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
515 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
516 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
517
518*PyQt4-4.8.1-r1 (30 Dec 2010)
519
520 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
521 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
522 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
523
524 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
525 PyQt4-4.8.2.ebuild:
526 Fix dependencies (bug #349672).
527
528*PyQt4-4.8.2 (24 Dec 2010)
529
530 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
531 +PyQt4-4.8.2.ebuild:
532 Version bump.
533
534 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
535 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
536 Restrict Jython ABIs.
537
538 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
539 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
540 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
541 -files/configure.py.patch:
542 Delete.
543
544 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
545 old, depends on qt 4.5
546
547 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
548 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
549 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
550 Remove HPPA keywording (bug #239441).
551
552*PyQt4-4.8.1 (30 Oct 2010)
553
554 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
555 +PyQt4-4.8.1.ebuild:
556 Version bump.
557
558 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
559 ia64/sparc stable wrt #315775
560
561*PyQt4-4.8 (23 Oct 2010)
562
563 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
564 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
565 +PyQt4-4.8.ebuild, metadata.xml:
566 Version bump.
567
568*PyQt4-4.7.7-r1 (06 Oct 2010)
569
570 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
571 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
572 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
573
574*PyQt4-4.7.7 (21 Sep 2010)
575
576 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
577 +PyQt4-4.7.7.ebuild:
578 Version bump. Remove old bogus version
579
580 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
581 Stable on alpha, bug #315775
582
583 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
584 Marked ppc stable for bug #315775.
585
586 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
587 PyQt4-4.7.6.ebuild:
588 Update EAPI. Fix dependencies.
589
590*PyQt4-4.7.6 (08 Sep 2010)
591
592 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
593 +PyQt4-4.7.6.ebuild:
594 Version bump. Remove old ebuild
595
596 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
597 PyQt4-4.7.5.ebuild:
598 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
599
600*PyQt4-4.7.5 (01 Sep 2010)
601
602 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
603 +PyQt4-4.7.5.ebuild:
604 Version bump
605
606 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
607 Stable for HPPA (bug #315775).
4 608
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 609 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 610 Bump sip dependency to 4.10.3. Fix arm epatch command
7 611
8*PyQt4-4.7.4 (13 Jul 2010) 612*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 1093*PyQt4-4.0_beta1 (05 May 2006)
490 1094
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1095 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 1096 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 1097 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.273

  ViewVC Help
Powered by ViewVC 1.1.20