/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.275
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.275 2014/11/01 02:58:19 pesa Exp $
4
5*PyQt4-4.11.3_pre20141024 (01 Nov 2014)
6
7 01 Nov 2014; Davide Pesavento <pesa@gentoo.org>
8 +PyQt4-4.11.3_pre20141024.ebuild, -PyQt4-4.11.2-r1.ebuild:
9 Bump to 4.11.3 prerelease, which contains upstream fixes for bugs #525392 and
10 #525470. Also switch to out-of-source builds.
11
12 15 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.2-r1.ebuild:
13 Fix bug #525392.
14
15 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
16 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
17 Fix building against media-libs/phonon (bug 525354).
18
19*PyQt4-4.11.2-r1 (13 Oct 2014)
20
21 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
22 metadata.xml:
23 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
24 from QtGui.
25
26 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
27 Revert to ~amd64, see bug #523322 comment #4.
28
29 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
30 Stable for amd64, wrt bug #523322
31
32 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
33 arm stable, bug #523322
34
35*PyQt4-4.11.2 (20 Sep 2014)
36
37 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
38 PyQt4-4.11.1.ebuild:
39 Version bump. Silence harmless repoman warning.
40
41 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
42 Drop deprecated python versions.
43
44 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
45 PyQt4-4.11.1.ebuild:
46 Stop using dohtml, remove old.
47
48 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
49 Remove old.
50
51*PyQt4-4.11.1 (15 Jul 2014)
52
53 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
54 PyQt4-4.11.ebuild:
55 Version bump.
56
57 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
58 PyQt4-4.11.ebuild:
59 add py3.4 support req'd to support py packages such as pandas
60
61 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
62 PyQt4-4.10.3-r3.ebuild:
63 Restrict sip dep to =4.15* for older PyQt4 versions.
64
65*PyQt4-4.11 (30 May 2014)
66
67 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
68 Version bump.
69
70 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
71 PyQt4-4.10.3-r3.ebuild, metadata.xml:
72 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
73 Martin Walch in bug 510812.
74
75 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
76 -PyQt4-4.10.3.ebuild:
77 Drop the old versions that required python-exec:0.
78
79 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
80 Remove python herd as discussed with them.
81
82*PyQt4-4.10.3-r3 (27 Mar 2014)
83
84 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
85 Replace manual Python wrapping with proper eclass functions, bug #484404.
86
87 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
88 Stable for sparc, wrt bug #495638
89
90 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
91 Stable for x86, wrt bug #495638
92
93 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
94 Stable for alpha, wrt bug #495638
95
96 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
97 Stable for ia64, wrt bug #495638
98
99 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
100 Stable for ppc64, wrt bug #495638
101
102 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
103 amd64 stable, bug 495638
104
105 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
106 Stable for ppc, wrt bug #495638
107
108 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
109 arm stable, bug #495638
110
111 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
112 files/PyQt4-4.7.3-qreal_float_support.patch:
113 Updated qreal_float patch to remove first hunk (already applied
114 upstream). Tested on arm chromebook; no existing bug.
115
116*PyQt4-4.10.3-r2 (25 Dec 2013)
117
118 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
119 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
120 Introduce USE="designer".
121
122 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
123 old
124
125 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
126 Stable for sparc, wrt bug #483112
127
128 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
129 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
130 Update the ebuilds to dep on dev-lang/python-exec.
131
132 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
133 old
134
135*PyQt4-4.10.3-r1 (23 Oct 2013)
136
137 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
138 Support python-exec:2.
139
140 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
141 Depend on sip >=4.15.0 to fix build failure (bug #485274)
142
143 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
144 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
145 Add explicit dep on python-exec:0 since the package wraps the script manually.
146
147*PyQt4-4.10.3 (17 Sep 2013)
148
149 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
150 Version bump
151
152 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
153 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
154 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
155
156 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
157 arm stable, bug #483112
158
159 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
160 Stable for x86, wrt bug #483112
161
162 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
163 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
164 Clean up PYTHON_COMPAT from old implementations.
165
166 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
167 Stable for ppc64, wrt bug #483112
168
169 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
170 Stable for ppc, wrt bug #483112
171
172 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
173 Stable for ia64, wrt bug #483112
174
175 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
176 Stable for alpha, wrt bug #483112
177
178 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
179 Stable for amd64, wrt bug #483112
180
181 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
182 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
183 Reorder Qt dependencies.
184
185 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
186 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
187 Fixing qtgui/designer deps for qt-4.8.5
188
189 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
190 PyQt4-4.9.6-r2.ebuild:
191 Fixing qtgui deps for qt-4.8.5
192
193 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
194 Remove wrong usedep for qtgui.
195
196*PyQt4-4.10.2 (24 Jun 2013)
197
198 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
199 Version bump.
200
201 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
202 PyQt4-4.10.1.ebuild:
203 Add PYTHON_REQUIRED_USE. Remove old.
204
205*PyQt4-4.10.1 (22 May 2013)
206
207 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
208 Version bump.
209
210 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
211 Remove unused flag description from metadata
212
213 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
214 -files/PyQt4-4.7.2-configure.py.patch,
215 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
216 old
217
218*PyQt4-4.10 (12 Mar 2013)
219
220 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
221 Version bump. Fix also bug #433944 by Franz Fellner.
222
223 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
224 Stable for sparc, wrt bug #457046
225
226 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
227 PyQt4-4.9.6-r2.ebuild:
228 Move Qt dependencies to the new category
229
230 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
231 Stable for ia64, wrt bug #457046
232
233 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
234 Stable for ppc64, wrt bug #457046
235
236 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
237 Stable for ppc, wrt bug #457046
238
239 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
240 Stable for alpha, wrt bug #457046
241
242 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
243 Stable for arm, wrt bug #457046
244
245 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
246 Stable for x86, wrt bug #457046
247
248 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
249 Stable for amd64, wrt bug #457046
250
251 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
252 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
253
254 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
255 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
256 Fix double prefix; remove old.
257
258 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
259 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
260
261*PyQt4-4.9.6-r2 (29 Jan 2013)
262
263 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
264 Migrate to the new python eclass.
265
266 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
267 Improve pyqt4_use_enable() as suggested by Arfrever.
268
269 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
270 old
271
272*PyQt4-4.9.6-r1 (26 Dec 2012)
273
274 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
275 metadata.xml:
276 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
277 pyside: rename assistant to help, add script and scripttools (bug 431460 by
278 Arfrever).
279
280*PyQt4-4.9.6 (10 Dec 2012)
281
282 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
283 Version bump, with some minor updates from qt overlay.
284
285 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
286 arm stable, bug #435074
287
288 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
289 PyQt4-4.9.4-r1.ebuild:
290 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
291
292 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
293 -PyQt4-4.9.1.ebuild:
294 Remove old
295
296*PyQt4-4.9.5 (05 Oct 2012)
297
298 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
299 Version bump
300
301 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
302 alpha/ia64/sparc stable wrt #429042
303
304*PyQt4-4.9.4-r1 (03 Sep 2012)
305
306 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
307 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
308 Apply upstream patch to fix regression in pyuic's handling of custom widgets
309 (bug 431070 by Laurent Bachelier).
310
311 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
312 Stable for x86, wrt bug #429042
313
314 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
315 Stable for amd64, wrt bug #429042
316
317 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
318 Stable ppc64, bug #429042
319
320 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
321 Stable ppc, bug #429042
322
323 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
324 ia64 stable
325
326 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
327 -files/PyQt4-4.6.1-configure-multilib.patch:
328 Remove old.
329
330 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
331 PyQt4-4.9.4.ebuild:
332 alpha/ia64/sparc stable wrt #412929
333
334*PyQt4-4.9.4 (02 Jul 2012)
335
336 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
337 -PyQt4-4.9.3.ebuild:
338 Version bump.
339
340*PyQt4-4.9.3 (27 Jun 2012)
341
342 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
343 -PyQt4-4.9.2.ebuild:
344 Version bump.
345
346 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
347 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
348
349*PyQt4-4.9.2 (21 Jun 2012)
350
351 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
352 Version bump
353
354 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
355 Destabling to ~ia64 because last available stable qt will be masked pending
356 removal
357
358 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
359 marked x86 per bug 412929
360
361 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
362 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
363 Inherit eutils.
364
365 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
366 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
367 Revert previous change.
368
369 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
370 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
371 Restrict python 3.1 to match dev-python/dbus-python.
372
373 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
374 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
375
376 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
377 Migrating dev-util/pkgconfig -> virtual/pkgconfig
378
379 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
380 Stable for amd64, wrt bug #412929
381
382 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
383 Stable on alpha, bug #354033
384
385 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
386 PyQt4-4.8.4.ebuild:
387 PyQt4-4.8 does not build with sip-4.13, bug 407291
388
389 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
390 Slightly improve the ewarn message in pkg_postinst().
391
392 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
393 Put qt as the primary herd in metadata.
394
395 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
396 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
397 <slong@rathaus.eclipse.co.uk> in bug #407281.
398
399 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
400 Switch to EAPI 4, add REQUIRED_USE.
401
402 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
403 PyQt4-4.8.4.ebuild:
404 Drop ~x86-fbsd because of unkeyworded dependencies.
405
406 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
407 Don't enable QtAssistant module because it was removed in qt-4.7 and we
408 already depend on 4.7.2 or later.
409
410 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
411 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
412 Restrict pypy for older versions too.
413
414 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
415 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
416 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
417 version.
418
419 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
420 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
421 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
422 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
423 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
424 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
425
426 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
427 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
428 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
429 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
430 Fixing pypy restricts to actually work
431
432*PyQt4-4.9.1 (12 Feb 2012)
433
434 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
435 version bump
436
437 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
438 builds with qt-opengl-4.8.0[egl], updated dep
439
440 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
441 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
442 Fixes backported from Progress Overlay. Patch by Arfrever.
443
444*PyQt4-4.9 (24 Dec 2011)
445
446 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
447 Version bump
448
449*PyQt4-4.8.6 (11 Nov 2011)
450
451 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
452 Version bump
453
454 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
455 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
456 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
457 python overlay.
458
459*PyQt4-4.8.5 (19 Aug 2011)
460
461 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
462 Version bump
463
464 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
465 ppc/ppc64 stable wrt #374591
466
467 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
468 x86 stable, bug #374591
469
470 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
471 ppc64 stable wrt #354033
472
473 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
474 Stable on amd64 wrt bug #374591
475
476 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
477 Marking PyQt4-4.8.3 ppc stable for bug 354033
478
479 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
480 Stable on amd64 wrt bug #354033
481
482 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
483 x86 stable per bug 354033
484
485*PyQt4-4.8.4 (02 May 2011)
486
487 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
488 +PyQt4-4.8.4.ebuild:
489 Version bump.
490
491 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
492 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
493 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
494 Adapt phonon dependency for package move
495
496 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
497 ppc64 stable wrt #349607
498
499 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
500 ia64/sparc stable wrt #349607
501
502 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
503 Stable on alpha, bug #349607
504
505 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
506 PyQt4-4.8.3.ebuild:
507 Update dependencies (bug #353053).
508
509*PyQt4-4.8.3 (25 Jan 2011)
510
511 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
512 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
513 Version bump.
514
515 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
516 x86 stable wrt bug #349607
517
518 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
519 Marking PyQt4-4.8.1 ppc stable for bug 349607
520
521 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
522 Stable on amd64 wrt bug #349607
523
524 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
525 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
526 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
527
528*PyQt4-4.8.1-r1 (30 Dec 2010)
529
530 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
531 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
532 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
533
534 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
535 PyQt4-4.8.2.ebuild:
536 Fix dependencies (bug #349672).
537
538*PyQt4-4.8.2 (24 Dec 2010)
539
540 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
541 +PyQt4-4.8.2.ebuild:
542 Version bump.
543
544 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
545 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
546 Restrict Jython ABIs.
547
548 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
549 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
550 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
551 -files/configure.py.patch:
552 Delete.
553
554 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
555 old, depends on qt 4.5
556
557 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
558 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
559 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
560 Remove HPPA keywording (bug #239441).
561
562*PyQt4-4.8.1 (30 Oct 2010)
563
564 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
565 +PyQt4-4.8.1.ebuild:
566 Version bump.
567
568 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
569 ia64/sparc stable wrt #315775
570
571*PyQt4-4.8 (23 Oct 2010)
572
573 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
574 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
575 +PyQt4-4.8.ebuild, metadata.xml:
576 Version bump.
577
578*PyQt4-4.7.7-r1 (06 Oct 2010)
579
580 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
581 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
582 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
583
584*PyQt4-4.7.7 (21 Sep 2010)
585
586 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
587 +PyQt4-4.7.7.ebuild:
588 Version bump. Remove old bogus version
589
590 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
591 Stable on alpha, bug #315775
592
593 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
594 Marked ppc stable for bug #315775.
595
596 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
597 PyQt4-4.7.6.ebuild:
598 Update EAPI. Fix dependencies.
599
600*PyQt4-4.7.6 (08 Sep 2010)
601
602 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
603 +PyQt4-4.7.6.ebuild:
604 Version bump. Remove old ebuild
605
606 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
607 PyQt4-4.7.5.ebuild:
608 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
609
610*PyQt4-4.7.5 (01 Sep 2010)
611
612 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
613 +PyQt4-4.7.5.ebuild:
614 Version bump
615
616 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
617 Stable for HPPA (bug #315775).
4 618
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 619 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 620 Bump sip dependency to 4.10.3. Fix arm epatch command
7 621
8*PyQt4-4.7.4 (13 Jul 2010) 622*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 1103*PyQt4-4.0_beta1 (05 May 2006)
490 1104
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1105 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 1106 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 1107 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.275

  ViewVC Help
Powered by ViewVC 1.1.20