/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.284
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.284 2015/04/08 08:05:00 mgorny Exp $
4
5 08 Apr 2015; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.3-r2.ebuild:
6 Drop old Python implementations
7
8 17 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
9 Stable for ppc64, wrt bug #517344
10
11 16 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
12 Stable for ppc, wrt bug #517344
13
14 14 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
15 Stable for x86, wrt bug #517344
16
17 09 Jan 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.3.ebuild:
18 Stop using deprecated python_parallel_foreach_impl.
19
20 31 Dec 2014; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.3-r2.ebuild,
21 PyQt4-4.11.1.ebuild, PyQt4-4.11.2.ebuild:
22 Enforce USE dependency for media-libs/phonon.
23
24 10 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> PyQt4-4.11.1.ebuild:
25 amd64 stable wrt bug #517344
26
27 22 Nov 2014; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.11.1.ebuild:
28 Stable on alpha, bug 523322
29
30*PyQt4-4.11.3 (15 Nov 2014)
31
32 15 Nov 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.3.ebuild,
33 -PyQt4-4.11.3_pre20141024.ebuild:
34 Version bump.
35
36*PyQt4-4.11.3_pre20141024 (01 Nov 2014)
37
38 01 Nov 2014; Davide Pesavento <pesa@gentoo.org>
39 +PyQt4-4.11.3_pre20141024.ebuild, -PyQt4-4.11.2-r1.ebuild:
40 Bump to 4.11.3 prerelease, which contains upstream fixes for bugs #525392 and
41 #525470. Also switch to out-of-source builds.
42
43 15 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.2-r1.ebuild:
44 Fix bug #525392.
45
46 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
47 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
48 Fix building against media-libs/phonon (bug 525354).
49
50*PyQt4-4.11.2-r1 (13 Oct 2014)
51
52 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
53 metadata.xml:
54 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
55 from QtGui.
56
57 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
58 Revert to ~amd64, see bug #523322 comment #4.
59
60 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
61 Stable for amd64, wrt bug #523322
62
63 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
64 arm stable, bug #523322
65
66*PyQt4-4.11.2 (20 Sep 2014)
67
68 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
69 PyQt4-4.11.1.ebuild:
70 Version bump. Silence harmless repoman warning.
71
72 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
73 Drop deprecated python versions.
74
75 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
76 PyQt4-4.11.1.ebuild:
77 Stop using dohtml, remove old.
78
79 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
80 Remove old.
81
82*PyQt4-4.11.1 (15 Jul 2014)
83
84 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
85 PyQt4-4.11.ebuild:
86 Version bump.
87
88 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
89 PyQt4-4.11.ebuild:
90 add py3.4 support req'd to support py packages such as pandas
91
92 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
93 PyQt4-4.10.3-r3.ebuild:
94 Restrict sip dep to =4.15* for older PyQt4 versions.
95
96*PyQt4-4.11 (30 May 2014)
97
98 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
99 Version bump.
100
101 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
102 PyQt4-4.10.3-r3.ebuild, metadata.xml:
103 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
104 Martin Walch in bug 510812.
105
106 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
107 -PyQt4-4.10.3.ebuild:
108 Drop the old versions that required python-exec:0.
109
110 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
111 Remove python herd as discussed with them.
112
113*PyQt4-4.10.3-r3 (27 Mar 2014)
114
115 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
116 Replace manual Python wrapping with proper eclass functions, bug #484404.
117
118 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
119 Stable for sparc, wrt bug #495638
120
121 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
122 Stable for x86, wrt bug #495638
123
124 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
125 Stable for alpha, wrt bug #495638
126
127 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
128 Stable for ia64, wrt bug #495638
129
130 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
131 Stable for ppc64, wrt bug #495638
132
133 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
134 amd64 stable, bug 495638
135
136 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
137 Stable for ppc, wrt bug #495638
138
139 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
140 arm stable, bug #495638
141
142 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
143 files/PyQt4-4.7.3-qreal_float_support.patch:
144 Updated qreal_float patch to remove first hunk (already applied
145 upstream). Tested on arm chromebook; no existing bug.
146
147*PyQt4-4.10.3-r2 (25 Dec 2013)
148
149 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
150 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
151 Introduce USE="designer".
152
153 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
154 old
155
156 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
157 Stable for sparc, wrt bug #483112
158
159 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
160 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
161 Update the ebuilds to dep on dev-lang/python-exec.
162
163 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
164 old
165
166*PyQt4-4.10.3-r1 (23 Oct 2013)
167
168 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
169 Support python-exec:2.
170
171 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
172 Depend on sip >=4.15.0 to fix build failure (bug #485274)
173
174 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
175 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
176 Add explicit dep on python-exec:0 since the package wraps the script manually.
177
178*PyQt4-4.10.3 (17 Sep 2013)
179
180 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
181 Version bump
182
183 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
184 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
185 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
186
187 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
188 arm stable, bug #483112
189
190 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
191 Stable for x86, wrt bug #483112
192
193 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
194 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
195 Clean up PYTHON_COMPAT from old implementations.
196
197 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
198 Stable for ppc64, wrt bug #483112
199
200 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
201 Stable for ppc, wrt bug #483112
202
203 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
204 Stable for ia64, wrt bug #483112
205
206 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
207 Stable for alpha, wrt bug #483112
208
209 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
210 Stable for amd64, wrt bug #483112
211
212 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
213 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
214 Reorder Qt dependencies.
215
216 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
217 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
218 Fixing qtgui/designer deps for qt-4.8.5
219
220 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
221 PyQt4-4.9.6-r2.ebuild:
222 Fixing qtgui deps for qt-4.8.5
223
224 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
225 Remove wrong usedep for qtgui.
226
227*PyQt4-4.10.2 (24 Jun 2013)
228
229 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
230 Version bump.
231
232 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
233 PyQt4-4.10.1.ebuild:
234 Add PYTHON_REQUIRED_USE. Remove old.
235
236*PyQt4-4.10.1 (22 May 2013)
237
238 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
239 Version bump.
240
241 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
242 Remove unused flag description from metadata
243
244 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
245 -files/PyQt4-4.7.2-configure.py.patch,
246 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
247 old
248
249*PyQt4-4.10 (12 Mar 2013)
250
251 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
252 Version bump. Fix also bug #433944 by Franz Fellner.
253
254 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
255 Stable for sparc, wrt bug #457046
256
257 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
258 PyQt4-4.9.6-r2.ebuild:
259 Move Qt dependencies to the new category
260
261 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
262 Stable for ia64, wrt bug #457046
263
264 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
265 Stable for ppc64, wrt bug #457046
266
267 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
268 Stable for ppc, wrt bug #457046
269
270 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
271 Stable for alpha, wrt bug #457046
272
273 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
274 Stable for arm, wrt bug #457046
275
276 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
277 Stable for x86, wrt bug #457046
278
279 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
280 Stable for amd64, wrt bug #457046
281
282 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
283 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
284
285 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
286 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
287 Fix double prefix; remove old.
288
289 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
290 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
291
292*PyQt4-4.9.6-r2 (29 Jan 2013)
293
294 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
295 Migrate to the new python eclass.
296
297 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
298 Improve pyqt4_use_enable() as suggested by Arfrever.
299
300 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
301 old
302
303*PyQt4-4.9.6-r1 (26 Dec 2012)
304
305 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
306 metadata.xml:
307 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
308 pyside: rename assistant to help, add script and scripttools (bug 431460 by
309 Arfrever).
310
311*PyQt4-4.9.6 (10 Dec 2012)
312
313 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
314 Version bump, with some minor updates from qt overlay.
315
316 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
317 arm stable, bug #435074
318
319 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
320 PyQt4-4.9.4-r1.ebuild:
321 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
322
323 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
324 -PyQt4-4.9.1.ebuild:
325 Remove old
326
327*PyQt4-4.9.5 (05 Oct 2012)
328
329 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
330 Version bump
331
332 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
333 alpha/ia64/sparc stable wrt #429042
334
335*PyQt4-4.9.4-r1 (03 Sep 2012)
336
337 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
338 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
339 Apply upstream patch to fix regression in pyuic's handling of custom widgets
340 (bug 431070 by Laurent Bachelier).
341
342 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
343 Stable for x86, wrt bug #429042
344
345 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
346 Stable for amd64, wrt bug #429042
347
348 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
349 Stable ppc64, bug #429042
350
351 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
352 Stable ppc, bug #429042
353
354 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
355 ia64 stable
356
357 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
358 -files/PyQt4-4.6.1-configure-multilib.patch:
359 Remove old.
360
361 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
362 PyQt4-4.9.4.ebuild:
363 alpha/ia64/sparc stable wrt #412929
364
365*PyQt4-4.9.4 (02 Jul 2012)
366
367 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
368 -PyQt4-4.9.3.ebuild:
369 Version bump.
370
371*PyQt4-4.9.3 (27 Jun 2012)
372
373 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
374 -PyQt4-4.9.2.ebuild:
375 Version bump.
376
377 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
378 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
379
380*PyQt4-4.9.2 (21 Jun 2012)
381
382 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
383 Version bump
384
385 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
386 Destabling to ~ia64 because last available stable qt will be masked pending
387 removal
388
389 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
390 marked x86 per bug 412929
391
392 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
393 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
394 Inherit eutils.
395
396 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
397 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
398 Revert previous change.
399
400 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
401 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
402 Restrict python 3.1 to match dev-python/dbus-python.
403
404 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
405 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
406
407 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
408 Migrating dev-util/pkgconfig -> virtual/pkgconfig
409
410 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
411 Stable for amd64, wrt bug #412929
412
413 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
414 Stable on alpha, bug #354033
415
416 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
417 PyQt4-4.8.4.ebuild:
418 PyQt4-4.8 does not build with sip-4.13, bug 407291
419
420 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
421 Slightly improve the ewarn message in pkg_postinst().
422
423 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
424 Put qt as the primary herd in metadata.
425
426 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
427 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
428 <slong@rathaus.eclipse.co.uk> in bug #407281.
429
430 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
431 Switch to EAPI 4, add REQUIRED_USE.
432
433 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
434 PyQt4-4.8.4.ebuild:
435 Drop ~x86-fbsd because of unkeyworded dependencies.
436
437 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
438 Don't enable QtAssistant module because it was removed in qt-4.7 and we
439 already depend on 4.7.2 or later.
440
441 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
442 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
443 Restrict pypy for older versions too.
444
445 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
446 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
447 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
448 version.
449
450 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
451 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
452 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
453 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
454 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
455 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
456
457 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
458 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
459 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
460 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
461 Fixing pypy restricts to actually work
462
463*PyQt4-4.9.1 (12 Feb 2012)
464
465 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
466 version bump
467
468 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
469 builds with qt-opengl-4.8.0[egl], updated dep
470
471 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
472 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
473 Fixes backported from Progress Overlay. Patch by Arfrever.
474
475*PyQt4-4.9 (24 Dec 2011)
476
477 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
478 Version bump
479
480*PyQt4-4.8.6 (11 Nov 2011)
481
482 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
483 Version bump
484
485 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
486 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
487 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
488 python overlay.
489
490*PyQt4-4.8.5 (19 Aug 2011)
491
492 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
493 Version bump
494
495 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
496 ppc/ppc64 stable wrt #374591
497
498 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
499 x86 stable, bug #374591
500
501 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
502 ppc64 stable wrt #354033
503
504 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
505 Stable on amd64 wrt bug #374591
506
507 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
508 Marking PyQt4-4.8.3 ppc stable for bug 354033
509
510 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
511 Stable on amd64 wrt bug #354033
512
513 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
514 x86 stable per bug 354033
515
516*PyQt4-4.8.4 (02 May 2011)
517
518 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
519 +PyQt4-4.8.4.ebuild:
520 Version bump.
521
522 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
523 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
524 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
525 Adapt phonon dependency for package move
526
527 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
528 ppc64 stable wrt #349607
529
530 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
531 ia64/sparc stable wrt #349607
532
533 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
534 Stable on alpha, bug #349607
535
536 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
537 PyQt4-4.8.3.ebuild:
538 Update dependencies (bug #353053).
539
540*PyQt4-4.8.3 (25 Jan 2011)
541
542 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
543 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
544 Version bump.
545
546 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
547 x86 stable wrt bug #349607
548
549 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
550 Marking PyQt4-4.8.1 ppc stable for bug 349607
551
552 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
553 Stable on amd64 wrt bug #349607
554
555 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
556 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
557 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
558
559*PyQt4-4.8.1-r1 (30 Dec 2010)
560
561 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
562 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
563 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
564
565 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
566 PyQt4-4.8.2.ebuild:
567 Fix dependencies (bug #349672).
568
569*PyQt4-4.8.2 (24 Dec 2010)
570
571 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
572 +PyQt4-4.8.2.ebuild:
573 Version bump.
574
575 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
576 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
577 Restrict Jython ABIs.
578
579 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
580 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
581 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
582 -files/configure.py.patch:
583 Delete.
584
585 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
586 old, depends on qt 4.5
587
588 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
589 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
590 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
591 Remove HPPA keywording (bug #239441).
592
593*PyQt4-4.8.1 (30 Oct 2010)
594
595 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
596 +PyQt4-4.8.1.ebuild:
597 Version bump.
598
599 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
600 ia64/sparc stable wrt #315775
601
602*PyQt4-4.8 (23 Oct 2010)
603
604 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
605 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
606 +PyQt4-4.8.ebuild, metadata.xml:
607 Version bump.
608
609*PyQt4-4.7.7-r1 (06 Oct 2010)
610
611 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
612 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
613 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
614
615*PyQt4-4.7.7 (21 Sep 2010)
616
617 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
618 +PyQt4-4.7.7.ebuild:
619 Version bump. Remove old bogus version
620
621 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
622 Stable on alpha, bug #315775
623
624 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
625 Marked ppc stable for bug #315775.
626
627 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
628 PyQt4-4.7.6.ebuild:
629 Update EAPI. Fix dependencies.
630
631*PyQt4-4.7.6 (08 Sep 2010)
632
633 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
634 +PyQt4-4.7.6.ebuild:
635 Version bump. Remove old ebuild
636
637 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
638 PyQt4-4.7.5.ebuild:
639 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
640
641*PyQt4-4.7.5 (01 Sep 2010)
642
643 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
644 +PyQt4-4.7.5.ebuild:
645 Version bump
646
647 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
648 Stable for HPPA (bug #315775).
4 649
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 650 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 651 Bump sip dependency to 4.10.3. Fix arm epatch command
7 652
8*PyQt4-4.7.4 (13 Jul 2010) 653*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 1134*PyQt4-4.0_beta1 (05 May 2006)
490 1135
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1136 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 1137 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 1138 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.284

  ViewVC Help
Powered by ViewVC 1.1.20