/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.290
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.290 2015/06/14 14:07:15 pesa Exp $
4
5 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.4.ebuild:
6 Use the new --no-python-dbus configure option.
7
8 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.4.ebuild:
9 PyQt4 became GPL-3 only.
10
11*PyQt4-4.11.4 (14 Jun 2015)
12
13 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.4.ebuild:
14 Version bump.
15
16 09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
17 Updating remote-id in metadata.xml
18
19 11 May 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.2.ebuild,
20 PyQt4-4.11.3.ebuild:
21 Enable tracing with USE=debug; enable configure verbose output to get useful
22 build logs in bug reports; stop passing deprecated --no-timestamp option; use
23 qt4_get_bindir().
24
25 14 Apr 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
26 Stable for ia64, wrt bug #523322
27
28 08 Apr 2015; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.3-r2.ebuild:
29 Drop old Python implementations
30
31 17 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
32 Stable for ppc64, wrt bug #517344
33
34 16 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
35 Stable for ppc, wrt bug #517344
36
37 14 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
38 Stable for x86, wrt bug #517344
39
40 09 Jan 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.3.ebuild:
41 Stop using deprecated python_parallel_foreach_impl.
42
43 31 Dec 2014; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.3-r2.ebuild,
44 PyQt4-4.11.1.ebuild, PyQt4-4.11.2.ebuild:
45 Enforce USE dependency for media-libs/phonon.
46
47 10 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> PyQt4-4.11.1.ebuild:
48 amd64 stable wrt bug #517344
49
50 22 Nov 2014; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.11.1.ebuild:
51 Stable on alpha, bug 523322
52
53*PyQt4-4.11.3 (15 Nov 2014)
54
55 15 Nov 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.3.ebuild,
56 -PyQt4-4.11.3_pre20141024.ebuild:
57 Version bump.
58
59*PyQt4-4.11.3_pre20141024 (01 Nov 2014)
60
61 01 Nov 2014; Davide Pesavento <pesa@gentoo.org>
62 +PyQt4-4.11.3_pre20141024.ebuild, -PyQt4-4.11.2-r1.ebuild:
63 Bump to 4.11.3 prerelease, which contains upstream fixes for bugs #525392 and
64 #525470. Also switch to out-of-source builds.
65
66 15 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.2-r1.ebuild:
67 Fix bug #525392.
68
69 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
70 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
71 Fix building against media-libs/phonon (bug 525354).
72
73*PyQt4-4.11.2-r1 (13 Oct 2014)
74
75 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
76 metadata.xml:
77 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
78 from QtGui.
79
80 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
81 Revert to ~amd64, see bug #523322 comment #4.
82
83 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
84 Stable for amd64, wrt bug #523322
85
86 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
87 arm stable, bug #523322
88
89*PyQt4-4.11.2 (20 Sep 2014)
90
91 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
92 PyQt4-4.11.1.ebuild:
93 Version bump. Silence harmless repoman warning.
94
95 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
96 Drop deprecated python versions.
97
98 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
99 PyQt4-4.11.1.ebuild:
100 Stop using dohtml, remove old.
101
102 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
103 Remove old.
104
105*PyQt4-4.11.1 (15 Jul 2014)
106
107 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
108 PyQt4-4.11.ebuild:
109 Version bump.
110
111 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
112 PyQt4-4.11.ebuild:
113 add py3.4 support req'd to support py packages such as pandas
114
115 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
116 PyQt4-4.10.3-r3.ebuild:
117 Restrict sip dep to =4.15* for older PyQt4 versions.
118
119*PyQt4-4.11 (30 May 2014)
120
121 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
122 Version bump.
123
124 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
125 PyQt4-4.10.3-r3.ebuild, metadata.xml:
126 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
127 Martin Walch in bug 510812.
128
129 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
130 -PyQt4-4.10.3.ebuild:
131 Drop the old versions that required python-exec:0.
132
133 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
134 Remove python herd as discussed with them.
135
136*PyQt4-4.10.3-r3 (27 Mar 2014)
137
138 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
139 Replace manual Python wrapping with proper eclass functions, bug #484404.
140
141 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
142 Stable for sparc, wrt bug #495638
143
144 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
145 Stable for x86, wrt bug #495638
146
147 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
148 Stable for alpha, wrt bug #495638
149
150 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
151 Stable for ia64, wrt bug #495638
152
153 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
154 Stable for ppc64, wrt bug #495638
155
156 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
157 amd64 stable, bug 495638
158
159 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
160 Stable for ppc, wrt bug #495638
161
162 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
163 arm stable, bug #495638
164
165 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
166 files/PyQt4-4.7.3-qreal_float_support.patch:
167 Updated qreal_float patch to remove first hunk (already applied
168 upstream). Tested on arm chromebook; no existing bug.
169
170*PyQt4-4.10.3-r2 (25 Dec 2013)
171
172 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
173 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
174 Introduce USE="designer".
175
176 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
177 old
178
179 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
180 Stable for sparc, wrt bug #483112
181
182 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
183 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
184 Update the ebuilds to dep on dev-lang/python-exec.
185
186 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
187 old
188
189*PyQt4-4.10.3-r1 (23 Oct 2013)
190
191 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
192 Support python-exec:2.
193
194 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
195 Depend on sip >=4.15.0 to fix build failure (bug #485274)
196
197 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
198 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
199 Add explicit dep on python-exec:0 since the package wraps the script manually.
200
201*PyQt4-4.10.3 (17 Sep 2013)
202
203 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
204 Version bump
205
206 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
207 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
208 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
209
210 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
211 arm stable, bug #483112
212
213 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
214 Stable for x86, wrt bug #483112
215
216 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
217 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
218 Clean up PYTHON_COMPAT from old implementations.
219
220 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
221 Stable for ppc64, wrt bug #483112
222
223 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
224 Stable for ppc, wrt bug #483112
225
226 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
227 Stable for ia64, wrt bug #483112
228
229 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
230 Stable for alpha, wrt bug #483112
231
232 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
233 Stable for amd64, wrt bug #483112
234
235 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
236 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
237 Reorder Qt dependencies.
238
239 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
240 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
241 Fixing qtgui/designer deps for qt-4.8.5
242
243 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
244 PyQt4-4.9.6-r2.ebuild:
245 Fixing qtgui deps for qt-4.8.5
246
247 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
248 Remove wrong usedep for qtgui.
249
250*PyQt4-4.10.2 (24 Jun 2013)
251
252 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
253 Version bump.
254
255 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
256 PyQt4-4.10.1.ebuild:
257 Add PYTHON_REQUIRED_USE. Remove old.
258
259*PyQt4-4.10.1 (22 May 2013)
260
261 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
262 Version bump.
263
264 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
265 Remove unused flag description from metadata
266
267 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
268 -files/PyQt4-4.7.2-configure.py.patch,
269 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
270 old
271
272*PyQt4-4.10 (12 Mar 2013)
273
274 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
275 Version bump. Fix also bug #433944 by Franz Fellner.
276
277 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
278 Stable for sparc, wrt bug #457046
279
280 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
281 PyQt4-4.9.6-r2.ebuild:
282 Move Qt dependencies to the new category
283
284 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
285 Stable for ia64, wrt bug #457046
286
287 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
288 Stable for ppc64, wrt bug #457046
289
290 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
291 Stable for ppc, wrt bug #457046
292
293 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
294 Stable for alpha, wrt bug #457046
295
296 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
297 Stable for arm, wrt bug #457046
298
299 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
300 Stable for x86, wrt bug #457046
301
302 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
303 Stable for amd64, wrt bug #457046
304
305 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
306 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
307
308 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
309 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
310 Fix double prefix; remove old.
311
312 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
313 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
314
315*PyQt4-4.9.6-r2 (29 Jan 2013)
316
317 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
318 Migrate to the new python eclass.
319
320 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
321 Improve pyqt4_use_enable() as suggested by Arfrever.
322
323 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
324 old
325
326*PyQt4-4.9.6-r1 (26 Dec 2012)
327
328 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
329 metadata.xml:
330 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
331 pyside: rename assistant to help, add script and scripttools (bug 431460 by
332 Arfrever).
333
334*PyQt4-4.9.6 (10 Dec 2012)
335
336 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
337 Version bump, with some minor updates from qt overlay.
338
339 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
340 arm stable, bug #435074
341
342 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
343 PyQt4-4.9.4-r1.ebuild:
344 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
345
346 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
347 -PyQt4-4.9.1.ebuild:
348 Remove old
349
350*PyQt4-4.9.5 (05 Oct 2012)
351
352 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
353 Version bump
354
355 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
356 alpha/ia64/sparc stable wrt #429042
357
358*PyQt4-4.9.4-r1 (03 Sep 2012)
359
360 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
361 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
362 Apply upstream patch to fix regression in pyuic's handling of custom widgets
363 (bug 431070 by Laurent Bachelier).
364
365 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
366 Stable for x86, wrt bug #429042
367
368 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
369 Stable for amd64, wrt bug #429042
370
371 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
372 Stable ppc64, bug #429042
373
374 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
375 Stable ppc, bug #429042
376
377 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
378 ia64 stable
379
380 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
381 -files/PyQt4-4.6.1-configure-multilib.patch:
382 Remove old.
383
384 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
385 PyQt4-4.9.4.ebuild:
386 alpha/ia64/sparc stable wrt #412929
387
388*PyQt4-4.9.4 (02 Jul 2012)
389
390 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
391 -PyQt4-4.9.3.ebuild:
392 Version bump.
393
394*PyQt4-4.9.3 (27 Jun 2012)
395
396 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
397 -PyQt4-4.9.2.ebuild:
398 Version bump.
399
400 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
401 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
402
403*PyQt4-4.9.2 (21 Jun 2012)
404
405 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
406 Version bump
407
408 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
409 Destabling to ~ia64 because last available stable qt will be masked pending
410 removal
411
412 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
413 marked x86 per bug 412929
414
415 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
416 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
417 Inherit eutils.
418
419 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
420 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
421 Revert previous change.
422
423 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
424 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
425 Restrict python 3.1 to match dev-python/dbus-python.
426
427 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
428 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
429
430 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
431 Migrating dev-util/pkgconfig -> virtual/pkgconfig
432
433 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
434 Stable for amd64, wrt bug #412929
435
436 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
437 Stable on alpha, bug #354033
438
439 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
440 PyQt4-4.8.4.ebuild:
441 PyQt4-4.8 does not build with sip-4.13, bug 407291
442
443 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
444 Slightly improve the ewarn message in pkg_postinst().
445
446 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
447 Put qt as the primary herd in metadata.
448
449 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
450 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
451 <slong@rathaus.eclipse.co.uk> in bug #407281.
452
453 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
454 Switch to EAPI 4, add REQUIRED_USE.
455
456 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
457 PyQt4-4.8.4.ebuild:
458 Drop ~x86-fbsd because of unkeyworded dependencies.
459
460 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
461 Don't enable QtAssistant module because it was removed in qt-4.7 and we
462 already depend on 4.7.2 or later.
463
464 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
465 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
466 Restrict pypy for older versions too.
467
468 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
469 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
470 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
471 version.
472
473 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
474 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
475 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
476 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
477 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
478 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
479
480 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
481 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
482 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
483 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
484 Fixing pypy restricts to actually work
485
486*PyQt4-4.9.1 (12 Feb 2012)
487
488 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
489 version bump
490
491 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
492 builds with qt-opengl-4.8.0[egl], updated dep
493
494 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
495 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
496 Fixes backported from Progress Overlay. Patch by Arfrever.
497
498*PyQt4-4.9 (24 Dec 2011)
499
500 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
501 Version bump
502
503*PyQt4-4.8.6 (11 Nov 2011)
504
505 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
506 Version bump
507
508 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
509 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
510 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
511 python overlay.
512
513*PyQt4-4.8.5 (19 Aug 2011)
514
515 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
516 Version bump
517
518 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
519 ppc/ppc64 stable wrt #374591
520
521 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
522 x86 stable, bug #374591
523
524 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
525 ppc64 stable wrt #354033
526
527 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
528 Stable on amd64 wrt bug #374591
529
530 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
531 Marking PyQt4-4.8.3 ppc stable for bug 354033
532
533 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
534 Stable on amd64 wrt bug #354033
535
536 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
537 x86 stable per bug 354033
538
539*PyQt4-4.8.4 (02 May 2011)
540
541 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
542 +PyQt4-4.8.4.ebuild:
543 Version bump.
544
545 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
546 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
547 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
548 Adapt phonon dependency for package move
549
550 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
551 ppc64 stable wrt #349607
552
553 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
554 ia64/sparc stable wrt #349607
555
556 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
557 Stable on alpha, bug #349607
558
559 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
560 PyQt4-4.8.3.ebuild:
561 Update dependencies (bug #353053).
562
563*PyQt4-4.8.3 (25 Jan 2011)
564
565 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
566 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
567 Version bump.
568
569 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
570 x86 stable wrt bug #349607
571
572 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
573 Marking PyQt4-4.8.1 ppc stable for bug 349607
574
575 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
576 Stable on amd64 wrt bug #349607
577
578 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
579 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
580 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
581
582*PyQt4-4.8.1-r1 (30 Dec 2010)
583
584 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
585 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
586 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
587
588 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
589 PyQt4-4.8.2.ebuild:
590 Fix dependencies (bug #349672).
591
592*PyQt4-4.8.2 (24 Dec 2010)
593
594 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
595 +PyQt4-4.8.2.ebuild:
596 Version bump.
597
598 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
599 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
600 Restrict Jython ABIs.
601
602 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
603 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
604 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
605 -files/configure.py.patch:
606 Delete.
607
608 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
609 old, depends on qt 4.5
610
611 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
612 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
613 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
614 Remove HPPA keywording (bug #239441).
615
616*PyQt4-4.8.1 (30 Oct 2010)
617
618 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
619 +PyQt4-4.8.1.ebuild:
620 Version bump.
621
622 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
623 ia64/sparc stable wrt #315775
624
625*PyQt4-4.8 (23 Oct 2010)
626
627 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
628 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
629 +PyQt4-4.8.ebuild, metadata.xml:
630 Version bump.
631
632*PyQt4-4.7.7-r1 (06 Oct 2010)
633
634 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
635 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
636 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
637
638*PyQt4-4.7.7 (21 Sep 2010)
639
640 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
641 +PyQt4-4.7.7.ebuild:
642 Version bump. Remove old bogus version
643
644 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
645 Stable on alpha, bug #315775
646
647 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
648 Marked ppc stable for bug #315775.
649
650 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
651 PyQt4-4.7.6.ebuild:
652 Update EAPI. Fix dependencies.
653
654*PyQt4-4.7.6 (08 Sep 2010)
655
656 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
657 +PyQt4-4.7.6.ebuild:
658 Version bump. Remove old ebuild
659
660 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
661 PyQt4-4.7.5.ebuild:
662 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
663
664*PyQt4-4.7.5 (01 Sep 2010)
665
666 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
667 +PyQt4-4.7.5.ebuild:
668 Version bump
669
670 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
671 Stable for HPPA (bug #315775).
4 672
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 673 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 674 Bump sip dependency to 4.10.3. Fix arm epatch command
7 675
8*PyQt4-4.7.4 (13 Jul 2010) 676*PyQt4-4.7.4 (13 Jul 2010)
489*PyQt4-4.0_beta1 (05 May 2006) 1157*PyQt4-4.0_beta1 (05 May 2006)
490 1158
491 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1159 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
492 +PyQt4-4.0_beta1.ebuild: 1160 +PyQt4-4.0_beta1.ebuild:
493 initial import, from bug #121554 1161 initial import, from bug #121554
494

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.290

  ViewVC Help
Powered by ViewVC 1.1.20