/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.175
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.175 2012/03/07 18:54:33 pesa Exp $
4
5 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
6 Slightly improve the ewarn message in pkg_postinst().
7
8 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
9 Put qt as the primary herd in metadata.
10
11 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
12 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
13 <slong@rathaus.eclipse.co.uk> in bug #407281.
14
15 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
16 Switch to EAPI 4, add REQUIRED_USE.
17
18 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
19 PyQt4-4.8.4.ebuild:
20 Drop ~x86-fbsd because of unkeyworded dependencies.
21
22 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
23 Don't enable QtAssistant module because it was removed in qt-4.7 and we
24 already depend on 4.7.2 or later.
25
26 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
27 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
28 Restrict pypy for older versions too.
29
30 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
31 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
32 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
33 version.
34
35 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
36 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
37 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
38 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
39 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
40 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
41
42 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
43 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
44 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
45 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
46 Fixing pypy restricts to actually work
47
48*PyQt4-4.9.1 (12 Feb 2012)
49
50 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
51 version bump
52
53 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
54 builds with qt-opengl-4.8.0[egl], updated dep
55
56 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
57 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
58 Fixes backported from Progress Overlay. Patch by Arfrever.
59
60*PyQt4-4.9 (24 Dec 2011)
61
62 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
63 Version bump
64
65*PyQt4-4.8.6 (11 Nov 2011)
66
67 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
68 Version bump
69
70 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
71 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
72 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
73 python overlay.
74
75*PyQt4-4.8.5 (19 Aug 2011)
76
77 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
78 Version bump
79
80 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
81 ppc/ppc64 stable wrt #374591
82
83 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
84 x86 stable, bug #374591
85
86 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
87 ppc64 stable wrt #354033
88
89 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
90 Stable on amd64 wrt bug #374591
91
92 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
93 Marking PyQt4-4.8.3 ppc stable for bug 354033
94
95 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
96 Stable on amd64 wrt bug #354033
97
98 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
99 x86 stable per bug 354033
100
101*PyQt4-4.8.4 (02 May 2011)
102
103 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
104 +PyQt4-4.8.4.ebuild:
105 Version bump.
106
107 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
108 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
109 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
110 Adapt phonon dependency for package move
111
112 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
113 ppc64 stable wrt #349607
114
115 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
116 ia64/sparc stable wrt #349607
117
118 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
119 Stable on alpha, bug #349607
120
121 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
122 PyQt4-4.8.3.ebuild:
123 Update dependencies (bug #353053).
124
125*PyQt4-4.8.3 (25 Jan 2011)
126
127 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
128 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
129 Version bump.
130
131 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
132 x86 stable wrt bug #349607
133
134 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
135 Marking PyQt4-4.8.1 ppc stable for bug 349607
136
137 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
138 Stable on amd64 wrt bug #349607
139
140 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
141 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
142 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
143
144*PyQt4-4.8.1-r1 (30 Dec 2010)
145
146 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
147 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
148 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
149
150 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
151 PyQt4-4.8.2.ebuild:
152 Fix dependencies (bug #349672).
153
154*PyQt4-4.8.2 (24 Dec 2010)
155
156 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
157 +PyQt4-4.8.2.ebuild:
158 Version bump.
159
160 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
161 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
162 Restrict Jython ABIs.
163
164 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
165 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
166 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
167 -files/configure.py.patch:
168 Delete.
169
170 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
171 old, depends on qt 4.5
172
173 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
174 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
175 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
176 Remove HPPA keywording (bug #239441).
4 177
5*PyQt4-4.8.1 (30 Oct 2010) 178*PyQt4-4.8.1 (30 Oct 2010)
6 179
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 180 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 181 +PyQt4-4.8.1.ebuild:

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.175

  ViewVC Help
Powered by ViewVC 1.1.20