/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.182
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.182 2012/05/16 02:01:14 floppym Exp $
4
5 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
6 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
7 Revert previous change.
8
9 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
10 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
11 Restrict python 3.1 to match dev-python/dbus-python.
12
13 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
14 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
15
16 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
17 Migrating dev-util/pkgconfig -> virtual/pkgconfig
18
19 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
20 Stable for amd64, wrt bug #412929
21
22 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
23 Stable on alpha, bug #354033
24
25 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
26 PyQt4-4.8.4.ebuild:
27 PyQt4-4.8 does not build with sip-4.13, bug 407291
28
29 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
30 Slightly improve the ewarn message in pkg_postinst().
31
32 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
33 Put qt as the primary herd in metadata.
34
35 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
36 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
37 <slong@rathaus.eclipse.co.uk> in bug #407281.
38
39 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
40 Switch to EAPI 4, add REQUIRED_USE.
41
42 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
43 PyQt4-4.8.4.ebuild:
44 Drop ~x86-fbsd because of unkeyworded dependencies.
45
46 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
47 Don't enable QtAssistant module because it was removed in qt-4.7 and we
48 already depend on 4.7.2 or later.
49
50 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
51 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
52 Restrict pypy for older versions too.
53
54 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
55 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
56 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
57 version.
58
59 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
60 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
61 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
62 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
63 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
64 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
65
66 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
67 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
68 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
69 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
70 Fixing pypy restricts to actually work
71
72*PyQt4-4.9.1 (12 Feb 2012)
73
74 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
75 version bump
76
77 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
78 builds with qt-opengl-4.8.0[egl], updated dep
79
80 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
81 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
82 Fixes backported from Progress Overlay. Patch by Arfrever.
83
84*PyQt4-4.9 (24 Dec 2011)
85
86 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
87 Version bump
88
89*PyQt4-4.8.6 (11 Nov 2011)
90
91 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
92 Version bump
93
94 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
95 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
96 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
97 python overlay.
98
99*PyQt4-4.8.5 (19 Aug 2011)
100
101 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
102 Version bump
103
104 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
105 ppc/ppc64 stable wrt #374591
106
107 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
108 x86 stable, bug #374591
109
110 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
111 ppc64 stable wrt #354033
112
113 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
114 Stable on amd64 wrt bug #374591
115
116 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
117 Marking PyQt4-4.8.3 ppc stable for bug 354033
118
119 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
120 Stable on amd64 wrt bug #354033
121
122 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
123 x86 stable per bug 354033
124
125*PyQt4-4.8.4 (02 May 2011)
126
127 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
128 +PyQt4-4.8.4.ebuild:
129 Version bump.
130
131 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
132 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
133 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
134 Adapt phonon dependency for package move
135
136 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
137 ppc64 stable wrt #349607
138
139 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
140 ia64/sparc stable wrt #349607
141
142 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
143 Stable on alpha, bug #349607
144
145 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
146 PyQt4-4.8.3.ebuild:
147 Update dependencies (bug #353053).
148
149*PyQt4-4.8.3 (25 Jan 2011)
150
151 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
152 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
153 Version bump.
154
155 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
156 x86 stable wrt bug #349607
157
158 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
159 Marking PyQt4-4.8.1 ppc stable for bug 349607
160
161 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
162 Stable on amd64 wrt bug #349607
163
164 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
165 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
166 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
167
168*PyQt4-4.8.1-r1 (30 Dec 2010)
169
170 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
171 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
172 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
173
174 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
175 PyQt4-4.8.2.ebuild:
176 Fix dependencies (bug #349672).
177
178*PyQt4-4.8.2 (24 Dec 2010)
179
180 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
181 +PyQt4-4.8.2.ebuild:
182 Version bump.
183
184 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
185 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
186 Restrict Jython ABIs.
187
188 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
189 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
190 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
191 -files/configure.py.patch:
192 Delete.
193
194 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
195 old, depends on qt 4.5
196
197 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
198 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
199 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
200 Remove HPPA keywording (bug #239441).
4 201
5*PyQt4-4.8.1 (30 Oct 2010) 202*PyQt4-4.8.1 (30 Oct 2010)
6 203
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 204 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 205 +PyQt4-4.8.1.ebuild:

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.182

  ViewVC Help
Powered by ViewVC 1.1.20