/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.191
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.191 2012/07/09 13:25:50 pesa Exp $
4
5 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
6 -files/PyQt4-4.6.1-configure-multilib.patch:
7 Remove old.
8
9 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
10 PyQt4-4.9.4.ebuild:
11 alpha/ia64/sparc stable wrt #412929
12
13*PyQt4-4.9.4 (02 Jul 2012)
14
15 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
16 -PyQt4-4.9.3.ebuild:
17 Version bump.
18
19*PyQt4-4.9.3 (27 Jun 2012)
20
21 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
22 -PyQt4-4.9.2.ebuild:
23 Version bump.
24
25 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
26 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
27
28*PyQt4-4.9.2 (21 Jun 2012)
29
30 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
31 Version bump
32
33 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
34 Destabling to ~ia64 because last available stable qt will be masked pending
35 removal
36
37 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
38 marked x86 per bug 412929
39
40 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
41 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
42 Inherit eutils.
43
44 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
45 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
46 Revert previous change.
47
48 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
49 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
50 Restrict python 3.1 to match dev-python/dbus-python.
51
52 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
53 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
54
55 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
56 Migrating dev-util/pkgconfig -> virtual/pkgconfig
57
58 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
59 Stable for amd64, wrt bug #412929
60
61 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
62 Stable on alpha, bug #354033
63
64 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
65 PyQt4-4.8.4.ebuild:
66 PyQt4-4.8 does not build with sip-4.13, bug 407291
67
68 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
69 Slightly improve the ewarn message in pkg_postinst().
70
71 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
72 Put qt as the primary herd in metadata.
73
74 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
75 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
76 <slong@rathaus.eclipse.co.uk> in bug #407281.
77
78 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
79 Switch to EAPI 4, add REQUIRED_USE.
80
81 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
82 PyQt4-4.8.4.ebuild:
83 Drop ~x86-fbsd because of unkeyworded dependencies.
84
85 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
86 Don't enable QtAssistant module because it was removed in qt-4.7 and we
87 already depend on 4.7.2 or later.
88
89 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
90 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
91 Restrict pypy for older versions too.
92
93 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
94 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
95 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
96 version.
97
98 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
99 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
100 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
101 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
102 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
103 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
104
105 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
106 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
107 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
108 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
109 Fixing pypy restricts to actually work
110
111*PyQt4-4.9.1 (12 Feb 2012)
112
113 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
114 version bump
115
116 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
117 builds with qt-opengl-4.8.0[egl], updated dep
118
119 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
120 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
121 Fixes backported from Progress Overlay. Patch by Arfrever.
122
123*PyQt4-4.9 (24 Dec 2011)
124
125 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
126 Version bump
127
128*PyQt4-4.8.6 (11 Nov 2011)
129
130 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
131 Version bump
132
133 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
134 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
135 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
136 python overlay.
137
138*PyQt4-4.8.5 (19 Aug 2011)
139
140 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
141 Version bump
142
143 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
144 ppc/ppc64 stable wrt #374591
145
146 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
147 x86 stable, bug #374591
148
149 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
150 ppc64 stable wrt #354033
151
152 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
153 Stable on amd64 wrt bug #374591
154
155 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
156 Marking PyQt4-4.8.3 ppc stable for bug 354033
157
158 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
159 Stable on amd64 wrt bug #354033
160
161 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
162 x86 stable per bug 354033
163
164*PyQt4-4.8.4 (02 May 2011)
165
166 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
167 +PyQt4-4.8.4.ebuild:
168 Version bump.
169
170 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
171 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
172 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
173 Adapt phonon dependency for package move
174
175 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
176 ppc64 stable wrt #349607
177
178 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
179 ia64/sparc stable wrt #349607
180
181 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
182 Stable on alpha, bug #349607
183
184 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
185 PyQt4-4.8.3.ebuild:
186 Update dependencies (bug #353053).
187
188*PyQt4-4.8.3 (25 Jan 2011)
189
190 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
191 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
192 Version bump.
193
194 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
195 x86 stable wrt bug #349607
196
197 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
198 Marking PyQt4-4.8.1 ppc stable for bug 349607
199
200 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
201 Stable on amd64 wrt bug #349607
202
203 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
204 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
205 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
206
207*PyQt4-4.8.1-r1 (30 Dec 2010)
208
209 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
210 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
211 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
212
213 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
214 PyQt4-4.8.2.ebuild:
215 Fix dependencies (bug #349672).
216
217*PyQt4-4.8.2 (24 Dec 2010)
218
219 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
220 +PyQt4-4.8.2.ebuild:
221 Version bump.
222
223 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
224 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
225 Restrict Jython ABIs.
226
227 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
228 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
229 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
230 -files/configure.py.patch:
231 Delete.
232
233 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
234 old, depends on qt 4.5
235
236 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
237 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
238 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
239 Remove HPPA keywording (bug #239441).
4 240
5*PyQt4-4.8.1 (30 Oct 2010) 241*PyQt4-4.8.1 (30 Oct 2010)
6 242
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 243 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 244 +PyQt4-4.8.1.ebuild:
546*PyQt4-4.0_beta1 (05 May 2006) 782*PyQt4-4.0_beta1 (05 May 2006)
547 783
548 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 784 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
549 +PyQt4-4.0_beta1.ebuild: 785 +PyQt4-4.0_beta1.ebuild:
550 initial import, from bug #121554 786 initial import, from bug #121554
551

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.191

  ViewVC Help
Powered by ViewVC 1.1.20