/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.196
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.196 2012/08/20 18:52:36 johu Exp $
4
5 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
6 Stable for x86, wrt bug #429042
7
8 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
9 Stable for amd64, wrt bug #429042
10
11 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
12 Stable ppc64, bug #429042
13
14 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
15 Stable ppc, bug #429042
16
17 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
18 ia64 stable
19
20 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
21 -files/PyQt4-4.6.1-configure-multilib.patch:
22 Remove old.
23
24 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
25 PyQt4-4.9.4.ebuild:
26 alpha/ia64/sparc stable wrt #412929
27
28*PyQt4-4.9.4 (02 Jul 2012)
29
30 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
31 -PyQt4-4.9.3.ebuild:
32 Version bump.
33
34*PyQt4-4.9.3 (27 Jun 2012)
35
36 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
37 -PyQt4-4.9.2.ebuild:
38 Version bump.
39
40 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
41 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
42
43*PyQt4-4.9.2 (21 Jun 2012)
44
45 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
46 Version bump
47
48 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
49 Destabling to ~ia64 because last available stable qt will be masked pending
50 removal
51
52 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
53 marked x86 per bug 412929
54
55 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
56 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
57 Inherit eutils.
58
59 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
60 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
61 Revert previous change.
62
63 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
64 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
65 Restrict python 3.1 to match dev-python/dbus-python.
66
67 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
68 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
69
70 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
71 Migrating dev-util/pkgconfig -> virtual/pkgconfig
72
73 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
74 Stable for amd64, wrt bug #412929
75
76 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
77 Stable on alpha, bug #354033
78
79 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
80 PyQt4-4.8.4.ebuild:
81 PyQt4-4.8 does not build with sip-4.13, bug 407291
82
83 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
84 Slightly improve the ewarn message in pkg_postinst().
85
86 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
87 Put qt as the primary herd in metadata.
88
89 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
90 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
91 <slong@rathaus.eclipse.co.uk> in bug #407281.
92
93 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
94 Switch to EAPI 4, add REQUIRED_USE.
95
96 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
97 PyQt4-4.8.4.ebuild:
98 Drop ~x86-fbsd because of unkeyworded dependencies.
99
100 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
101 Don't enable QtAssistant module because it was removed in qt-4.7 and we
102 already depend on 4.7.2 or later.
103
104 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
105 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
106 Restrict pypy for older versions too.
107
108 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
109 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
110 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
111 version.
112
113 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
114 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
115 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
116 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
117 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
118 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
119
120 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
121 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
122 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
123 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
124 Fixing pypy restricts to actually work
125
126*PyQt4-4.9.1 (12 Feb 2012)
127
128 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
129 version bump
130
131 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
132 builds with qt-opengl-4.8.0[egl], updated dep
133
134 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
135 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
136 Fixes backported from Progress Overlay. Patch by Arfrever.
137
138*PyQt4-4.9 (24 Dec 2011)
139
140 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
141 Version bump
142
143*PyQt4-4.8.6 (11 Nov 2011)
144
145 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
146 Version bump
147
148 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
149 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
150 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
151 python overlay.
152
153*PyQt4-4.8.5 (19 Aug 2011)
154
155 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
156 Version bump
157
158 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
159 ppc/ppc64 stable wrt #374591
160
161 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
162 x86 stable, bug #374591
163
164 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
165 ppc64 stable wrt #354033
166
167 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
168 Stable on amd64 wrt bug #374591
169
170 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
171 Marking PyQt4-4.8.3 ppc stable for bug 354033
172
173 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
174 Stable on amd64 wrt bug #354033
175
176 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
177 x86 stable per bug 354033
178
179*PyQt4-4.8.4 (02 May 2011)
180
181 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
182 +PyQt4-4.8.4.ebuild:
183 Version bump.
184
185 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
186 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
187 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
188 Adapt phonon dependency for package move
189
190 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
191 ppc64 stable wrt #349607
192
193 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
194 ia64/sparc stable wrt #349607
195
196 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
197 Stable on alpha, bug #349607
198
199 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
200 PyQt4-4.8.3.ebuild:
201 Update dependencies (bug #353053).
202
203*PyQt4-4.8.3 (25 Jan 2011)
204
205 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
206 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
207 Version bump.
208
209 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
210 x86 stable wrt bug #349607
211
212 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
213 Marking PyQt4-4.8.1 ppc stable for bug 349607
214
215 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
216 Stable on amd64 wrt bug #349607
217
218 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
219 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
220 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
221
222*PyQt4-4.8.1-r1 (30 Dec 2010)
223
224 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
225 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
226 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
227
228 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
229 PyQt4-4.8.2.ebuild:
230 Fix dependencies (bug #349672).
231
232*PyQt4-4.8.2 (24 Dec 2010)
233
234 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
235 +PyQt4-4.8.2.ebuild:
236 Version bump.
237
238 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
239 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
240 Restrict Jython ABIs.
241
242 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
243 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
244 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
245 -files/configure.py.patch:
246 Delete.
247
248 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
249 old, depends on qt 4.5
250
251 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
252 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
253 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
254 Remove HPPA keywording (bug #239441).
4 255
5*PyQt4-4.8.1 (30 Oct 2010) 256*PyQt4-4.8.1 (30 Oct 2010)
6 257
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 258 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 259 +PyQt4-4.8.1.ebuild:
546*PyQt4-4.0_beta1 (05 May 2006) 797*PyQt4-4.0_beta1 (05 May 2006)
547 798
548 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 799 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
549 +PyQt4-4.0_beta1.ebuild: 800 +PyQt4-4.0_beta1.ebuild:
550 initial import, from bug #121554 801 initial import, from bug #121554
551

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.196

  ViewVC Help
Powered by ViewVC 1.1.20