/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.210
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.210 2013/02/15 08:07:48 pesa Exp $
4
5 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
6 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
7
8 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
9 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
10 Fix double prefix; remove old.
11
12 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
13 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
14
15*PyQt4-4.9.6-r2 (29 Jan 2013)
16
17 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
18 Migrate to the new python eclass.
19
20 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
21 Improve pyqt4_use_enable() as suggested by Arfrever.
22
23 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
24 old
25
26*PyQt4-4.9.6-r1 (26 Dec 2012)
27
28 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
29 metadata.xml:
30 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
31 pyside: rename assistant to help, add script and scripttools (bug 431460 by
32 Arfrever).
33
34*PyQt4-4.9.6 (10 Dec 2012)
35
36 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
37 Version bump, with some minor updates from qt overlay.
38
39 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
40 arm stable, bug #435074
41
42 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
43 PyQt4-4.9.4-r1.ebuild:
44 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
45
46 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
47 -PyQt4-4.9.1.ebuild:
48 Remove old
49
50*PyQt4-4.9.5 (05 Oct 2012)
51
52 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
53 Version bump
54
55 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
56 alpha/ia64/sparc stable wrt #429042
57
58*PyQt4-4.9.4-r1 (03 Sep 2012)
59
60 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
61 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
62 Apply upstream patch to fix regression in pyuic's handling of custom widgets
63 (bug 431070 by Laurent Bachelier).
64
65 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
66 Stable for x86, wrt bug #429042
67
68 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
69 Stable for amd64, wrt bug #429042
70
71 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
72 Stable ppc64, bug #429042
73
74 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
75 Stable ppc, bug #429042
76
77 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
78 ia64 stable
79
80 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
81 -files/PyQt4-4.6.1-configure-multilib.patch:
82 Remove old.
83
84 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
85 PyQt4-4.9.4.ebuild:
86 alpha/ia64/sparc stable wrt #412929
87
88*PyQt4-4.9.4 (02 Jul 2012)
89
90 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
91 -PyQt4-4.9.3.ebuild:
92 Version bump.
93
94*PyQt4-4.9.3 (27 Jun 2012)
95
96 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
97 -PyQt4-4.9.2.ebuild:
98 Version bump.
99
100 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
101 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
102
103*PyQt4-4.9.2 (21 Jun 2012)
104
105 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
106 Version bump
107
108 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
109 Destabling to ~ia64 because last available stable qt will be masked pending
110 removal
111
112 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
113 marked x86 per bug 412929
114
115 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
116 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
117 Inherit eutils.
118
119 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
120 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
121 Revert previous change.
122
123 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
124 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
125 Restrict python 3.1 to match dev-python/dbus-python.
126
127 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
128 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
129
130 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
131 Migrating dev-util/pkgconfig -> virtual/pkgconfig
132
133 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
134 Stable for amd64, wrt bug #412929
135
136 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
137 Stable on alpha, bug #354033
138
139 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
140 PyQt4-4.8.4.ebuild:
141 PyQt4-4.8 does not build with sip-4.13, bug 407291
142
143 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
144 Slightly improve the ewarn message in pkg_postinst().
145
146 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
147 Put qt as the primary herd in metadata.
148
149 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
150 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
151 <slong@rathaus.eclipse.co.uk> in bug #407281.
152
153 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
154 Switch to EAPI 4, add REQUIRED_USE.
155
156 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
157 PyQt4-4.8.4.ebuild:
158 Drop ~x86-fbsd because of unkeyworded dependencies.
159
160 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
161 Don't enable QtAssistant module because it was removed in qt-4.7 and we
162 already depend on 4.7.2 or later.
163
164 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
165 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
166 Restrict pypy for older versions too.
167
168 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
169 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
170 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
171 version.
172
173 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
174 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
175 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
176 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
177 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
178 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
179
180 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
181 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
182 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
183 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
184 Fixing pypy restricts to actually work
185
186*PyQt4-4.9.1 (12 Feb 2012)
187
188 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
189 version bump
190
191 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
192 builds with qt-opengl-4.8.0[egl], updated dep
193
194 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
195 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
196 Fixes backported from Progress Overlay. Patch by Arfrever.
197
198*PyQt4-4.9 (24 Dec 2011)
199
200 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
201 Version bump
202
203*PyQt4-4.8.6 (11 Nov 2011)
204
205 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
206 Version bump
207
208 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
209 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
210 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
211 python overlay.
212
213*PyQt4-4.8.5 (19 Aug 2011)
214
215 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
216 Version bump
217
218 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
219 ppc/ppc64 stable wrt #374591
220
221 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
222 x86 stable, bug #374591
223
224 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
225 ppc64 stable wrt #354033
226
227 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
228 Stable on amd64 wrt bug #374591
229
230 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
231 Marking PyQt4-4.8.3 ppc stable for bug 354033
232
233 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
234 Stable on amd64 wrt bug #354033
235
236 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
237 x86 stable per bug 354033
238
239*PyQt4-4.8.4 (02 May 2011)
240
241 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
242 +PyQt4-4.8.4.ebuild:
243 Version bump.
244
245 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
246 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
247 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
248 Adapt phonon dependency for package move
249
250 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
251 ppc64 stable wrt #349607
252
253 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
254 ia64/sparc stable wrt #349607
255
256 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
257 Stable on alpha, bug #349607
258
259 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
260 PyQt4-4.8.3.ebuild:
261 Update dependencies (bug #353053).
262
263*PyQt4-4.8.3 (25 Jan 2011)
264
265 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
266 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
267 Version bump.
268
269 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
270 x86 stable wrt bug #349607
271
272 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
273 Marking PyQt4-4.8.1 ppc stable for bug 349607
274
275 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
276 Stable on amd64 wrt bug #349607
277
278 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
279 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
280 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
281
282*PyQt4-4.8.1-r1 (30 Dec 2010)
283
284 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
285 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
286 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
287
288 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
289 PyQt4-4.8.2.ebuild:
290 Fix dependencies (bug #349672).
291
292*PyQt4-4.8.2 (24 Dec 2010)
293
294 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
295 +PyQt4-4.8.2.ebuild:
296 Version bump.
297
298 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
299 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
300 Restrict Jython ABIs.
301
302 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
303 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
304 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
305 -files/configure.py.patch:
306 Delete.
307
308 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
309 old, depends on qt 4.5
310
311 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
312 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
313 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
314 Remove HPPA keywording (bug #239441).
4 315
5*PyQt4-4.8.1 (30 Oct 2010) 316*PyQt4-4.8.1 (30 Oct 2010)
6 317
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 318 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 319 +PyQt4-4.8.1.ebuild:
546*PyQt4-4.0_beta1 (05 May 2006) 857*PyQt4-4.0_beta1 (05 May 2006)
547 858
548 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 859 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
549 +PyQt4-4.0_beta1.ebuild: 860 +PyQt4-4.0_beta1.ebuild:
550 initial import, from bug #121554 861 initial import, from bug #121554
551

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.210

  ViewVC Help
Powered by ViewVC 1.1.20