/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.218
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.218 2013/03/03 00:36:24 hwoarang Exp $
4
5 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
6 PyQt4-4.9.6-r2.ebuild:
7 Move Qt dependencies to the new category
8
9 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
10 Stable for ia64, wrt bug #457046
11
12 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
13 Stable for ppc64, wrt bug #457046
14
15 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
16 Stable for ppc, wrt bug #457046
17
18 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
19 Stable for alpha, wrt bug #457046
20
21 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
22 Stable for arm, wrt bug #457046
23
24 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
25 Stable for x86, wrt bug #457046
26
27 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
28 Stable for amd64, wrt bug #457046
29
30 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
31 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
32
33 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
34 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
35 Fix double prefix; remove old.
36
37 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
38 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
39
40*PyQt4-4.9.6-r2 (29 Jan 2013)
41
42 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
43 Migrate to the new python eclass.
44
45 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
46 Improve pyqt4_use_enable() as suggested by Arfrever.
47
48 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
49 old
50
51*PyQt4-4.9.6-r1 (26 Dec 2012)
52
53 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
54 metadata.xml:
55 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
56 pyside: rename assistant to help, add script and scripttools (bug 431460 by
57 Arfrever).
58
59*PyQt4-4.9.6 (10 Dec 2012)
60
61 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
62 Version bump, with some minor updates from qt overlay.
63
64 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
65 arm stable, bug #435074
66
67 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
68 PyQt4-4.9.4-r1.ebuild:
69 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
70
71 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
72 -PyQt4-4.9.1.ebuild:
73 Remove old
74
75*PyQt4-4.9.5 (05 Oct 2012)
76
77 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
78 Version bump
79
80 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
81 alpha/ia64/sparc stable wrt #429042
82
83*PyQt4-4.9.4-r1 (03 Sep 2012)
84
85 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
86 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
87 Apply upstream patch to fix regression in pyuic's handling of custom widgets
88 (bug 431070 by Laurent Bachelier).
89
90 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
91 Stable for x86, wrt bug #429042
92
93 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
94 Stable for amd64, wrt bug #429042
95
96 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
97 Stable ppc64, bug #429042
98
99 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
100 Stable ppc, bug #429042
101
102 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
103 ia64 stable
104
105 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
106 -files/PyQt4-4.6.1-configure-multilib.patch:
107 Remove old.
108
109 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
110 PyQt4-4.9.4.ebuild:
111 alpha/ia64/sparc stable wrt #412929
112
113*PyQt4-4.9.4 (02 Jul 2012)
114
115 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
116 -PyQt4-4.9.3.ebuild:
117 Version bump.
118
119*PyQt4-4.9.3 (27 Jun 2012)
120
121 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
122 -PyQt4-4.9.2.ebuild:
123 Version bump.
124
125 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
126 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
127
128*PyQt4-4.9.2 (21 Jun 2012)
129
130 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
131 Version bump
132
133 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
134 Destabling to ~ia64 because last available stable qt will be masked pending
135 removal
136
137 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
138 marked x86 per bug 412929
139
140 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
141 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
142 Inherit eutils.
143
144 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
145 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
146 Revert previous change.
147
148 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
149 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
150 Restrict python 3.1 to match dev-python/dbus-python.
151
152 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
153 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
154
155 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
156 Migrating dev-util/pkgconfig -> virtual/pkgconfig
157
158 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
159 Stable for amd64, wrt bug #412929
160
161 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
162 Stable on alpha, bug #354033
163
164 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
165 PyQt4-4.8.4.ebuild:
166 PyQt4-4.8 does not build with sip-4.13, bug 407291
167
168 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
169 Slightly improve the ewarn message in pkg_postinst().
170
171 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
172 Put qt as the primary herd in metadata.
173
174 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
175 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
176 <slong@rathaus.eclipse.co.uk> in bug #407281.
177
178 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
179 Switch to EAPI 4, add REQUIRED_USE.
180
181 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
182 PyQt4-4.8.4.ebuild:
183 Drop ~x86-fbsd because of unkeyworded dependencies.
184
185 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
186 Don't enable QtAssistant module because it was removed in qt-4.7 and we
187 already depend on 4.7.2 or later.
188
189 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
190 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
191 Restrict pypy for older versions too.
192
193 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
194 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
195 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
196 version.
197
198 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
199 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
200 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
201 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
202 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
203 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
204
205 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
206 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
207 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
208 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
209 Fixing pypy restricts to actually work
210
211*PyQt4-4.9.1 (12 Feb 2012)
212
213 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
214 version bump
215
216 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
217 builds with qt-opengl-4.8.0[egl], updated dep
218
219 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
220 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
221 Fixes backported from Progress Overlay. Patch by Arfrever.
222
223*PyQt4-4.9 (24 Dec 2011)
224
225 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
226 Version bump
227
228*PyQt4-4.8.6 (11 Nov 2011)
229
230 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
231 Version bump
232
233 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
234 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
235 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
236 python overlay.
237
238*PyQt4-4.8.5 (19 Aug 2011)
239
240 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
241 Version bump
242
243 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
244 ppc/ppc64 stable wrt #374591
245
246 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
247 x86 stable, bug #374591
248
249 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
250 ppc64 stable wrt #354033
251
252 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
253 Stable on amd64 wrt bug #374591
254
255 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
256 Marking PyQt4-4.8.3 ppc stable for bug 354033
257
258 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
259 Stable on amd64 wrt bug #354033
260
261 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
262 x86 stable per bug 354033
263
264*PyQt4-4.8.4 (02 May 2011)
265
266 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
267 +PyQt4-4.8.4.ebuild:
268 Version bump.
269
270 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
271 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
272 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
273 Adapt phonon dependency for package move
274
275 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
276 ppc64 stable wrt #349607
277
278 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
279 ia64/sparc stable wrt #349607
280
281 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
282 Stable on alpha, bug #349607
283
284 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
285 PyQt4-4.8.3.ebuild:
286 Update dependencies (bug #353053).
287
288*PyQt4-4.8.3 (25 Jan 2011)
289
290 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
291 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
292 Version bump.
293
294 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
295 x86 stable wrt bug #349607
296
297 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
298 Marking PyQt4-4.8.1 ppc stable for bug 349607
299
300 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
301 Stable on amd64 wrt bug #349607
302
303 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
304 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
305 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
306
307*PyQt4-4.8.1-r1 (30 Dec 2010)
308
309 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
310 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
311 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
312
313 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
314 PyQt4-4.8.2.ebuild:
315 Fix dependencies (bug #349672).
316
317*PyQt4-4.8.2 (24 Dec 2010)
318
319 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
320 +PyQt4-4.8.2.ebuild:
321 Version bump.
322
323 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
324 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
325 Restrict Jython ABIs.
326
327 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
328 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
329 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
330 -files/configure.py.patch:
331 Delete.
332
333 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
334 old, depends on qt 4.5
335
336 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
337 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
338 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
339 Remove HPPA keywording (bug #239441).
4 340
5*PyQt4-4.8.1 (30 Oct 2010) 341*PyQt4-4.8.1 (30 Oct 2010)
6 342
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 343 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 344 +PyQt4-4.8.1.ebuild:
546*PyQt4-4.0_beta1 (05 May 2006) 882*PyQt4-4.0_beta1 (05 May 2006)
547 883
548 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 884 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
549 +PyQt4-4.0_beta1.ebuild: 885 +PyQt4-4.0_beta1.ebuild:
550 initial import, from bug #121554 886 initial import, from bug #121554
551

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.218

  ViewVC Help
Powered by ViewVC 1.1.20