/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.234
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.234 2013/09/05 13:41:08 ago Exp $
4
5 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
6 Stable for ppc64, wrt bug #483112
7
8 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
9 Stable for ppc, wrt bug #483112
10
11 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
12 Stable for ia64, wrt bug #483112
13
14 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
15 Stable for alpha, wrt bug #483112
16
17 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
18 Stable for amd64, wrt bug #483112
19
20 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
21 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
22 Reorder Qt dependencies.
23
24 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
25 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
26 Fixing qtgui/designer deps for qt-4.8.5
27
28 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
29 PyQt4-4.9.6-r2.ebuild:
30 Fixing qtgui deps for qt-4.8.5
31
32 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
33 Remove wrong usedep for qtgui.
34
35*PyQt4-4.10.2 (24 Jun 2013)
36
37 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
38 Version bump.
39
40 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
41 PyQt4-4.10.1.ebuild:
42 Add PYTHON_REQUIRED_USE. Remove old.
43
44*PyQt4-4.10.1 (22 May 2013)
45
46 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
47 Version bump.
48
49 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
50 Remove unused flag description from metadata
51
52 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
53 -files/PyQt4-4.7.2-configure.py.patch,
54 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
55 old
56
57*PyQt4-4.10 (12 Mar 2013)
58
59 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
60 Version bump. Fix also bug #433944 by Franz Fellner.
61
62 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
63 Stable for sparc, wrt bug #457046
64
65 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
66 PyQt4-4.9.6-r2.ebuild:
67 Move Qt dependencies to the new category
68
69 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
70 Stable for ia64, wrt bug #457046
71
72 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
73 Stable for ppc64, wrt bug #457046
74
75 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
76 Stable for ppc, wrt bug #457046
77
78 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
79 Stable for alpha, wrt bug #457046
80
81 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
82 Stable for arm, wrt bug #457046
83
84 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
85 Stable for x86, wrt bug #457046
86
87 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
88 Stable for amd64, wrt bug #457046
89
90 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
91 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
92
93 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
94 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
95 Fix double prefix; remove old.
96
97 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
98 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
99
100*PyQt4-4.9.6-r2 (29 Jan 2013)
101
102 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
103 Migrate to the new python eclass.
104
105 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
106 Improve pyqt4_use_enable() as suggested by Arfrever.
107
108 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
109 old
110
111*PyQt4-4.9.6-r1 (26 Dec 2012)
112
113 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
114 metadata.xml:
115 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
116 pyside: rename assistant to help, add script and scripttools (bug 431460 by
117 Arfrever).
118
119*PyQt4-4.9.6 (10 Dec 2012)
120
121 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
122 Version bump, with some minor updates from qt overlay.
123
124 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
125 arm stable, bug #435074
126
127 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
128 PyQt4-4.9.4-r1.ebuild:
129 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
130
131 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
132 -PyQt4-4.9.1.ebuild:
133 Remove old
134
135*PyQt4-4.9.5 (05 Oct 2012)
136
137 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
138 Version bump
139
140 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
141 alpha/ia64/sparc stable wrt #429042
142
143*PyQt4-4.9.4-r1 (03 Sep 2012)
144
145 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
146 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
147 Apply upstream patch to fix regression in pyuic's handling of custom widgets
148 (bug 431070 by Laurent Bachelier).
149
150 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
151 Stable for x86, wrt bug #429042
152
153 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
154 Stable for amd64, wrt bug #429042
155
156 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
157 Stable ppc64, bug #429042
158
159 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
160 Stable ppc, bug #429042
161
162 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
163 ia64 stable
164
165 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
166 -files/PyQt4-4.6.1-configure-multilib.patch:
167 Remove old.
168
169 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
170 PyQt4-4.9.4.ebuild:
171 alpha/ia64/sparc stable wrt #412929
172
173*PyQt4-4.9.4 (02 Jul 2012)
174
175 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
176 -PyQt4-4.9.3.ebuild:
177 Version bump.
178
179*PyQt4-4.9.3 (27 Jun 2012)
180
181 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
182 -PyQt4-4.9.2.ebuild:
183 Version bump.
184
185 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
186 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
187
188*PyQt4-4.9.2 (21 Jun 2012)
189
190 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
191 Version bump
192
193 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
194 Destabling to ~ia64 because last available stable qt will be masked pending
195 removal
196
197 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
198 marked x86 per bug 412929
199
200 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
201 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
202 Inherit eutils.
203
204 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
205 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
206 Revert previous change.
207
208 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
209 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
210 Restrict python 3.1 to match dev-python/dbus-python.
211
212 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
213 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
214
215 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
216 Migrating dev-util/pkgconfig -> virtual/pkgconfig
217
218 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
219 Stable for amd64, wrt bug #412929
220
221 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
222 Stable on alpha, bug #354033
223
224 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
225 PyQt4-4.8.4.ebuild:
226 PyQt4-4.8 does not build with sip-4.13, bug 407291
227
228 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
229 Slightly improve the ewarn message in pkg_postinst().
230
231 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
232 Put qt as the primary herd in metadata.
233
234 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
235 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
236 <slong@rathaus.eclipse.co.uk> in bug #407281.
237
238 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
239 Switch to EAPI 4, add REQUIRED_USE.
240
241 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
242 PyQt4-4.8.4.ebuild:
243 Drop ~x86-fbsd because of unkeyworded dependencies.
244
245 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
246 Don't enable QtAssistant module because it was removed in qt-4.7 and we
247 already depend on 4.7.2 or later.
248
249 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
250 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
251 Restrict pypy for older versions too.
252
253 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
254 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
255 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
256 version.
257
258 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
259 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
260 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
261 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
262 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
263 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
264
265 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
266 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
267 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
268 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
269 Fixing pypy restricts to actually work
270
271*PyQt4-4.9.1 (12 Feb 2012)
272
273 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
274 version bump
275
276 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
277 builds with qt-opengl-4.8.0[egl], updated dep
278
279 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
280 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
281 Fixes backported from Progress Overlay. Patch by Arfrever.
282
283*PyQt4-4.9 (24 Dec 2011)
284
285 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
286 Version bump
287
288*PyQt4-4.8.6 (11 Nov 2011)
289
290 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
291 Version bump
292
293 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
294 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
295 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
296 python overlay.
297
298*PyQt4-4.8.5 (19 Aug 2011)
299
300 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
301 Version bump
302
303 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
304 ppc/ppc64 stable wrt #374591
305
306 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
307 x86 stable, bug #374591
308
309 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
310 ppc64 stable wrt #354033
311
312 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
313 Stable on amd64 wrt bug #374591
314
315 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
316 Marking PyQt4-4.8.3 ppc stable for bug 354033
317
318 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
319 Stable on amd64 wrt bug #354033
320
321 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
322 x86 stable per bug 354033
323
324*PyQt4-4.8.4 (02 May 2011)
325
326 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
327 +PyQt4-4.8.4.ebuild:
328 Version bump.
329
330 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
331 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
332 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
333 Adapt phonon dependency for package move
334
335 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
336 ppc64 stable wrt #349607
337
338 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
339 ia64/sparc stable wrt #349607
340
341 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
342 Stable on alpha, bug #349607
343
344 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
345 PyQt4-4.8.3.ebuild:
346 Update dependencies (bug #353053).
347
348*PyQt4-4.8.3 (25 Jan 2011)
349
350 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
351 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
352 Version bump.
353
354 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
355 x86 stable wrt bug #349607
356
357 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
358 Marking PyQt4-4.8.1 ppc stable for bug 349607
359
360 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
361 Stable on amd64 wrt bug #349607
362
363 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
364 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
365 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
366
367*PyQt4-4.8.1-r1 (30 Dec 2010)
368
369 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
370 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
371 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
372
373 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
374 PyQt4-4.8.2.ebuild:
375 Fix dependencies (bug #349672).
376
377*PyQt4-4.8.2 (24 Dec 2010)
378
379 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
380 +PyQt4-4.8.2.ebuild:
381 Version bump.
382
383 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
384 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
385 Restrict Jython ABIs.
386
387 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
388 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
389 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
390 -files/configure.py.patch:
391 Delete.
392
393 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
394 old, depends on qt 4.5
395
396 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
397 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
398 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
399 Remove HPPA keywording (bug #239441).
4 400
5*PyQt4-4.8.1 (30 Oct 2010) 401*PyQt4-4.8.1 (30 Oct 2010)
6 402
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 403 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 404 +PyQt4-4.8.1.ebuild:
546*PyQt4-4.0_beta1 (05 May 2006) 942*PyQt4-4.0_beta1 (05 May 2006)
547 943
548 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 944 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
549 +PyQt4-4.0_beta1.ebuild: 945 +PyQt4-4.0_beta1.ebuild:
550 initial import, from bug #121554 946 initial import, from bug #121554
551

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.234

  ViewVC Help
Powered by ViewVC 1.1.20