/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.176 Revision 1.270
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.176 2012/03/07 21:47:34 dilfridge Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.270 2014/10/09 09:35:04 ago Exp $
4
5 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
6 Stable for amd64, wrt bug #523322
7
8 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
9 arm stable, bug #523322
10
11*PyQt4-4.11.2 (20 Sep 2014)
12
13 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
14 PyQt4-4.11.1.ebuild:
15 Version bump. Silence harmless repoman warning.
16
17 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
18 Drop deprecated python versions.
19
20 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
21 PyQt4-4.11.1.ebuild:
22 Stop using dohtml, remove old.
23
24 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
25 Remove old.
26
27*PyQt4-4.11.1 (15 Jul 2014)
28
29 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
30 PyQt4-4.11.ebuild:
31 Version bump.
32
33 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
34 PyQt4-4.11.ebuild:
35 add py3.4 support req'd to support py packages such as pandas
36
37 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
38 PyQt4-4.10.3-r3.ebuild:
39 Restrict sip dep to =4.15* for older PyQt4 versions.
40
41*PyQt4-4.11 (30 May 2014)
42
43 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
44 Version bump.
45
46 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
47 PyQt4-4.10.3-r3.ebuild, metadata.xml:
48 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
49 Martin Walch in bug 510812.
50
51 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
52 -PyQt4-4.10.3.ebuild:
53 Drop the old versions that required python-exec:0.
54
55 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
56 Remove python herd as discussed with them.
57
58*PyQt4-4.10.3-r3 (27 Mar 2014)
59
60 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
61 Replace manual Python wrapping with proper eclass functions, bug #484404.
62
63 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
64 Stable for sparc, wrt bug #495638
65
66 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
67 Stable for x86, wrt bug #495638
68
69 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
70 Stable for alpha, wrt bug #495638
71
72 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
73 Stable for ia64, wrt bug #495638
74
75 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
76 Stable for ppc64, wrt bug #495638
77
78 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
79 amd64 stable, bug 495638
80
81 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
82 Stable for ppc, wrt bug #495638
83
84 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
85 arm stable, bug #495638
86
87 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
88 files/PyQt4-4.7.3-qreal_float_support.patch:
89 Updated qreal_float patch to remove first hunk (already applied
90 upstream). Tested on arm chromebook; no existing bug.
91
92*PyQt4-4.10.3-r2 (25 Dec 2013)
93
94 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
95 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
96 Introduce USE="designer".
97
98 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
99 old
100
101 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
102 Stable for sparc, wrt bug #483112
103
104 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
105 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
106 Update the ebuilds to dep on dev-lang/python-exec.
107
108 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
109 old
110
111*PyQt4-4.10.3-r1 (23 Oct 2013)
112
113 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
114 Support python-exec:2.
115
116 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
117 Depend on sip >=4.15.0 to fix build failure (bug #485274)
118
119 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
120 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
121 Add explicit dep on python-exec:0 since the package wraps the script manually.
122
123*PyQt4-4.10.3 (17 Sep 2013)
124
125 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
126 Version bump
127
128 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
129 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
130 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
131
132 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
133 arm stable, bug #483112
134
135 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
136 Stable for x86, wrt bug #483112
137
138 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
139 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
140 Clean up PYTHON_COMPAT from old implementations.
141
142 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
143 Stable for ppc64, wrt bug #483112
144
145 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
146 Stable for ppc, wrt bug #483112
147
148 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
149 Stable for ia64, wrt bug #483112
150
151 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
152 Stable for alpha, wrt bug #483112
153
154 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
155 Stable for amd64, wrt bug #483112
156
157 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
158 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
159 Reorder Qt dependencies.
160
161 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
162 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
163 Fixing qtgui/designer deps for qt-4.8.5
164
165 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
166 PyQt4-4.9.6-r2.ebuild:
167 Fixing qtgui deps for qt-4.8.5
168
169 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
170 Remove wrong usedep for qtgui.
171
172*PyQt4-4.10.2 (24 Jun 2013)
173
174 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
175 Version bump.
176
177 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
178 PyQt4-4.10.1.ebuild:
179 Add PYTHON_REQUIRED_USE. Remove old.
180
181*PyQt4-4.10.1 (22 May 2013)
182
183 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
184 Version bump.
185
186 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
187 Remove unused flag description from metadata
188
189 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
190 -files/PyQt4-4.7.2-configure.py.patch,
191 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
192 old
193
194*PyQt4-4.10 (12 Mar 2013)
195
196 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
197 Version bump. Fix also bug #433944 by Franz Fellner.
198
199 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
200 Stable for sparc, wrt bug #457046
201
202 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
203 PyQt4-4.9.6-r2.ebuild:
204 Move Qt dependencies to the new category
205
206 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
207 Stable for ia64, wrt bug #457046
208
209 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
210 Stable for ppc64, wrt bug #457046
211
212 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
213 Stable for ppc, wrt bug #457046
214
215 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
216 Stable for alpha, wrt bug #457046
217
218 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
219 Stable for arm, wrt bug #457046
220
221 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
222 Stable for x86, wrt bug #457046
223
224 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
225 Stable for amd64, wrt bug #457046
226
227 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
228 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
229
230 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
231 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
232 Fix double prefix; remove old.
233
234 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
235 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
236
237*PyQt4-4.9.6-r2 (29 Jan 2013)
238
239 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
240 Migrate to the new python eclass.
241
242 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
243 Improve pyqt4_use_enable() as suggested by Arfrever.
244
245 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
246 old
247
248*PyQt4-4.9.6-r1 (26 Dec 2012)
249
250 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
251 metadata.xml:
252 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
253 pyside: rename assistant to help, add script and scripttools (bug 431460 by
254 Arfrever).
255
256*PyQt4-4.9.6 (10 Dec 2012)
257
258 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
259 Version bump, with some minor updates from qt overlay.
260
261 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
262 arm stable, bug #435074
263
264 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
265 PyQt4-4.9.4-r1.ebuild:
266 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
267
268 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
269 -PyQt4-4.9.1.ebuild:
270 Remove old
271
272*PyQt4-4.9.5 (05 Oct 2012)
273
274 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
275 Version bump
276
277 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
278 alpha/ia64/sparc stable wrt #429042
279
280*PyQt4-4.9.4-r1 (03 Sep 2012)
281
282 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
283 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
284 Apply upstream patch to fix regression in pyuic's handling of custom widgets
285 (bug 431070 by Laurent Bachelier).
286
287 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
288 Stable for x86, wrt bug #429042
289
290 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
291 Stable for amd64, wrt bug #429042
292
293 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
294 Stable ppc64, bug #429042
295
296 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
297 Stable ppc, bug #429042
298
299 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
300 ia64 stable
301
302 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
303 -files/PyQt4-4.6.1-configure-multilib.patch:
304 Remove old.
305
306 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
307 PyQt4-4.9.4.ebuild:
308 alpha/ia64/sparc stable wrt #412929
309
310*PyQt4-4.9.4 (02 Jul 2012)
311
312 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
313 -PyQt4-4.9.3.ebuild:
314 Version bump.
315
316*PyQt4-4.9.3 (27 Jun 2012)
317
318 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
319 -PyQt4-4.9.2.ebuild:
320 Version bump.
321
322 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
323 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
324
325*PyQt4-4.9.2 (21 Jun 2012)
326
327 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
328 Version bump
329
330 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
331 Destabling to ~ia64 because last available stable qt will be masked pending
332 removal
333
334 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
335 marked x86 per bug 412929
336
337 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
338 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
339 Inherit eutils.
340
341 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
342 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
343 Revert previous change.
344
345 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
346 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
347 Restrict python 3.1 to match dev-python/dbus-python.
348
349 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
350 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
351
352 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
353 Migrating dev-util/pkgconfig -> virtual/pkgconfig
354
355 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
356 Stable for amd64, wrt bug #412929
357
358 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
359 Stable on alpha, bug #354033
4 360
5 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild, 361 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
6 PyQt4-4.8.4.ebuild: 362 PyQt4-4.8.4.ebuild:
7 PyQt4-4.8 does not build with sip-4.13, bug 407291 363 PyQt4-4.8 does not build with sip-4.13, bug 407291
8 364
723*PyQt4-4.0_beta1 (05 May 2006) 1079*PyQt4-4.0_beta1 (05 May 2006)
724 1080
725 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1081 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
726 +PyQt4-4.0_beta1.ebuild: 1082 +PyQt4-4.0_beta1.ebuild:
727 initial import, from bug #121554 1083 initial import, from bug #121554
728

Legend:
Removed from v.1.176  
changed lines
  Added in v.1.270

  ViewVC Help
Powered by ViewVC 1.1.20