/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.21 Revision 1.66
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.21 2007/12/26 00:56:22 caleb Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.66 2009/06/20 14:22:51 arfrever Exp $
4
5 20 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
6 PyQt4-4.5.1.ebuild:
7 Don't install modules specific for other versions of Python (bug #274499).
8
9 16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.5.1.ebuild:
10 Raise sip dependency to 4.8.1
11
12*PyQt4-4.5.1 (16 Jun 2009)
13
14 16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.4.4-r5.ebuild,
15 PyQt4-4.5.ebuild, +PyQt4-4.5.1.ebuild:
16 Drop qt3support use flag. Version bump. Bug-fix release
17
18 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.4.4-r2.ebuild,
19 PyQt4-4.4.4-r4.ebuild, PyQt4-4.4.4-r5.ebuild:
20 Add correct sip dependencies, fixes bug 273430
21
22*PyQt4-4.5 (09 Jun 2009)
23
24 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.ebuild:
25 Version bump
26
27 05 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild:
28 Specify !kde for qt-phonon dep
29
30 03 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild,
31 metadata.xml:
32 Add kde useflag, for selecting media-sound/phonon, bug 270188
33
34 02 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild:
35 QtDesigner is triggered by USE=X, so hide sed behind X useflag. Thanks
36 to Davide Pesavento for alerting.
37
38 01 Jun 2009; Markos Chandras <hwoarang@gentoo.org>
39 +files/fix_license_check.patch:
40 Add missing patch. Fixes bug 272126
41
42*PyQt4-4.4.4-r5 (01 Jun 2009)
43
44 01 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.4.4-r5.ebuild,
45 files/configure.py.patch, metadata.xml:
46 Fixed automagic dependency issue. ( bug 236341 ). Fixed rpath issues ( bug
47 235819 , bug 271870 ). Thanks to Davide Pesavento <davidepesa@gmail.com>
48 for the ebuilds and the rpath patch.
49
50 20 May 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4-r1.ebuild,
51 -PyQt4-4.4.4-r1.ebuild, -PyQt4-4.4.4-r3.ebuild, PyQt4-4.4.4-r4.ebuild:
52 Turn on default useflags for all Qt modules. Remove old. Move src_unpack
53 content to src_prepare, where it belongs.
54
55 15 May 2009; Alexis Ballier <aballier@gentoo.org> PyQt4-4.4.4-r4.ebuild:
56 keyword ~x86-fbsd, bug #269880
57
58*PyQt4-4.4.4-r4 (26 Apr 2009)
59
60 26 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
61 +files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
62 +PyQt4-4.4.4-r4.ebuild:
63 Adding qt-xmlpatterns as dependency. Add patch for QGraphicsProxyWidget (
64 thanks to Fabio Erculiani <lxnay@sabayonlinux.org> for providing the patch
65 ). Fixes bug #267012
66
67*PyQt4-4.4.4-r3 (07 Apr 2009)
68
69 07 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
70 +files/configure.py.patch, +PyQt4-4.4.4-r3.ebuild:
71 Fixed bug #204877 ( thanks to Davide Pesavento <davidepesa@gmail.com> )
72
73 27 Mar 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r2.ebuild:
74 Stable for HPPA (bug #261652).
75
76 24 Mar 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r2.ebuild:
77 stable ppc64, bug 261652
78
79 22 Mar 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.4.4-r2.ebuild:
80 amd64 stable, bug #261652
81
82 20 Mar 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.4.4-r2.ebuild:
83 alpha/ia64/sparc/x86 stable wrt #261652
84
85 20 Mar 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r2.ebuild:
86 stable ppc, bug 261652
87
88 20 Mar 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.3.1.ebuild,
89 -PyQt4-4.3.3.ebuild:
90 Dropping old packages due to qt-4.3 removal
91
92 18 Feb 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r1.ebuild:
93 Stable for HPPA (bug #248083).
94
95 06 Feb 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.4.4-r1.ebuild:
96 ia64/sparc stable wrt #248038
97
98 04 Feb 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r1.ebuild:
99 Marking PyQt4-4.4.4-r1 ppc64 stable for bug 248038
100
101 31 Jan 2009; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.4.4-r1.ebuild:
102 Stable on alpha, bug #248038
103
104*PyQt4-4.4.4-r2 (25 Jan 2009)
105
106 25 Jan 2009; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.4-r2.ebuild:
107 Add dbus-python dep, thanks to Maciej Mrozowski. Remove no longer needed
108 zlib useflag check.
109
110 18 Jan 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.4.4-r1.ebuild:
111 amd64/x86 stable, bug #248038
112
113 17 Jan 2009; nixnut <nixnut@gentoo.org> PyQt4-4.4.4-r1.ebuild:
114 ppc stable #248038
115
116 09 Jan 2009; Patrick Lauer <patrick@gentoo.org> -PyQt4-4.4.3.ebuild,
117 -PyQt4-4.4.4.ebuild:
118 Removing old
119
120*PyQt4-4.4.4-r1 (23 Nov 2008)
121
122 23 Nov 2008; Patrick Lauer <patrick@gentoo.org> +PyQt4-4.4.4-r1.ebuild:
123 Adding webkit useflag. Fixes pykde failing to build because of ordering
124 issues.
125
126*PyQt4-4.4.4 (21 Nov 2008)
127
128 21 Nov 2008; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4.2.ebuild,
129 PyQt4-4.4.3.ebuild, +PyQt4-4.4.4.ebuild:
130 Drop ~x86-fbsd, as qt-core isn't keyworded for that arch yet.
131 Version bump, with updated deps. Remove hardmasked 4.4.2 version.
132
133 07 Oct 2008; Jeroen Roovers <jer@gentoo.org> PyQt4-4.3.3.ebuild:
134 Stable for HPPA too.
135
136*PyQt4-4.4.3 (06 Sep 2008)
137
138 06 Sep 2008; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.3.ebuild:
139 Version bump. Fixes bug 234559.
140
141 06 Aug 2008; Jesus Rivero <neurogeek@gentoo.org> metadata.xml:
142 add GLEP 56 USE flag desc from use.local.desc
143
144*PyQt4-4.4-r1 (31 Jul 2008)
145
146 31 Jul 2008; Jesus Rivero <neurogeek@gentoo.org>
147 +files/PyQt4-4.4_compile.patch, -PyQt4-4.4.ebuild, +PyQt4-4.4-r1.ebuild:
148 Fixes bugs #233369 and #222435, thanks to Remy Bosch for the patch.
149 Removed old version
150
151 25 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> PyQt4-4.4.2.ebuild:
152 dev-python/PyQt4-4.4.2 needs Qt-4.4.0, fix dependencies, mask package.
153
154*PyQt4-4.4.2 (24 May 2008)
155
156 24 May 2008; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.2.ebuild:
157 Version bump. Updated homepage URL. Added split qt deps from bug 222709.
158
159*PyQt4-4.4 (14 May 2008)
160
161 14 May 2008; Ali Polatel <hawking@gentoo.org> PyQt4-4.3.1.ebuild,
162 PyQt4-4.3.3.ebuild, +PyQt4-4.4.ebuild:
163 Version bump. Change SRC_URI of old ebuilds to mirror://gentoo because
164 upstream doesn't have it anymore.
165
166 13 May 2008; Ali Polatel <hawking@gentoo.org> PyQt4-4.3.1.ebuild,
167 PyQt4-4.3.3.ebuild:
168 Changed HOMEPAGE. Thanks to Elias Probst, #220653
169
170 12 May 2008; Markus Rothe <corsair@gentoo.org> PyQt4-4.3.3.ebuild:
171 Stable on ppc64
172
173 07 Apr 2008; Alexis Ballier <aballier@gentoo.org> PyQt4-4.3.3.ebuild:
174 keyword ~x86-fbsd
175
176 02 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org> PyQt4-4.3.1.ebuild:
177 Marked stable on amd64 as per bug 201474.
178
179 21 Feb 2008; Raúl Porcel <armin76@gentoo.org> PyQt4-4.3.3.ebuild:
180 alpha/ia64/sparc stable
181
182 15 Feb 2008; nixnut <nixnut@gentoo.org> PyQt4-4.3.1.ebuild:
183 Stable on ppc wrt bug 201474
184
185 09 Feb 2008; Markus Ullmann <jokey@gentoo.org> PyQt4-4.3.3.ebuild:
186 Stable on x86
187
188 28 Dec 2007; Caleb Tennis <caleb@gentoo.org> PyQt4-4.3.1.ebuild,
189 PyQt4-4.3.3.ebuild:
190 Explicitly depend on Qt 4.3 for these versions
4 191
5*PyQt4-4.3.3 (26 Dec 2007) 192*PyQt4-4.3.3 (26 Dec 2007)
6 193
7 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.3.ebuild: 194 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.3.ebuild:
8 version bump 195 version bump

Legend:
Removed from v.1.21  
changed lines
  Added in v.1.66

  ViewVC Help
Powered by ViewVC 1.1.20