/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.260 Revision 1.291
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.260 2014/05/21 21:29:32 pesa Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.291 2015/06/17 17:25:08 pesa Exp $
4
5 17 Jun 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.3.ebuild:
6 Drop version that is not going to get stabilized.
7
8 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.4.ebuild:
9 Use the new --no-python-dbus configure option.
10
11 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.4.ebuild:
12 PyQt4 became GPL-3 only.
13
14*PyQt4-4.11.4 (14 Jun 2015)
15
16 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.4.ebuild:
17 Version bump.
18
19 09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
20 Updating remote-id in metadata.xml
21
22 11 May 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.2.ebuild,
23 PyQt4-4.11.3.ebuild:
24 Enable tracing with USE=debug; enable configure verbose output to get useful
25 build logs in bug reports; stop passing deprecated --no-timestamp option; use
26 qt4_get_bindir().
27
28 14 Apr 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
29 Stable for ia64, wrt bug #523322
30
31 08 Apr 2015; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.3-r2.ebuild:
32 Drop old Python implementations
33
34 17 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
35 Stable for ppc64, wrt bug #517344
36
37 16 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
38 Stable for ppc, wrt bug #517344
39
40 14 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
41 Stable for x86, wrt bug #517344
42
43 09 Jan 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.3.ebuild:
44 Stop using deprecated python_parallel_foreach_impl.
45
46 31 Dec 2014; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.3-r2.ebuild,
47 PyQt4-4.11.1.ebuild, PyQt4-4.11.2.ebuild:
48 Enforce USE dependency for media-libs/phonon.
49
50 10 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> PyQt4-4.11.1.ebuild:
51 amd64 stable wrt bug #517344
52
53 22 Nov 2014; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.11.1.ebuild:
54 Stable on alpha, bug 523322
55
56*PyQt4-4.11.3 (15 Nov 2014)
57
58 15 Nov 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.3.ebuild,
59 -PyQt4-4.11.3_pre20141024.ebuild:
60 Version bump.
61
62*PyQt4-4.11.3_pre20141024 (01 Nov 2014)
63
64 01 Nov 2014; Davide Pesavento <pesa@gentoo.org>
65 +PyQt4-4.11.3_pre20141024.ebuild, -PyQt4-4.11.2-r1.ebuild:
66 Bump to 4.11.3 prerelease, which contains upstream fixes for bugs #525392 and
67 #525470. Also switch to out-of-source builds.
68
69 15 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.2-r1.ebuild:
70 Fix bug #525392.
71
72 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
73 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
74 Fix building against media-libs/phonon (bug 525354).
75
76*PyQt4-4.11.2-r1 (13 Oct 2014)
77
78 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
79 metadata.xml:
80 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
81 from QtGui.
82
83 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
84 Revert to ~amd64, see bug #523322 comment #4.
85
86 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
87 Stable for amd64, wrt bug #523322
88
89 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
90 arm stable, bug #523322
91
92*PyQt4-4.11.2 (20 Sep 2014)
93
94 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
95 PyQt4-4.11.1.ebuild:
96 Version bump. Silence harmless repoman warning.
97
98 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
99 Drop deprecated python versions.
100
101 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
102 PyQt4-4.11.1.ebuild:
103 Stop using dohtml, remove old.
104
105 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
106 Remove old.
107
108*PyQt4-4.11.1 (15 Jul 2014)
109
110 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
111 PyQt4-4.11.ebuild:
112 Version bump.
113
114 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
115 PyQt4-4.11.ebuild:
116 add py3.4 support req'd to support py packages such as pandas
117
118 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
119 PyQt4-4.10.3-r3.ebuild:
120 Restrict sip dep to =4.15* for older PyQt4 versions.
121
122*PyQt4-4.11 (30 May 2014)
123
124 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
125 Version bump.
4 126
5 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild, 127 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
6 PyQt4-4.10.3-r3.ebuild, metadata.xml: 128 PyQt4-4.10.3-r3.ebuild, metadata.xml:
7 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to 129 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
8 Martin Walch in bug 510812. 130 Martin Walch in bug 510812.

Legend:
Removed from v.1.260  
changed lines
  Added in v.1.291

  ViewVC Help
Powered by ViewVC 1.1.20