/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.90 Revision 1.260
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.90 2009/09/22 22:06:13 maekke Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.260 2014/05/21 21:29:32 pesa Exp $
4
5 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
6 PyQt4-4.10.3-r3.ebuild, metadata.xml:
7 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
8 Martin Walch in bug 510812.
9
10 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
11 -PyQt4-4.10.3.ebuild:
12 Drop the old versions that required python-exec:0.
13
14 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
15 Remove python herd as discussed with them.
16
17*PyQt4-4.10.3-r3 (27 Mar 2014)
18
19 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
20 Replace manual Python wrapping with proper eclass functions, bug #484404.
21
22 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
23 Stable for sparc, wrt bug #495638
24
25 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
26 Stable for x86, wrt bug #495638
27
28 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
29 Stable for alpha, wrt bug #495638
30
31 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
32 Stable for ia64, wrt bug #495638
33
34 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
35 Stable for ppc64, wrt bug #495638
36
37 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
38 amd64 stable, bug 495638
39
40 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
41 Stable for ppc, wrt bug #495638
42
43 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
44 arm stable, bug #495638
45
46 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
47 files/PyQt4-4.7.3-qreal_float_support.patch:
48 Updated qreal_float patch to remove first hunk (already applied
49 upstream). Tested on arm chromebook; no existing bug.
50
51*PyQt4-4.10.3-r2 (25 Dec 2013)
52
53 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
54 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
55 Introduce USE="designer".
56
57 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
58 old
59
60 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
61 Stable for sparc, wrt bug #483112
62
63 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
64 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
65 Update the ebuilds to dep on dev-lang/python-exec.
66
67 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
68 old
69
70*PyQt4-4.10.3-r1 (23 Oct 2013)
71
72 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
73 Support python-exec:2.
74
75 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
76 Depend on sip >=4.15.0 to fix build failure (bug #485274)
77
78 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
79 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
80 Add explicit dep on python-exec:0 since the package wraps the script manually.
81
82*PyQt4-4.10.3 (17 Sep 2013)
83
84 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
85 Version bump
86
87 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
88 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
89 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
90
91 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
92 arm stable, bug #483112
93
94 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
95 Stable for x86, wrt bug #483112
96
97 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
98 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
99 Clean up PYTHON_COMPAT from old implementations.
100
101 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
102 Stable for ppc64, wrt bug #483112
103
104 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
105 Stable for ppc, wrt bug #483112
106
107 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
108 Stable for ia64, wrt bug #483112
109
110 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
111 Stable for alpha, wrt bug #483112
112
113 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
114 Stable for amd64, wrt bug #483112
115
116 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
117 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
118 Reorder Qt dependencies.
119
120 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
121 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
122 Fixing qtgui/designer deps for qt-4.8.5
123
124 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
125 PyQt4-4.9.6-r2.ebuild:
126 Fixing qtgui deps for qt-4.8.5
127
128 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
129 Remove wrong usedep for qtgui.
130
131*PyQt4-4.10.2 (24 Jun 2013)
132
133 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
134 Version bump.
135
136 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
137 PyQt4-4.10.1.ebuild:
138 Add PYTHON_REQUIRED_USE. Remove old.
139
140*PyQt4-4.10.1 (22 May 2013)
141
142 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
143 Version bump.
144
145 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
146 Remove unused flag description from metadata
147
148 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
149 -files/PyQt4-4.7.2-configure.py.patch,
150 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
151 old
152
153*PyQt4-4.10 (12 Mar 2013)
154
155 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
156 Version bump. Fix also bug #433944 by Franz Fellner.
157
158 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
159 Stable for sparc, wrt bug #457046
160
161 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
162 PyQt4-4.9.6-r2.ebuild:
163 Move Qt dependencies to the new category
164
165 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
166 Stable for ia64, wrt bug #457046
167
168 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
169 Stable for ppc64, wrt bug #457046
170
171 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
172 Stable for ppc, wrt bug #457046
173
174 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
175 Stable for alpha, wrt bug #457046
176
177 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
178 Stable for arm, wrt bug #457046
179
180 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
181 Stable for x86, wrt bug #457046
182
183 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
184 Stable for amd64, wrt bug #457046
185
186 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
187 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
188
189 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
190 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
191 Fix double prefix; remove old.
192
193 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
194 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
195
196*PyQt4-4.9.6-r2 (29 Jan 2013)
197
198 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
199 Migrate to the new python eclass.
200
201 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
202 Improve pyqt4_use_enable() as suggested by Arfrever.
203
204 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
205 old
206
207*PyQt4-4.9.6-r1 (26 Dec 2012)
208
209 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
210 metadata.xml:
211 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
212 pyside: rename assistant to help, add script and scripttools (bug 431460 by
213 Arfrever).
214
215*PyQt4-4.9.6 (10 Dec 2012)
216
217 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
218 Version bump, with some minor updates from qt overlay.
219
220 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
221 arm stable, bug #435074
222
223 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
224 PyQt4-4.9.4-r1.ebuild:
225 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
226
227 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
228 -PyQt4-4.9.1.ebuild:
229 Remove old
230
231*PyQt4-4.9.5 (05 Oct 2012)
232
233 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
234 Version bump
235
236 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
237 alpha/ia64/sparc stable wrt #429042
238
239*PyQt4-4.9.4-r1 (03 Sep 2012)
240
241 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
242 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
243 Apply upstream patch to fix regression in pyuic's handling of custom widgets
244 (bug 431070 by Laurent Bachelier).
245
246 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
247 Stable for x86, wrt bug #429042
248
249 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
250 Stable for amd64, wrt bug #429042
251
252 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
253 Stable ppc64, bug #429042
254
255 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
256 Stable ppc, bug #429042
257
258 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
259 ia64 stable
260
261 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
262 -files/PyQt4-4.6.1-configure-multilib.patch:
263 Remove old.
264
265 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
266 PyQt4-4.9.4.ebuild:
267 alpha/ia64/sparc stable wrt #412929
268
269*PyQt4-4.9.4 (02 Jul 2012)
270
271 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
272 -PyQt4-4.9.3.ebuild:
273 Version bump.
274
275*PyQt4-4.9.3 (27 Jun 2012)
276
277 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
278 -PyQt4-4.9.2.ebuild:
279 Version bump.
280
281 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
282 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
283
284*PyQt4-4.9.2 (21 Jun 2012)
285
286 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
287 Version bump
288
289 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
290 Destabling to ~ia64 because last available stable qt will be masked pending
291 removal
292
293 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
294 marked x86 per bug 412929
295
296 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
297 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
298 Inherit eutils.
299
300 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
301 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
302 Revert previous change.
303
304 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
305 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
306 Restrict python 3.1 to match dev-python/dbus-python.
307
308 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
309 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
310
311 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
312 Migrating dev-util/pkgconfig -> virtual/pkgconfig
313
314 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
315 Stable for amd64, wrt bug #412929
316
317 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
318 Stable on alpha, bug #354033
319
320 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
321 PyQt4-4.8.4.ebuild:
322 PyQt4-4.8 does not build with sip-4.13, bug 407291
323
324 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
325 Slightly improve the ewarn message in pkg_postinst().
326
327 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
328 Put qt as the primary herd in metadata.
329
330 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
331 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
332 <slong@rathaus.eclipse.co.uk> in bug #407281.
333
334 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
335 Switch to EAPI 4, add REQUIRED_USE.
336
337 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
338 PyQt4-4.8.4.ebuild:
339 Drop ~x86-fbsd because of unkeyworded dependencies.
340
341 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
342 Don't enable QtAssistant module because it was removed in qt-4.7 and we
343 already depend on 4.7.2 or later.
344
345 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
346 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
347 Restrict pypy for older versions too.
348
349 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
350 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
351 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
352 version.
353
354 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
355 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
356 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
357 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
358 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
359 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
360
361 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
362 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
363 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
364 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
365 Fixing pypy restricts to actually work
366
367*PyQt4-4.9.1 (12 Feb 2012)
368
369 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
370 version bump
371
372 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
373 builds with qt-opengl-4.8.0[egl], updated dep
374
375 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
376 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
377 Fixes backported from Progress Overlay. Patch by Arfrever.
378
379*PyQt4-4.9 (24 Dec 2011)
380
381 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
382 Version bump
383
384*PyQt4-4.8.6 (11 Nov 2011)
385
386 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
387 Version bump
388
389 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
390 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
391 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
392 python overlay.
393
394*PyQt4-4.8.5 (19 Aug 2011)
395
396 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
397 Version bump
398
399 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
400 ppc/ppc64 stable wrt #374591
401
402 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
403 x86 stable, bug #374591
404
405 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
406 ppc64 stable wrt #354033
407
408 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
409 Stable on amd64 wrt bug #374591
410
411 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
412 Marking PyQt4-4.8.3 ppc stable for bug 354033
413
414 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
415 Stable on amd64 wrt bug #354033
416
417 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
418 x86 stable per bug 354033
419
420*PyQt4-4.8.4 (02 May 2011)
421
422 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
423 +PyQt4-4.8.4.ebuild:
424 Version bump.
425
426 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
427 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
428 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
429 Adapt phonon dependency for package move
430
431 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
432 ppc64 stable wrt #349607
433
434 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
435 ia64/sparc stable wrt #349607
436
437 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
438 Stable on alpha, bug #349607
439
440 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
441 PyQt4-4.8.3.ebuild:
442 Update dependencies (bug #353053).
443
444*PyQt4-4.8.3 (25 Jan 2011)
445
446 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
447 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
448 Version bump.
449
450 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
451 x86 stable wrt bug #349607
452
453 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
454 Marking PyQt4-4.8.1 ppc stable for bug 349607
455
456 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
457 Stable on amd64 wrt bug #349607
458
459 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
460 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
461 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
462
463*PyQt4-4.8.1-r1 (30 Dec 2010)
464
465 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
466 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
467 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
468
469 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
470 PyQt4-4.8.2.ebuild:
471 Fix dependencies (bug #349672).
472
473*PyQt4-4.8.2 (24 Dec 2010)
474
475 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
476 +PyQt4-4.8.2.ebuild:
477 Version bump.
478
479 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
480 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
481 Restrict Jython ABIs.
482
483 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
484 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
485 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
486 -files/configure.py.patch:
487 Delete.
488
489 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
490 old, depends on qt 4.5
491
492 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
493 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
494 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
495 Remove HPPA keywording (bug #239441).
496
497*PyQt4-4.8.1 (30 Oct 2010)
498
499 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
500 +PyQt4-4.8.1.ebuild:
501 Version bump.
502
503 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
504 ia64/sparc stable wrt #315775
505
506*PyQt4-4.8 (23 Oct 2010)
507
508 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
509 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
510 +PyQt4-4.8.ebuild, metadata.xml:
511 Version bump.
512
513*PyQt4-4.7.7-r1 (06 Oct 2010)
514
515 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
516 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
517 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
518
519*PyQt4-4.7.7 (21 Sep 2010)
520
521 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
522 +PyQt4-4.7.7.ebuild:
523 Version bump. Remove old bogus version
524
525 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
526 Stable on alpha, bug #315775
527
528 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
529 Marked ppc stable for bug #315775.
530
531 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
532 PyQt4-4.7.6.ebuild:
533 Update EAPI. Fix dependencies.
534
535*PyQt4-4.7.6 (08 Sep 2010)
536
537 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
538 +PyQt4-4.7.6.ebuild:
539 Version bump. Remove old ebuild
540
541 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
542 PyQt4-4.7.5.ebuild:
543 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
544
545*PyQt4-4.7.5 (01 Sep 2010)
546
547 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
548 +PyQt4-4.7.5.ebuild:
549 Version bump
550
551 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
552 Stable for HPPA (bug #315775).
553
554 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
555 Bump sip dependency to 4.10.3. Fix arm epatch command
556
557*PyQt4-4.7.4 (13 Jul 2010)
558
559 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
560 Version bump
561
562 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
563 ppc64 stable wrt #315775
564
565 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
566 +files/PyQt4-4.7.3-qreal_float_support.patch:
567 Add patch for qreal/float support in ARM wrt bug 322349
568
569 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
570 x86 stable wrt bug 315775
571
572 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
573 Stable on amd64 wrt bug 315775
574
575 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
576 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
577 Fix sip dep in PyQt4 ebuilds
578
579*PyQt4-4.7.3 (17 Apr 2010)
580
581 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
582 Version bump
583
584 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
585 ppc stable #301105
586
587*PyQt4-4.7.2 (18 Mar 2010)
588
589 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
590 +files/PyQt4-4.7.2-configure.py.patch:
591 Version bump. ChangeLog is no longer shipped. Update patch.
592
593 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
594 stable x86, bug 301105
595
596 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
597 amd64 stable wrt #301105
598
599 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
600 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
601 -files/fix_license_check.patch:
602 Drop old patches
603
604 10 Feb 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.6.2.ebuild:
605 Stable for HPPA (bug #300713).
606
607 08 Feb 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.6.2.ebuild:
608 stable x86, bug 300713
609
610 02 Feb 2010; Alex Alexander <wired@gentoo.org> PyQt4-4.5.4-r4.ebuild,
611 PyQt4-4.6.2.ebuild:
612 updated SRC_URI to use gentoo mirrors, upstream doesn't provide these
613 versions anymore
614
615 31 Jan 2010; <hwoarang@gentoo.org> PyQt4-4.6.2.ebuild:
616 Stable on amd64 wrt bug #300713
617
618 20 Jan 2010; Jonathan Callen <abcd@gentoo.org> PyQt4-4.7.ebuild:
619 Add prefix keywords, support
620
621*PyQt4-4.7 (15 Jan 2010)
622
623 15 Jan 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.ebuild:
624 Version bump
625
626 11 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
627 PyQt4-4.5.4-r4.ebuild, PyQt4-4.6.2.ebuild:
628 Don't call python_need_rebuild().
629
630 06 Jan 2010; <hwoarang@gentoo.org> PyQt4-4.6.2.ebuild:
631 Migrate to qt4-r2 eclass
632
633 02 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
634 PyQt4-4.5.4-r4.ebuild, PyQt4-4.6.2.ebuild:
635 Only restrict Python 3.2.
636
637 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> PyQt4-4.5.4-r4.ebuild,
638 PyQt4-4.6.2.ebuild:
639 Adding RESTRICT_PYTHON_ABIS for python3. Current PyQt4 versions only work
640 with python2. Fixes bug 292419.
641
642 13 Dec 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4.4-r2.ebuild,
643 -PyQt4-4.4.4-r5.ebuild, -PyQt4-4.5.2.ebuild, -PyQt4-4.5.4-r3.ebuild,
644 PyQt4-4.5.4-r4.ebuild, -PyQt4-4.6.1.ebuild, -PyQt4-4.6.1-r1.ebuild,
645 PyQt4-4.6.2.ebuild, metadata.xml:
646 Remove obsolete versions. Pin 4.5.4 on correct sip and Qt versions. Remove
647 qt3support useflag description from metadata, as it is no longer in use.
648
649 30 Nov 2009; Joseph Jezak <josejx@gentoo.org> PyQt4-4.5.4-r4.ebuild:
650 Marked ppc64 stable.
651
652*PyQt4-4.6.2 (20 Nov 2009)
653
654 20 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
655 +PyQt4-4.6.2.ebuild:
656 Version bump.
657
658*PyQt4-4.6.1-r1 (05 Nov 2009)
659
660 05 Nov 2009; Alex Alexander <wired@gentoo.org> +PyQt4-4.6.1-r1.ebuild,
661 +files/PyQt4-4.6.1-configure-multilib.patch:
662 added multilib patch wrt bug #283936
663
664*PyQt4-4.6.1 (28 Oct 2009)
665
666 28 Oct 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.6.1.ebuild,
667 +files/configure-4.6.1.py.patch:
668 Version bump. Add new configuration patch
669
670 18 Oct 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.5.4-r4.ebuild:
671 alpha/ia64/sparc stable wrt #284707
672
673 27 Sep 2009; nixnut <nixnut@gentoo.org> PyQt4-4.5.4-r4.ebuild:
674 ppc stable #284707
4 675
5 22 Sep 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.5.4-r4.ebuild: 676 22 Sep 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.5.4-r4.ebuild:
6 add ~arm 677 add ~arm
7 678
8 22 Sep 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild: 679 22 Sep 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild:
367*PyQt4-4.0_beta1 (05 May 2006) 1038*PyQt4-4.0_beta1 (05 May 2006)
368 1039
369 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1040 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
370 +PyQt4-4.0_beta1.ebuild: 1041 +PyQt4-4.0_beta1.ebuild:
371 initial import, from bug #121554 1042 initial import, from bug #121554
372

Legend:
Removed from v.1.90  
changed lines
  Added in v.1.260

  ViewVC Help
Powered by ViewVC 1.1.20