/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.99 Revision 1.287
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.99 2010/01/02 15:43:09 yngwin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.287 2015/06/09 15:02:09 jlec Exp $
4
5 09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
6 Updating remote-id in metadata.xml
7
8 11 May 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.2.ebuild,
9 PyQt4-4.11.3.ebuild:
10 Enable tracing with USE=debug; enable configure verbose output to get useful
11 build logs in bug reports; stop passing deprecated --no-timestamp option; use
12 qt4_get_bindir().
13
14 14 Apr 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
15 Stable for ia64, wrt bug #523322
16
17 08 Apr 2015; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.3-r2.ebuild:
18 Drop old Python implementations
19
20 17 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
21 Stable for ppc64, wrt bug #517344
22
23 16 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
24 Stable for ppc, wrt bug #517344
25
26 14 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
27 Stable for x86, wrt bug #517344
28
29 09 Jan 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.3.ebuild:
30 Stop using deprecated python_parallel_foreach_impl.
31
32 31 Dec 2014; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.3-r2.ebuild,
33 PyQt4-4.11.1.ebuild, PyQt4-4.11.2.ebuild:
34 Enforce USE dependency for media-libs/phonon.
35
36 10 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> PyQt4-4.11.1.ebuild:
37 amd64 stable wrt bug #517344
38
39 22 Nov 2014; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.11.1.ebuild:
40 Stable on alpha, bug 523322
41
42*PyQt4-4.11.3 (15 Nov 2014)
43
44 15 Nov 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.3.ebuild,
45 -PyQt4-4.11.3_pre20141024.ebuild:
46 Version bump.
47
48*PyQt4-4.11.3_pre20141024 (01 Nov 2014)
49
50 01 Nov 2014; Davide Pesavento <pesa@gentoo.org>
51 +PyQt4-4.11.3_pre20141024.ebuild, -PyQt4-4.11.2-r1.ebuild:
52 Bump to 4.11.3 prerelease, which contains upstream fixes for bugs #525392 and
53 #525470. Also switch to out-of-source builds.
54
55 15 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.2-r1.ebuild:
56 Fix bug #525392.
57
58 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
59 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
60 Fix building against media-libs/phonon (bug 525354).
61
62*PyQt4-4.11.2-r1 (13 Oct 2014)
63
64 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
65 metadata.xml:
66 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
67 from QtGui.
68
69 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
70 Revert to ~amd64, see bug #523322 comment #4.
71
72 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
73 Stable for amd64, wrt bug #523322
74
75 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
76 arm stable, bug #523322
77
78*PyQt4-4.11.2 (20 Sep 2014)
79
80 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
81 PyQt4-4.11.1.ebuild:
82 Version bump. Silence harmless repoman warning.
83
84 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
85 Drop deprecated python versions.
86
87 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
88 PyQt4-4.11.1.ebuild:
89 Stop using dohtml, remove old.
90
91 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
92 Remove old.
93
94*PyQt4-4.11.1 (15 Jul 2014)
95
96 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
97 PyQt4-4.11.ebuild:
98 Version bump.
99
100 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
101 PyQt4-4.11.ebuild:
102 add py3.4 support req'd to support py packages such as pandas
103
104 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
105 PyQt4-4.10.3-r3.ebuild:
106 Restrict sip dep to =4.15* for older PyQt4 versions.
107
108*PyQt4-4.11 (30 May 2014)
109
110 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
111 Version bump.
112
113 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
114 PyQt4-4.10.3-r3.ebuild, metadata.xml:
115 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
116 Martin Walch in bug 510812.
117
118 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
119 -PyQt4-4.10.3.ebuild:
120 Drop the old versions that required python-exec:0.
121
122 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
123 Remove python herd as discussed with them.
124
125*PyQt4-4.10.3-r3 (27 Mar 2014)
126
127 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
128 Replace manual Python wrapping with proper eclass functions, bug #484404.
129
130 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
131 Stable for sparc, wrt bug #495638
132
133 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
134 Stable for x86, wrt bug #495638
135
136 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
137 Stable for alpha, wrt bug #495638
138
139 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
140 Stable for ia64, wrt bug #495638
141
142 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
143 Stable for ppc64, wrt bug #495638
144
145 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
146 amd64 stable, bug 495638
147
148 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
149 Stable for ppc, wrt bug #495638
150
151 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
152 arm stable, bug #495638
153
154 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
155 files/PyQt4-4.7.3-qreal_float_support.patch:
156 Updated qreal_float patch to remove first hunk (already applied
157 upstream). Tested on arm chromebook; no existing bug.
158
159*PyQt4-4.10.3-r2 (25 Dec 2013)
160
161 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
162 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
163 Introduce USE="designer".
164
165 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
166 old
167
168 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
169 Stable for sparc, wrt bug #483112
170
171 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
172 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
173 Update the ebuilds to dep on dev-lang/python-exec.
174
175 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
176 old
177
178*PyQt4-4.10.3-r1 (23 Oct 2013)
179
180 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
181 Support python-exec:2.
182
183 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
184 Depend on sip >=4.15.0 to fix build failure (bug #485274)
185
186 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
187 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
188 Add explicit dep on python-exec:0 since the package wraps the script manually.
189
190*PyQt4-4.10.3 (17 Sep 2013)
191
192 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
193 Version bump
194
195 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
196 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
197 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
198
199 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
200 arm stable, bug #483112
201
202 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
203 Stable for x86, wrt bug #483112
204
205 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
206 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
207 Clean up PYTHON_COMPAT from old implementations.
208
209 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
210 Stable for ppc64, wrt bug #483112
211
212 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
213 Stable for ppc, wrt bug #483112
214
215 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
216 Stable for ia64, wrt bug #483112
217
218 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
219 Stable for alpha, wrt bug #483112
220
221 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
222 Stable for amd64, wrt bug #483112
223
224 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
225 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
226 Reorder Qt dependencies.
227
228 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
229 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
230 Fixing qtgui/designer deps for qt-4.8.5
231
232 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
233 PyQt4-4.9.6-r2.ebuild:
234 Fixing qtgui deps for qt-4.8.5
235
236 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
237 Remove wrong usedep for qtgui.
238
239*PyQt4-4.10.2 (24 Jun 2013)
240
241 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
242 Version bump.
243
244 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
245 PyQt4-4.10.1.ebuild:
246 Add PYTHON_REQUIRED_USE. Remove old.
247
248*PyQt4-4.10.1 (22 May 2013)
249
250 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
251 Version bump.
252
253 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
254 Remove unused flag description from metadata
255
256 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
257 -files/PyQt4-4.7.2-configure.py.patch,
258 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
259 old
260
261*PyQt4-4.10 (12 Mar 2013)
262
263 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
264 Version bump. Fix also bug #433944 by Franz Fellner.
265
266 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
267 Stable for sparc, wrt bug #457046
268
269 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
270 PyQt4-4.9.6-r2.ebuild:
271 Move Qt dependencies to the new category
272
273 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
274 Stable for ia64, wrt bug #457046
275
276 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
277 Stable for ppc64, wrt bug #457046
278
279 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
280 Stable for ppc, wrt bug #457046
281
282 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
283 Stable for alpha, wrt bug #457046
284
285 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
286 Stable for arm, wrt bug #457046
287
288 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
289 Stable for x86, wrt bug #457046
290
291 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
292 Stable for amd64, wrt bug #457046
293
294 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
295 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
296
297 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
298 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
299 Fix double prefix; remove old.
300
301 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
302 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
303
304*PyQt4-4.9.6-r2 (29 Jan 2013)
305
306 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
307 Migrate to the new python eclass.
308
309 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
310 Improve pyqt4_use_enable() as suggested by Arfrever.
311
312 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
313 old
314
315*PyQt4-4.9.6-r1 (26 Dec 2012)
316
317 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
318 metadata.xml:
319 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
320 pyside: rename assistant to help, add script and scripttools (bug 431460 by
321 Arfrever).
322
323*PyQt4-4.9.6 (10 Dec 2012)
324
325 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
326 Version bump, with some minor updates from qt overlay.
327
328 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
329 arm stable, bug #435074
330
331 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
332 PyQt4-4.9.4-r1.ebuild:
333 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
334
335 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
336 -PyQt4-4.9.1.ebuild:
337 Remove old
338
339*PyQt4-4.9.5 (05 Oct 2012)
340
341 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
342 Version bump
343
344 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
345 alpha/ia64/sparc stable wrt #429042
346
347*PyQt4-4.9.4-r1 (03 Sep 2012)
348
349 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
350 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
351 Apply upstream patch to fix regression in pyuic's handling of custom widgets
352 (bug 431070 by Laurent Bachelier).
353
354 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
355 Stable for x86, wrt bug #429042
356
357 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
358 Stable for amd64, wrt bug #429042
359
360 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
361 Stable ppc64, bug #429042
362
363 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
364 Stable ppc, bug #429042
365
366 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
367 ia64 stable
368
369 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
370 -files/PyQt4-4.6.1-configure-multilib.patch:
371 Remove old.
372
373 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
374 PyQt4-4.9.4.ebuild:
375 alpha/ia64/sparc stable wrt #412929
376
377*PyQt4-4.9.4 (02 Jul 2012)
378
379 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
380 -PyQt4-4.9.3.ebuild:
381 Version bump.
382
383*PyQt4-4.9.3 (27 Jun 2012)
384
385 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
386 -PyQt4-4.9.2.ebuild:
387 Version bump.
388
389 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
390 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
391
392*PyQt4-4.9.2 (21 Jun 2012)
393
394 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
395 Version bump
396
397 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
398 Destabling to ~ia64 because last available stable qt will be masked pending
399 removal
400
401 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
402 marked x86 per bug 412929
403
404 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
405 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
406 Inherit eutils.
407
408 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
409 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
410 Revert previous change.
411
412 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
413 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
414 Restrict python 3.1 to match dev-python/dbus-python.
415
416 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
417 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
418
419 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
420 Migrating dev-util/pkgconfig -> virtual/pkgconfig
421
422 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
423 Stable for amd64, wrt bug #412929
424
425 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
426 Stable on alpha, bug #354033
427
428 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
429 PyQt4-4.8.4.ebuild:
430 PyQt4-4.8 does not build with sip-4.13, bug 407291
431
432 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
433 Slightly improve the ewarn message in pkg_postinst().
434
435 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
436 Put qt as the primary herd in metadata.
437
438 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
439 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
440 <slong@rathaus.eclipse.co.uk> in bug #407281.
441
442 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
443 Switch to EAPI 4, add REQUIRED_USE.
444
445 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
446 PyQt4-4.8.4.ebuild:
447 Drop ~x86-fbsd because of unkeyworded dependencies.
448
449 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
450 Don't enable QtAssistant module because it was removed in qt-4.7 and we
451 already depend on 4.7.2 or later.
452
453 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
454 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
455 Restrict pypy for older versions too.
456
457 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
458 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
459 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
460 version.
461
462 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
463 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
464 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
465 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
466 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
467 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
468
469 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
470 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
471 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
472 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
473 Fixing pypy restricts to actually work
474
475*PyQt4-4.9.1 (12 Feb 2012)
476
477 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
478 version bump
479
480 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
481 builds with qt-opengl-4.8.0[egl], updated dep
482
483 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
484 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
485 Fixes backported from Progress Overlay. Patch by Arfrever.
486
487*PyQt4-4.9 (24 Dec 2011)
488
489 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
490 Version bump
491
492*PyQt4-4.8.6 (11 Nov 2011)
493
494 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
495 Version bump
496
497 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
498 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
499 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
500 python overlay.
501
502*PyQt4-4.8.5 (19 Aug 2011)
503
504 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
505 Version bump
506
507 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
508 ppc/ppc64 stable wrt #374591
509
510 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
511 x86 stable, bug #374591
512
513 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
514 ppc64 stable wrt #354033
515
516 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
517 Stable on amd64 wrt bug #374591
518
519 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
520 Marking PyQt4-4.8.3 ppc stable for bug 354033
521
522 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
523 Stable on amd64 wrt bug #354033
524
525 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
526 x86 stable per bug 354033
527
528*PyQt4-4.8.4 (02 May 2011)
529
530 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
531 +PyQt4-4.8.4.ebuild:
532 Version bump.
533
534 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
535 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
536 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
537 Adapt phonon dependency for package move
538
539 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
540 ppc64 stable wrt #349607
541
542 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
543 ia64/sparc stable wrt #349607
544
545 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
546 Stable on alpha, bug #349607
547
548 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
549 PyQt4-4.8.3.ebuild:
550 Update dependencies (bug #353053).
551
552*PyQt4-4.8.3 (25 Jan 2011)
553
554 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
555 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
556 Version bump.
557
558 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
559 x86 stable wrt bug #349607
560
561 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
562 Marking PyQt4-4.8.1 ppc stable for bug 349607
563
564 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
565 Stable on amd64 wrt bug #349607
566
567 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
568 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
569 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
570
571*PyQt4-4.8.1-r1 (30 Dec 2010)
572
573 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
574 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
575 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
576
577 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
578 PyQt4-4.8.2.ebuild:
579 Fix dependencies (bug #349672).
580
581*PyQt4-4.8.2 (24 Dec 2010)
582
583 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
584 +PyQt4-4.8.2.ebuild:
585 Version bump.
586
587 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
588 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
589 Restrict Jython ABIs.
590
591 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
592 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
593 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
594 -files/configure.py.patch:
595 Delete.
596
597 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
598 old, depends on qt 4.5
599
600 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
601 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
602 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
603 Remove HPPA keywording (bug #239441).
604
605*PyQt4-4.8.1 (30 Oct 2010)
606
607 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
608 +PyQt4-4.8.1.ebuild:
609 Version bump.
610
611 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
612 ia64/sparc stable wrt #315775
613
614*PyQt4-4.8 (23 Oct 2010)
615
616 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
617 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
618 +PyQt4-4.8.ebuild, metadata.xml:
619 Version bump.
620
621*PyQt4-4.7.7-r1 (06 Oct 2010)
622
623 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
624 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
625 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
626
627*PyQt4-4.7.7 (21 Sep 2010)
628
629 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
630 +PyQt4-4.7.7.ebuild:
631 Version bump. Remove old bogus version
632
633 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
634 Stable on alpha, bug #315775
635
636 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
637 Marked ppc stable for bug #315775.
638
639 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
640 PyQt4-4.7.6.ebuild:
641 Update EAPI. Fix dependencies.
642
643*PyQt4-4.7.6 (08 Sep 2010)
644
645 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
646 +PyQt4-4.7.6.ebuild:
647 Version bump. Remove old ebuild
648
649 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
650 PyQt4-4.7.5.ebuild:
651 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
652
653*PyQt4-4.7.5 (01 Sep 2010)
654
655 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
656 +PyQt4-4.7.5.ebuild:
657 Version bump
658
659 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
660 Stable for HPPA (bug #315775).
661
662 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
663 Bump sip dependency to 4.10.3. Fix arm epatch command
664
665*PyQt4-4.7.4 (13 Jul 2010)
666
667 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
668 Version bump
669
670 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
671 ppc64 stable wrt #315775
672
673 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
674 +files/PyQt4-4.7.3-qreal_float_support.patch:
675 Add patch for qreal/float support in ARM wrt bug 322349
676
677 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
678 x86 stable wrt bug 315775
679
680 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
681 Stable on amd64 wrt bug 315775
682
683 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
684 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
685 Fix sip dep in PyQt4 ebuilds
686
687*PyQt4-4.7.3 (17 Apr 2010)
688
689 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
690 Version bump
691
692 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
693 ppc stable #301105
694
695*PyQt4-4.7.2 (18 Mar 2010)
696
697 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
698 +files/PyQt4-4.7.2-configure.py.patch:
699 Version bump. ChangeLog is no longer shipped. Update patch.
700
701 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
702 stable x86, bug 301105
703
704 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
705 amd64 stable wrt #301105
706
707 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
708 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
709 -files/fix_license_check.patch:
710 Drop old patches
711
712 10 Feb 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.6.2.ebuild:
713 Stable for HPPA (bug #300713).
714
715 08 Feb 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.6.2.ebuild:
716 stable x86, bug 300713
717
718 02 Feb 2010; Alex Alexander <wired@gentoo.org> PyQt4-4.5.4-r4.ebuild,
719 PyQt4-4.6.2.ebuild:
720 updated SRC_URI to use gentoo mirrors, upstream doesn't provide these
721 versions anymore
722
723 31 Jan 2010; <hwoarang@gentoo.org> PyQt4-4.6.2.ebuild:
724 Stable on amd64 wrt bug #300713
725
726 20 Jan 2010; Jonathan Callen <abcd@gentoo.org> PyQt4-4.7.ebuild:
727 Add prefix keywords, support
728
729*PyQt4-4.7 (15 Jan 2010)
730
731 15 Jan 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.ebuild:
732 Version bump
733
734 11 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
735 PyQt4-4.5.4-r4.ebuild, PyQt4-4.6.2.ebuild:
736 Don't call python_need_rebuild().
737
738 06 Jan 2010; <hwoarang@gentoo.org> PyQt4-4.6.2.ebuild:
739 Migrate to qt4-r2 eclass
740
741 02 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
742 PyQt4-4.5.4-r4.ebuild, PyQt4-4.6.2.ebuild:
743 Only restrict Python 3.2.
4 744
5 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> PyQt4-4.5.4-r4.ebuild, 745 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> PyQt4-4.5.4-r4.ebuild,
6 PyQt4-4.6.2.ebuild: 746 PyQt4-4.6.2.ebuild:
7 Adding RESTRICT_PYTHON_ABIS for python3. Current PyQt4 versions only work 747 Adding RESTRICT_PYTHON_ABIS for python3. Current PyQt4 versions only work
8 with python2. Fixes bug 292419. 748 with python2. Fixes bug 292419.
406*PyQt4-4.0_beta1 (05 May 2006) 1146*PyQt4-4.0_beta1 (05 May 2006)
407 1147
408 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1148 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
409 +PyQt4-4.0_beta1.ebuild: 1149 +PyQt4-4.0_beta1.ebuild:
410 initial import, from bug #121554 1150 initial import, from bug #121554
411

Legend:
Removed from v.1.99  
changed lines
  Added in v.1.287

  ViewVC Help
Powered by ViewVC 1.1.20