/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.147 Revision 1.292
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.147 2011/02/27 13:22:34 klausman Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.292 2015/06/29 21:07:51 pesa Exp $
4
5 29 Jun 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r2.ebuild:
6 Drop old version. As of now, sparc no longer has a stable PyQt4, see bug
7 #523322 comment #15.
8
9 17 Jun 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.3.ebuild:
10 Drop version that is not going to get stabilized.
11
12 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.4.ebuild:
13 Use the new --no-python-dbus configure option.
14
15 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.4.ebuild:
16 PyQt4 became GPL-3 only.
17
18*PyQt4-4.11.4 (14 Jun 2015)
19
20 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.4.ebuild:
21 Version bump.
22
23 09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
24 Updating remote-id in metadata.xml
25
26 11 May 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.2.ebuild,
27 PyQt4-4.11.3.ebuild:
28 Enable tracing with USE=debug; enable configure verbose output to get useful
29 build logs in bug reports; stop passing deprecated --no-timestamp option; use
30 qt4_get_bindir().
31
32 14 Apr 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
33 Stable for ia64, wrt bug #523322
34
35 08 Apr 2015; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.3-r2.ebuild:
36 Drop old Python implementations
37
38 17 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
39 Stable for ppc64, wrt bug #517344
40
41 16 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
42 Stable for ppc, wrt bug #517344
43
44 14 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
45 Stable for x86, wrt bug #517344
46
47 09 Jan 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.3.ebuild:
48 Stop using deprecated python_parallel_foreach_impl.
49
50 31 Dec 2014; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.3-r2.ebuild,
51 PyQt4-4.11.1.ebuild, PyQt4-4.11.2.ebuild:
52 Enforce USE dependency for media-libs/phonon.
53
54 10 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> PyQt4-4.11.1.ebuild:
55 amd64 stable wrt bug #517344
56
57 22 Nov 2014; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.11.1.ebuild:
58 Stable on alpha, bug 523322
59
60*PyQt4-4.11.3 (15 Nov 2014)
61
62 15 Nov 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.3.ebuild,
63 -PyQt4-4.11.3_pre20141024.ebuild:
64 Version bump.
65
66*PyQt4-4.11.3_pre20141024 (01 Nov 2014)
67
68 01 Nov 2014; Davide Pesavento <pesa@gentoo.org>
69 +PyQt4-4.11.3_pre20141024.ebuild, -PyQt4-4.11.2-r1.ebuild:
70 Bump to 4.11.3 prerelease, which contains upstream fixes for bugs #525392 and
71 #525470. Also switch to out-of-source builds.
72
73 15 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.2-r1.ebuild:
74 Fix bug #525392.
75
76 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
77 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
78 Fix building against media-libs/phonon (bug 525354).
79
80*PyQt4-4.11.2-r1 (13 Oct 2014)
81
82 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
83 metadata.xml:
84 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
85 from QtGui.
86
87 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
88 Revert to ~amd64, see bug #523322 comment #4.
89
90 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
91 Stable for amd64, wrt bug #523322
92
93 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
94 arm stable, bug #523322
95
96*PyQt4-4.11.2 (20 Sep 2014)
97
98 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
99 PyQt4-4.11.1.ebuild:
100 Version bump. Silence harmless repoman warning.
101
102 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
103 Drop deprecated python versions.
104
105 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
106 PyQt4-4.11.1.ebuild:
107 Stop using dohtml, remove old.
108
109 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
110 Remove old.
111
112*PyQt4-4.11.1 (15 Jul 2014)
113
114 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
115 PyQt4-4.11.ebuild:
116 Version bump.
117
118 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
119 PyQt4-4.11.ebuild:
120 add py3.4 support req'd to support py packages such as pandas
121
122 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
123 PyQt4-4.10.3-r3.ebuild:
124 Restrict sip dep to =4.15* for older PyQt4 versions.
125
126*PyQt4-4.11 (30 May 2014)
127
128 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
129 Version bump.
130
131 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
132 PyQt4-4.10.3-r3.ebuild, metadata.xml:
133 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
134 Martin Walch in bug 510812.
135
136 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
137 -PyQt4-4.10.3.ebuild:
138 Drop the old versions that required python-exec:0.
139
140 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
141 Remove python herd as discussed with them.
142
143*PyQt4-4.10.3-r3 (27 Mar 2014)
144
145 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
146 Replace manual Python wrapping with proper eclass functions, bug #484404.
147
148 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
149 Stable for sparc, wrt bug #495638
150
151 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
152 Stable for x86, wrt bug #495638
153
154 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
155 Stable for alpha, wrt bug #495638
156
157 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
158 Stable for ia64, wrt bug #495638
159
160 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
161 Stable for ppc64, wrt bug #495638
162
163 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
164 amd64 stable, bug 495638
165
166 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
167 Stable for ppc, wrt bug #495638
168
169 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
170 arm stable, bug #495638
171
172 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
173 files/PyQt4-4.7.3-qreal_float_support.patch:
174 Updated qreal_float patch to remove first hunk (already applied
175 upstream). Tested on arm chromebook; no existing bug.
176
177*PyQt4-4.10.3-r2 (25 Dec 2013)
178
179 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
180 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
181 Introduce USE="designer".
182
183 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
184 old
185
186 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
187 Stable for sparc, wrt bug #483112
188
189 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
190 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
191 Update the ebuilds to dep on dev-lang/python-exec.
192
193 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
194 old
195
196*PyQt4-4.10.3-r1 (23 Oct 2013)
197
198 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
199 Support python-exec:2.
200
201 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
202 Depend on sip >=4.15.0 to fix build failure (bug #485274)
203
204 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
205 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
206 Add explicit dep on python-exec:0 since the package wraps the script manually.
207
208*PyQt4-4.10.3 (17 Sep 2013)
209
210 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
211 Version bump
212
213 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
214 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
215 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
216
217 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
218 arm stable, bug #483112
219
220 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
221 Stable for x86, wrt bug #483112
222
223 05 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
224 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
225 Clean up PYTHON_COMPAT from old implementations.
226
227 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
228 Stable for ppc64, wrt bug #483112
229
230 04 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
231 Stable for ppc, wrt bug #483112
232
233 03 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
234 Stable for ia64, wrt bug #483112
235
236 02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
237 Stable for alpha, wrt bug #483112
238
239 31 Aug 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
240 Stable for amd64, wrt bug #483112
241
242 22 Jul 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.1.ebuild,
243 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
244 Reorder Qt dependencies.
245
246 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
247 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
248 Fixing qtgui/designer deps for qt-4.8.5
249
250 10 Jul 2013; Patrick Lauer <patrick@gentoo.org> PyQt4-4.10.1.ebuild,
251 PyQt4-4.9.6-r2.ebuild:
252 Fixing qtgui deps for qt-4.8.5
253
254 08 Jul 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.2.ebuild:
255 Remove wrong usedep for qtgui.
256
257*PyQt4-4.10.2 (24 Jun 2013)
258
259 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.2.ebuild:
260 Version bump.
261
262 24 Jun 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.ebuild,
263 PyQt4-4.10.1.ebuild:
264 Add PYTHON_REQUIRED_USE. Remove old.
265
266*PyQt4-4.10.1 (22 May 2013)
267
268 22 May 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.10.1.ebuild:
269 Version bump.
270
271 10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
272 Remove unused flag description from metadata
273
274 04 May 2013; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4-r1.ebuild,
275 -files/PyQt4-4.7.2-configure.py.patch,
276 -files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
277 old
278
279*PyQt4-4.10 (12 Mar 2013)
280
281 12 Mar 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.ebuild:
282 Version bump. Fix also bug #433944 by Franz Fellner.
283
284 11 Mar 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
285 Stable for sparc, wrt bug #457046
286
287 03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.4-r1.ebuild,
288 PyQt4-4.9.6-r2.ebuild:
289 Move Qt dependencies to the new category
290
291 21 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
292 Stable for ia64, wrt bug #457046
293
294 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
295 Stable for ppc64, wrt bug #457046
296
297 18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
298 Stable for ppc, wrt bug #457046
299
300 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
301 Stable for alpha, wrt bug #457046
302
303 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
304 Stable for arm, wrt bug #457046
305
306 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
307 Stable for x86, wrt bug #457046
308
309 15 Feb 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.6-r2.ebuild:
310 Stable for amd64, wrt bug #457046
311
312 15 Feb 2013; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r2.ebuild:
313 BUILDDIR -> BUILD_DIR, fixes bug 457538 by ago.
314
315 13 Feb 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r1.ebuild,
316 -PyQt4-4.9.6.ebuild, PyQt4-4.9.6-r2.ebuild:
317 Fix double prefix; remove old.
318
319 04 Feb 2013; Michael Palimaka <kensington@gentoo.org> PyQt4-4.9.6-r2.ebuild:
320 Use run_in_build_dir. Add python-3.3 support wrt bug #455020.
321
322*PyQt4-4.9.6-r2 (29 Jan 2013)
323
324 29 Jan 2013; Michael Palimaka <kensington@gentoo.org> +PyQt4-4.9.6-r2.ebuild:
325 Migrate to the new python eclass.
326
327 27 Dec 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.6-r1.ebuild:
328 Improve pyqt4_use_enable() as suggested by Arfrever.
329
330 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.5.ebuild:
331 old
332
333*PyQt4-4.9.6-r1 (26 Dec 2012)
334
335 26 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6-r1.ebuild,
336 metadata.xml:
337 EAPI=5 to be able to use slot operators in sip dependency. Sync USE flags with
338 pyside: rename assistant to help, add script and scripttools (bug 431460 by
339 Arfrever).
340
341*PyQt4-4.9.6 (10 Dec 2012)
342
343 10 Dec 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.6.ebuild:
344 Version bump, with some minor updates from qt overlay.
345
346 22 Nov 2012; Markus Meier <maekke@gentoo.org> PyQt4-4.9.4-r1.ebuild:
347 arm stable, bug #435074
348
349 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
350 PyQt4-4.9.4-r1.ebuild:
351 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
352
353 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
354 -PyQt4-4.9.1.ebuild:
355 Remove old
356
357*PyQt4-4.9.5 (05 Oct 2012)
358
359 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
360 Version bump
361
362 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
363 alpha/ia64/sparc stable wrt #429042
364
365*PyQt4-4.9.4-r1 (03 Sep 2012)
366
367 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
368 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
369 Apply upstream patch to fix regression in pyuic's handling of custom widgets
370 (bug 431070 by Laurent Bachelier).
371
372 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
373 Stable for x86, wrt bug #429042
374
375 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
376 Stable for amd64, wrt bug #429042
377
378 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
379 Stable ppc64, bug #429042
380
381 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
382 Stable ppc, bug #429042
383
384 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
385 ia64 stable
386
387 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
388 -files/PyQt4-4.6.1-configure-multilib.patch:
389 Remove old.
390
391 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
392 PyQt4-4.9.4.ebuild:
393 alpha/ia64/sparc stable wrt #412929
394
395*PyQt4-4.9.4 (02 Jul 2012)
396
397 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
398 -PyQt4-4.9.3.ebuild:
399 Version bump.
400
401*PyQt4-4.9.3 (27 Jun 2012)
402
403 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
404 -PyQt4-4.9.2.ebuild:
405 Version bump.
406
407 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
408 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
409
410*PyQt4-4.9.2 (21 Jun 2012)
411
412 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
413 Version bump
414
415 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
416 Destabling to ~ia64 because last available stable qt will be masked pending
417 removal
418
419 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
420 marked x86 per bug 412929
421
422 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
423 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
424 Inherit eutils.
425
426 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
427 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
428 Revert previous change.
429
430 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
431 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
432 Restrict python 3.1 to match dev-python/dbus-python.
433
434 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
435 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
436
437 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
438 Migrating dev-util/pkgconfig -> virtual/pkgconfig
439
440 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
441 Stable for amd64, wrt bug #412929
442
443 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
444 Stable on alpha, bug #354033
445
446 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
447 PyQt4-4.8.4.ebuild:
448 PyQt4-4.8 does not build with sip-4.13, bug 407291
449
450 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
451 Slightly improve the ewarn message in pkg_postinst().
452
453 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
454 Put qt as the primary herd in metadata.
455
456 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
457 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
458 <slong@rathaus.eclipse.co.uk> in bug #407281.
459
460 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
461 Switch to EAPI 4, add REQUIRED_USE.
462
463 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
464 PyQt4-4.8.4.ebuild:
465 Drop ~x86-fbsd because of unkeyworded dependencies.
466
467 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
468 Don't enable QtAssistant module because it was removed in qt-4.7 and we
469 already depend on 4.7.2 or later.
470
471 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
472 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
473 Restrict pypy for older versions too.
474
475 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
476 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
477 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
478 version.
479
480 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
481 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
482 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
483 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
484 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
485 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
486
487 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
488 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
489 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
490 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
491 Fixing pypy restricts to actually work
492
493*PyQt4-4.9.1 (12 Feb 2012)
494
495 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
496 version bump
497
498 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
499 builds with qt-opengl-4.8.0[egl], updated dep
500
501 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
502 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
503 Fixes backported from Progress Overlay. Patch by Arfrever.
504
505*PyQt4-4.9 (24 Dec 2011)
506
507 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
508 Version bump
509
510*PyQt4-4.8.6 (11 Nov 2011)
511
512 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
513 Version bump
514
515 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
516 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
517 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
518 python overlay.
519
520*PyQt4-4.8.5 (19 Aug 2011)
521
522 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
523 Version bump
524
525 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
526 ppc/ppc64 stable wrt #374591
527
528 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
529 x86 stable, bug #374591
530
531 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
532 ppc64 stable wrt #354033
533
534 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
535 Stable on amd64 wrt bug #374591
536
537 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
538 Marking PyQt4-4.8.3 ppc stable for bug 354033
539
540 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
541 Stable on amd64 wrt bug #354033
542
543 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
544 x86 stable per bug 354033
545
546*PyQt4-4.8.4 (02 May 2011)
547
548 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
549 +PyQt4-4.8.4.ebuild:
550 Version bump.
551
552 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
553 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
554 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
555 Adapt phonon dependency for package move
556
557 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
558 ppc64 stable wrt #349607
559
560 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
561 ia64/sparc stable wrt #349607
4 562
5 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild: 563 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
6 Stable on alpha, bug #349607 564 Stable on alpha, bug #349607
7 565
8 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 566 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
606*PyQt4-4.0_beta1 (05 May 2006) 1164*PyQt4-4.0_beta1 (05 May 2006)
607 1165
608 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 1166 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
609 +PyQt4-4.0_beta1.ebuild: 1167 +PyQt4-4.0_beta1.ebuild:
610 initial import, from bug #121554 1168 initial import, from bug #121554
611

Legend:
Removed from v.1.147  
changed lines
  Added in v.1.292

  ViewVC Help
Powered by ViewVC 1.1.20