/[gentoo-x86]/dev-python/python-keystoneclient/python-keystoneclient-1.5.0.ebuild
Gentoo

Contents of /dev-python/python-keystoneclient/python-keystoneclient-1.5.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (hide annotations) (download)
Sat May 30 01:43:54 2015 UTC (5 years, 3 months ago) by prometheanfire
Branch: MAIN
CVS Tags: HEAD
bup

(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)

1 prometheanfire 1.1 # Copyright 1999-2015 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3     # $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-1.4.0.ebuild,v 1.2 2015/04/28 00:55:04 prometheanfire Exp $
4    
5     EAPI=5
6     PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
7    
8     inherit distutils-r1
9    
10     DESCRIPTION="Client Library for OpenStack Identity"
11     HOMEPAGE="http://www.openstack.org/"
12     SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13    
14     LICENSE="Apache-2.0"
15     SLOT="0"
16     KEYWORDS="~amd64 ~amd64-linux ~x86 ~x86-linux"
17     IUSE="doc examples test"
18    
19     # Note: blacklist version not in portage:
20     #doc? ( !~dev-python/sphinx-1.3_preb1[${PYTHON_USEDEP}] )
21    
22     TCDEPEND="
23     >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
24     >=dev-python/mock-1.0[${PYTHON_USEDEP}]
25     >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
26     >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
27     >=dev-python/tempest-lib-0.5.0[${PYTHON_USEDEP}]
28     >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
29     >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
30     "
31     DEPEND="
32     dev-python/setuptools[${PYTHON_USEDEP}]
33     >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
34     <dev-python/pbr-2.0[${PYTHON_USEDEP}]
35     test? (
36     ${TCDEPEND}
37     >=dev-python/hacking-0.10.0[${PYTHON_USEDEP}]
38     <dev-python/hacking-0.11[${PYTHON_USEDEP}]
39     >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
40     >=dev-python/keyring-2.1[${PYTHON_USEDEP}]
41     !~dev-python/keyring-3.3[${PYTHON_USEDEP}]
42     >=dev-python/oauthlib-0.6[${PYTHON_USEDEP}]
43     >=dev-python/oslotest-1.5.1[${PYTHON_USEDEP}]
44     >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
45     >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
46     >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
47     >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
48     !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
49     )
50     doc? (
51     ${TCDEPEND}
52     >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
53     >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
54     >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
55     !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
56     <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
57     )
58     "
59     RDEPEND="
60     >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
61     >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
62     >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
63     >=dev-python/oslo-config-1.11.0[${PYTHON_USEDEP}]
64     >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
65     >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
66     >=dev-python/oslo-utils-1.4.0[${PYTHON_USEDEP}]
67     >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
68     <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
69     >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
70     >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
71     >=dev-python/stevedore-1.3.0[${PYTHON_USEDEP}]
72     "
73     PATCHES=(
74     )
75    
76     python_prepare_all() {
77     use doc && esetup.py build_sphinx
78     distutils-r1_python_prepare_all
79     }
80    
81     python_test() {
82     rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
83    
84     testr init || die "testr init failed under ${EPYTHON}"
85     testr run || die "testr run failed under ${EPYTHON}"
86     }
87    
88     python_install_all() {
89     use doc && local HTML_DOCS=( doc/build/html/. )
90     use examples && local EXAMPLES=( examples/. )
91    
92     distutils-r1_python_install_all
93     }

  ViewVC Help
Powered by ViewVC 1.1.20