/[gentoo-x86]/dev-ruby/activerecord/activerecord-4.2.2.ebuild
Gentoo

Contents of /dev-ruby/activerecord/activerecord-4.2.2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (show annotations) (download)
Tue Jun 16 21:59:35 2015 UTC (2 years, 5 months ago) by graaff
Branch: MAIN
CVS Tags: HEAD
Version bump.

(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)

1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.2.1.ebuild,v 1.2 2015/06/09 14:39:00 mrueg Exp $
4
5 EAPI=5
6 USE_RUBY="ruby19 ruby20 ruby21"
7
8 # this is not null so that the dependencies will actually be filled
9 RUBY_FAKEGEM_TASK_TEST="test"
10
11 RUBY_FAKEGEM_TASK_DOC=""
12 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
13
14 RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
15
16 inherit ruby-fakegem versionator
17
18 DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
19 HOMEPAGE="https://github.com/rails/rails/"
20 SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
21
22 LICENSE="MIT"
23 SLOT="$(get_version_component_range 1-2)"
24 KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
25 IUSE="mysql postgres sqlite"
26
27 RUBY_S="rails-${PV}/${PN}"
28
29 ruby_add_rdepend "~dev-ruby/activesupport-${PV}
30 ~dev-ruby/activemodel-${PV}
31 >=dev-ruby/arel-6.0:6.0
32 sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
33 mysql? ( >=dev-ruby/mysql2-0.3.13:0.3 )
34 postgres? ( >=dev-ruby/pg-0.15.0 )"
35
36 ruby_add_bdepend "
37 test? (
38 dev-ruby/bundler
39 ~dev-ruby/actionpack-${PV}
40 ~dev-ruby/actionmailer-${PV}
41 >=dev-ruby/sqlite3-1.3.5
42 dev-ruby/mocha:0.13
43 <dev-ruby/minitest-5.4:5
44 )"
45
46 all_ruby_prepare() {
47 # Remove items from the common Gemfile that we don't need for this
48 # test run. This also requires handling some gemspecs.
49 rm ../Gemfile.lock || die
50 sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\)/ s:^:#:" \
51 -e '/:job/,/end/ s:^:#:' \
52 -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
53 sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
54 sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
55
56 sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
57
58 # Add back json in the Gemfile because we dropped some dependencies
59 # earlier that implicitly required it.
60 sed -i -e '$agem "json"' ../Gemfile || die
61
62 # Avoid test depending on mysql adapter which we don't support for
63 # this Rails version to simplify our dependencies.
64 rm test/cases/connection_specification/resolver_test.rb || die
65
66 # Avoid single test using mysql dependencies.
67 rm test/cases/invalid_connection_test.rb || die
68 }
69
70 each_ruby_test() {
71 if use sqlite; then
72 ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
73 fi
74 }

  ViewVC Help
Powered by ViewVC 1.1.20