/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Diff of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.106 Revision 1.176
1# ChangeLog for dev-ruby/rails 1# ChangeLog for dev-ruby/rails
2# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.106 2008/05/16 17:37:47 nixnut Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.176 2010/09/05 09:22:59 graaff Exp $
4
5*rails-2.3.9 (05 Sep 2010)
6
7 05 Sep 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.9.ebuild:
8 Version bump for Rails 2.3.9
9
10*rails-2.3.8 (31 May 2010)
11
12 31 May 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.8.ebuild:
13 Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
14 dependency.
15
16*rails-2.3.5-r3 (23 May 2010)
17
18 23 May 2010; Alex Legler <a3li@gentoo.org> +rails-2.3.5-r3.ebuild:
19 Add REE18 support
20
21 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> rails-2.3.5.ebuild,
22 -rails-2.3.5-r1.ebuild, rails-2.3.5-r2.ebuild:
23 Cleanup old versions, use new syntax.
24
25 21 Feb 2010; Jonathan Callen <abcd@gentoo.org> rails-2.3.5-r2.ebuild:
26 Transfer prefix keywords (no other changes)
27
28*rails-2.3.5-r2 (17 Feb 2010)
29
30 17 Feb 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.5-r2.ebuild:
31 Install more files so that creating a new project works again, fixing
32 #303581.
33
34 13 Feb 2010; Raúl Porcel <armin76@gentoo.org> rails-2.3.5-r1.ebuild:
35 Add ~ia64/~sparc
36
37 01 Feb 2010; Markus Meier <maekke@gentoo.org> rails-2.3.5-r1.ebuild:
38 add ~x86, bug #301007
39
40 18 Jan 2010; Brent Baude <ranger@gentoo.org> rails-2.3.5-r1.ebuild:
41 Marking rails-2.3.5-r1 ~ppc64 for bug 301007
42
43 18 Jan 2010; Brent Baude <ranger@gentoo.org> rails-2.3.5-r1.ebuild:
44 Marking rails-2.3.5-r1 ~ppc for bug 301007
45
46*rails-2.3.5-r1 (14 Jan 2010)
47
48 14 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
49 +rails-2.3.5-r1.ebuild:
50 Bump to ruby-fakegem. Tests cannot be executed because upstream does not
51 package them.
52
53 20 Dec 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.3.ebuild,
54 -rails-2.3.4.ebuild:
55 Removing vulnerable versions
56
57 19 Dec 2009; Jeroen Roovers <jer@gentoo.org> rails-2.2.3-r1.ebuild,
58 rails-2.3.5.ebuild:
59 Stable for PPC (bug #294797).
60
61 30 Nov 2009; Raúl Porcel <armin76@gentoo.org> rails-2.2.3-r1.ebuild,
62 rails-2.3.5.ebuild:
63 ia64/sparc stable wrt #294797
64
65 30 Nov 2009; Brent Baude <ranger@gentoo.org> rails-2.2.3-r1.ebuild,
66 rails-2.3.5.ebuild:
67 Marking rails-2.3.5 ppc64 stable for bug 294797
68
69 30 Nov 2009; Markus Meier <maekke@gentoo.org> rails-2.3.5.ebuild:
70 amd64/x86 stable, bug #294797
71
72 30 Nov 2009; Markus Meier <maekke@gentoo.org> rails-2.2.3-r1.ebuild:
73 amd64/x86 stable, bug #294797
74
75*rails-2.2.3-r1 (28 Nov 2009)
76
77 28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.2.3-r1.ebuild:
78 Revision bump, security bug 294797.
79
80*rails-2.3.5 (28 Nov 2009)
81
82 28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.5.ebuild:
83 Version bump, security bug 294797
84
85 22 Oct 2009; Alex Legler <a3li@gentoo.org> -rails-1.2.6-r1.ebuild,
86 -rails-2.0.5-r1.ebuild, -rails-2.1.2-r1.ebuild:
87 Removing three old versions
88
89 18 Oct 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.2-r1.ebuild:
90 removing vulnerable ebuild, bug 283396
91
92 18 Oct 2009; nixnut <nixnut@gentoo.org> rails-2.2.3.ebuild:
93 ppc stable #283396
94
95 18 Oct 2009; Brent Baude <ranger@gentoo.org> rails-2.2.3.ebuild:
96 Marking rails-2.2.3 ppc64 stable for bug 283396
97
98 08 Oct 2009; Raúl Porcel <armin76@gentoo.org> rails-2.2.3.ebuild:
99 ia64/sparc stable wrt #283396
100
101 07 Oct 2009; Markus Meier <maekke@gentoo.org> rails-2.2.3.ebuild:
102 amd64 stable, bug #283396
103
104 04 Oct 2009; Christian Faulhammer <fauli@gentoo.org> rails-2.2.3.ebuild:
105 stable x86, bug 283396
106
107*rails-2.2.3 (03 Oct 2009)
108
109 03 Oct 2009; Alex Legler <a3li@gentoo.org> +rails-2.2.3.ebuild:
110 Version bump, security bug 283396
111
112 26 Sep 2009; Hans de Graaff <graaff@gentoo.org> -rails-2.3.2.ebuild,
113 -rails-2.3.3.ebuild:
114 Remove insecure versions, bug 283396.
115
116 26 Sep 2009; Hans de Graaff <graaff@gentoo.org> ChangeLog:
117 Remove insecure versions, bug 283396.
118
119 25 Sep 2009; Brent Baude <ranger@gentoo.org> rails-2.3.4.ebuild:
120 Marking rails-2.3.4 ppc64 stable for bug 283396
121
122 20 Sep 2009; nixnut <nixnut@gentoo.org> rails-2.3.4.ebuild:
123 ppc stable #283396
124
125 19 Sep 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.4.ebuild:
126 ia64/sparc stable wrt #283396
127
128 14 Sep 2009; Markus Meier <maekke@gentoo.org> rails-2.3.4.ebuild:
129 amd64/x86 stable, bug #283396
130
131 14 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org> rails-2.3.4.ebuild:
132 Bump rubygems requirement to 1.3.2.
133
134*rails-2.3.4 (04 Sep 2009)
135
136 04 Sep 2009; Hans de Graaff <graaff@gentoo.org> +rails-2.3.4.ebuild:
137 Version bump: fix security issues reported in #283396.
138
139 16 Aug 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.3.ebuild:
140 Add ~ia64 wrt #279123
141
142 26 Jul 2009; Hans de Graaff <graaff@gentoo.org> rails-2.3.3.ebuild:
143 Drop ia64 keyword #279123.
144
145*rails-2.3.3 (22 Jul 2009)
146
147 22 Jul 2009; Hans de Graaff <graaff@gentoo.org> +rails-2.3.3.ebuild:
148 Version bump for Rails 2.3.3.
149
150 28 May 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.2.ebuild:
151 ia64 stable wrt #270331
152
153 24 May 2009; Markus Meier <maekke@gentoo.org> rails-2.3.2.ebuild:
154 x86 stable, bug #270331
155
156 23 May 2009; Thomas Anderson <gentoofan23@gentoo.org> rails-2.3.2.ebuild:
157 stable amd64, bug 270331
158
159 23 May 2009; Brent Baude <ranger@gentoo.org> rails-2.3.2.ebuild:
160 Marking rails-2.3.2 ppc64 stable for bug 270331
161
162 23 May 2009; Brent Baude <ranger@gentoo.org> rails-2.3.2.ebuild:
163 Marking rails-2.3.2 ppc stable for bug 270331
164
165 18 May 2009; Ferris McCormick <fmccor@gentoo.org> rails-2.3.2.ebuild:
166 Sparc stable, Bug #270331.
167
168 18 May 2009; Hans de Graaff <graaff@gentoo.org> -rails-1.2.6.ebuild,
169 -rails-2.0.5.ebuild, -rails-2.1.2.ebuild, -rails-2.2.2.ebuild:
170 Remove old and vulnerable versions.
171
172*rails-2.3.2 (17 Mar 2009)
173
174 17 Mar 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.2.ebuild:
175 Version bump
176
177 10 Jan 2009; Raúl Porcel <armin76@gentoo.org> rails-1.2.6-r1.ebuild,
178 rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
179 ia64 stable wrt #253425
180
181 09 Jan 2009; Brent Baude <ranger@gentoo.org> rails-1.2.6-r1.ebuild,
182 rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
183 rails-1.2.6-r1 rails-2.0.5-r1 rails-2.1.2-r1 rails-2.2.2-r1 ppc stable for
184 bug 253425
185
186 07 Jan 2009; Ferris McCormick <fmccor@gentoo.org> rails-2.2.2-r1.ebuild:
187 Sparc stable, Bug #253425.
188
189 07 Jan 2009; Ferris McCormick <fmccor@gentoo.org> rails-1.2.6-r1.ebuild,
190 rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild:
191 Sparc stable, part of Bug #253425.
192
193 07 Jan 2009; Brent Baude <ranger@gentoo.org> rails-1.2.6-r1.ebuild,
194 rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
195 rails-1.2.6-r1 rails-2.0.5-r1 rails-2.1.2-r1 rails-2.2.2-r1 ppc64 stable
196
197 04 Jan 2009; Markus Meier <maekke@gentoo.org> rails-1.2.6-r1.ebuild,
198 rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
199 amd64/x86 stable, bug #253425
200
201 08 Dec 2008; Hans de Graaff <graaff@gentoo.org> rails-2.2.2-r1.ebuild:
202 Add missing RDEPEND on >=rubygems-1.3.1 as per #250245.
203
204 03 Dec 2008; Hans de Graaff <graaff@gentoo.org> rails-1.2.6-r1.ebuild:
205 Fix quoting.
206
207*rails-2.2.2-r1 (03 Dec 2008)
208*rails-2.1.2-r1 (03 Dec 2008)
209*rails-2.0.5-r1 (03 Dec 2008)
210*rails-1.2.6-r1 (03 Dec 2008)
211
212 03 Dec 2008; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6-r1.ebuild,
213 +rails-2.0.5-r1.ebuild, +rails-2.1.2-r1.ebuild, +rails-2.2.2-r1.ebuild:
214 Make sure /usr/bin/rails loads the correct version of rails. Depend on and use
215 select-rails-0.14 to simplify the rails update process. Fixes #221899. Thanks
216 to Mark Somerville for initial patches and Alex Legler for getting it ready
217 for the tree and testing.
218
219*rails-2.2.2 (27 Nov 2008)
220
221 27 Nov 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.2.2.ebuild:
222 Version bump for Rails 2.2.2
223
224 17 Nov 2008; Hans de Graaff <graaff@gentoo.org> -rails-2.0.2.ebuild,
225 -rails-2.0.4.ebuild, -rails-2.1.0.ebuild, -rails-2.1.1.ebuild:
226 Remove old, insecure, versions
227
228 15 Nov 2008; Tobias Scherbaum <dertobi123@gentoo.org> rails-2.0.5.ebuild,
229 rails-2.1.2.ebuild:
230 ppc stable, bug #237385
231
232 06 Nov 2008; Raúl Porcel <armin76@gentoo.org> rails-2.1.2.ebuild:
233 ia64 stable wrt #237385
234
235 05 Nov 2008; Markus Meier <maekke@gentoo.org> rails-2.0.5.ebuild:
236 amd64/x86 stable, bug #237385
237
238 04 Nov 2008; Brent Baude <ranger@gentoo.org> rails-2.0.5.ebuild,
239 rails-2.1.2.ebuild:
240 Marking rails-2.0.5|2.1.2 ppc64 for bug 237385
241
242 03 Nov 2008; Markus Meier <maekke@gentoo.org> rails-2.1.2.ebuild:
243 amd64/x86 stable, bug #237385
244
245 03 Nov 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.5.ebuild,
246 rails-2.1.2.ebuild:
247 Sparc stable, Security Bug #237385.
248
249*rails-2.1.2 (24 Oct 2008)
250
251 24 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.2.ebuild:
252 Version bump. Fixes security issue #242914 (header-injection) and #237285.
253 Also features minor fixes.
254
255*rails-2.0.5 (20 Oct 2008)
256
257 20 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.5.ebuild:
258 Version bump for Rails 2.0.5
259
260*rails-2.1.1 (13 Sep 2008)
261
262 13 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.1.ebuild:
263 Version bump for Rails 2.1.1, bug #237392
264
265*rails-2.0.4 (12 Sep 2008)
266
267 12 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.4.ebuild:
268 Version bump for Rails 2.0.4, bug #237385
269
270 13 Jul 2008; Hans de Graaff <graaff@gentoo.org>
271 -files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.6.ebuild,
272 -rails-1.1.6-r2.ebuild:
273 Belated removal for GLSA 200711-17
274
275 04 Jul 2008; Hans de Graaff <graaff@gentoo.org> rails-2.1.0.ebuild:
276 Rails now depends on rake 0.8.1 or better.
277
278 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> -rails-1.2.5.ebuild:
279 Remove old version
280
281*rails-2.1.0 (17 Jun 2008)
282
283 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.0.ebuild:
284 Version bump for Rails 2.1.0
4 285
5 16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild: 286 16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
6 Stable on ppc wrt bug 221309 287 Stable on ppc wrt bug 221309
7 288
8 13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild: 289 13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild:

Legend:
Removed from v.1.106  
changed lines
  Added in v.1.176

  ViewVC Help
Powered by ViewVC 1.1.20