/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Diff of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.48 Revision 1.106
1# ChangeLog for dev-ruby/rails 1# ChangeLog for dev-ruby/rails
2# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.48 2006/06/02 13:28:16 flameeyes Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.106 2008/05/16 17:37:47 nixnut Exp $
4
5 16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
6 Stable on ppc wrt bug 221309
7
8 13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild:
9 ia64 stable wrt #221309
10
11 13 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
12 Sparc stable (again), following Hans de Graff's comment 7 in Bug #221309.
13 RMD160 for rails-2.0.2.gem should now be correct.
14
15 12 May 2008; Markus Rothe <corsair@gentoo.org> rails-2.0.2.ebuild:
16 Stable on ppc64; bug #221309
17
18 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
19 Back to ~sparc because of Friedrich Oslage's comments in Bug #221309.
20
21 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
22 Sparc stable --- part of Bug #221309 --- Good for about 5 months.
23
24 11 May 2008; Markus Meier <maekke@gentoo.org> rails-2.0.2.ebuild:
25 x86 stable, bug #221309
26
27 11 May 2008; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
28 Stable on amd64, bug #221309
29
30 19 Mar 2008; Hans de Graaff <graaff@gentoo.org> Manifest:
31 Redigest due to upstream repackaging
32
33 04 Jan 2008; <nichoj@gentoo.org> ChangeLog:
34 Updated dependencies not to relay on specific version, and allowing for
35 later revisions (ie change =dev-ruby/activerecord-2.0.2 to
36 ~dev-ruby/activerecord-2.0.2.
37
38 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
39 Fix quoting; database USE flags have moved to dev-ruby/activerecord, make this
40 a warn instead of an info message.
41
42*rails-2.0.2 (18 Dec 2007)
43
44 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rails-2.0.2.ebuild:
45 Version bump for Rails 2.0.2
46
47 01 Dec 2007; Christoph Mende <angelos@gentoo.org> rails-1.2.6.ebuild:
48 Stable on amd64 wrt bug #200159
49
50 01 Dec 2007; Hans de Graaff <graaff@gentoo.org> -rails-1.2.3.ebuild,
51 -rails-1.2.3-r1.ebuild, -rails-1.2.4.ebuild:
52 Remove old vulnerable versions
53
54 27 Nov 2007; Markus Rothe <corsair@gentoo.org> rails-1.2.6.ebuild:
55 Added ~ppc64; bug #200159
56
57 27 Nov 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.6.ebuild:
58 ia64/sparc stable wrt security #200159
59
60 26 Nov 2007; Brent Baude <ranger@gentoo.org> rails-1.2.6.ebuild:
61 Marking rails-1.2.6 ppc for bug 200159
62
63 26 Nov 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.6.ebuild:
64 stable x86, security bug 200159
65
66*rails-1.2.6 (25 Nov 2007)
67
68 25 Nov 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6.ebuild:
69 Version bump for Rails 1.2.6, security bug #200159
70
71 21 Oct 2007; Steve Dibb <beandog@gentoo.org> rails-1.2.5.ebuild:
72 amd64 stable, security bug 195315
73
74 18 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.2.5.ebuild:
75 ppc stable, bug #195315
76
77 16 Oct 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.5.ebuild:
78 ia64/sparc stable wrt security #195315
79
80 16 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.5.ebuild:
81 Add back the dependency on eselect-rails that got dropped somehow after
82 rails-1.2.3-r1
83
84 16 Oct 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.5.ebuild:
85 stable x86, security bug 195315
86
87*rails-1.2.5 (13 Oct 2007)
88
89 13 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.5.ebuild:
90 Version bump with security fixes, bug 195315
91
92 07 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.4.ebuild:
93 Add back the code that handles eselect, I must have used the wrong file to
94 start from :-(
95
96 06 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
97 rails-1.2.3-r1.ebuild:
98 stable x86, bug 177209
99
100*rails-1.2.4 (06 Oct 2007)
101
102 06 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.4.ebuild:
103 Version bump for rails 1.2.4
104
105 06 Oct 2007; Hans de Graaff <graaff@gentoo.org>
106 -files/rails-1.0.0-rdoc-rake-0.7.patch, -rails-1.1.6-r1.ebuild,
107 -rails-1.2.0.ebuild, -rails-1.2.1.ebuild, -rails-1.2.2.ebuild:
108 Remove versions that are old or won't become stable
109
110 06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
111 rails-1.2.3-r1.ebuild:
112 ppc stable, bug #177209
113
114 05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> rails-1.2.3-r1.ebuild:
115 Sparc stable --- Bug #177209
116
117 03 Sep 2007; Joshua Nichols <nichoj@gentoo.org> rails-1.1.6.ebuild,
118 rails-1.1.6-r1.ebuild, rails-1.1.6-r2.ebuild, rails-1.2.0.ebuild,
119 rails-1.2.1.ebuild, rails-1.2.2.ebuild, rails-1.2.3.ebuild,
120 rails-1.2.3-r1.ebuild:
121 Changed eselect-rails from PDEPEND to DEPEND. Moved blockers from
122 eselect-rails to here. Should address bug #172812.
123
124*rails-1.2.3-r1 (01 Sep 2007)
125*rails-1.1.6-r2 (01 Sep 2007)
126
127 01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.1.6-r2.ebuild,
128 +rails-1.2.3-r1.ebuild:
129 Revision bumps for both slots. No longer installs /usr/bin/rails. Instead,
130 uses app-admin/eselect-rails to manage the symlink.
131
132 14 Mar 2007; Richard Brown <rbrown@gentoo.org> rails-1.2.3.ebuild:
133 Fix rails-1.2.3 rake dependency
134
135*rails-1.2.3 (14 Mar 2007)
136
137 14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.3.ebuild:
138 Version bump for rails 1.2.3.
139
140*rails-1.2.2 (11 Feb 2007)
141
142 11 Feb 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.2.ebuild:
143 Version bump.
144
145 10 Feb 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
146 rails-1.1.6.ebuild, rails-1.1.6-r1.ebuild, rails-1.2.0.ebuild,
147 rails-1.2.1.ebuild:
148 Updated rails license to MIT, #165876
149
150*rails-1.2.1 (21 Jan 2007)
151
152 21 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
153 -rails-1.2.0_rc1.ebuild, +rails-1.2.1.ebuild:
154 1.2.1 in, 1.2.0_rc1 out
155
156*rails-1.2.0 (19 Jan 2007)
157
158 19 Jan 2007; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0.ebuild:
159 rails 1.2.0
160
161*rails-1.2.0_rc1 (24 Nov 2006)
162
163 24 Nov 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0_rc1.ebuild:
164 1.2.0_rc1
165
166*rails-1.1.6-r1 (03 Oct 2006)
167
168 03 Oct 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
169 +files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.2.ebuild,
170 -rails-1.1.3.ebuild, -rails-1.1.4.ebuild, -rails-1.1.5.ebuild,
171 +rails-1.1.6-r1.ebuild:
172 Removed old ebuilds. Added 1.1.6-r1 to ignore lighttpd older than 1.4.10
173 (bug #133500)
174
175 02 Sep 2006; Bryan Østergaard <kloeri@gentoo.org> rails-1.1.6.ebuild:
176 Stable on ia64.
177
178*rails-1.1.6 (10 Aug 2006)
179
180 10 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.6.ebuild:
181 version bump
182
183 10 Aug 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.5.ebuild:
184 Stable on sparc --- Bug #143369 (mandatory security upgrade) --- installs and
185 works.
186
187 10 Aug 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.5.ebuild:
188 Stable x86; bug # 143369
189
190 09 Aug 2006; Thomas Cort <tcort@gentoo.org> rails-1.1.5.ebuild:
191 Stable on amd64 wrt security Bug #143369.
192
193 09 Aug 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.5.ebuild:
194 ppc stable, bug #143369
195
196*rails-1.1.5 (09 Aug 2006)
197
198 09 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.5.ebuild:
199 version bump
200
201 31 Jul 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.4.ebuild:
202 stable on amd64 wrt bug 138323
203
204 13 Jul 2006; Aron Griffis <agriffis@gentoo.org> rails-1.1.4.ebuild:
205 Mark 1.1.4 stable on ia64. #138323
206
207 06 Jul 2006; Jason Wever <weeve@gentoo.org> rails-1.1.4.ebuild:
208 Stable on SPARC wrt security bug #138323.
209
210 05 Jul 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.4.ebuild:
211 Stable x86; bug #138323
212
213 03 Jul 2006; Lars Weiler <pylon@gentoo.org> rails-1.1.4.ebuild:
214 Stable on ppc; security bug #138323.
215
216*rails-1.1.4 (03 Jul 2006)
217
218 03 Jul 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.4.ebuild:
219 Version bump
220
221*rails-1.1.3 (28 Jun 2006)
222
223 28 Jun 2006; Caleb Tennis <caleb@gentoo.org> -rails-1.0.0.ebuild,
224 -rails-1.1.0.ebuild, -rails-1.1.1.ebuild, +rails-1.1.3.ebuild:
225 version bump, remove old versions
226
227 25 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.2.ebuild:
228 ppc stable, bug #133003
229
230 14 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> rails-1.1.2.ebuild:
231 Somebody left out ppc. It works fine here.
232
233 06 Jun 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.2.ebuild:
234 stable on amd64
4 235
5 02 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> 236 02 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
6 +files/rails-1.0.0-rdoc-rake-0.7.patch, rails-1.0.0.ebuild: 237 +files/rails-1.0.0-rdoc-rake-0.7.patch, rails-1.0.0.ebuild:
7 Add patch to fix rdoc call with rake 0.7. Thanks to Stephen Tallowitz in bug 238 Add patch to fix rdoc call with rake 0.7. Thanks to Stephen Tallowitz in bug
8 #132692. 239 #132692.

Legend:
Removed from v.1.48  
changed lines
  Added in v.1.106

  ViewVC Help
Powered by ViewVC 1.1.20