/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Diff of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.62 Revision 1.111
1# ChangeLog for dev-ruby/rails 1# ChangeLog for dev-ruby/rails
2# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.62 2006/08/10 03:58:36 tsunam Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.111 2008/09/12 05:58:12 graaff Exp $
4
5*rails-2.0.4 (12 Sep 2008)
6
7 12 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.4.ebuild:
8 Version bump for Rails 2.0.4, bug #237385
9
10 13 Jul 2008; Hans de Graaff <graaff@gentoo.org>
11 -files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.6.ebuild,
12 -rails-1.1.6-r2.ebuild:
13 Belated removal for GLSA 200711-17
14
15 04 Jul 2008; Hans de Graaff <graaff@gentoo.org> rails-2.1.0.ebuild:
16 Rails now depends on rake 0.8.1 or better.
17
18 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> -rails-1.2.5.ebuild:
19 Remove old version
20
21*rails-2.1.0 (17 Jun 2008)
22
23 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.0.ebuild:
24 Version bump for Rails 2.1.0
25
26 16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
27 Stable on ppc wrt bug 221309
28
29 13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild:
30 ia64 stable wrt #221309
31
32 13 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
33 Sparc stable (again), following Hans de Graff's comment 7 in Bug #221309.
34 RMD160 for rails-2.0.2.gem should now be correct.
35
36 12 May 2008; Markus Rothe <corsair@gentoo.org> rails-2.0.2.ebuild:
37 Stable on ppc64; bug #221309
38
39 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
40 Back to ~sparc because of Friedrich Oslage's comments in Bug #221309.
41
42 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
43 Sparc stable --- part of Bug #221309 --- Good for about 5 months.
44
45 11 May 2008; Markus Meier <maekke@gentoo.org> rails-2.0.2.ebuild:
46 x86 stable, bug #221309
47
48 11 May 2008; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
49 Stable on amd64, bug #221309
50
51 19 Mar 2008; Hans de Graaff <graaff@gentoo.org> Manifest:
52 Redigest due to upstream repackaging
53
54 04 Jan 2008; <nichoj@gentoo.org> ChangeLog:
55 Updated dependencies not to relay on specific version, and allowing for
56 later revisions (ie change =dev-ruby/activerecord-2.0.2 to
57 ~dev-ruby/activerecord-2.0.2.
58
59 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
60 Fix quoting; database USE flags have moved to dev-ruby/activerecord, make this
61 a warn instead of an info message.
62
63*rails-2.0.2 (18 Dec 2007)
64
65 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rails-2.0.2.ebuild:
66 Version bump for Rails 2.0.2
67
68 01 Dec 2007; Christoph Mende <angelos@gentoo.org> rails-1.2.6.ebuild:
69 Stable on amd64 wrt bug #200159
70
71 01 Dec 2007; Hans de Graaff <graaff@gentoo.org> -rails-1.2.3.ebuild,
72 -rails-1.2.3-r1.ebuild, -rails-1.2.4.ebuild:
73 Remove old vulnerable versions
74
75 27 Nov 2007; Markus Rothe <corsair@gentoo.org> rails-1.2.6.ebuild:
76 Added ~ppc64; bug #200159
77
78 27 Nov 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.6.ebuild:
79 ia64/sparc stable wrt security #200159
80
81 26 Nov 2007; Brent Baude <ranger@gentoo.org> rails-1.2.6.ebuild:
82 Marking rails-1.2.6 ppc for bug 200159
83
84 26 Nov 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.6.ebuild:
85 stable x86, security bug 200159
86
87*rails-1.2.6 (25 Nov 2007)
88
89 25 Nov 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6.ebuild:
90 Version bump for Rails 1.2.6, security bug #200159
91
92 21 Oct 2007; Steve Dibb <beandog@gentoo.org> rails-1.2.5.ebuild:
93 amd64 stable, security bug 195315
94
95 18 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.2.5.ebuild:
96 ppc stable, bug #195315
97
98 16 Oct 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.5.ebuild:
99 ia64/sparc stable wrt security #195315
100
101 16 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.5.ebuild:
102 Add back the dependency on eselect-rails that got dropped somehow after
103 rails-1.2.3-r1
104
105 16 Oct 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.5.ebuild:
106 stable x86, security bug 195315
107
108*rails-1.2.5 (13 Oct 2007)
109
110 13 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.5.ebuild:
111 Version bump with security fixes, bug 195315
112
113 07 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.4.ebuild:
114 Add back the code that handles eselect, I must have used the wrong file to
115 start from :-(
116
117 06 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
118 rails-1.2.3-r1.ebuild:
119 stable x86, bug 177209
120
121*rails-1.2.4 (06 Oct 2007)
122
123 06 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.4.ebuild:
124 Version bump for rails 1.2.4
125
126 06 Oct 2007; Hans de Graaff <graaff@gentoo.org>
127 -files/rails-1.0.0-rdoc-rake-0.7.patch, -rails-1.1.6-r1.ebuild,
128 -rails-1.2.0.ebuild, -rails-1.2.1.ebuild, -rails-1.2.2.ebuild:
129 Remove versions that are old or won't become stable
130
131 06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
132 rails-1.2.3-r1.ebuild:
133 ppc stable, bug #177209
134
135 05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> rails-1.2.3-r1.ebuild:
136 Sparc stable --- Bug #177209
137
138 03 Sep 2007; Joshua Nichols <nichoj@gentoo.org> rails-1.1.6.ebuild,
139 rails-1.1.6-r1.ebuild, rails-1.1.6-r2.ebuild, rails-1.2.0.ebuild,
140 rails-1.2.1.ebuild, rails-1.2.2.ebuild, rails-1.2.3.ebuild,
141 rails-1.2.3-r1.ebuild:
142 Changed eselect-rails from PDEPEND to DEPEND. Moved blockers from
143 eselect-rails to here. Should address bug #172812.
144
145*rails-1.2.3-r1 (01 Sep 2007)
146*rails-1.1.6-r2 (01 Sep 2007)
147
148 01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.1.6-r2.ebuild,
149 +rails-1.2.3-r1.ebuild:
150 Revision bumps for both slots. No longer installs /usr/bin/rails. Instead,
151 uses app-admin/eselect-rails to manage the symlink.
152
153 14 Mar 2007; Richard Brown <rbrown@gentoo.org> rails-1.2.3.ebuild:
154 Fix rails-1.2.3 rake dependency
155
156*rails-1.2.3 (14 Mar 2007)
157
158 14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.3.ebuild:
159 Version bump for rails 1.2.3.
160
161*rails-1.2.2 (11 Feb 2007)
162
163 11 Feb 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.2.ebuild:
164 Version bump.
165
166 10 Feb 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
167 rails-1.1.6.ebuild, rails-1.1.6-r1.ebuild, rails-1.2.0.ebuild,
168 rails-1.2.1.ebuild:
169 Updated rails license to MIT, #165876
170
171*rails-1.2.1 (21 Jan 2007)
172
173 21 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
174 -rails-1.2.0_rc1.ebuild, +rails-1.2.1.ebuild:
175 1.2.1 in, 1.2.0_rc1 out
176
177*rails-1.2.0 (19 Jan 2007)
178
179 19 Jan 2007; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0.ebuild:
180 rails 1.2.0
181
182*rails-1.2.0_rc1 (24 Nov 2006)
183
184 24 Nov 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0_rc1.ebuild:
185 1.2.0_rc1
186
187*rails-1.1.6-r1 (03 Oct 2006)
188
189 03 Oct 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
190 +files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.2.ebuild,
191 -rails-1.1.3.ebuild, -rails-1.1.4.ebuild, -rails-1.1.5.ebuild,
192 +rails-1.1.6-r1.ebuild:
193 Removed old ebuilds. Added 1.1.6-r1 to ignore lighttpd older than 1.4.10
194 (bug #133500)
195
196 02 Sep 2006; Bryan Østergaard <kloeri@gentoo.org> rails-1.1.6.ebuild:
197 Stable on ia64.
198
199*rails-1.1.6 (10 Aug 2006)
200
201 10 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.6.ebuild:
202 version bump
203
204 10 Aug 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.5.ebuild:
205 Stable on sparc --- Bug #143369 (mandatory security upgrade) --- installs and
206 works.
4 207
5 10 Aug 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.5.ebuild: 208 10 Aug 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.5.ebuild:
6 Stable x86; bug # 143369 209 Stable x86; bug # 143369
7 210
8 09 Aug 2006; Thomas Cort <tcort@gentoo.org> rails-1.1.5.ebuild: 211 09 Aug 2006; Thomas Cort <tcort@gentoo.org> rails-1.1.5.ebuild:

Legend:
Removed from v.1.62  
changed lines
  Added in v.1.111

  ViewVC Help
Powered by ViewVC 1.1.20