/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Diff of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.48 Revision 1.114
1# ChangeLog for dev-ruby/rails 1# ChangeLog for dev-ruby/rails
2# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.48 2006/06/02 13:28:16 flameeyes Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.114 2008/10/24 12:23:04 graaff Exp $
4
5*rails-2.1.2 (24 Oct 2008)
6
7 24 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.2.ebuild:
8 Version bump. Fixes security issue #242914 (header-injection) and #237285.
9 Also features minor fixes.
10
11*rails-2.0.5 (20 Oct 2008)
12
13 20 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.5.ebuild:
14 Version bump for Rails 2.0.5
15
16*rails-2.1.1 (13 Sep 2008)
17
18 13 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.1.ebuild:
19 Version bump for Rails 2.1.1, bug #237392
20
21*rails-2.0.4 (12 Sep 2008)
22
23 12 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.4.ebuild:
24 Version bump for Rails 2.0.4, bug #237385
25
26 13 Jul 2008; Hans de Graaff <graaff@gentoo.org>
27 -files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.6.ebuild,
28 -rails-1.1.6-r2.ebuild:
29 Belated removal for GLSA 200711-17
30
31 04 Jul 2008; Hans de Graaff <graaff@gentoo.org> rails-2.1.0.ebuild:
32 Rails now depends on rake 0.8.1 or better.
33
34 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> -rails-1.2.5.ebuild:
35 Remove old version
36
37*rails-2.1.0 (17 Jun 2008)
38
39 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.0.ebuild:
40 Version bump for Rails 2.1.0
41
42 16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
43 Stable on ppc wrt bug 221309
44
45 13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild:
46 ia64 stable wrt #221309
47
48 13 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
49 Sparc stable (again), following Hans de Graff's comment 7 in Bug #221309.
50 RMD160 for rails-2.0.2.gem should now be correct.
51
52 12 May 2008; Markus Rothe <corsair@gentoo.org> rails-2.0.2.ebuild:
53 Stable on ppc64; bug #221309
54
55 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
56 Back to ~sparc because of Friedrich Oslage's comments in Bug #221309.
57
58 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
59 Sparc stable --- part of Bug #221309 --- Good for about 5 months.
60
61 11 May 2008; Markus Meier <maekke@gentoo.org> rails-2.0.2.ebuild:
62 x86 stable, bug #221309
63
64 11 May 2008; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
65 Stable on amd64, bug #221309
66
67 19 Mar 2008; Hans de Graaff <graaff@gentoo.org> Manifest:
68 Redigest due to upstream repackaging
69
70 04 Jan 2008; <nichoj@gentoo.org> ChangeLog:
71 Updated dependencies not to relay on specific version, and allowing for
72 later revisions (ie change =dev-ruby/activerecord-2.0.2 to
73 ~dev-ruby/activerecord-2.0.2.
74
75 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
76 Fix quoting; database USE flags have moved to dev-ruby/activerecord, make this
77 a warn instead of an info message.
78
79*rails-2.0.2 (18 Dec 2007)
80
81 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rails-2.0.2.ebuild:
82 Version bump for Rails 2.0.2
83
84 01 Dec 2007; Christoph Mende <angelos@gentoo.org> rails-1.2.6.ebuild:
85 Stable on amd64 wrt bug #200159
86
87 01 Dec 2007; Hans de Graaff <graaff@gentoo.org> -rails-1.2.3.ebuild,
88 -rails-1.2.3-r1.ebuild, -rails-1.2.4.ebuild:
89 Remove old vulnerable versions
90
91 27 Nov 2007; Markus Rothe <corsair@gentoo.org> rails-1.2.6.ebuild:
92 Added ~ppc64; bug #200159
93
94 27 Nov 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.6.ebuild:
95 ia64/sparc stable wrt security #200159
96
97 26 Nov 2007; Brent Baude <ranger@gentoo.org> rails-1.2.6.ebuild:
98 Marking rails-1.2.6 ppc for bug 200159
99
100 26 Nov 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.6.ebuild:
101 stable x86, security bug 200159
102
103*rails-1.2.6 (25 Nov 2007)
104
105 25 Nov 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6.ebuild:
106 Version bump for Rails 1.2.6, security bug #200159
107
108 21 Oct 2007; Steve Dibb <beandog@gentoo.org> rails-1.2.5.ebuild:
109 amd64 stable, security bug 195315
110
111 18 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.2.5.ebuild:
112 ppc stable, bug #195315
113
114 16 Oct 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.5.ebuild:
115 ia64/sparc stable wrt security #195315
116
117 16 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.5.ebuild:
118 Add back the dependency on eselect-rails that got dropped somehow after
119 rails-1.2.3-r1
120
121 16 Oct 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.5.ebuild:
122 stable x86, security bug 195315
123
124*rails-1.2.5 (13 Oct 2007)
125
126 13 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.5.ebuild:
127 Version bump with security fixes, bug 195315
128
129 07 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.4.ebuild:
130 Add back the code that handles eselect, I must have used the wrong file to
131 start from :-(
132
133 06 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
134 rails-1.2.3-r1.ebuild:
135 stable x86, bug 177209
136
137*rails-1.2.4 (06 Oct 2007)
138
139 06 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.4.ebuild:
140 Version bump for rails 1.2.4
141
142 06 Oct 2007; Hans de Graaff <graaff@gentoo.org>
143 -files/rails-1.0.0-rdoc-rake-0.7.patch, -rails-1.1.6-r1.ebuild,
144 -rails-1.2.0.ebuild, -rails-1.2.1.ebuild, -rails-1.2.2.ebuild:
145 Remove versions that are old or won't become stable
146
147 06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
148 rails-1.2.3-r1.ebuild:
149 ppc stable, bug #177209
150
151 05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> rails-1.2.3-r1.ebuild:
152 Sparc stable --- Bug #177209
153
154 03 Sep 2007; Joshua Nichols <nichoj@gentoo.org> rails-1.1.6.ebuild,
155 rails-1.1.6-r1.ebuild, rails-1.1.6-r2.ebuild, rails-1.2.0.ebuild,
156 rails-1.2.1.ebuild, rails-1.2.2.ebuild, rails-1.2.3.ebuild,
157 rails-1.2.3-r1.ebuild:
158 Changed eselect-rails from PDEPEND to DEPEND. Moved blockers from
159 eselect-rails to here. Should address bug #172812.
160
161*rails-1.2.3-r1 (01 Sep 2007)
162*rails-1.1.6-r2 (01 Sep 2007)
163
164 01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.1.6-r2.ebuild,
165 +rails-1.2.3-r1.ebuild:
166 Revision bumps for both slots. No longer installs /usr/bin/rails. Instead,
167 uses app-admin/eselect-rails to manage the symlink.
168
169 14 Mar 2007; Richard Brown <rbrown@gentoo.org> rails-1.2.3.ebuild:
170 Fix rails-1.2.3 rake dependency
171
172*rails-1.2.3 (14 Mar 2007)
173
174 14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.3.ebuild:
175 Version bump for rails 1.2.3.
176
177*rails-1.2.2 (11 Feb 2007)
178
179 11 Feb 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.2.ebuild:
180 Version bump.
181
182 10 Feb 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
183 rails-1.1.6.ebuild, rails-1.1.6-r1.ebuild, rails-1.2.0.ebuild,
184 rails-1.2.1.ebuild:
185 Updated rails license to MIT, #165876
186
187*rails-1.2.1 (21 Jan 2007)
188
189 21 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
190 -rails-1.2.0_rc1.ebuild, +rails-1.2.1.ebuild:
191 1.2.1 in, 1.2.0_rc1 out
192
193*rails-1.2.0 (19 Jan 2007)
194
195 19 Jan 2007; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0.ebuild:
196 rails 1.2.0
197
198*rails-1.2.0_rc1 (24 Nov 2006)
199
200 24 Nov 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0_rc1.ebuild:
201 1.2.0_rc1
202
203*rails-1.1.6-r1 (03 Oct 2006)
204
205 03 Oct 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
206 +files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.2.ebuild,
207 -rails-1.1.3.ebuild, -rails-1.1.4.ebuild, -rails-1.1.5.ebuild,
208 +rails-1.1.6-r1.ebuild:
209 Removed old ebuilds. Added 1.1.6-r1 to ignore lighttpd older than 1.4.10
210 (bug #133500)
211
212 02 Sep 2006; Bryan Østergaard <kloeri@gentoo.org> rails-1.1.6.ebuild:
213 Stable on ia64.
214
215*rails-1.1.6 (10 Aug 2006)
216
217 10 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.6.ebuild:
218 version bump
219
220 10 Aug 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.5.ebuild:
221 Stable on sparc --- Bug #143369 (mandatory security upgrade) --- installs and
222 works.
223
224 10 Aug 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.5.ebuild:
225 Stable x86; bug # 143369
226
227 09 Aug 2006; Thomas Cort <tcort@gentoo.org> rails-1.1.5.ebuild:
228 Stable on amd64 wrt security Bug #143369.
229
230 09 Aug 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.5.ebuild:
231 ppc stable, bug #143369
232
233*rails-1.1.5 (09 Aug 2006)
234
235 09 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.5.ebuild:
236 version bump
237
238 31 Jul 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.4.ebuild:
239 stable on amd64 wrt bug 138323
240
241 13 Jul 2006; Aron Griffis <agriffis@gentoo.org> rails-1.1.4.ebuild:
242 Mark 1.1.4 stable on ia64. #138323
243
244 06 Jul 2006; Jason Wever <weeve@gentoo.org> rails-1.1.4.ebuild:
245 Stable on SPARC wrt security bug #138323.
246
247 05 Jul 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.4.ebuild:
248 Stable x86; bug #138323
249
250 03 Jul 2006; Lars Weiler <pylon@gentoo.org> rails-1.1.4.ebuild:
251 Stable on ppc; security bug #138323.
252
253*rails-1.1.4 (03 Jul 2006)
254
255 03 Jul 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.4.ebuild:
256 Version bump
257
258*rails-1.1.3 (28 Jun 2006)
259
260 28 Jun 2006; Caleb Tennis <caleb@gentoo.org> -rails-1.0.0.ebuild,
261 -rails-1.1.0.ebuild, -rails-1.1.1.ebuild, +rails-1.1.3.ebuild:
262 version bump, remove old versions
263
264 25 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.2.ebuild:
265 ppc stable, bug #133003
266
267 14 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> rails-1.1.2.ebuild:
268 Somebody left out ppc. It works fine here.
269
270 06 Jun 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.2.ebuild:
271 stable on amd64
4 272
5 02 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> 273 02 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
6 +files/rails-1.0.0-rdoc-rake-0.7.patch, rails-1.0.0.ebuild: 274 +files/rails-1.0.0-rdoc-rake-0.7.patch, rails-1.0.0.ebuild:
7 Add patch to fix rdoc call with rake 0.7. Thanks to Stephen Tallowitz in bug 275 Add patch to fix rdoc call with rake 0.7. Thanks to Stephen Tallowitz in bug
8 #132692. 276 #132692.

Legend:
Removed from v.1.48  
changed lines
  Added in v.1.114

  ViewVC Help
Powered by ViewVC 1.1.20