/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Diff of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.67 Revision 1.117
1# ChangeLog for dev-ruby/rails 1# ChangeLog for dev-ruby/rails
2# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.67 2006/11/24 01:29:06 caleb Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.117 2008/11/04 17:50:22 ranger Exp $
4
5 04 Nov 2008; Brent Baude <ranger@gentoo.org> rails-2.0.5.ebuild,
6 rails-2.1.2.ebuild:
7 Marking rails-2.0.5|2.1.2 ppc64 for bug 237385
8
9 03 Nov 2008; Markus Meier <maekke@gentoo.org> rails-2.1.2.ebuild:
10 amd64/x86 stable, bug #237385
11
12 03 Nov 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.5.ebuild,
13 rails-2.1.2.ebuild:
14 Sparc stable, Security Bug #237385.
15
16*rails-2.1.2 (24 Oct 2008)
17
18 24 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.2.ebuild:
19 Version bump. Fixes security issue #242914 (header-injection) and #237285.
20 Also features minor fixes.
21
22*rails-2.0.5 (20 Oct 2008)
23
24 20 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.5.ebuild:
25 Version bump for Rails 2.0.5
26
27*rails-2.1.1 (13 Sep 2008)
28
29 13 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.1.ebuild:
30 Version bump for Rails 2.1.1, bug #237392
31
32*rails-2.0.4 (12 Sep 2008)
33
34 12 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.4.ebuild:
35 Version bump for Rails 2.0.4, bug #237385
36
37 13 Jul 2008; Hans de Graaff <graaff@gentoo.org>
38 -files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.6.ebuild,
39 -rails-1.1.6-r2.ebuild:
40 Belated removal for GLSA 200711-17
41
42 04 Jul 2008; Hans de Graaff <graaff@gentoo.org> rails-2.1.0.ebuild:
43 Rails now depends on rake 0.8.1 or better.
44
45 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> -rails-1.2.5.ebuild:
46 Remove old version
47
48*rails-2.1.0 (17 Jun 2008)
49
50 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.0.ebuild:
51 Version bump for Rails 2.1.0
52
53 16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
54 Stable on ppc wrt bug 221309
55
56 13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild:
57 ia64 stable wrt #221309
58
59 13 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
60 Sparc stable (again), following Hans de Graff's comment 7 in Bug #221309.
61 RMD160 for rails-2.0.2.gem should now be correct.
62
63 12 May 2008; Markus Rothe <corsair@gentoo.org> rails-2.0.2.ebuild:
64 Stable on ppc64; bug #221309
65
66 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
67 Back to ~sparc because of Friedrich Oslage's comments in Bug #221309.
68
69 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
70 Sparc stable --- part of Bug #221309 --- Good for about 5 months.
71
72 11 May 2008; Markus Meier <maekke@gentoo.org> rails-2.0.2.ebuild:
73 x86 stable, bug #221309
74
75 11 May 2008; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
76 Stable on amd64, bug #221309
77
78 19 Mar 2008; Hans de Graaff <graaff@gentoo.org> Manifest:
79 Redigest due to upstream repackaging
80
81 04 Jan 2008; <nichoj@gentoo.org> ChangeLog:
82 Updated dependencies not to relay on specific version, and allowing for
83 later revisions (ie change =dev-ruby/activerecord-2.0.2 to
84 ~dev-ruby/activerecord-2.0.2.
85
86 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
87 Fix quoting; database USE flags have moved to dev-ruby/activerecord, make this
88 a warn instead of an info message.
89
90*rails-2.0.2 (18 Dec 2007)
91
92 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rails-2.0.2.ebuild:
93 Version bump for Rails 2.0.2
94
95 01 Dec 2007; Christoph Mende <angelos@gentoo.org> rails-1.2.6.ebuild:
96 Stable on amd64 wrt bug #200159
97
98 01 Dec 2007; Hans de Graaff <graaff@gentoo.org> -rails-1.2.3.ebuild,
99 -rails-1.2.3-r1.ebuild, -rails-1.2.4.ebuild:
100 Remove old vulnerable versions
101
102 27 Nov 2007; Markus Rothe <corsair@gentoo.org> rails-1.2.6.ebuild:
103 Added ~ppc64; bug #200159
104
105 27 Nov 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.6.ebuild:
106 ia64/sparc stable wrt security #200159
107
108 26 Nov 2007; Brent Baude <ranger@gentoo.org> rails-1.2.6.ebuild:
109 Marking rails-1.2.6 ppc for bug 200159
110
111 26 Nov 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.6.ebuild:
112 stable x86, security bug 200159
113
114*rails-1.2.6 (25 Nov 2007)
115
116 25 Nov 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6.ebuild:
117 Version bump for Rails 1.2.6, security bug #200159
118
119 21 Oct 2007; Steve Dibb <beandog@gentoo.org> rails-1.2.5.ebuild:
120 amd64 stable, security bug 195315
121
122 18 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.2.5.ebuild:
123 ppc stable, bug #195315
124
125 16 Oct 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.5.ebuild:
126 ia64/sparc stable wrt security #195315
127
128 16 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.5.ebuild:
129 Add back the dependency on eselect-rails that got dropped somehow after
130 rails-1.2.3-r1
131
132 16 Oct 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.5.ebuild:
133 stable x86, security bug 195315
134
135*rails-1.2.5 (13 Oct 2007)
136
137 13 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.5.ebuild:
138 Version bump with security fixes, bug 195315
139
140 07 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.4.ebuild:
141 Add back the code that handles eselect, I must have used the wrong file to
142 start from :-(
143
144 06 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
145 rails-1.2.3-r1.ebuild:
146 stable x86, bug 177209
147
148*rails-1.2.4 (06 Oct 2007)
149
150 06 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.4.ebuild:
151 Version bump for rails 1.2.4
152
153 06 Oct 2007; Hans de Graaff <graaff@gentoo.org>
154 -files/rails-1.0.0-rdoc-rake-0.7.patch, -rails-1.1.6-r1.ebuild,
155 -rails-1.2.0.ebuild, -rails-1.2.1.ebuild, -rails-1.2.2.ebuild:
156 Remove versions that are old or won't become stable
157
158 06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
159 rails-1.2.3-r1.ebuild:
160 ppc stable, bug #177209
161
162 05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> rails-1.2.3-r1.ebuild:
163 Sparc stable --- Bug #177209
164
165 03 Sep 2007; Joshua Nichols <nichoj@gentoo.org> rails-1.1.6.ebuild,
166 rails-1.1.6-r1.ebuild, rails-1.1.6-r2.ebuild, rails-1.2.0.ebuild,
167 rails-1.2.1.ebuild, rails-1.2.2.ebuild, rails-1.2.3.ebuild,
168 rails-1.2.3-r1.ebuild:
169 Changed eselect-rails from PDEPEND to DEPEND. Moved blockers from
170 eselect-rails to here. Should address bug #172812.
171
172*rails-1.2.3-r1 (01 Sep 2007)
173*rails-1.1.6-r2 (01 Sep 2007)
174
175 01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.1.6-r2.ebuild,
176 +rails-1.2.3-r1.ebuild:
177 Revision bumps for both slots. No longer installs /usr/bin/rails. Instead,
178 uses app-admin/eselect-rails to manage the symlink.
179
180 14 Mar 2007; Richard Brown <rbrown@gentoo.org> rails-1.2.3.ebuild:
181 Fix rails-1.2.3 rake dependency
182
183*rails-1.2.3 (14 Mar 2007)
184
185 14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.3.ebuild:
186 Version bump for rails 1.2.3.
187
188*rails-1.2.2 (11 Feb 2007)
189
190 11 Feb 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.2.ebuild:
191 Version bump.
192
193 10 Feb 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
194 rails-1.1.6.ebuild, rails-1.1.6-r1.ebuild, rails-1.2.0.ebuild,
195 rails-1.2.1.ebuild:
196 Updated rails license to MIT, #165876
197
198*rails-1.2.1 (21 Jan 2007)
199
200 21 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
201 -rails-1.2.0_rc1.ebuild, +rails-1.2.1.ebuild:
202 1.2.1 in, 1.2.0_rc1 out
203
204*rails-1.2.0 (19 Jan 2007)
205
206 19 Jan 2007; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0.ebuild:
207 rails 1.2.0
4 208
5*rails-1.2.0_rc1 (24 Nov 2006) 209*rails-1.2.0_rc1 (24 Nov 2006)
6 210
7 24 Nov 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0_rc1.ebuild: 211 24 Nov 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0_rc1.ebuild:
8 1.2.0_rc1 212 1.2.0_rc1

Legend:
Removed from v.1.67  
changed lines
  Added in v.1.117

  ViewVC Help
Powered by ViewVC 1.1.20