/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Diff of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.165 Revision 1.220
1# ChangeLog for dev-ruby/rails 1# ChangeLog for dev-ruby/rails
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.165 2009/12/20 09:08:15 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.220 2012/06/01 06:06:35 graaff Exp $
4
5 01 Jun 2012; Hans de Graaff <graaff@gentoo.org> -rails-3.0.10.ebuild,
6 -rails-3.0.11.ebuild, -rails-3.1.3-r1.ebuild:
7 Remove old versions.
8
9 17 May 2012; Thomas Kahle <tomka@gentoo.org> rails-3.1.4.ebuild,
10 rails-3.2.3.ebuild:
11 marked ~x86 per bug 396547
12
13 01 May 2012; Raúl Porcel <armin76@gentoo.org> rails-2.3.14.ebuild,
14 rails-3.0.10.ebuild, rails-3.0.11.ebuild, rails-3.0.12.ebuild:
15 Drop ia64/sparc keywords
16
17*rails-3.2.3 (20 Apr 2012)
18
19 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.2.3.ebuild:
20 Version bump.
21
22 08 Apr 2012; Hans de Graaff <graaff@gentoo.org> rails-3.1.3-r1.ebuild,
23 rails-3.1.4.ebuild:
24 Add slot to jquery-rails dependency for forthcoming Rails 3.2-only versions.
25
26*rails-3.1.4 (04 Apr 2012)
27
28 04 Apr 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.1.4.ebuild:
29 Version bump for Rails 3.1.4, security bug 406547.
30
31*rails-3.0.12 (04 Apr 2012)
32
33 04 Apr 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.0.12.ebuild:
34 Version bump for security bug 406547.
35
36 11 Mar 2012; Brent Baude <ranger@gentoo.org> rails-3.1.3.ebuild:
37 Marking rails-3.1.3 ~ppc64 for bug 396547
38
39*rails-3.1.3-r1 (02 Jan 2012)
40
41 02 Jan 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.1.3-r1.ebuild,
42 metadata.xml:
43 Revision bump which also installs the components of the default Rails asset
44 pipeline by default.
45
46 31 Dec 2011; Fabian Groffen <grobian@gentoo.org> rails-3.1.3.ebuild:
47 Add Prefix keywords, bug #396547
48
49 31 Dec 2011; Hans de Graaff <graaff@gentoo.org> rails-3.1.3.ebuild:
50 Add ruby19.
51
52*rails-3.1.3 (30 Dec 2011)
53
54 30 Dec 2011; Hans de Graaff <graaff@gentoo.org> +rails-3.1.3.ebuild:
55 Version bump. Add ruby19. Drop arches due to bug 396547.
56
57*rails-3.0.11 (19 Nov 2011)
58
59 19 Nov 2011; Hans de Graaff <graaff@gentoo.org> +rails-3.0.11.ebuild:
60 Version bump for Rails 3.0.11.
61
62 05 Oct 2011; Hans de Graaff <graaff@gentoo.org> -rails-3.0.7.ebuild,
63 -rails-3.0.9.ebuild:
64 Remove old versions.
65
66 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> -rails-2.3.5.ebuild,
67 -rails-2.3.11.ebuild, -rails-2.3.12.ebuild:
68 Remove old versions.
69
70*rails-3.0.10 (28 Sep 2011)
71
72 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> +rails-3.0.10.ebuild:
73 Version bump for Rails 3.0.10
74
75 09 Sep 2011; Fabian Groffen <grobian@gentoo.org> rails-3.0.9.ebuild:
76 Marked ~sparc-solaris
77
78 27 Aug 2011; Raúl Porcel <armin76@gentoo.org> rails-2.3.14.ebuild:
79 ia64/sparc stable wrt #379511
80
81 24 Aug 2011; Markus Meier <maekke@gentoo.org> rails-2.3.14.ebuild:
82 x86 stable, bug #379511
83
84 18 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> rails-2.3.14.ebuild:
85 ppc64/ppc stable wrt #379511
86
87 18 Aug 2011; Tony Vroon <chainsaw@gentoo.org> rails-2.3.14.ebuild:
88 Marked stable on AMD64 based on arch testing by Agostino "ago" Saurbbo in
89 security bug #379511 filed by Hans de Graaff.
90
91*rails-2.3.14 (17 Aug 2011)
92
93 17 Aug 2011; Hans de Graaff <graaff@gentoo.org> +rails-2.3.14.ebuild:
94 Version bump.
95
96 07 Aug 2011; Raúl Porcel <armin76@gentoo.org> rails-3.0.9.ebuild:
97 Add ~ia64/~sparc wrt #351835
98
99 24 Jul 2011; Raúl Porcel <armin76@gentoo.org> rails-2.3.12.ebuild:
100 ia64/sparc stable wrt #372391
101
102 24 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> rails-3.0.9.ebuild:
103 Marked ~ppc/~ppc64 wrt #351835
104
105 23 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> rails-2.3.12.ebuild:
106 ppc/ppc64 stable wrt #372391
107
108 13 Jul 2011; Markus Meier <maekke@gentoo.org> rails-2.3.12.ebuild:
109 x86 stable, bug #372391
110
111 07 Jul 2011; Markos Chandras <hwoarang@gentoo.org> rails-2.3.12.ebuild:
112 Stable on amd64 wrt bug #372391
113
114*rails-3.0.9 (04 Jul 2011)
115
116 04 Jul 2011; Hans de Graaff <graaff@gentoo.org> +rails-3.0.9.ebuild:
117 Version bump for Rails 3.0.9.
118
119 19 Jun 2011; Hans de Graaff <graaff@gentoo.org> rails-2.3.12.ebuild:
120 Add a runtime dependency on dev-ruby/rdoc since the new Rails task expects a
121 task file that is only distributed as part of the rdoc gem.
122
123*rails-2.3.12 (09 Jun 2011)
124
125 09 Jun 2011; Hans de Graaff <graaff@gentoo.org> +rails-2.3.12.ebuild:
126 Version bump.
127
128 09 Jun 2011; Hans de Graaff <graaff@gentoo.org> -rails-2.2.3-r1.ebuild:
129 Remove old version.
130
131 01 May 2011; Hans de Graaff <graaff@gentoo.org> -rails-2.3.10.ebuild,
132 -rails-3.0.3.ebuild:
133 Remove old versions.
134
135*rails-3.0.7 (26 Apr 2011)
136
137 26 Apr 2011; Hans de Graaff <graaff@gentoo.org> +rails-3.0.7.ebuild:
138 Version bump for Rails 3.0.7.
139
140*rails-2.3.11 (21 Feb 2011)
141
142 21 Feb 2011; Hans de Graaff <graaff@gentoo.org> +rails-2.3.11.ebuild:
143 Version bump for Rails 2.3.11.
144
145 13 Feb 2011; Thomas Kahle <tomka@gentoo.org> rails-3.0.3.ebuild:
146 keyworded ~x86 per bug 351835
147
148 22 Jan 2011; Hans de Graaff <graaff@gentoo.org> -rails-2.3.5-r2.ebuild,
149 -rails-2.3.5-r3.ebuild, -rails-2.3.8.ebuild:
150 Remove old versions.
151
152 12 Jan 2011; Hans de Graaff <graaff@gentoo.org> rails-3.0.3.ebuild:
153 Update dependency on eselect-rails to a version that understands Rails
154 3.x. Thanks to Elias Probst in bug 351434.
155
156 07 Jan 2011; Hans de Graaff <graaff@gentoo.org> rails-2.3.10.ebuild:
157 Move forward ppc and ppc64 keywords that got missed on a version bump.
158
159*rails-3.0.3 (28 Dec 2010)
160
161 28 Dec 2010; Hans de Graaff <graaff@gentoo.org> +rails-3.0.3.ebuild:
162 Version bump for Rails 3.0.3.
163
164 15 Oct 2010; Hans de Graaff <graaff@gentoo.org> -rails-2.3.9.ebuild:
165 Remove vulnerable version.
166
167*rails-2.3.10 (15 Oct 2010)
168
169 15 Oct 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.10.ebuild:
170 Version bump for rails 2.3.10.
171
172 29 Sep 2010; Brent Baude <ranger@gentoo.org> rails-2.3.8.ebuild:
173 Marking rails-2.3.8 ~ppc64 for bug 322175
174
175 28 Sep 2010; Brent Baude <ranger@gentoo.org> rails-2.3.8.ebuild:
176 Marking rails-2.3.8 ~ppc for bug 322175
177
178*rails-2.3.9 (05 Sep 2010)
179
180 05 Sep 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.9.ebuild:
181 Version bump for Rails 2.3.9
182
183*rails-2.3.8 (31 May 2010)
184
185 31 May 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.8.ebuild:
186 Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
187 dependency.
188
189*rails-2.3.5-r3 (23 May 2010)
190
191 23 May 2010; Alex Legler <a3li@gentoo.org> +rails-2.3.5-r3.ebuild:
192 Add REE18 support
193
194 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> rails-2.3.5.ebuild,
195 -rails-2.3.5-r1.ebuild, rails-2.3.5-r2.ebuild:
196 Cleanup old versions, use new syntax.
197
198 21 Feb 2010; Jonathan Callen <abcd@gentoo.org> rails-2.3.5-r2.ebuild:
199 Transfer prefix keywords (no other changes)
200
201*rails-2.3.5-r2 (17 Feb 2010)
202
203 17 Feb 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.5-r2.ebuild:
204 Install more files so that creating a new project works again, fixing
205 #303581.
206
207 13 Feb 2010; Raúl Porcel <armin76@gentoo.org> rails-2.3.5-r1.ebuild:
208 Add ~ia64/~sparc
209
210 01 Feb 2010; Markus Meier <maekke@gentoo.org> rails-2.3.5-r1.ebuild:
211 add ~x86, bug #301007
212
213 18 Jan 2010; Brent Baude <ranger@gentoo.org> rails-2.3.5-r1.ebuild:
214 Marking rails-2.3.5-r1 ~ppc64 for bug 301007
215
216 18 Jan 2010; Brent Baude <ranger@gentoo.org> rails-2.3.5-r1.ebuild:
217 Marking rails-2.3.5-r1 ~ppc for bug 301007
218
219*rails-2.3.5-r1 (14 Jan 2010)
220
221 14 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
222 +rails-2.3.5-r1.ebuild:
223 Bump to ruby-fakegem. Tests cannot be executed because upstream does not
224 package them.
4 225
5 20 Dec 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.3.ebuild, 226 20 Dec 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.3.ebuild,
6 -rails-2.3.4.ebuild: 227 -rails-2.3.4.ebuild:
7 Removing vulnerable versions 228 Removing vulnerable versions
8 229

Legend:
Removed from v.1.165  
changed lines
  Added in v.1.220

  ViewVC Help
Powered by ViewVC 1.1.20