/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Contents of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.109 - (show annotations) (download)
Fri Jul 4 07:00:57 2008 UTC (7 years, 2 months ago) by graaff
Branch: MAIN
Changes since 1.108: +4 -1 lines
Update rake depedency
(Portage version: 2.1.4.4)

1 # ChangeLog for dev-ruby/rails
2 # Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.108 2008/06/17 05:51:25 graaff Exp $
4
5 04 Jul 2008; Hans de Graaff <graaff@gentoo.org> rails-2.1.0.ebuild:
6 Rails now depends on rake 0.8.1 or better.
7
8 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> -rails-1.2.5.ebuild:
9 Remove old version
10
11 *rails-2.1.0 (17 Jun 2008)
12
13 17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.0.ebuild:
14 Version bump for Rails 2.1.0
15
16 16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
17 Stable on ppc wrt bug 221309
18
19 13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild:
20 ia64 stable wrt #221309
21
22 13 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
23 Sparc stable (again), following Hans de Graff's comment 7 in Bug #221309.
24 RMD160 for rails-2.0.2.gem should now be correct.
25
26 12 May 2008; Markus Rothe <corsair@gentoo.org> rails-2.0.2.ebuild:
27 Stable on ppc64; bug #221309
28
29 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
30 Back to ~sparc because of Friedrich Oslage's comments in Bug #221309.
31
32 11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
33 Sparc stable --- part of Bug #221309 --- Good for about 5 months.
34
35 11 May 2008; Markus Meier <maekke@gentoo.org> rails-2.0.2.ebuild:
36 x86 stable, bug #221309
37
38 11 May 2008; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
39 Stable on amd64, bug #221309
40
41 19 Mar 2008; Hans de Graaff <graaff@gentoo.org> Manifest:
42 Redigest due to upstream repackaging
43
44 04 Jan 2008; <nichoj@gentoo.org> ChangeLog:
45 Updated dependencies not to relay on specific version, and allowing for
46 later revisions (ie change =dev-ruby/activerecord-2.0.2 to
47 ~dev-ruby/activerecord-2.0.2.
48
49 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
50 Fix quoting; database USE flags have moved to dev-ruby/activerecord, make this
51 a warn instead of an info message.
52
53 *rails-2.0.2 (18 Dec 2007)
54
55 18 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rails-2.0.2.ebuild:
56 Version bump for Rails 2.0.2
57
58 01 Dec 2007; Christoph Mende <angelos@gentoo.org> rails-1.2.6.ebuild:
59 Stable on amd64 wrt bug #200159
60
61 01 Dec 2007; Hans de Graaff <graaff@gentoo.org> -rails-1.2.3.ebuild,
62 -rails-1.2.3-r1.ebuild, -rails-1.2.4.ebuild:
63 Remove old vulnerable versions
64
65 27 Nov 2007; Markus Rothe <corsair@gentoo.org> rails-1.2.6.ebuild:
66 Added ~ppc64; bug #200159
67
68 27 Nov 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.6.ebuild:
69 ia64/sparc stable wrt security #200159
70
71 26 Nov 2007; Brent Baude <ranger@gentoo.org> rails-1.2.6.ebuild:
72 Marking rails-1.2.6 ppc for bug 200159
73
74 26 Nov 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.6.ebuild:
75 stable x86, security bug 200159
76
77 *rails-1.2.6 (25 Nov 2007)
78
79 25 Nov 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6.ebuild:
80 Version bump for Rails 1.2.6, security bug #200159
81
82 21 Oct 2007; Steve Dibb <beandog@gentoo.org> rails-1.2.5.ebuild:
83 amd64 stable, security bug 195315
84
85 18 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.2.5.ebuild:
86 ppc stable, bug #195315
87
88 16 Oct 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.5.ebuild:
89 ia64/sparc stable wrt security #195315
90
91 16 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.5.ebuild:
92 Add back the dependency on eselect-rails that got dropped somehow after
93 rails-1.2.3-r1
94
95 16 Oct 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.5.ebuild:
96 stable x86, security bug 195315
97
98 *rails-1.2.5 (13 Oct 2007)
99
100 13 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.5.ebuild:
101 Version bump with security fixes, bug 195315
102
103 07 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.4.ebuild:
104 Add back the code that handles eselect, I must have used the wrong file to
105 start from :-(
106
107 06 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
108 rails-1.2.3-r1.ebuild:
109 stable x86, bug 177209
110
111 *rails-1.2.4 (06 Oct 2007)
112
113 06 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.4.ebuild:
114 Version bump for rails 1.2.4
115
116 06 Oct 2007; Hans de Graaff <graaff@gentoo.org>
117 -files/rails-1.0.0-rdoc-rake-0.7.patch, -rails-1.1.6-r1.ebuild,
118 -rails-1.2.0.ebuild, -rails-1.2.1.ebuild, -rails-1.2.2.ebuild:
119 Remove versions that are old or won't become stable
120
121 06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
122 rails-1.2.3-r1.ebuild:
123 ppc stable, bug #177209
124
125 05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> rails-1.2.3-r1.ebuild:
126 Sparc stable --- Bug #177209
127
128 03 Sep 2007; Joshua Nichols <nichoj@gentoo.org> rails-1.1.6.ebuild,
129 rails-1.1.6-r1.ebuild, rails-1.1.6-r2.ebuild, rails-1.2.0.ebuild,
130 rails-1.2.1.ebuild, rails-1.2.2.ebuild, rails-1.2.3.ebuild,
131 rails-1.2.3-r1.ebuild:
132 Changed eselect-rails from PDEPEND to DEPEND. Moved blockers from
133 eselect-rails to here. Should address bug #172812.
134
135 *rails-1.2.3-r1 (01 Sep 2007)
136 *rails-1.1.6-r2 (01 Sep 2007)
137
138 01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.1.6-r2.ebuild,
139 +rails-1.2.3-r1.ebuild:
140 Revision bumps for both slots. No longer installs /usr/bin/rails. Instead,
141 uses app-admin/eselect-rails to manage the symlink.
142
143 14 Mar 2007; Richard Brown <rbrown@gentoo.org> rails-1.2.3.ebuild:
144 Fix rails-1.2.3 rake dependency
145
146 *rails-1.2.3 (14 Mar 2007)
147
148 14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.3.ebuild:
149 Version bump for rails 1.2.3.
150
151 *rails-1.2.2 (11 Feb 2007)
152
153 11 Feb 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.2.ebuild:
154 Version bump.
155
156 10 Feb 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
157 rails-1.1.6.ebuild, rails-1.1.6-r1.ebuild, rails-1.2.0.ebuild,
158 rails-1.2.1.ebuild:
159 Updated rails license to MIT, #165876
160
161 *rails-1.2.1 (21 Jan 2007)
162
163 21 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
164 -rails-1.2.0_rc1.ebuild, +rails-1.2.1.ebuild:
165 1.2.1 in, 1.2.0_rc1 out
166
167 *rails-1.2.0 (19 Jan 2007)
168
169 19 Jan 2007; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0.ebuild:
170 rails 1.2.0
171
172 *rails-1.2.0_rc1 (24 Nov 2006)
173
174 24 Nov 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0_rc1.ebuild:
175 1.2.0_rc1
176
177 *rails-1.1.6-r1 (03 Oct 2006)
178
179 03 Oct 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
180 +files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.2.ebuild,
181 -rails-1.1.3.ebuild, -rails-1.1.4.ebuild, -rails-1.1.5.ebuild,
182 +rails-1.1.6-r1.ebuild:
183 Removed old ebuilds. Added 1.1.6-r1 to ignore lighttpd older than 1.4.10
184 (bug #133500)
185
186 02 Sep 2006; Bryan Østergaard <kloeri@gentoo.org> rails-1.1.6.ebuild:
187 Stable on ia64.
188
189 *rails-1.1.6 (10 Aug 2006)
190
191 10 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.6.ebuild:
192 version bump
193
194 10 Aug 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.5.ebuild:
195 Stable on sparc --- Bug #143369 (mandatory security upgrade) --- installs and
196 works.
197
198 10 Aug 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.5.ebuild:
199 Stable x86; bug # 143369
200
201 09 Aug 2006; Thomas Cort <tcort@gentoo.org> rails-1.1.5.ebuild:
202 Stable on amd64 wrt security Bug #143369.
203
204 09 Aug 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.5.ebuild:
205 ppc stable, bug #143369
206
207 *rails-1.1.5 (09 Aug 2006)
208
209 09 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.5.ebuild:
210 version bump
211
212 31 Jul 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.4.ebuild:
213 stable on amd64 wrt bug 138323
214
215 13 Jul 2006; Aron Griffis <agriffis@gentoo.org> rails-1.1.4.ebuild:
216 Mark 1.1.4 stable on ia64. #138323
217
218 06 Jul 2006; Jason Wever <weeve@gentoo.org> rails-1.1.4.ebuild:
219 Stable on SPARC wrt security bug #138323.
220
221 05 Jul 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.4.ebuild:
222 Stable x86; bug #138323
223
224 03 Jul 2006; Lars Weiler <pylon@gentoo.org> rails-1.1.4.ebuild:
225 Stable on ppc; security bug #138323.
226
227 *rails-1.1.4 (03 Jul 2006)
228
229 03 Jul 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.4.ebuild:
230 Version bump
231
232 *rails-1.1.3 (28 Jun 2006)
233
234 28 Jun 2006; Caleb Tennis <caleb@gentoo.org> -rails-1.0.0.ebuild,
235 -rails-1.1.0.ebuild, -rails-1.1.1.ebuild, +rails-1.1.3.ebuild:
236 version bump, remove old versions
237
238 25 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.2.ebuild:
239 ppc stable, bug #133003
240
241 14 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> rails-1.1.2.ebuild:
242 Somebody left out ppc. It works fine here.
243
244 06 Jun 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.2.ebuild:
245 stable on amd64
246
247 02 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
248 +files/rails-1.0.0-rdoc-rake-0.7.patch, rails-1.0.0.ebuild:
249 Add patch to fix rdoc call with rake 0.7. Thanks to Stephen Tallowitz in bug
250 #132692.
251
252 16 May 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.2.ebuild:
253 x86 stable; bug #133003
254
255 11 May 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.2.ebuild:
256 Stable on sparc (Bug #133003).
257
258 08 May 2006; Seemant Kulleen <seemant@gentoo.org> rails-1.1.2.ebuild:
259 keyworded for ~amd64
260
261 27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-rails-1.0.0,
262 files/digest-rails-1.1.0, files/digest-rails-1.1.1, Manifest:
263 Fixing SHA256 digest, pass four
264
265 17 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> rails-1.1.2.ebuild:
266 Add ~x86-fbsd keyword.
267
268 *rails-1.1.2 (14 Apr 2006)
269
270 14 Apr 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.2.ebuild:
271 Version bump
272
273 08 Apr 2006; Caleb Tennis <caleb@gentoo.org> rails-1.1.1.ebuild:
274 make it dep on rake 0.7.1
275
276 *rails-1.1.1 (06 Apr 2006)
277
278 06 Apr 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.1.ebuild:
279 version bump
280
281 31 Mar 2006; Caleb Tennis <caleb@gentoo.org> rails-1.0.0.ebuild:
282 Fix deps to lock rails 1.0 components together
283
284 30 Mar 2006; Aron Griffis <agriffis@gentoo.org> rails-1.1.0.ebuild:
285 Mark 1.1.0 ~ia64
286
287 *rails-1.1.0 (28 Mar 2006)
288
289 28 Mar 2006; Caleb Tennis <caleb@gentoo.org> -rails-1.0.0.4008.ebuild,
290 +rails-1.1.0.ebuild:
291 Rails 1.1
292
293 *rails-1.0.0.4008 (22 Mar 2006)
294
295 22 Mar 2006; Caleb Tennis <caleb@gentoo.org> -rails-0.13.1.ebuild,
296 +rails-1.0.0.4008.ebuild:
297 New 1.1 release candidate, slotted to install alongside existing rails
298
299 27 Jan 2006; Michael Hanselmann <hansmi@gentoo.org> rails-1.0.0.ebuild:
300 Stable on ppc.
301
302 10 Jan 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.0.0.ebuild:
303 Stable on sparc (at gustavoz's request); works as it should for me.
304
305 02 Jan 2006; Caleb Tennis <caleb@gentoo.org> rails-1.0.0.ebuild:
306 x86 stable
307
308 20 Dec 2005; <dang@gentoo.org> rails-1.0.0.ebuild:
309 Marked ~amd64 Per bug#115774
310
311 *rails-1.0.0 (13 Dec 2005)
312
313 13 Dec 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.4.ebuild,
314 +rails-1.0.0.ebuild:
315 Version bump
316
317 *rails-0.14.4 (08 Dec 2005)
318
319 08 Dec 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.3.ebuild,
320 +rails-0.14.4.ebuild:
321 Version bump
322
323 13 Nov 2005; Jason Wever <weeve@gentoo.org> rails-0.13.1.ebuild:
324 Stable on SPARC.
325
326 *rails-0.14.3 (08 Nov 2005)
327
328 08 Nov 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.2.ebuild,
329 +rails-0.14.3.ebuild:
330 version bump
331
332 *rails-0.14.2 (04 Nov 2005)
333
334 04 Nov 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.1.ebuild,
335 +rails-0.14.2.ebuild:
336 bump and remove previous version
337
338 01 Nov 2005; Caleb Tennis <caleb@gentoo.org> rails-0.14.1.ebuild:
339 Requires rake-0.6.2
340
341 19 Oct 2005; Luca Barbato <lu_zero@gentoo.org> rails-0.13.1.ebuild:
342 Marked ppc
343
344 *rails-0.14.1 (19 Oct 2005)
345
346 19 Oct 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.14.1.ebuild:
347 Version bump
348
349 23 Sep 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.9.5.ebuild,
350 -rails-0.10.0-r1.ebuild, -rails-0.10.1.ebuild, -rails-0.11.0-r1.ebuild,
351 -rails-0.11.1-r1.ebuild, -rails-0.12.1.ebuild:
352 Remove old versions
353
354 01 Aug 2005; Ferris McCormick <fmccor@gentoo.org> rails-0.13.1.ebuild:
355 Add ~sparc keyword. Builds and appears to run without problems.
356
357 27 Jul 2005; Caleb Tennis <caleb@gentoo.org> rails-0.13.1.ebuild:
358 x86 stable
359
360 *rails-0.13.1 (12 Jul 2005)
361
362 12 Jul 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.13.1.ebuild:
363 Version bump
364
365 12 Jul 2005; David Holm <dholm@gentoo.org> rails-0.12.1.ebuild:
366 Added to ~ppc.
367
368 *rails-0.12.1 (20 Apr 2005)
369
370 20 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> -rails-0.12.0.ebuild,
371 +rails-0.12.1.ebuild:
372 Version bump removed bad version.
373
374 19 Apr 2005; Caleb Tennis <caleb@gentoo.org> rails-0.12.0.ebuild:
375 This version of rails seems to require rake 0.5.3
376
377 19 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.12.0.ebuild:
378 Removed obsolete postinst_info
379
380 *rails-0.12.0 (19 Apr 2005)
381
382 19 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.12.0.ebuild:
383 Version bump.
384
385 01 Apr 2005; Caleb Tennis <caleb@gentoo.org> rails-0.11.1-r1.ebuild:
386 x86 stable
387
388 30 Mar 2005; Caleb Tennis <caleb@gentoo.org> rails-0.11.1-r1.ebuild:
389 This version of rails requires rake 0.5.0
390
391 *rails-0.11.1-r1 (29 Mar 2005)
392
393 29 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> -rails-0.11.1.ebuild,
394 +rails-0.11.1-r1.ebuild:
395 Fixed rubyforge gem url.
396
397 *rails-0.11.1 (28 Mar 2005)
398
399 28 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.11.1.ebuild:
400 Version bump.
401
402 26 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.11.0-r1.ebuild:
403 Added fastcgi support/USE flag
404
405 25 Mar 2005; Rob Cakebread <pythonhead@gentoo.org>
406 +files/rails-0.11.0-dispatch.fcgi.diff, +rails-0.11.0-r1.ebuild:
407 Patched borken dispatch.fcgi, added some helpful einfo about upgrading from
408 0.10. Removed 0.11.0
409
410 *rails-0.11.0 (22 Mar 2005)
411
412 22 Mar 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.11.0.ebuild:
413 version bump
414
415 *rails-0.10.1 (10 Mar 2005)
416
417 10 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.10.1.ebuild:
418 Version bump.
419
420 08 Mar 2005; Caleb Tennis <caleb@gentoo.org> rails-0.10.0-r1.ebuild:
421 x86 stable
422
423 01 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.10.0-r1.ebuild:
424 Added upgrade postinst info
425
426 *rails-0.10.0-r1 (01 Mar 2005)
427
428 01 Mar 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.10.0-r1.ebuild,
429 -rails-0.10.0.ebuild:
430 Bump because my SRC_URI was wrong
431
432 *rails-0.10.0 (28 Feb 2005)
433
434 28 Feb 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.10.0.ebuild:
435 Version bump - bug #83446
436
437 *rails-0.9.5 (15 Feb 2005)
438
439 15 Feb 2005; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
440 +rails-0.9.5.ebuild:
441 Initial commit. bug# 80828

  ViewVC Help
Powered by ViewVC 1.1.20