/[gentoo-x86]/dev-ruby/ruby-gnomeprintui/ruby-gnomeprintui-0.19.4.ebuild
Gentoo

Contents of /dev-ruby/ruby-gnomeprintui/ruby-gnomeprintui-0.19.4.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.6 - (show annotations) (download)
Thu Apr 28 15:49:47 2011 UTC (7 years, 3 months ago) by scarabeus
Branch: MAIN
CVS Tags: HEAD
Changes since 1.5: +1 -1 lines
FILE REMOVED
Punt obsolete packages as per bug #358431.

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gnomeprintui/ruby-gnomeprintui-0.19.4.ebuild,v 1.5 2010/10/20 21:54:39 ranger Exp $
4
5 EAPI="2"
6 USE_RUBY="ruby18"
7
8 inherit ruby-ng-gnome2
9
10 DESCRIPTION="Ruby bindings for gnomeprintui"
11 KEYWORDS="amd64 ~ia64 ppc sparc x86"
12 IUSE=""
13
14 RDEPEND="${RDEPEND}
15 >=gnome-base/libgnomeprintui-2.8"
16 DEPEND="${DEPEND}
17 >=gnome-base/libgnomeprintui-2.8
18 dev-util/pkgconfig"
19
20 ruby_add_rdepend ">=dev-ruby/ruby-gnomeprint-${PV}
21 >=dev-ruby/ruby-gtk2-${PV}"
22
23 # Needed to generate rblibgnomeprintversion.h
24 each_ruby_configure() {
25 pushd ../gnomeprint
26 ruby extconf.rb || die "ruby-libgnomeprint's extconf.rb failed"
27
28 popd
29 ruby extconf.rb || die "ruby-libgnomeprintui's extconf.rb failed"
30 }

  ViewVC Help
Powered by ViewVC 1.1.20