/[gentoo-x86]/dev-ruby/ruby-ldap/ruby-ldap-0.9.12.ebuild
Gentoo

Contents of /dev-ruby/ruby-ldap/ruby-ldap-0.9.12.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.9 - (hide annotations) (download)
Thu Jan 8 11:34:26 2015 UTC (6 months, 2 weeks ago) by mrueg
Branch: MAIN
CVS Tags: HEAD
Changes since 1.8: +1 -1 lines
FILE REMOVED
Remove old.

(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )

1 mrueg 1.7 # Copyright 1999-2014 Gentoo Foundation
2 matsuu 1.1 # Distributed under the terms of the GNU General Public License v2
3 mrueg 1.9 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ruby-ldap-0.9.12.ebuild,v 1.8 2014/06/03 19:39:16 graaff Exp $
4 matsuu 1.1
5     EAPI="4"
6     # jruby: mkmf
7     # rbx: require 'ldap' no such file to load
8 mrueg 1.7 USE_RUBY="ruby19"
9 matsuu 1.1
10     RUBY_FAKEGEM_TASK_DOC=""
11     RUBY_FAKEGEM_TASK_TEST=""
12     RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
13    
14 graaff 1.8 inherit ruby-fakegem
15    
16 matsuu 1.1 DESCRIPTION="A Ruby interface to some LDAP libraries"
17     HOMEPAGE="http://ruby-ldap.sourceforge.net/"
18     SRC_URI="mirror://rubygems/${P}.gem"
19     LICENSE="BSD"
20     SLOT="0"
21 jer 1.6 KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc64 sparc x86 ~x86-macos"
22 matsuu 1.1 IUSE="ssl"
23     DEPEND=">=net-nds/openldap-2
24     dev-libs/cyrus-sasl
25     ssl? ( dev-libs/openssl )"
26     RDEPEND="${DEPEND}"
27    
28     # Current test set is interactive due to certificate generation and requires
29     # running LDAP daemon
30     RESTRICT="test"
31    
32     each_ruby_configure() {
33     local myconf="--with-openldap2"
34     if ! use ssl ; then
35     myconf="${myconf} --without-libcrypto --without-libssl"
36     fi
37     ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
38     sed -i -e 's:-Wl,--no-undefined::' \
39     -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
40     }
41    
42     each_ruby_compile() {
43     emake || die
44     cp ldap.so lib/
45     }

  ViewVC Help
Powered by ViewVC 1.1.20