/[gentoo-x86]/dev-ruby/rubygems/rubygems-0.9.1.ebuild
Gentoo

Contents of /dev-ruby/rubygems/rubygems-0.9.1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.6 - (show annotations) (download)
Tue May 1 17:30:10 2007 UTC (11 years, 11 months ago) by graaff
Branch: MAIN
CVS Tags: HEAD
Changes since 1.5: +1 -1 lines
FILE REMOVED
Remove broken version
(Portage version: 2.1.2.2)

1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-0.9.1.ebuild,v 1.5 2007/02/28 22:07:44 genstef Exp $
4
5 RUBY_BUG_145222=yes
6 inherit ruby
7
8 DESCRIPTION="Centralized Ruby extension management system"
9 HOMEPAGE="http://rubyforge.org/projects/rubygems/"
10 LICENSE="Ruby"
11
12 # The URL depends implicitly on the version, unfortunately. Even if you
13 # change the filename on the end, it still downloads the same file.
14 SRC_URI="http://rubyforge.org/frs/download.php/16452/${P}.tgz"
15
16 KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
17 SLOT="0"
18 IUSE="doc server examples"
19 DEPEND=">=dev-lang/ruby-1.8"
20 PDEPEND="server? ( dev-ruby/builder )" # index_gem_repository.rb
21
22 PATCHES="${FILESDIR}/${P}-no_post_install.patch
23 ${FILESDIR}/no-system-rubygems.patch"
24 USE_RUBY="ruby18"
25
26 src_unpack() {
27 ruby_src_unpack
28 use doc || epatch "${FILESDIR}/${P}-no_rdoc_install.patch"
29 }
30
31 src_compile() {
32 return
33 }
34
35 src_install() {
36 # RUBYOPT=-rauto_gem without rubygems installed will cause ruby to fail, bug #158455
37 export RUBYOPT="${GENTOO_RUBYOPT}"
38 ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["MAJOR"] + "." + Config::CONFIG["MINOR"]')
39 GEM_HOME=${D}usr/lib/ruby/gems/$ver ruby_src_install
40 cp "${FILESDIR}/auto_gem.rb" "${D}"/$(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')
41 keepdir /usr/lib/ruby/gems/$ver/doc
42 doenvd "${FILESDIR}/10rubygems"
43 }
44
45 src_test() {
46 #rake test || die "test failed"
47 for i in test/{test,functional}*.rb; do
48 ruby ${i} || die "$i failed"
49 done
50 }
51
52 pkg_postinst()
53 {
54 ewarn "If you have previously switched to using ruby18_with_gems using ruby-config, this"
55 ewarn "package has removed that file and makes it unnecessary anymore. Please use ruby-config"
56 ewarn "to revert back to ruby18."
57 }
58
59 pkg_postrm()
60 {
61 # If we potentially downgraded, then getting rid of RUBYOPT from env.d is probably a smart idea.
62 env-update
63 source /etc/profile
64 ewarn "You have removed dev-ruby/rubygems. Ruby applications are unlikely"
65 ewarn "to run in current shells because of missing auto_gem."
66 ewarn "Please source /etc/profile in your shells before using ruby"
67 ewarn "or start new shells"
68 }

  ViewVC Help
Powered by ViewVC 1.1.20