/[gentoo-x86]/dev-ruby/termcolor/termcolor-1.2.1-r1.ebuild
Gentoo

Contents of /dev-ruby/termcolor/termcolor-1.2.1-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (show annotations) (download)
Thu Apr 24 16:49:24 2014 UTC (4 years, 7 months ago) by mrueg
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +3 -3 lines
Remove ruby18 support.

(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )

1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.1-r1.ebuild,v 1.1 2013/11/11 10:53:26 mrueg Exp $
4
5 EAPI=5
6
7 #*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
8 USE_RUBY="ruby19 ruby20"
9
10 RUBY_FAKEGEM_RECIPE_TEST="rspec"
11
12 RUBY_FAKEGEM_TASK_DOC=""
13 RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
14
15 inherit ruby-fakegem
16
17 DESCRIPTION="a library for ANSI color formatting like HTML for output in terminal"
18 HOMEPAGE="http://termcolor.rubyforge.org/"
19
20 LICENSE="MIT"
21 SLOT="0"
22 KEYWORDS="~amd64 ~x86"
23 IUSE=""
24
25 RUBY_PATCHES=( ${P}-fix-spec.patch )
26
27 ruby_add_rdepend ">=dev-ruby/highline-1.5.0"

  ViewVC Help
Powered by ViewVC 1.1.20