/[gentoo-x86]/dev-util/valgrind/files/valgrind-3.6.1-glibc-2.15.patch
Gentoo

Contents of /dev-util/valgrind/files/valgrind-3.6.1-glibc-2.15.patch

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (show annotations) (download)
Wed Jul 25 15:34:34 2012 UTC (3 years ago) by blueness
Branch: MAIN
Allow valgrind 3.6.1-to build against glibc-2.15 so Andrew doesn't yell at me, bug #390323 comment #31

(Portage version: 2.1.10.65/cvs/Linux x86_64)

1 diff -Naur valgrind-3.6.1.orig//configure.in valgrind-3.6.1/configure.in
2 --- valgrind-3.6.1.orig//configure.in 2012-07-25 14:46:59.600964127 +0000
3 +++ valgrind-3.6.1/configure.in 2012-07-25 14:48:56.910013096 +0000
4 @@ -763,6 +763,13 @@
5 DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
6 DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
7 ;;
8 + 2.15)
9 + AC_MSG_RESULT(2.15 family)
10 + AC_DEFINE([GLIBC_2_15], 1, [Define to 1 if you're using glibc 2.15.x])
11 + DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
12 + DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
13 + DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
14 + ;;
15 aix5)
16 AC_MSG_RESULT(AIX 5.1 or 5.2 or 5.3)
17 AC_DEFINE([AIX5_LIBC], 1, [Define to 1 if you're using AIX 5.1 or 5.2 or 5.3])

  ViewVC Help
Powered by ViewVC 1.1.20