/[gentoo-x86]/eclass/autotools.eclass
Gentoo

Diff of /eclass/autotools.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.50 Revision 1.64
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.50 2006/10/17 18:59:36 flameeyes Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.64 2007/01/19 23:39:29 vapier Exp $
4# 4#
5# Author: Diego Pettenò <flameeyes@gentoo.org> 5# Author: Diego Pettenò <flameeyes@gentoo.org>
6# Enhancements: Martin Schlemmer <azarah@gentoo.org> 6# Enhancements: Martin Schlemmer <azarah@gentoo.org>
7# 7#
8# This eclass is for handling autotooled software packages that 8# This eclass is for handling autotooled software packages that
10# 10#
11# NB: If you add anything, please comment it! 11# NB: If you add anything, please comment it!
12 12
13inherit eutils libtool 13inherit eutils libtool
14 14
15[[ -z ${WANT_AUTOCONF} ]] && WANT_AUTOCONF="latest"
16[[ -z ${WANT_AUTOMAKE} ]] && WANT_AUTOMAKE="latest"
17
15_automake_atom="sys-devel/automake" 18_automake_atom="sys-devel/automake"
16_autoconf_atom="sys-devel/autoconf" 19_autoconf_atom="sys-devel/autoconf"
17if [[ -n ${WANT_AUTOMAKE} ]] && [[ ${WANT_AUTOMAKE} != "latest" ]]; then 20if [[ -n ${WANT_AUTOMAKE} ]]; then
18 case ${WANT_AUTOMAKE} in 21 case ${WANT_AUTOMAKE} in
19 # workaround while we have different versions of automake in arch and ~arch 22 # workaround while we have different versions of automake in arch and ~arch
23 none) _automake_atom="" ;; # some packages don't require automake at all
20 latest) _automake_atom="|| ( =sys-devel/automake-1.10* =sys-devel/automake-1.9* )" ;; 24 latest) _automake_atom="=sys-devel/automake-1.10*" ;;
21 *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;; 25 *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;;
22 esac 26 esac
27 [[ ${WANT_AUTOMAKE} == "latest" ]] && WANT_AUTOMAKE="1.10"
28 export WANT_AUTOMAKE
23fi 29fi
24 30
25if [[ -n ${WANT_AUTOCONF} ]] ; then 31if [[ -n ${WANT_AUTOCONF} ]] ; then
26 case ${WANT_AUTOCONF} in 32 case ${WANT_AUTOCONF} in
27 2.1) _autoconf_atom="=sys-devel/autoconf-${WANT_AUTOCONF}*" ;; 33 2.1) _autoconf_atom="=sys-devel/autoconf-${WANT_AUTOCONF}*" ;;
28 latest | 2.5) _autoconf_atom=">=sys-devel/autoconf-2.59" ;; 34 latest | 2.5) _autoconf_atom=">=sys-devel/autoconf-2.59" ;;
29 esac 35 esac
36 [[ ${WANT_AUTOCONF} == "latest" ]] && WANT_AUTOCONF="2.5"
37 export WANT_AUTOCONF
30fi 38fi
31DEPEND="${_automake_atom} 39DEPEND="${_automake_atom}
32 ${_autoconf_atom} 40 ${_autoconf_atom}
33 sys-devel/libtool" 41 sys-devel/libtool"
34RDEPEND="" 42RDEPEND=""
37# Variables: 45# Variables:
38# 46#
39# AT_M4DIR - Additional director(y|ies) aclocal should search 47# AT_M4DIR - Additional director(y|ies) aclocal should search
40# AM_OPTS - Additional options to pass to automake during 48# AM_OPTS - Additional options to pass to automake during
41# eautoreconf call. 49# eautoreconf call.
50# AT_NOELIBTOOLIZE - Don't run elibtoolize command if set to 'yes',
51# useful when elibtoolize needs to be ran with
52# particular options
42 53
43# Functions: 54# Functions:
44# 55#
45# eautoreconf() - Should do a full autoreconf - normally what most people 56# eautoreconf() - Should do a full autoreconf - normally what most people
46# will be interested in. Also should handle additional 57# will be interested in. Also should handle additional
114 ;; 125 ;;
115 esac 126 esac
116 done 127 done
117 fi 128 fi
118 129
119 autotools_set_versions
120 [[ ! -f aclocal.m4 || -n $(grep -e 'generated.*by aclocal' aclocal.m4) ]] && \ 130 [[ ! -f aclocal.m4 || -n $(grep -e 'generated.*by aclocal' aclocal.m4) ]] && \
121 autotools_run_tool aclocal "$@" ${aclocal_opts} 131 autotools_run_tool aclocal "$@" ${aclocal_opts}
122} 132}
123 133
124_elibtoolize() { 134_elibtoolize() {
140} 150}
141 151
142eautoheader() { 152eautoheader() {
143 # Check if we should run autoheader 153 # Check if we should run autoheader
144 [[ -n $(autotools_check_macro "AC_CONFIG_HEADERS") ]] || return 0 154 [[ -n $(autotools_check_macro "AC_CONFIG_HEADERS") ]] || return 0
145 autotools_set_versions
146 autotools_run_tool autoheader "$@" 155 NO_FAIL=1 autotools_run_tool autoheader "$@"
147} 156}
148 157
149eautoconf() { 158eautoconf() {
150 if [[ ! -f configure.ac && ! -f configure.in ]] ; then 159 if [[ ! -f configure.ac && ! -f configure.in ]] ; then
151 echo 160 echo
152 eerror "No configure.{ac,in} present in '$(pwd | sed -e 's:.*/::')'!" 161 eerror "No configure.{ac,in} present in '$(pwd | sed -e 's:.*/::')'!"
153 echo 162 echo
154 die "No configure.{ac,in} present!" 163 die "No configure.{ac,in} present!"
155 fi 164 fi
156 165
157 autotools_set_versions
158 autotools_run_tool autoconf "$@" 166 autotools_run_tool autoconf "$@"
159} 167}
160 168
161eautomake() { 169eautomake() {
162 local extra_opts 170 local extra_opts
163 171
164 [[ -f Makefile.am ]] || return 0 172 [[ -f Makefile.am ]] || return 0
165 173
166 autotools_set_versions
167 if [[ -z ${FROM_EAUTORECONF} && -f Makefile.in ]]; then 174 if [[ -z ${FROM_EAUTORECONF} && -f Makefile.in ]]; then
168 local used_automake 175 local used_automake
169 local installed_automake 176 local installed_automake
170 177
171 installed_automake=$(automake --version | head -n 1 | \ 178 installed_automake=$(automake --version | head -n 1 | \
186 193
187 # --force-missing seems not to be recognized by some flavours of automake 194 # --force-missing seems not to be recognized by some flavours of automake
188 autotools_run_tool automake --add-missing --copy ${extra_opts} "$@" 195 autotools_run_tool automake --add-missing --copy ${extra_opts} "$@"
189} 196}
190 197
191autotools_set_versions() {
192 [[ -n ${autotools_version_sets} ]] && return 0
193
194 if [[ -n ${WANT_AUTOCONF} ]]; then
195 [[ ${WANT_AUTOCONF} == "latest" ]] && WANT_AUTOCONF="2.5"
196 export WANT_AUTOCONF
197 einfo "Requested autoconf ${WANT_AUTOCONF}"
198 einfo "Using $(autoconf --version 2>/dev/null | head -n 1)"
199 einfo "Using $(autoheader --version 2>/dev/null | head -n 1)"
200 fi
201
202 if [[ -n ${WANT_AUTOMAKE} ]]; then
203 if [[ ${WANT_AUTOMAKE} == "latest" ]]; then
204 # Consider starting from 1.9, as that is stable everywhere.
205 has_version '~sys-devel/automake-1.9' && WANT_AUTOMAKE="1.9"
206 has_version '~sys-devel/automake-1.10' && WANT_AUTOMAKE="1.10"
207 fi
208 export WANT_AUTOMAKE
209 einfo "Requested automake ${WANT_AUTOMAKE}"
210 einfo "Using $(automake --version 2>/dev/null | head -n 1)"
211 einfo "Using $(aclocal --version 2>/dev/null | head -n 1)"
212 fi
213
214 autotools_version_sets="yes"
215}
216
217# Internal function to run an autotools' tool 198# Internal function to run an autotools' tool
218autotools_run_tool() { 199autotools_run_tool() {
219 local STDERR_TARGET="${T}/$$.out" 200 local STDERR_TARGET="${T}/$$.out"
220 local PATCH_TARGET="${T}/$$.patch"
221 local ris 201 local ris
222 202
223 echo "***** $1 *****" > ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/} 203 echo "***** $1 *****" > ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/}
224 echo >> ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/} 204 echo >> ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/}
225 205
226 ebegin "Running $@" 206 ebegin "Running $@"
227 $@ >> ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/} 2>&1 207 $@ >> ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/} 2>&1
228 ris=$? 208 ris=$?
229 eend ${ris} 209 eend ${ris}
230 210
231 if [[ ${ris} != 0 ]]; then 211 if [[ ${ris} != 0 && ${NO_FAIL} != 1 ]]; then
232 echo 212 echo
233 eerror "Failed Running $1 !" 213 eerror "Failed Running $1 !"
234 eerror 214 eerror
235 eerror "Include in your bugreport the contents of:" 215 eerror "Include in your bugreport the contents of:"
236 eerror 216 eerror

Legend:
Removed from v.1.50  
changed lines
  Added in v.1.64

  ViewVC Help
Powered by ViewVC 1.1.20