/[gentoo-x86]/eclass/depend.php.eclass
Gentoo

Diff of /eclass/depend.php.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.1.1.1 Revision 1.37
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2015 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.php.eclass,v 1.1.1.1 2005/11/30 09:59:31 chriswhite Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.php.eclass,v 1.37 2015/07/17 18:29:39 grknight Exp $
4# 4
5# ======================================================================== 5# @DEAD
6#
7# depend.php.eclass 6# @ECLASS: depend.php.eclass
8# functions to allow ebuilds to depend on php4 and/or php5 7# @MAINTAINER:
9# 8# Gentoo PHP team <php-bugs@gentoo.org>
10# Author: Stuart Herbert 9# @AUTHOR:
11# <stuart@gentoo.org> 10# Author: Stuart Herbert <stuart@gentoo.org>
12# 11# Author: Luca Longinotti <chtekk@gentoo.org>
13# Author: Luca Longinotti 12# Author: Jakub Moc <jakub@gentoo.org> (documentation)
14# <chtekk@gentoo.org> 13# @BLURB: Functions to allow ebuilds to depend on php5 and check for specific features.
15# 14# @DESCRIPTION:
16# Maintained by the PHP Herd <php-bugs@gentoo.org> 15# This eclass provides functions that allow ebuilds to depend on php5 and check
17# 16# for specific PHP features, SAPIs etc. Also provides dodoc-php wrapper to install
18# ======================================================================== 17# documentation for PHP packages to php-specific location.
18# This eclass is deprecated and is set to be removed 30 days after bug 552836 is resolved
19 19
20inherit eutils 20inherit eutils multilib
21
22# PHP4-only depend functions
23need_php4_cli()
24{
25 DEPEND="${DEPEND} =virtual/php-4*"
26 RDEPEND="${RDEPEND} =virtual/php-4*"
27 PHP_VERSION=4
28}
29
30need_php4_httpd()
31{
32 DEPEND="${DEPEND} =virtual/httpd-php-4*"
33 RDEPEND="${RDEPEND} =virtual/httpd-php-4*"
34 PHP_VERSION=4
35}
36
37need_php4()
38{
39 DEPEND="${DEPEND} =dev-lang/php-4*"
40 RDEPEND="${RDEPEND} =dev-lang/php-4*"
41 PHP_VERSION=4
42 PHP_SHARED_CAT="php4"
43}
44
45# common settings go in here
46uses_php4()
47{
48 # cache this
49 libdir=$(get_libdir)
50
51 PHPIZE="/usr/${libdir}/php4/bin/phpize"
52 PHPCONFIG="/usr/${libdir}/php4/bin/php-config"
53 PHPCLI="/usr/${libdir}/php4/bin/php"
54 PHPCGI="/usr/${libdir}/php4/bin/php-cgi"
55 PHP_PKG="`best_version =dev-lang/php-4*`"
56 PHPPREFIX="/usr/${libdir}/php4"
57
58 einfo
59 einfo "Using ${PHP_PKG}"
60 einfo
61}
62 21
63# PHP5-only depend functions 22# PHP5-only depend functions
64need_php5_cli()
65{
66 DEPEND="${DEPEND} =virtual/php-5*"
67 RDEPEND="${RDEPEND} =virtual/php-5*"
68 PHP_VERSION=5
69}
70 23
71need_php5_httpd() 24# @FUNCTION: need_php5
72{ 25# @DESCRIPTION:
73 DEPEND="${DEPEND} =virtual/httpd-php-5*" 26# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP5
74 RDEPEND="${RDEPEND} =virtual/httpd-php-5*" 27# (with any SAPI).
75 PHP_VERSION=5
76}
77
78need_php5() 28need_php5() {
79{
80 DEPEND="${DEPEND} =dev-lang/php-5*" 29 DEPEND="${DEPEND} =dev-lang/php-5*"
81 RDEPEND="${RDEPEND} =dev-lang/php-5*" 30 RDEPEND="${RDEPEND} =dev-lang/php-5*"
82 PHP_VERSION=5 31 PHP_VERSION="5"
83 PHP_SHARED_CAT="php5" 32 PHP_SHARED_CAT="php5"
84} 33}
85 34
86# common settings go in here 35# common settings go in here
87uses_php5() 36uses_php5() {
88{
89 # cache this 37 # cache this
90 libdir=$(get_libdir) 38 libdir=$(get_libdir)
91 39
92 PHPIZE="/usr/${libdir}/php5/bin/phpize" 40 PHPIZE="/usr/${libdir}/php5/bin/phpize"
93 PHPCONFIG="/usr/${libdir}/php5/bin/php-config" 41 PHPCONFIG="/usr/${libdir}/php5/bin/php-config"
94 PHPCLI="/usr/${libdir}/php5/bin/php" 42 PHPCLI="/usr/${libdir}/php5/bin/php"
95 PHPCGI="/usr/${libdir}/php5/bin/php-cgi" 43 PHPCGI="/usr/${libdir}/php5/bin/php-cgi"
96 PHP_PKG="`best_version =dev-lang/php-5*`" 44 PHP_PKG="$(best_version =dev-lang/php-5*)"
97 PHPPREFIX="/usr/${libdir}/php5" 45 PHPPREFIX="/usr/${libdir}/php5"
46 EXT_DIR="$(${PHPCONFIG} --extension-dir 2>/dev/null)"
98 47
99 einfo 48 einfo
100 einfo "Using ${PHP_PKG}" 49 einfo "Using ${PHP_PKG}"
101 einfo 50 einfo
102} 51}
103 52
104# general PHP depend functions 53# general PHP depend functions
105need_php_cli()
106{
107 DEPEND="${DEPEND} virtual/php"
108 RDEPEND="${RDEPEND} virtual/php"
109}
110 54
55# @FUNCTION: need_php_httpd
56# @DESCRIPTION:
57# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP
58# (any version) with either cgi or apache2 SAPI.
111need_php_httpd() 59need_php_httpd() {
112{
113 DEPEND="${DEPEND} virtual/httpd-php" 60 DEPEND="${DEPEND} virtual/httpd-php"
114 RDEPEND="${RDEPEND} virtual/httpd-php" 61 RDEPEND="${RDEPEND} virtual/httpd-php"
115} 62}
116 63
64# @FUNCTION: need_php
65# @DESCRIPTION:
66# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP
67# (any version with any SAPI).
117need_php() 68need_php() {
118{
119 DEPEND="${DEPEND} dev-lang/php" 69 DEPEND="${DEPEND} dev-lang/php"
120 RDEPEND="${RDEPEND} dev-lang/php" 70 RDEPEND="${RDEPEND} dev-lang/php"
121 PHP_SHARED_CAT="php" 71 PHP_SHARED_CAT="php"
122} 72}
123 73
124need_php_by_category() 74# @FUNCTION: has_php
125{ 75# @DESCRIPTION:
126 case "${CATEGORY}" in 76# Call this function from your pkg_setup, src_compile, src_install etc. if you
127 dev-php) need_php ;; 77# need to know which PHP version is being used and where the PHP binaries/data
128 dev-php4) need_php4 ;; 78# are installed.
129 dev-php5) need_php5 ;; 79has_php() {
130 *) die "I don't know which version of PHP packages in ${CATEGORY} require" 80 # Detect which PHP version we have installed
131 esac 81 if has_version '=dev-lang/php-5*' ; then
132} 82 PHP_VERSION="5"
83 else
84 die "Unable to find an installed dev-lang/php package"
85 fi
133 86
134# call this function from pkg_setup if your PHP extension only works with 87 # If we get here, then PHP_VERSION tells us which version of PHP we
135# specific SAPIs 88 # want to use
89 uses_php${PHP_VERSION}
90}
91
92# @FUNCTION: require_php_with_use
93# @USAGE: <list of USE flags>
94# @DESCRIPTION:
95# Call this function from pkg_setup if your package requires PHP compiled
96# with specific USE flags. Returns if all of the listed USE flags are enabled.
97# Dies if any of the listed USE flags are disabled.
98
99# @VARIABLE: PHPCHECKNODIE
100# @DESCRIPTION:
101# You can set PHPCHECKNODIE to non-empty value in your ebuild to chain multiple
102# require_php_with_(any)_use checks without making the ebuild die on every failure.
103# This is useful in cases when certain PHP features are only required if specific
104# USE flag(s) are enabled for that ebuild.
105# @CODE
106# Example:
136# 107#
137# this function will disappear when USE-based deps are supported by 108# local flags="pcre session snmp sockets wddx"
138# Portage 109# use mysql && flags="${flags} mysql"
139# 110# use postgres && flags="${flags} postgres"
140# $1 ... a list of SAPI USE flags (eg cli, cgi, apache2) 111# if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
141# 112# || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
142# returns if any one of the listed SAPIs has been installed 113# die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
143# dies if none of the listed SAPIs has been installed 114# fi
144 115# @CODE
145require_php_sapi_from() 116require_php_with_use() {
146{
147 has_php 117 has_php
148 118
149 local has_sapi=0 119 local missing_use=""
150 local x 120 local x
151 121
152 einfo "Checking for compatible SAPI(s)" 122 einfo "Checking for required PHP feature(s) ..."
153 123
154 for x in $@ ; do 124 for x in $@ ; do
155 if built_with_use =${PHP_PKG} ${x} ; then 125 case $x in
156 einfo " Discovered compatible SAPI ${x}" 126 pcre|spl|reflection|mhash)
157 has_sapi=1 127 eqawarn "require_php_with_use MUST NOT check for the pcre, spl, mhash or reflection USE flag."
158 fi 128 eqawarn "These USE flags are removed from >=dev-lang/php-5.3 and your ebuild will break"
159 done 129 eqawarn "if you check the USE flags against PHP 5.3 ebuilds."
130 eqawarn "Please use USE dependencies from EAPI 2 instead"
131 ;;
132 esac
160 133
161 if [[ ${has_sapi} == 1 ]]; then
162 return
163 fi
164
165 eerror
166 eerror "${PHP_PKG} needs to be re-installed with one of the following"
167 eerror "USE flags enabled:"
168 eerror
169 eerror " $@"
170 eerror
171 die "Re-install ${PHP_PKG}"
172}
173
174# call this function from pkg_setup if your package requires PHP compiled
175# with specific USE flags
176#
177# this function will disappear when USE-based deps are supported by
178# Portage
179#
180# $1 ... a list of USE flags
181#
182# returns if all of the listed USE flags are set
183# dies if any of the listed USE flags are not set
184
185require_php_with_use()
186{
187 has_php
188
189 local missing_use=
190 local x
191
192 einfo "Checking for required PHP feature(s):"
193
194 for x in $@ ; do
195 if ! built_with_use =${PHP_PKG} ${x} ; then 134 if ! built_with_use =${PHP_PKG} ${x} ; then
196 einfo " Discovered missing USE flag ${x}" 135 einfo " Discovered missing USE flag: ${x}"
197 missing_use="${missing_use} ${x}" 136 missing_use="${missing_use} ${x}"
198 fi 137 fi
199 done 138 done
200 139
201 if [[ -z ${missing_use} ]]; then 140 if [[ -z "${missing_use}" ]] ; then
141 if [[ -z "${PHPCHECKNODIE}" ]] ; then
202 return 142 return
203 fi
204
205 eerror
206 eerror "${PHP_PKG} needs to be re-installed with all of the following"
207 eerror "USE flags enabled:"
208 eerror
209 eerror " $@"
210 eerror
211 die "Re-install ${PHP_PKG}"
212}
213
214# call this function from your pkg_setup, src_compile & src_install methods
215# if you need to know where the PHP binaries are installed and their data
216
217has_php()
218{
219 # if PHP_PKG is set, then we have remembered our PHP settings
220 # from last time
221
222 if [[ -n ${PHP_PKG} ]]; then
223 return
224 fi
225
226 if [[ -z ${PHP_VERSION} ]]; then
227 # detect which PHP version installed
228 if has_version '=dev-lang/php-4*' ; then
229 PHP_VERSION=4
230 elif has_version '=dev-lang/php-5*' ; then
231 PHP_VERSION=5
232 else 143 else
233 die "Unable to find an installed dev-lang/php package" 144 return 0
234 fi 145 fi
235 fi 146 fi
236 147
237 # if we get here, then PHP_VERSION tells us which version of PHP we 148 if [[ -z "${PHPCHECKNODIE}" ]] ; then
238 # want to use 149 eerror
239 150 eerror "${PHP_PKG} needs to be re-installed with all of the following"
240 uses_php${PHP_VERSION} 151 eerror "USE flags enabled:"
241} 152 eerror
242 153 eerror " $@"
243# ======================================================================== 154 eerror
244# has_*() functions 155 die "Missing PHP USE flags found"
245# 156 else
246# these functions return 0 if the condition is satisfied, or 1 otherwise
247# ========================================================================
248
249# check if our PHP was compiled with ZTS (Zend Thread Safety)
250
251has_zts()
252{
253 has_php
254
255 if built_with_use =${PHP_PKG} apache2 threads ; then
256 return 0
257 fi
258
259 return 1 157 return 1
260}
261
262# check if our PHP was built with Hardened-PHP active
263
264has_hardenedphp()
265{
266 has_php
267
268 if built_with_use =${PHP_PKG} hardenedphp ; then
269 return 0
270 fi 158 fi
271
272 return 1
273} 159}
160
274 161
275# ======================================================================== 162# ========================================================================
276# require_*() functions 163# require_*() functions
277# 164#
278# These functions die() if PHP was built without the required USE flag(s) 165# These functions die() if PHP was built without the required features
279# ======================================================================== 166# ========================================================================
280 167
281# require a PHP built with PDO support for PHP5 168# @FUNCTION: require_php_cgi
282 169# @DESCRIPTION:
283require_pdo() 170# Determines which installed PHP version has the CGI SAPI enabled.
284{ 171# Useful for anything which needs to run PHP scripts depending on the CGI SAPI.
285 has_php 172# @RETURN: die if feature is missing
286 173require_php_cgi() {
287 # do we have php5.1 installed? 174 # If PHP_PKG is set, then we have remembered our PHP settings
288 175 # from last time
289 if [[ ${PHP_VERSION} == 4 ]] ; then 176 if [[ -n ${PHP_PKG} ]] ; then
290 eerror
291 eerror "This package requires PDO."
292 eerror "PDO is only available for PHP 5."
293 eerror "Please install dev-lang/php-5*"
294 eerror
295 die "PHP 5 not installed"
296 fi
297
298 # was php5 compiled w/ pdo support?
299
300 if built_with_use =${PHP_PKG} pdo ; then
301 return 177 return
302 fi 178 fi
303 179
304 # ok, maybe PDO was built as an external extension? 180 local PHP_PACKAGE_FOUND=""
305 181
306 if built_with_use =${PHP_PKG} pdo-external && has_version dev-php5/pecl-pdo ; then
307 return
308 fi
309
310 # ok, as last resort, it suffices that pecl-pdo was installed to have PDO support
311
312 if has_version dev-php5/pecl-pdo ; then
313 return
314 fi
315
316 # if we get here, then we have no PDO support
317
318 eerror
319 eerror "No PDO extension for PHP found."
320 eerror "Please note that PDO only exists for PHP 5."
321 eerror "Please install a PDO extension for PHP 5,"
322 eerror "you must install dev-lang/php-5.0* with"
323 eerror "the 'pdo-external' USE flag or you must"
324 eerror "install dev-lang/php-5.1* with either"
325 eerror "the 'pdo' or the 'pdo-external' USE flags"
326 eerror "turned on."
327 eerror
328 die "No PDO extension found for PHP 5"
329}
330
331# determines which installed PHP version has the CLI sapi
332# useful for PEAR eclass, or anything which needs to run PHP
333# scripts depending on the cli sapi
334
335require_php_cli()
336{
337 # if PHP_PKG is set, then we have remembered our PHP settings
338 # from last time
339
340 if [[ -n ${PHP_PKG} ]]; then
341 return
342 fi
343
344 # detect which PHP version installed
345 if has_version '=dev-lang/php-4*' ; then 182 if has_version '=dev-lang/php-5*' ; then
183 PHP_PACKAGE_FOUND="1"
346 pkg="`best_version '=dev-lang/php-4*'`" 184 pkg="$(best_version '=dev-lang/php-5*')"
347 if built_with_use =${pkg} cli ; then 185 if built_with_use =${pkg} cgi ; then
348 PHP_VERSION=4 186 PHP_VERSION="5"
349 fi 187 fi
350 elif has_version '=dev-lang/php-5*' ; then
351 pkg="`best_version '=dev-lang/php-5*'`"
352 if built_with_use =${pkg} cli ; then
353 PHP_VERSION=5
354 fi 188 fi
355 else 189
190 if [[ -z ${PHP_PACKAGE_FOUND} ]] ; then
356 die "Unable to find an installed dev-lang/php package" 191 die "Unable to find an installed dev-lang/php package"
357 fi 192 fi
358 193
359 if [[ -z ${PHP_VERSION} ]]; then 194 if [[ -z ${PHP_VERSION} ]] ; then
360 die "No PHP CLI installed" 195 die "No PHP CGI installed. Re-emerge dev-lang/php with USE=cgi."
361 fi 196 fi
362 197
363 # if we get here, then PHP_VERSION tells us which version of PHP we 198 # If we get here, then PHP_VERSION tells us which version of PHP we
364 # want to use 199 # want to use
365
366 uses_php${PHP_VERSION} 200 uses_php${PHP_VERSION}
367}
368
369# determines which installed PHP version has the CGI sapi
370# useful for anything which needs to run PHP scripts
371# depending on the cgi sapi
372
373require_php_cgi()
374{
375 # if PHP_PKG is set, then we have remembered our PHP settings
376 # from last time
377
378 if [[ -n ${PHP_PKG} ]]; then
379 return
380 fi
381
382 # detect which PHP version installed
383 if has_version '=dev-lang/php-4*' ; then
384 pkg="`best_version '=dev-lang/php-4*'`"
385 if built_with_use =${pkg} cgi ; then
386 PHP_VERSION=4
387 fi
388 elif has_version '=dev-lang/php-5*' ; then
389 pkg="`best_version '=dev-lang/php-5*'`"
390 if built_with_use =${pkg} cgi ; then
391 PHP_VERSION=5
392 fi
393 else
394 die "Unable to find an installed dev-lang/php package"
395 fi
396
397 if [[ -z ${PHP_VERSION} ]]; then
398 die "No PHP CGI installed"
399 fi
400
401 # if we get here, then PHP_VERSION tells us which version of PHP we
402 # want to use
403
404 uses_php${PHP_VERSION}
405}
406
407# require a PHP built with sqlite support
408
409require_sqlite()
410{
411 has_php
412
413 # has our PHP been built with sqlite?
414
415 if built_with_use =${PHP_PKG} sqlite ; then
416 return
417 fi
418
419 # do we have pecl-sqlite installed for PHP 4?
420
421 if [[ ${PHP_VERSION} == 4 ]] ; then
422 if has_version dev-php4/pecl-sqlite ; then
423 return
424 fi
425 fi
426
427 # if we get here, then we don't have any sqlite support for PHP installed
428
429 eerror
430 eerror "No sqlite extension for PHP found."
431 eerror "Please install an sqlite extension for PHP,"
432 eerror "this is done best by simply adding the"
433 eerror "'sqlite' USE flag when emerging dev-lang/php."
434 eerror
435 die "No sqlite extension for PHP found"
436}
437
438# require a PHP built with GD support
439
440require_gd()
441{
442 has_php
443
444 # do we have the internal GD support installed?
445
446 if built_with_use =${PHP_PKG} gd ; then
447 return
448 fi
449
450 # ok, maybe GD was built using the external support?
451
452 if built_with_use =${PHP_PKG} gd-external ; then
453 return
454 fi
455
456 # if we get here, then we have no GD support
457
458 eerror
459 eerror "No GD support for PHP found."
460 eerror "Please install the GD support for PHP,"
461 eerror "you must install dev-lang/php with either"
462 eerror "the 'gd' or the 'gd-external' USE flags"
463 eerror "turned on."
464 eerror
465 die "No GD support found for PHP"
466} 201}
467 202
468# ======================================================================== 203# ========================================================================
469# Misc functions 204# Misc functions
470# 205#
471# These functions provide miscellaneous checks and functionality. 206# These functions provide miscellaneous checks and functionality.
472# ======================================================================== 207# ========================================================================
473 208
474# executes some checks needed when installing a binary PHP extension 209# @FUNCTION: dodoc-php
475 210# @USAGE: <list of docs>
476php_binary_extension() { 211# @DESCRIPTION:
477 has_php
478
479 # binary extensions do not support the change of PHP
480 # API version, so they can't be installed when USE flags
481 # are enabled wich change the PHP API version
482
483 if built_with_use =${PHP_PKG} hardenedphp ; then
484 eerror
485 eerror "You cannot install binary PHP extensions"
486 eerror "when the 'hardenedphp' USE flag is enabled!"
487 eerror "Please reemerge dev-lang/php with the"
488 eerror "'hardenedphp' USE flag turned off."
489 eerror
490 die "'hardenedphp' USE flag turned on"
491 fi
492
493 if built_with_use =${PHP_PKG} debug ; then
494 eerror
495 eerror "You cannot install binary PHP extensions"
496 eerror "when the 'debug' USE flag is enabled!"
497 eerror "Please reemerge dev-lang/php with the"
498 eerror "'debug' USE flag turned off."
499 eerror
500 die "'debug' USE flag turned on"
501 fi
502}
503
504# alternative to dodoc for use in our php eclasses and ebuilds 212# Alternative to dodoc function for use in our PHP eclasses and ebuilds.
505# stored here because depend.php gets always sourced everywhere 213# Stored here because depend.php gets always sourced everywhere in the PHP
506# in the PHP ebuilds and eclasses
507# it simply is dodoc with a changed path to the docs 214# ebuilds and eclasses. It simply is dodoc with a changed path to the docs.
508# no support for docinto is given! 215# NOTE: No support for docinto is provided!
509
510dodoc-php() 216dodoc-php() {
511{
512if [ $# -lt 1 ] ; then 217if [[ $# -lt 1 ]] ; then
513 echo "$0: at least one argument needed" 1>&2 218 echo "$0: at least one argument needed" 1>&2
514 exit 1 219 exit 1
515fi 220fi
516 221
517phpdocdir="${D}/usr/share/doc/${CATEGORY}/${PF}/" 222phpdocdir="/usr/share/doc/${CATEGORY}/${PF}/"
518 223
519if [ ! -d "${phpdocdir}" ] ; then 224for x in $@ ; do
225 if [[ -s "${x}" ]] ; then
520 install -d "${phpdocdir}" 226 insinto "${phpdocdir}"
227 doins "${x}"
228 gzip -f -9 "${D}/${phpdocdir}/${x##*/}"
229 elif [[ ! -e "${x}" ]] ; then
230 echo "dodoc-php: ${x} does not exist" 1>&2
231 fi
232done
233}
234
235# @FUNCTION: dohtml-php
236# @USAGE: <list of html docs>
237# @DESCRIPTION:
238# Alternative to dohtml function for use in our PHP eclasses and ebuilds.
239# Stored here because depend.php gets always sourced everywhere in the PHP
240# ebuilds and eclasses. It simply is dohtml with a changed path to the docs.
241# NOTE: No support for [-a|-A|-p|-x] options is provided!
242dohtml-php() {
243if [[ $# -lt 1 ]] ; then
244 echo "$0: at least one argument needed" 1>&2
245 exit 1
521fi 246fi
522 247
248phphtmldir="/usr/share/doc/${CATEGORY}/${PF}/html"
249
523for x in "$@" ; do 250for x in $@ ; do
524 if [ -s "${x}" ] ; then 251 if [[ -s "${x}" ]] ; then
525 install -m0644 "${x}" "${phpdocdir}" 252 insinto "${phphtmldir}"
526 gzip -f -9 "${phpdocdir}/${x##*/}" 253 doins "${x}"
527 elif [ ! -e "${x}" ] ; then 254 elif [[ ! -e "${x}" ]] ; then
528 echo "dodoc-php: ${x} does not exist" 1>&2 255 echo "dohtml-php: ${x} does not exist" 1>&2
529 fi 256 fi
530done 257done
531} 258}

Legend:
Removed from v.1.1.1.1  
changed lines
  Added in v.1.37

  ViewVC Help
Powered by ViewVC 1.1.20