/[gentoo-x86]/eclass/gnome2.eclass
Gentoo

Contents of /eclass/gnome2.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.129 - (show annotations) (download)
Mon Feb 23 10:57:38 2015 UTC (3 years, 6 months ago) by pacho
Branch: MAIN
Changes since 1.128: +12 -2 lines
Deprecate eapis 2 and 3 for gnome2.eclass (#539118)

1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/gnome2.eclass,v 1.128 2015/01/29 09:59:51 pacho Exp $
4
5 # @ECLASS: gnome2.eclass
6 # @MAINTAINER:
7 # gnome@gentoo.org
8 # @BLURB: Provides phases for Gnome/Gtk+ based packages.
9 # @DESCRIPTION:
10 # Exports portage base functions used by ebuilds written for packages using the
11 # GNOME framework. For additional functions, see gnome2-utils.eclass.
12
13 inherit eutils fdo-mime libtool gnome.org gnome2-utils
14
15 case "${EAPI:-0}" in
16 2|3)
17 eqawarn
18 eqawarn "${CATEGORY}/${PF}: EAPI 2/3 support is now deprecated."
19 eqawarn "If you are the package maintainer, please"
20 eqawarn "update this package to a newer EAPI."
21 eqawarn "Support for EAPIs 2 and 3 for gnome2.eclass will be dropped"
22 eqawarn "in a month (around 23rd March)."
23 eqawarn
24 EXPORT_FUNCTIONS src_unpack src_prepare src_configure src_compile src_install pkg_preinst pkg_postinst pkg_postrm
25 ;;
26 4|5)
27 EXPORT_FUNCTIONS src_unpack src_prepare src_configure src_compile src_install pkg_preinst pkg_postinst pkg_postrm
28 ;;
29 *) die "EAPI=${EAPI} is not supported" ;;
30 esac
31
32 # @ECLASS-VARIABLE: G2CONF
33 # @DEFAULT_UNSET
34 # @DESCRIPTION:
35 # Extra configure opts passed to econf
36 G2CONF=${G2CONF:-""}
37
38 # @ECLASS-VARIABLE: GNOME2_LA_PUNT
39 # @DESCRIPTION:
40 # Should we delete ALL the .la files?
41 # NOT to be used without due consideration.
42 if has ${EAPI:-0} 2 3 4; then
43 GNOME2_LA_PUNT=${GNOME2_LA_PUNT:-"no"}
44 else
45 GNOME2_LA_PUNT=${GNOME2_LA_PUNT:-""}
46 fi
47
48 # @ECLASS-VARIABLE: ELTCONF
49 # @DEFAULT_UNSET
50 # @DESCRIPTION:
51 # Extra options passed to elibtoolize
52 ELTCONF=${ELTCONF:-""}
53
54 # @ECLASS-VARIABLE: USE_EINSTALL
55 # @DEFAULT_UNSET
56 # @DESCRIPTION:
57 # Should we use EINSTALL instead of DESTDIR. DEPRECATED
58 USE_EINSTALL=${USE_EINSTALL:-""}
59
60 # @ECLASS-VARIABLE: DOCS
61 # @DEFAULT_UNSET
62 # @DESCRIPTION:
63 # String containing documents passed to dodoc command.
64
65 # @ECLASS-VARIABLE: GCONF_DEBUG
66 # @DEFAULT_UNSET
67 # @DESCRIPTION:
68 # Whether to handle debug or not.
69 # Some gnome applications support various levels of debugging (yes, no, minimum,
70 # etc), but using --disable-debug also removes g_assert which makes debugging
71 # harder. This variable should be set to yes for such packages for the eclass
72 # to handle it properly. It will enable minimal debug with USE=-debug.
73 # Note that this is most commonly found in configure.ac as GNOME_DEBUG_CHECK.
74
75
76 if [[ ${GCONF_DEBUG} != "no" ]]; then
77 IUSE="debug"
78 fi
79
80 # @FUNCTION: gnome2_src_unpack
81 # @DESCRIPTION:
82 # Stub function for old EAPI.
83 gnome2_src_unpack() {
84 unpack ${A}
85 cd "${S}"
86 }
87
88 # @FUNCTION: gnome2_src_prepare
89 # @DESCRIPTION:
90 # Prepare environment for build, fix build of scrollkeeper documentation,
91 # run elibtoolize.
92 gnome2_src_prepare() {
93 # Prevent assorted access violations and test failures
94 gnome2_environment_reset
95
96 # Prevent scrollkeeper access violations
97 gnome2_omf_fix
98
99 # Disable all deprecation warnings
100 gnome2_disable_deprecation_warning
101
102 # Run libtoolize
103 if has ${EAPI:-0} 2 3; then
104 elibtoolize ${ELTCONF}
105 else
106 # Everything is fatal EAPI 4 onwards
107 nonfatal elibtoolize ${ELTCONF}
108 fi
109
110 }
111
112 # @FUNCTION: gnome2_src_configure
113 # @DESCRIPTION:
114 # Gnome specific configure handling
115 gnome2_src_configure() {
116 # Update the GNOME configuration options
117 if [[ ${GCONF_DEBUG} != 'no' ]] ; then
118 if use debug ; then
119 G2CONF="--enable-debug=yes ${G2CONF}"
120 fi
121 fi
122
123 # Starting with EAPI=5, we consider packages installing gtk-doc to be
124 # handled by adding DEPEND="dev-util/gtk-doc-am" which provides tools to
125 # relink URLs in documentation to already installed documentation.
126 # This decision also greatly helps with constantly broken doc generation.
127 # Remember to drop 'doc' USE flag from your package if it was only used to
128 # rebuild docs.
129 # Preserve old behavior for older EAPI.
130 if grep -q "enable-gtk-doc" "${ECONF_SOURCE:-.}"/configure ; then
131 if has ${EAPI:-0} 2 3 4 && in_iuse doc ; then
132 G2CONF="$(use_enable doc gtk-doc) ${G2CONF}"
133 else
134 G2CONF="--disable-gtk-doc ${G2CONF}"
135 fi
136 fi
137
138 # Pass --disable-maintainer-mode when needed
139 if grep -q "^[[:space:]]*AM_MAINTAINER_MODE(\[enable\])" \
140 "${ECONF_SOURCE:-.}"/configure.*; then
141 G2CONF="--disable-maintainer-mode ${G2CONF}"
142 fi
143
144 # Pass --disable-scrollkeeper when possible
145 if grep -q "disable-scrollkeeper" "${ECONF_SOURCE:-.}"/configure; then
146 G2CONF="--disable-scrollkeeper ${G2CONF}"
147 fi
148
149 # Pass --disable-silent-rules when possible (not needed for eapi5), bug #429308
150 if has ${EAPI:-0} 2 3 4; then
151 if grep -q "disable-silent-rules" "${ECONF_SOURCE:-.}"/configure; then
152 G2CONF="--disable-silent-rules ${G2CONF}"
153 fi
154 fi
155
156 # Pass --disable-schemas-install when possible
157 if grep -q "disable-schemas-install" "${ECONF_SOURCE:-.}"/configure; then
158 G2CONF="--disable-schemas-install ${G2CONF}"
159 fi
160
161 # Pass --disable-schemas-compile when possible
162 if grep -q "disable-schemas-compile" "${ECONF_SOURCE:-.}"/configure; then
163 G2CONF="--disable-schemas-compile ${G2CONF}"
164 fi
165
166 # Pass --enable-compile-warnings=minimum as we don't want -Werror* flags, bug #471336
167 if grep -q "enable-compile-warnings" "${ECONF_SOURCE:-.}"/configure; then
168 G2CONF="--enable-compile-warnings=minimum ${G2CONF}"
169 fi
170
171 # Pass --docdir with proper directory, bug #482646
172 if grep -q "^ *--docdir=" "${ECONF_SOURCE:-.}"/configure; then
173 G2CONF="--docdir="${EPREFIX}"/usr/share/doc/${PF} ${G2CONF}"
174 fi
175
176 # Avoid sandbox violations caused by gnome-vfs (bug #128289 and #345659)
177 addwrite "$(unset HOME; echo ~)/.gnome2"
178
179 econf ${G2CONF} "$@"
180 }
181
182 # @FUNCTION: gnome2_src_compile
183 # @DESCRIPTION:
184 # Only default src_compile for now
185 gnome2_src_compile() {
186 emake || die "compile failure"
187 }
188
189 # @FUNCTION: gnome2_src_install
190 # @DESCRIPTION:
191 # Gnome specific install. Handles typical GConf and scrollkeeper setup
192 # in packages and removal of .la files if requested
193 gnome2_src_install() {
194 has ${EAPI:-0} 2 && ! use prefix && ED="${D}"
195 # if this is not present, scrollkeeper-update may segfault and
196 # create bogus directories in /var/lib/
197 local sk_tmp_dir="/var/lib/scrollkeeper"
198 dodir "${sk_tmp_dir}" || die "dodir failed"
199
200 # we must delay gconf schema installation due to sandbox
201 export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
202
203 if [[ -z "${USE_EINSTALL}" || "${USE_EINSTALL}" = "0" ]]; then
204 debug-print "Installing with 'make install'"
205 emake DESTDIR="${D}" "scrollkeeper_localstate_dir=${ED}${sk_tmp_dir} " "$@" install || die "install failed"
206 else
207 debug-print "Installing with 'einstall'"
208 eqawarn
209 eqawarn "Support for USE_EINSTALL will be dropped in a month,"
210 eqawarn "please stop using it (#482082)"
211 eqawarn
212 einstall "scrollkeeper_localstate_dir=${ED}${sk_tmp_dir} " "$@" || die "einstall failed"
213 fi
214
215 unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
216
217 # Handle documentation as 'default' for eapi5 and newer, bug #373131
218 if has ${EAPI:-0} 2 3 4; then
219 # Manual document installation
220 if [[ -n "${DOCS}" ]]; then
221 dodoc ${DOCS} || die "dodoc failed"
222 fi
223 else
224 einstalldocs
225 fi
226
227 # Do not keep /var/lib/scrollkeeper because:
228 # 1. The scrollkeeper database is regenerated at pkg_postinst()
229 # 2. ${ED}/var/lib/scrollkeeper contains only indexes for the current pkg
230 # thus it makes no sense if pkg_postinst ISN'T run for some reason.
231 rm -rf "${ED}${sk_tmp_dir}"
232 rmdir "${ED}/var/lib" 2>/dev/null
233 rmdir "${ED}/var" 2>/dev/null
234
235 # Make sure this one doesn't get in the portage db
236 rm -fr "${ED}/usr/share/applications/mimeinfo.cache"
237
238 # Delete all .la files
239 if has ${EAPI:-0} 2 3 4; then
240 if [[ "${GNOME2_LA_PUNT}" != "no" ]]; then
241 ebegin "Removing .la files"
242 if ! use_if_iuse static-libs ; then
243 find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
244 fi
245 eend
246 fi
247 else
248 case "${GNOME2_LA_PUNT}" in
249 yes) prune_libtool_files --modules;;
250 no) ;;
251 *) prune_libtool_files;;
252 esac
253 fi
254 }
255
256 # @FUNCTION: gnome2_pkg_preinst
257 # @DESCRIPTION:
258 # Finds Icons, GConf and GSettings schemas for later handling in pkg_postinst
259 gnome2_pkg_preinst() {
260 gnome2_gconf_savelist
261 gnome2_icon_savelist
262 gnome2_schemas_savelist
263 gnome2_scrollkeeper_savelist
264 gnome2_gdk_pixbuf_savelist
265 }
266
267 # @FUNCTION: gnome2_pkg_postinst
268 # @DESCRIPTION:
269 # Handle scrollkeeper, GConf, GSettings, Icons, desktop and mime
270 # database updates.
271 gnome2_pkg_postinst() {
272 gnome2_gconf_install
273 fdo-mime_desktop_database_update
274 fdo-mime_mime_database_update
275 gnome2_icon_cache_update
276 gnome2_schemas_update
277 gnome2_scrollkeeper_update
278 gnome2_gdk_pixbuf_update
279 }
280
281 # # FIXME Handle GConf schemas removal
282 #gnome2_pkg_prerm() {
283 # gnome2_gconf_uninstall
284 #}
285
286 # @FUNCTION: gnome2_pkg_postrm
287 # @DESCRIPTION:
288 # Handle scrollkeeper, GSettings, Icons, desktop and mime database updates.
289 gnome2_pkg_postrm() {
290 fdo-mime_desktop_database_update
291 fdo-mime_mime_database_update
292 gnome2_icon_cache_update
293 gnome2_schemas_update
294 gnome2_scrollkeeper_update
295 }

  ViewVC Help
Powered by ViewVC 1.1.20