/[gentoo-x86]/eclass/gst-plugins-bad.eclass
Gentoo

Diff of /eclass/gst-plugins-bad.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.39 Revision 1.40
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-bad.eclass,v 1.39 2011/07/13 06:10:47 leio Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-bad.eclass,v 1.40 2011/07/29 07:01:40 leio Exp $
4 4
5# 5#
6# Original Author: Saleem Abdulrasool <compnerd@gentoo.org> 6# Original Author: Saleem Abdulrasool <compnerd@gentoo.org>
7# Based on the work of foser <foser@gentoo.org> and zaheerm <zaheerm@gentoo.org> 7# Based on the work of foser <foser@gentoo.org> and zaheerm <zaheerm@gentoo.org>
8# Purpose: This elcass is designed to help package external gst-plugins per 8# Purpose: This elcass is designed to help package external gst-plugins per
34 my_gst_plugins_bad+=" theoradec" 34 my_gst_plugins_bad+=" theoradec"
35fi 35fi
36 36
37# Changes in 0.10.21: 37# Changes in 0.10.21:
38# New opencv and apple_media plugins 38# New opencv and apple_media plugins
39# exif for a specific jifmux tests purpose only
40if version_is_at_least "0.10.21"; then 39if version_is_at_least "0.10.21"; then
41 my_gst_plugins_bad+=" opencv apple_media exif" 40 my_gst_plugins_bad+=" opencv apple_media"
41fi
42
43# exif for a specific jifmux tests purpose only.
44# Made automagic in 0.10.22, which is fine as a non-installed test
45if [ ${PV} == "0.10.21" ]; then
46 my_gst_plugins_bad+=" exif"
42fi 47fi
43 48
44# jack moved to -good, metadata removed (functionality in base classes) 49# jack moved to -good, metadata removed (functionality in base classes)
45# alsaspdif gone (gst-plugins-alsa from -base can do spdif on its own long ago) 50# alsaspdif gone (gst-plugins-alsa from -base can do spdif on its own long ago)
46if ! version_is_at_least "0.10.21"; then 51if ! version_is_at_least "0.10.21"; then

Legend:
Removed from v.1.39  
changed lines
  Added in v.1.40

  ViewVC Help
Powered by ViewVC 1.1.20