/[gentoo-x86]/eclass/gtk-sharp-module.eclass
Gentoo

Contents of /eclass/gtk-sharp-module.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.19 - (hide annotations) (download)
Mon Mar 9 01:02:13 2009 UTC (6 years, 3 months ago) by loki_val
Branch: MAIN
Changes since 1.18: +14 -3 lines
Prepare eclass for gnome-sharp-2.24.1. Fix typo in eclass-manpages stuff.

1 loki_val 1.1 # Copyright 1999-2008 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 loki_val 1.19 # $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-module.eclass,v 1.18 2009/03/03 10:41:21 loki_val Exp $
4 loki_val 1.1
5 loki_val 1.14 # @ECLASS: gtk-sharp-module.eclass
6     # @MAINTAINER:
7     # dotnet@gentoo.org
8     # @BLURB: Manages the modules of the gtk-, gnome-, and gnome-desktop-sharp tarballs
9     # @DESCRIPTION:
10     # This eclass provides phase functions and helper functions for the modules
11     # of the gtk-sharp, gnome-sharp and gnome-desktop-sharp tarballs.
12     # PLEASE TAKE NOTE: ONLY FOR EAPI-2 EBUILDS
13 loki_val 1.1
14 loki_val 1.14 WANT_AUTOMAKE=none
15     WANT_AUTOCONF=none
16 loki_val 1.1
17 loki_val 1.8 inherit eutils mono multilib autotools base versionator
18 loki_val 1.1
19 loki_val 1.14 # @ECLASS-VARIABLE: GTK_SHARP_MODULE
20     # @DESCRIPTION:
21     # The name of the Gtk# module.
22     # Default value: ${PN/-sharp/}
23 loki_val 1.1 GTK_SHARP_MODULE=${GTK_SHARP_MODULE:=${PN/-sharp/}}
24 loki_val 1.14
25     # @ECLASS-VARIABLE: GTK_SHARP_MODULE_DIR
26     # @DESCRIPTION:
27     # The subdirectory of S in which GTK_SHARP_MODULE is installed.
28     # Default value: ${PN/-sharp/}
29 loki_val 1.1 GTK_SHARP_MODULE_DIR=${GTK_SHARP_MODULE_DIR:=${PN/-sharp/}}
30    
31 loki_val 1.14 # @ECLASS-VARIABLE: GTK_SHARP_REQUIRED_VERSION
32     # @DESCRIPTION:
33     # The version of the gtk-sharp tarball this package requires.
34     # Optional.
35     GTK_SHARP_REQUIRED_VERSION="${GTK_SHARP_REQUIRED_VERSION}"
36    
37     # @ECLASS-VARIABLE: gapi_users_list
38     # @DESCRIPTION:
39     # List of modules that use one of gapi2-codegen, gapi2-fixup or gapi2-parser
40     # No ebuild-serviceable parts inside.
41     gapi_users_list="art gnome gnomevfs ${gnome_desktop_sharp_module_list} atk gtk gdk glade pango"
42    
43     # @ECLASS-VARIABLE: PV_MAJOR
44     # @DESCRIPTION:
45     # The first two components of the PV variable.
46 loki_val 1.8 PV_MAJOR=$(get_version_component_range 1-2)
47    
48 loki_val 1.14 # @FUNCTION: add_bdepends
49     # @USAGE: <package atom>
50     # @DESCRIPTION:
51     # Adds to the DEPEND variable
52 loki_val 1.8 add_bdepend() {
53 loki_val 1.14 [[ ${#@} -eq 1 ]] || die "${FUNCNAME} needs ONE (1) argument"
54 loki_val 1.8 DEPEND="${DEPEND} $@"
55     }
56    
57 loki_val 1.14 # @FUNCTION: add_rdepends
58     # @USAGE: <package atom>
59     # @DESCRIPTION:
60     # Adds to the RDEPEND variable
61 loki_val 1.8 add_rdepend() {
62 loki_val 1.14 [[ ${#@} -eq 1 ]] || die "${FUNCNAME} needs ONE (1) argument"
63 loki_val 1.8 RDEPEND="${RDEPEND} $@"
64     }
65    
66 loki_val 1.14 # @FUNCTION: add_depend
67     # @USAGE: <package atom>
68     # @DESCRIPTION:
69     # Adds to the DEPEND and RDEPEND variables
70 loki_val 1.8 add_depend() {
71 loki_val 1.14 [[ ${#@} -eq 1 ]] || die "${FUNCNAME} needs ONE (1) argument"
72 loki_val 1.8 DEPEND="${DEPEND} $@"
73     RDEPEND="${RDEPEND} $@"
74     }
75    
76 loki_val 1.14 # @ECLASS-VARIABLE: TARBALL
77     # @DESCRIPTION:
78     # The GtkSharp modules are currently divided into three seperate tarball
79     # distributions. The TARBALL variable holds the name of the tarball
80     # to which GTK_SHARP_MODULE belongs.
81     case ${GTK_SHARP_MODULE} in
82     glib|glade|gtk|gdk|atk|pango|gtk-dotnet|gtk-gapi|gtk-docs)
83     TARBALL="gtk-sharp"
84     case ${PVR} in
85 loki_val 1.15 2.12.*)
86 loki_val 1.19 SRC_URI="mirror://gentoo/${TARBALL}-2.12.7.patch.bz2"
87 loki_val 1.14 #Upstream: https://bugzilla.novell.com/show_bug.cgi?id=$bugno
88     #Upstream bug #470390 for the gtk-sharp-2.12.7.patch
89 loki_val 1.15 PATCHES=(
90     "${WORKDIR}/${TARBALL}-2.12.7.patch"
91     )
92 loki_val 1.14 EAUTORECONF="YES"
93     add_bdepend "=sys-devel/automake-1.10*"
94     add_bdepend ">=sys-devel/autoconf-2.61"
95     ;;
96     esac
97     ;;
98     art|gnome|gnomevfs|gconf)
99     TARBALL="gnome-sharp"
100     add_depend "=dev-dotnet/gtk-sharp-${GTK_SHARP_REQUIRED_VERSION}*"
101     has "${GTK_SHARP_MODULE}" "${gapi_users_list}" && \
102     add_bdepend "=dev-dotnet/gtk-sharp-gapi-${GTK_SHARP_REQUIRED_VERSION}*"
103 loki_val 1.19 case ${PVR} in
104     2.24.1*)
105     SRC_URI="mirror://gentoo/${TARBALL}-2.24.1.patch.bz2"
106     PATCHES=(
107     "${WORKDIR}/${TARBALL}-2.24.1.patch"
108     )
109     EAUTORECONF="YES"
110     add_bdepend "=sys-devel/automake-1.10*"
111     add_bdepend ">=sys-devel/autoconf-2.61"
112     ;;
113     esac
114 loki_val 1.14 ;;
115     gnome-desktop|gnome-print|gnome-panel|gtkhtml|gtksourceview|nautilusburn|rsvg|vte|wnck)
116     TARBALL="gnome-desktop-sharp"
117     add_depend "=dev-dotnet/gtk-sharp-${GTK_SHARP_REQUIRED_VERSION}*"
118     add_depend "=dev-dotnet/gnome-sharp-${PV_MAJOR}*"
119     add_bdepend "=dev-dotnet/gtk-sharp-gapi-${GTK_SHARP_REQUIRED_VERSION}*"
120     ;;
121     *)
122     eerror "Huh? Sonny boy, looks like your GTK_SHARP_MODULE is not on the approved list. BAILING!"
123     die "How did we get here!!?"
124     ;;
125     esac
126 loki_val 1.8
127     case ${PF} in
128     #gtk-sharp tarball
129 loki_val 1.14 gtk-sharp-docs*)
130     add_depend ">=virtual/monodoc-2.0"
131     ;;
132 loki_val 1.8 gtk-sharp-gapi*)
133 loki_val 1.10 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
134 loki_val 1.8 add_depend "dev-perl/XML-LibXML"
135     ;;
136     gtk-sharp-*)
137 loki_val 1.14 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
138     add_depend "~dev-dotnet/glib-sharp-${PV}"
139 loki_val 1.8 add_depend "~dev-dotnet/atk-sharp-${PV}"
140     add_depend "~dev-dotnet/gdk-sharp-${PV}"
141     add_depend "~dev-dotnet/pango-sharp-${PV}"
142     ;;
143     gdk-sharp-*)
144 loki_val 1.14 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
145     add_depend "~dev-dotnet/glib-sharp-${PV}"
146 loki_val 1.8 add_depend "x11-libs/gtk+:2"
147     add_depend "~dev-dotnet/pango-sharp-${PV}"
148 loki_val 1.14 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
149 loki_val 1.8 ;;
150     atk-sharp-*)
151 loki_val 1.14 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
152     add_depend "~dev-dotnet/glib-sharp-${PV}"
153     add_depend "dev-libs/atk"
154 loki_val 1.8 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
155     ;;
156     glib-sharp-*)
157     add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
158     add_depend "dev-libs/glib:2"
159     ;;
160     pango-sharp-*)
161 loki_val 1.14 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
162     add_depend "~dev-dotnet/glib-sharp-${PV}"
163     add_depend "x11-libs/pango"
164 loki_val 1.8 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
165     ;;
166     gtk-dotnet-*)
167 loki_val 1.14 add_depend "~dev-dotnet/glib-sharp-${PV}"
168 loki_val 1.8 add_depend "~dev-dotnet/gdk-sharp-${PV}"
169     add_depend "~dev-dotnet/pango-sharp-${PV}"
170 loki_val 1.14 add_depend "~dev-dotnet/gtk-sharp-${PV}"
171     add_depend "dev-lang/mono[-minimal]"
172     add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
173 loki_val 1.8 ;;
174     glade-sharp-*)
175 loki_val 1.14 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
176     add_depend "~dev-dotnet/glib-sharp-${PV}"
177 loki_val 1.8 add_depend "~dev-dotnet/atk-sharp-${PV}"
178     add_depend "~dev-dotnet/gdk-sharp-${PV}"
179 loki_val 1.14 add_depend "~dev-dotnet/gtk-sharp-${PV}"
180 loki_val 1.8 add_depend "~dev-dotnet/pango-sharp-${PV}"
181     add_depend ">=gnome-base/libglade-2.3.6"
182     ;;
183     #gnome-sharp tarball
184     art-sharp-*)
185     add_depend ">=media-libs/libart_lgpl-2.3.20"
186     ;;
187     gnome-sharp-*)
188     add_depend ">=gnome-base/libgnomeui-${PV_MAJOR}"
189     add_depend ">=gnome-base/gnome-panel-${PV_MAJOR}"
190     add_depend "~dev-dotnet/gnomevfs-sharp-${PV}"
191     add_depend "~dev-dotnet/art-sharp-${PV}"
192     add_depend ">=gnome-base/libgnomecanvas-${GNOMECANVAS_REQUIRED_VERSION}"
193     ;;
194     gconf-sharp-*)
195     add_depend ">=gnome-base/gconf-${PV_MAJOR}"
196     add_depend ">=dev-dotnet/glade-sharp-${GTK_SHARP_REQUIRED_VERSION}"
197     add_depend "~dev-dotnet/gnome-sharp-${PV}"
198     add_depend "~dev-dotnet/art-sharp-${PV}"
199     ;;
200     gnomevfs-sharp-*)
201     add_depend ">=gnome-base/gnome-vfs-${PV_MAJOR}"
202     ;;
203     #gnome-desktop-sharp tarball
204     gnome-desktop-sharp-*)
205 loki_val 1.18 # NOTE: This is REQUIRED to be locked to PV_MAJOR
206     # libgnome-desktop-2.so.INTEGER is hardcoded in gnomedesktop-sharp.dll.config
207     add_depend "=gnome-base/gnome-desktop-${PV_MAJOR}*"
208 loki_val 1.8 ;;
209     gnome-panel-sharp-*)
210 zmedico 1.17 add_depend ">=gnome-base/gnome-panel-${PV_MAJOR}"
211 loki_val 1.8 ;;
212     gnome-print-sharp-*)
213     add_depend ">=gnome-base/libgnomeprint-${API_VERSION}"
214     ;;
215     gtkhtml-sharp-*)
216     #NOTE: gtkhtml dependency must follow gtkhtml-sharp version.
217     #i.e. gtkhtml-sharp-2.24.0 >=gtkhtml-3.24
218     # gtkhtml-sharp-2.16.0 >=gtkhtml-3.16
219     # See bug 249540 for unpleasant side effects.
220     add_depend ">=gnome-extra/gtkhtml-$(($(get_version_component_range 1) + 1 )).$(get_version_component_range 2)"
221     ;;
222     gtksourceview-sharp-*)
223     add_depend ">=x11-libs/gtksourceview-${GTKSOURCEVIEW_REQUIRED_VERSION}:2.0"
224     ;;
225     nautilusburn-sharp-*)
226     add_depend ">=gnome-extra/nautilus-cd-burner-${PV_MAJOR}"
227     ;;
228     rsvg-sharp-*)
229     add_depend ">=gnome-base/librsvg-${RSVG_REQUIRED_VERSION}"
230     ;;
231     vte-sharp-*)
232     add_depend ">=x11-libs/vte-${VTE_REQUIRED_VERSION}"
233     ;;
234     wnck-sharp-*)
235     add_depend ">=x11-libs/libwnck-${PV_MAJOR}"
236     ;;
237     esac
238    
239 loki_val 1.14 # @ECLASS-VARIABLE: DESCRIPTION
240     # @DESCRIPTION:
241     # Default value: GtkSharp's ${GTK_SHARP_MODULE} module of the ${TARBALL} tarball
242     DESCRIPTION="GtkSharp's ${GTK_SHARP_MODULE} module of the ${TARBALL} tarball"
243     # @ECLASS-VARIABLE: HOMEPAGE
244     # @DESCRIPTION:
245     # Default value: http://www.mono-project.com/GtkSharp
246     HOMEPAGE="http://www.mono-project.com/GtkSharp"
247     # @ECLASS-VARIABLE: DESCRIPTION
248     # @DESCRIPTION:
249     # Default value: LGPL-2.1
250     LICENSE="LGPL-2.1"
251 loki_val 1.8
252 loki_val 1.14 add_depend ">=dev-lang/mono-2.0.1"
253     add_bdepend ">=sys-apps/sed-4"
254     add_bdepend ">=dev-util/pkgconfig-0.23"
255     add_bdepend ">=app-shells/bash-3.1"
256 loki_val 1.8
257 loki_val 1.14 IUSE="debug"
258 loki_val 1.19 # @ECLASS-VARIABLE: S
259 loki_val 1.14 # @DESCRIPTION:
260     # Default value: ${WORKDIR}/${TARBALL}-${PV}
261     S="${WORKDIR}/${TARBALL}-${PV}"
262     # @ECLASS-VARIABLE: SRC_URI
263     # @DESCRIPTION:
264     # Default value: mirror://gnome/sources/${TARBALL}/${PV_MAJOR}/${TARBALL}-${PV}.tar.bz2
265     SRC_URI="${SRC_URI}
266     mirror://gnome/sources/${TARBALL}/${PV_MAJOR}/${TARBALL}-${PV}.tar.bz2"
267    
268     # @FUNCTION: get_sharp_apis
269     # @USAGE: <type> <pkgconfig-package>
270     # @RETURN: .NET API files
271     # @DESCRIPTION:
272     # Given a valid pkg-config package, will return a list of API xml files.
273     # <type> can be either --prefixed or --bare. If prefixed, each API file
274     # will be prefixed with -I:
275     get_sharp_apis() {
276     [[ ${#@} -eq 2 ]] || die "${FUNCNAME} needs two arguments"
277     get_sharp_assemblies "$@"
278     }
279    
280     # @FUNCTION: get_sharp_assemblies
281     # @USAGE: <type> <pkgconfig-package>
282     # @RETURN: .NET .dll assemblies
283     # @DESCRIPTION:
284     # Given a valid pkg-config package, will return a list of .dll assemblies.
285     # <type> can be either --prefixed or --bare. If prefixed, each .dll file
286     # will be prefixed with -r:
287     get_sharp_assemblies() {
288     [[ ${#@} -eq 2 ]] || die "${FUNCNAME} needs two arguments"
289     local string config=libs prefix="-r:"
290     local -a rvalue
291     [[ "${FUNCNAME[1]}" = "get_sharp_apis" ]] && config=cflags && prefix="-I:"
292     for string in $(pkg-config --${config} ${2} 2> /dev/null)
293 loki_val 1.8 do
294 loki_val 1.14 rvalue+=( ${string#-?:} )
295 loki_val 1.8 done
296 loki_val 1.14
297     case $1 in
298     --bare)
299     :
300     ;;
301     --prefixed)
302     for (( i=0 ; i< ${#rvalue[@]} ; i++ ))
303     do
304     rvalue[$i]=${prefix}${rvalue[$i]}
305     done
306     ;;
307     *)
308     die "${FUNCNAME}: Unknown parameter"
309     ;;
310     esac
311     echo "${rvalue[@]}"
312     }
313    
314     # @FUNCTION: phase_hook
315     # @USAGE: <prefix>
316     # Looks for functions named <prefix>_caller_suffix and executes them.
317     # _caller_suffix is the calling function with the prefix
318     # gtk-sharp-module removed.
319     phase_hook() {
320     [[ ${#@} -eq 1 ]] || die "${FUNCNAME} needs one argument"
321     if [[ "$(type -t ${1}${FUNCNAME[1]#gtk-sharp-module})" = "function" ]]
322     then
323     ebegin "Phase-hook: Running ${1}${FUNCNAME[1]#gtk-sharp-module}"
324     ${1}${FUNCNAME[1]#gtk-sharp-module}
325     eend 0
326     fi
327 loki_val 1.8 }
328    
329 loki_val 1.14 # @FUNCTION: ac_path_prog_override
330     # @USAGE: <PROG> [path]
331     # @DESCRIPTION:
332     # Override AC_PATH_PROG() autoconf macros. Path will be set to " " if
333     # not specified.
334     ac_path_prog_override() {
335     if [[ ${#@} -lt 1 || ${#@} -gt 2 ]]
336 loki_val 1.8 then
337 loki_val 1.14 eerror "${FUNCNAME[0]} requires at least one parameter and takes at most two:"
338     eerror "AC_PATH_PROG(PARAM1, param2)"
339     die "${FUNCNAME[0]} requires at least one parameter and takes at most two:"
340 loki_val 1.8 fi
341 loki_val 1.14 export ac_cv_path_${1}="${2:- }"
342 loki_val 1.8 }
343    
344 loki_val 1.14
345     # @FUNCTION: pkg_check_modules_override
346     # @USAGE: <GROUP> [package1] [package2]
347     # @DESCRIPTION:
348     # Will export the appropriate variables to override PKG_CHECK_MODULES autoconf
349     # macros, with the string " " by default. If packages are specified, they will
350     # be looked up with pkg-config and the appropriate LIBS and CFLAGS substituted.
351     # LIBS and CFLAGS can also be specified per-package with the following syntax:
352     # @CODE
353     # package=LIBS%CFLAGS
354     # @CODE
355     # = and % have no effect unless both are specified.
356     # Here is an example:
357     # @CODE
358     # pkg_check_modules_override GASH "gtk+-2.0=-jule%" gobject-2.0
359     # @CODE
360     # The above example will do:
361     # export GASH_CFLAGS+=" -jule"
362     # export GASH_LIBS+=" "
363     # export GASH_CFLAGS+=" $(pkg-config --cflags gobject-2.0)"
364     # export GASH_LIBS+=" $(pkg-config --libs gobject-2.0)"
365     #
366     # NOTE: If a package is not found, the string " " will be inserted in place of
367     # <GROUP>_CFLAGS and <GROUP>_LIBS
368     pkg_check_modules_override() {
369     local package
370     local group="${1}"
371     local packages="${*:2}"
372     export ${group}_CFLAGS=" "
373     export ${group}_LIBS=" "
374    
375     if [[ ${#@} -lt 1 ]]
376 loki_val 1.8 then
377 loki_val 1.14 eerror "${FUNCNAME[0]} requires at least one parameter: GROUP"
378     eerror "PKG_CHECK_MODULES(GROUP, package1 package2 etc)"
379     die "${FUNCNAME[0]} requires at least one parameter: GROUP"
380 loki_val 1.8 fi
381 loki_val 1.1
382 loki_val 1.14 for package in $packages
383     do
384     if [[ ${package/=} != ${package} && ${package/\%} != ${package} ]]
385     then
386     package_cflag_libs=${package##*=}
387     export ${group}_CFLAGS+=" ${package_cflag_libs%%\%*}"
388     export ${group}_LIBS+=" ${package_cflag_libs##*\%}"
389     else
390     if pkg-config --exists $package
391     then
392     export ${group}_CFLAGS+=" $(pkg-config --cflags $package)"
393     export ${group}_LIBS+=" $(pkg-config --libs $package)"
394     else
395     export ${group}_CFLAGS+=" "
396     export ${group}_LIBS+=" "
397     fi
398     fi
399     done
400     }
401 loki_val 1.1
402 loki_val 1.14 # @FUNCTION: gtk-sharp-tarball-post_src_prepare
403     # @DESCRIPTION:
404     # Runs a M-m-m-monster sed on GTK_SHARP_MODULE_DIR to convert references to
405     # local assemblies to the installed ones. Is only called by src_prepare when
406     # $GTK_SHARP_MODULE is a member of $gtk_sharp_module_list.
407     gtk-sharp-tarball-post_src_prepare() {
408 loki_val 1.6 cd "${S}/${GTK_SHARP_MODULE_DIR}"
409 loki_val 1.14 sed -i \
410     -e "s; \$(srcdir)/../glib/glib-api.xml; $(get_sharp_apis --bare glib-sharp-2.0);" \
411     -e "s; ../pango/pango-api.xml; $(get_sharp_apis --bare pango-sharp-2.0);" \
412     -e "s; ../atk/atk-api.xml; $(get_sharp_apis --bare atk-sharp-2.0);" \
413     -e "s; ../gdk/gdk-api.xml; $(get_sharp_apis --bare gdk-sharp-2.0);" \
414     -e "s; ../gtk/gtk-api.xml; $(get_sharp_apis --bare gtk-sharp-2.0);" \
415     -e "s; \.\./glib/glib-sharp.dll; $(get_sharp_assemblies --bare glib-sharp-2.0);g" \
416     -e "s; \.\./pango/pango-sharp.dll; $(get_sharp_assemblies --bare pango-sharp-2.0);g" \
417     -e "s; \.\./atk/atk-sharp.dll; $(get_sharp_assemblies --bare atk-sharp-2.0);g" \
418     -e "s; \.\./gdk/gdk-sharp.dll; $(get_sharp_assemblies --bare gdk-sharp-2.0);g" \
419     -e "s; \.\./gtk/gtk-sharp.dll; $(get_sharp_assemblies --bare gtk-sharp-2.0);g" \
420     -e "s;\$(RUNTIME) \$(top_builddir)/parser/gapi-fixup.exe;/usr/bin/gapi2-fixup;" \
421     -e "s;\$(RUNTIME) \$(top_builddir)/generator/gapi_codegen.exe;/usr/bin/gapi2-codegen;" \
422     -e "s:\$(SYMBOLS) \$(top_builddir)/parser/gapi-fixup.exe:\$(SYMBOLS):" \
423     -e "s:\$(INCLUDE_API) \$(top_builddir)/generator/gapi_codegen.exe:\$(INCLUDE_API):" \
424     $(find . -name Makefile.in) || die "failed to fix ${TARBALL}-tarball makefiles"
425     }
426    
427     # @FUNCTION: gnome-sharp-tarball-post_src_prepare
428     # @DESCRIPTION:
429     # Runs a M-m-m-monster sed on GTK_SHARP_MODULE_DIR to convert references to
430     # local assemblies to the installed ones. Is only called by src_prepare when
431     # $GTK_SHARP_MODULE is a member of $gnome_sharp_module_list.
432     gnome-sharp-tarball-post_src_prepare() {
433     cd "${S}/${GTK_SHARP_MODULE_DIR}"
434     sed -i \
435     -e "s; ../gnomevfs/gnome-vfs-api.xml; $(get_sharp_apis --bare gnome-vfs-sharp-2.0);" \
436     -e "s; ../art/art-api.xml; $(get_sharp_apis --bare art-sharp-2.0);" \
437     -e "s; \.\./art/art-sharp.dll; $(get_sharp_assemblies --bare art-sharp-2.0);g" \
438     -e "s; \.\./gnomevfs/gnome-vfs-sharp.dll; $(get_sharp_assemblies --bare gnome-vfs-sharp-2.0);g" \
439     -e "s;/r:\$(top_builddir)/art/art-sharp.dll;$(get_sharp_assemblies --prefixed art-sharp-2.0);" \
440     -e "s;/r:\$(top_builddir)/gnome/gnome-sharp.dll;$(get_sharp_assemblies --prefixed gnome-sharp-2.0);" \
441     $(find . -name Makefile.in) || die "failed to fix ${TARBALL}-tarball makefiles"
442     }
443    
444     # @FUNCTION: gtk-sharp-module_src_prepare
445     # @DESCRIPTION:
446     # Runs autopatch from base.eclass, eautoreconf if EAUTORECONF is set to any
447     # value.
448     # Contains a phase_hook, runs very last.
449     # phase_hook prefix trigger: ${TARBALL}-tarball-post
450     # Is exported.
451     gtk-sharp-module_src_prepare() {
452     base_src_util autopatch
453     # @ECLASS-VARIABLE: EAUTORECONF
454     # @DESCRIPTION:
455     # If set, EAUTORECONF will be run during src_prepare.
456     [[ ${EAUTORECONF} ]] && eautoreconf
457     phase_hook ${TARBALL}-tarball-post
458 loki_val 1.1 }
459    
460 loki_val 1.14 # @FUNCTION: gtk-sharp-tarball_src_configure
461     # @DESCRIPTION:
462     # Sets some environment variables that will allow us to make the dependencies
463     # for each ebuild be only its own dependencies, without patching configure.
464     # Is only called by gtk-sharp-module_src_configure when $GTK_SHARP_MODULE
465     # is a member of $gtk_sharp_module_list.
466     gtk-sharp-tarball_src_configure() {
467     pkg_check_modules_override GLIB gobject-2.0
468     pkg_check_modules_override GIO gio-2.0
469     pkg_check_modules_override PANGO pango
470     pkg_check_modules_override ATK atk
471     pkg_check_modules_override GTK gtk+-2.0
472     pkg_check_modules_override GLADE libglade-2.0
473     }
474    
475     # @FUNCTION: gnome-sharp-tarball_src_configure
476     # @DESCRIPTION:
477     # Sets some environment variables that will allow us to make the dependencies
478     # for each ebuild be only its own dependencies. Without patching configure.
479     # Is only called by gtk-sharp-module_src_configure when $GTK_SHARP_MODULE
480     # is a member of $gnome_sharp_module_list.
481     gnome-sharp-tarball_src_configure() {
482     pkg_check_modules_override GLADESHARP glade-sharp-2.0
483     pkg_check_modules_override GAPI gapi-2.0
484     ac_path_prog_override GAPI_PARSER /usr/bin/gapi2-parser
485     ac_path_prog_override GAPI_CODEGEN /usr/bin/gapi2-codegen
486     ac_path_prog_override GAPI_FIXUP /usr/bin/gapi2-fixup
487     }
488    
489     # @FUNCTION: gtk-sharp-module_src_configure
490     # @USAGE: [econf-arguments]
491     # @DESCRIPTION:
492     # Calls econf with some default values.
493     # Contains a phase_hook, run before econf.
494     # phase_hook prefix trigger: ${TARBALL}-tarball
495     # Is exported.
496 loki_val 1.1 gtk-sharp-module_src_configure() {
497 loki_val 1.14 phase_hook ${TARBALL}-tarball
498 loki_val 1.8 econf --disable-static \
499     --disable-dependency-tracking \
500     --disable-maintainer-mode \
501     $(use debug &&echo "--enable-debug" ) \
502     ${@} || die "econf failed"
503 loki_val 1.1 }
504    
505 loki_val 1.14 # @FUNCTION: gtk-sharp-module_src_compile
506     # @DESCRIPTION:
507     # Calls emake in the subdir of the module.
508     # Sets CSC=/usr/bin/gmcs. Deletes top_srcdir Makefiles to prevent recursing in
509     # case we missed some dll references.
510     # Is exported.
511 loki_val 1.1 gtk-sharp-module_src_compile() {
512 loki_val 1.14 rm -f "${S}"/Makefile* &> /dev/null
513 loki_val 1.6 cd "${S}/${GTK_SHARP_MODULE_DIR}"
514 loki_val 1.14 emake CSC=/usr/bin/gmcs || die "emake failed"
515 loki_val 1.1 }
516    
517 loki_val 1.14 # @FUNCTION: gtk-sharp-module_src_install
518     # @DESCRIPTION:
519     # Installs the module. Fixes up lib paths so they're multilib-safe.
520     # Gets rid of .la files.
521     # Is exported.
522 loki_val 1.1 gtk-sharp-module_src_install() {
523 loki_val 1.12 cd "${S}/${GTK_SHARP_MODULE_DIR}"
524 loki_val 1.14 emake DESTDIR="${D}" install || die "emake install failed"
525 loki_val 1.8 mono_multilib_comply
526 loki_val 1.14 find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
527     [[ $(find "${D}" -type f|wc -l) -lt 3 ]] && die "Too few files. This smells like a failed install."
528 loki_val 1.1 }
529    
530     EXPORT_FUNCTIONS src_prepare src_configure src_compile src_install

  ViewVC Help
Powered by ViewVC 1.1.20