/[gentoo-x86]/eclass/java-utils-2.eclass
Gentoo

Diff of /eclass/java-utils-2.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.164 Revision 1.165
4# Copyright (c) 2004, Karl Trygve Kalleberg <karltk@gentoo.org> 4# Copyright (c) 2004, Karl Trygve Kalleberg <karltk@gentoo.org>
5# Copyright (c) 2004-2015, Gentoo Foundation 5# Copyright (c) 2004-2015, Gentoo Foundation
6# 6#
7# Licensed under the GNU General Public License, v2 7# Licensed under the GNU General Public License, v2
8# 8#
9# $Header: /var/cvsroot/gentoo-x86/eclass/java-utils-2.eclass,v 1.164 2015/06/19 14:11:24 chewi Exp $ 9# $Header: /var/cvsroot/gentoo-x86/eclass/java-utils-2.eclass,v 1.165 2015/06/28 13:33:48 chewi Exp $
10 10
11# @ECLASS: java-utils-2.eclass 11# @ECLASS: java-utils-2.eclass
12# @MAINTAINER: 12# @MAINTAINER:
13# java@gentoo.org 13# java@gentoo.org
14# @AUTHOR: 14# @AUTHOR:
1590 if [[ -z "${want_source}" || -z "${want_target}" ]]; then 1590 if [[ -z "${want_source}" || -z "${want_target}" ]]; then
1591 debug-print "could not find valid -source/-target values for javac" 1591 debug-print "could not find valid -source/-target values for javac"
1592 echo "Could not find valid -source/-target values for javac" 1592 echo "Could not find valid -source/-target values for javac"
1593 return 1 1593 return 1
1594 else 1594 else
1595 if java-pkg_is-vm-version-ge "1.4"; then
1596 echo "${source_str} ${target_str}" 1595 echo "${source_str} ${target_str}"
1597 else
1598 echo "${target_str}"
1599 fi
1600 fi 1596 fi
1601} 1597}
1602 1598
1603# @FUNCTION: java-pkg_get-jni-cflags 1599# @FUNCTION: java-pkg_get-jni-cflags
1604# @DESCRIPTION: 1600# @DESCRIPTION:
2188 if ! has ${desired_target} ${supported_target}; then 2184 if ! has ${desired_target} ${supported_target}; then
2189 ewarn "${compiler} does not support -target ${desired_target}, skipping" 2185 ewarn "${compiler} does not support -target ${desired_target}, skipping"
2190 continue 2186 continue
2191 fi 2187 fi
2192 2188
2193 # -source was introduced in 1.3, so only check 1.3 and on
2194 if version_is_at_least "${desired_soure}" "1.3"; then
2195 # Verify that the compiler supports source 2189 # Verify that the compiler supports source
2196 local supported_source=$(source ${compiler_env} 1>/dev/null 2>&1; echo ${SUPPORTED_SOURCE}) 2190 local supported_source=$(source ${compiler_env} 1>/dev/null 2>&1; echo ${SUPPORTED_SOURCE})
2197 if ! has ${desired_source} ${supported_source}; then 2191 if ! has ${desired_source} ${supported_source}; then
2198 ewarn "${compiler} does not support -source ${desired_source}, skipping" 2192 ewarn "${compiler} does not support -source ${desired_source}, skipping"
2199 continue 2193 continue
2200 fi
2201 fi 2194 fi
2202 2195
2203 # if you get here, then the compiler should be good to go 2196 # if you get here, then the compiler should be good to go
2204 export GENTOO_COMPILER="${compiler}" 2197 export GENTOO_COMPILER="${compiler}"
2205 break 2198 break

Legend:
Removed from v.1.164  
changed lines
  Added in v.1.165

  ViewVC Help
Powered by ViewVC 1.1.20